Update to 3.23.1
This commit is contained in:
parent
949618baa0
commit
c0dbee3bf3
1
.gitignore
vendored
1
.gitignore
vendored
@ -115,3 +115,4 @@ evolution-2.31.5.tar.bz2
|
|||||||
/evolution-3.21.92.tar.xz
|
/evolution-3.21.92.tar.xz
|
||||||
/evolution-3.22.0.tar.xz
|
/evolution-3.22.0.tar.xz
|
||||||
/evolution-3.22.1.tar.xz
|
/evolution-3.22.1.tar.xz
|
||||||
|
/evolution-3.23.1.tar.xz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From d74c18bcc12f056d98cc1fcdb90f4372015ebf0e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Milan Crha <mcrha@redhat.com>
|
|
||||||
Date: Thu, 13 Oct 2016 13:00:36 +0200
|
|
||||||
Subject: [PATCH] Bug 772803 - Inline images cause busy loop on Reply in
|
|
||||||
WebKitWebProcess
|
|
||||||
|
|
||||||
---
|
|
||||||
src/modules/webkit-editor/web-extension/e-editor-dom-functions.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/modules/webkit-editor/web-extension/e-editor-dom-functions.c b/modules/webkit-editor/web-extension/e-editor-dom-functions.c
|
|
||||||
index c61d365..0e8da0d 100644
|
|
||||||
--- a/modules/webkit-editor/web-extension/e-editor-dom-functions.c
|
|
||||||
+++ b/modules/webkit-editor/web-extension/e-editor-dom-functions.c
|
|
||||||
@@ -8419,7 +8419,7 @@ change_cid_images_src_to_base64 (EEditorPage *editor_page)
|
|
||||||
|
|
||||||
list = webkit_dom_document_query_selector_all (
|
|
||||||
document, selector, NULL);
|
|
||||||
- for (jj = webkit_dom_node_list_get_length (list) - 1; jj--;) {
|
|
||||||
+ for (jj = webkit_dom_node_list_get_length (list); jj--;) {
|
|
||||||
WebKitDOMNode *node = webkit_dom_node_list_item (list, jj);
|
|
||||||
|
|
||||||
set_base64_to_element_attribute (
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -4,14 +4,13 @@
|
|||||||
%define gtk3_version 3.10.0
|
%define gtk3_version 3.10.0
|
||||||
%define gnome_autoar_version 0.1.1
|
%define gnome_autoar_version 0.1.1
|
||||||
%define gnome_desktop_version 2.91.3
|
%define gnome_desktop_version 2.91.3
|
||||||
%define gnome_doc_utils_version 0.8.0
|
|
||||||
%define intltool_version 0.35.5
|
%define intltool_version 0.35.5
|
||||||
%define libgdata_version 0.10.0
|
%define libgdata_version 0.10.0
|
||||||
%define libgweather_version 3.5.0
|
%define libgweather_version 3.5.0
|
||||||
%define libsoup_version 2.42
|
%define libsoup_version 2.42
|
||||||
%define webkit2gtk_version 2.13.90
|
%define webkit2gtk_version 2.13.90
|
||||||
|
|
||||||
%define evo_base_version 3.22
|
%define evo_base_version 3.24
|
||||||
|
|
||||||
%define last_anjal_version 0.3.2-3
|
%define last_anjal_version 0.3.2-3
|
||||||
%define last_libgal2_version 2:2.5.3-2
|
%define last_libgal2_version 2:2.5.3-2
|
||||||
@ -29,14 +28,14 @@
|
|||||||
### Abstract ###
|
### Abstract ###
|
||||||
|
|
||||||
Name: evolution
|
Name: evolution
|
||||||
Version: 3.22.1
|
Version: 3.23.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Group: Applications/Productivity
|
Group: Applications/Productivity
|
||||||
Summary: Mail and calendar client for GNOME
|
Summary: Mail and calendar client for GNOME
|
||||||
License: GPLv2+ and GFDL
|
License: GPLv2+ and GFDL
|
||||||
URL: https://wiki.gnome.org/Apps/Evolution
|
URL: https://wiki.gnome.org/Apps/Evolution
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
Source: http://download.gnome.org/sources/%{name}/3.22/%{name}-%{version}.tar.xz
|
Source: http://download.gnome.org/sources/%{name}/3.23/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
Obsoletes: anjal <= %{last_anjal_version}
|
Obsoletes: anjal <= %{last_anjal_version}
|
||||||
Obsoletes: libgal2 <= %{last_libgal2_version}
|
Obsoletes: libgal2 <= %{last_libgal2_version}
|
||||||
@ -46,7 +45,6 @@ Obsoletes: evolution-NetworkManager < %{last_evo_nm_version}
|
|||||||
|
|
||||||
# RH bug #
|
# RH bug #
|
||||||
#Patch01: evolution-3.17.1-doc-e-cell-renderer-color.patch
|
#Patch01: evolution-3.17.1-doc-e-cell-renderer-color.patch
|
||||||
Patch01: evolution-3.22.1-inline-images-reply.patch
|
|
||||||
|
|
||||||
## Dependencies ###
|
## Dependencies ###
|
||||||
|
|
||||||
@ -56,17 +54,13 @@ Requires: highlight
|
|||||||
|
|
||||||
### Build Dependencies ###
|
### Build Dependencies ###
|
||||||
|
|
||||||
BuildRequires: autoconf >= 2.59
|
BuildRequires: cmake
|
||||||
BuildRequires: automake >= 1.9
|
BuildRequires: gcc
|
||||||
BuildRequires: desktop-file-utils
|
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: gnome-common
|
|
||||||
BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
|
|
||||||
BuildRequires: gtk-doc
|
BuildRequires: gtk-doc
|
||||||
BuildRequires: highlight
|
BuildRequires: highlight
|
||||||
BuildRequires: intltool >= %{intltool_version}
|
BuildRequires: intltool >= %{intltool_version}
|
||||||
BuildRequires: itstool
|
BuildRequires: itstool
|
||||||
BuildRequires: libtool >= 1.5
|
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: yelp-tools
|
BuildRequires: yelp-tools
|
||||||
|
|
||||||
@ -92,6 +86,7 @@ BuildRequires: pkgconfig(libebackend-1.2) >= %{version}
|
|||||||
BuildRequires: pkgconfig(libebook-1.2) >= %{version}
|
BuildRequires: pkgconfig(libebook-1.2) >= %{version}
|
||||||
BuildRequires: pkgconfig(libecal-1.2) >= %{version}
|
BuildRequires: pkgconfig(libecal-1.2) >= %{version}
|
||||||
BuildRequires: pkgconfig(libedataserver-1.2) >= %{version}
|
BuildRequires: pkgconfig(libedataserver-1.2) >= %{version}
|
||||||
|
BuildRequires: pkgconfig(libedataserverui-1.2) >= %{version}
|
||||||
BuildRequires: pkgconfig(libgdata) >= %{libgdata_version}
|
BuildRequires: pkgconfig(libgdata) >= %{libgdata_version}
|
||||||
BuildRequires: pkgconfig(libsoup-2.4) >= %{libsoup_version}
|
BuildRequires: pkgconfig(libsoup-2.4) >= %{libsoup_version}
|
||||||
BuildRequires: pkgconfig(libxml-2.0)
|
BuildRequires: pkgconfig(libxml-2.0)
|
||||||
@ -99,6 +94,7 @@ BuildRequires: pkgconfig(nspr)
|
|||||||
BuildRequires: pkgconfig(nss)
|
BuildRequires: pkgconfig(nss)
|
||||||
BuildRequires: pkgconfig(shared-mime-info)
|
BuildRequires: pkgconfig(shared-mime-info)
|
||||||
BuildRequires: pkgconfig(webkit2gtk-4.0) >= %{webkit2gtk_version}
|
BuildRequires: pkgconfig(webkit2gtk-4.0) >= %{webkit2gtk_version}
|
||||||
|
BuildRequires: pkgconfig(webkit2gtk-web-extension-4.0) >= %{webkit2gtk_version}
|
||||||
|
|
||||||
%if %{ldap_support}
|
%if %{ldap_support}
|
||||||
BuildRequires: openldap-devel >= 2.0.11
|
BuildRequires: openldap-devel >= 2.0.11
|
||||||
@ -204,22 +200,25 @@ the functionality of the installed %{name} package.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n evolution-%{version}
|
%setup -q -n evolution-%{version}
|
||||||
#%patch01 -p1 -b .doc-e-cell-renderer-color
|
#%patch01 -p1 -b .doc-e-cell-renderer-color
|
||||||
%patch01 -p1 -b .inline-images-reply
|
|
||||||
|
|
||||||
# Remove the welcome email from Novell
|
# Remove the welcome email from Novell
|
||||||
for inbox in mail/default/*/Inbox; do
|
for inbox in src/mail/default/*/Inbox; do
|
||||||
echo -n "" > $inbox
|
echo -n "" > $inbox
|
||||||
done
|
done
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
|
mkdir -p _build
|
||||||
|
cd _build
|
||||||
|
|
||||||
# define all of our flags, this is kind of ugly :(
|
# define all of our flags, this is kind of ugly :(
|
||||||
%if %{ldap_support}
|
%if %{ldap_support}
|
||||||
%define ldap_flags --with-openldap=yes
|
%define ldap_flags -DWITH_OPENLDAP=ON
|
||||||
%else
|
%else
|
||||||
%define ldap_flags --without-openldap
|
%define ldap_flags -DWITH_OPENLDAP=OFF
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define ssl_flags --enable-nss=yes --enable-smime=yes
|
%define ssl_flags -DENABLE_SMIME=ON
|
||||||
|
|
||||||
if ! pkg-config --exists nss; then
|
if ! pkg-config --exists nss; then
|
||||||
echo "Unable to find suitable version of mozilla nss to use!"
|
echo "Unable to find suitable version of mozilla nss to use!"
|
||||||
@ -227,32 +226,28 @@ if ! pkg-config --exists nss; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%if %{with_docs}
|
%if %{with_docs}
|
||||||
%define gtkdoc_flags --enable-gtk-doc --with-help
|
%define gtkdoc_flags -DENABLE_GTK_DOC=ON -DWITH_HELP=ON
|
||||||
%else
|
%else
|
||||||
%define gtkdoc_flags --disable-gtk-doc --without-help
|
%define gtkdoc_flags -DENABLE_GTK_DOC=OFF -DWITH_HELP=OFF
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
CFLAGS="$RPM_OPT_FLAGS -fPIC -DLDAP_DEPRECATED -Wno-sign-compare -Wno-deprecated-declarations"; export CFLAGS
|
CFLAGS="$RPM_OPT_FLAGS -fPIC -DLDAP_DEPRECATED -Wno-sign-compare -Wno-deprecated-declarations"; export CFLAGS
|
||||||
|
|
||||||
# Regenerate configure to pick up configure.ac changes
|
%cmake -G "Unix Makefiles" \
|
||||||
aclocal -I m4
|
-DENABLE_MAINTAINER_MODE=OFF \
|
||||||
autoheader
|
-DVERSION_SUBSTRING=" (%{version}-%{release})" \
|
||||||
automake --add-missing
|
|
||||||
libtoolize
|
|
||||||
intltoolize --force
|
|
||||||
autoconf
|
|
||||||
|
|
||||||
%configure \
|
|
||||||
--disable-maintainer-mode \
|
|
||||||
--with-sub-version=" (%{version}-%{release})" \
|
|
||||||
%ldap_flags %ssl_flags %gtkdoc_flags \
|
%ldap_flags %ssl_flags %gtkdoc_flags \
|
||||||
--enable-plugins=all \
|
-DENABLE_PLUGINS=all \
|
||||||
--enable-installed-tests
|
-DENABLE_YTNEF=OFF \
|
||||||
export tagname=CC
|
-DENABLE_INSTALLED_TESTS=ON \
|
||||||
make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool CFLAGS="$CFLAGS -fno-strict-aliasing"
|
..
|
||||||
|
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%if %{with_docs}
|
%if %{with_docs}
|
||||||
|
|
||||||
|
cd ..
|
||||||
|
|
||||||
# Strip unneeded translations from .mo files.
|
# Strip unneeded translations from .mo files.
|
||||||
# This reduces the RPM size by several megabytes.
|
# This reduces the RPM size by several megabytes.
|
||||||
cd po
|
cd po
|
||||||
@ -287,19 +282,8 @@ done
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
|
cd _build
|
||||||
export tagname=CC
|
make DESTDIR=$RPM_BUILD_ROOT install
|
||||||
make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
|
|
||||||
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
|
|
||||||
|
|
||||||
# remove libtool archives for importers and the like
|
|
||||||
find $RPM_BUILD_ROOT/%{_libdir}/evolution -name '*.la' -exec rm {} \;
|
|
||||||
|
|
||||||
# remove statically built libraries:
|
|
||||||
find $RPM_BUILD_ROOT/%{_libdir}/evolution -name '*.a' -exec rm {} \;
|
|
||||||
|
|
||||||
# remove test GIO modules directory
|
|
||||||
rm -r $RPM_BUILD_ROOT/%{_libdir}/evolution/test-gio-modules
|
|
||||||
|
|
||||||
%find_lang evolution-%{evo_base_version} --all-name --with-gnome
|
%find_lang evolution-%{evo_base_version} --all-name --with-gnome
|
||||||
|
|
||||||
@ -329,7 +313,7 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
|
|||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%files -f translations.lang
|
%files -f _build/translations.lang
|
||||||
%doc AUTHORS COPYING NEWS README
|
%doc AUTHORS COPYING NEWS README
|
||||||
|
|
||||||
# GSettings schemas:
|
# GSettings schemas:
|
||||||
@ -415,8 +399,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
# Shared libraries:
|
# Shared libraries:
|
||||||
%{_libdir}/evolution/libevolution-mail-composer.so
|
%{_libdir}/evolution/libevolution-mail-composer.so
|
||||||
%{_libdir}/evolution/libeabutil.so
|
%{_libdir}/evolution/libeabutil.so
|
||||||
|
%{_libdir}/evolution/libeabwidgets.so
|
||||||
%{_libdir}/evolution/libecontacteditor.so
|
%{_libdir}/evolution/libecontacteditor.so
|
||||||
%{_libdir}/evolution/libecontactlisteditor.so
|
%{_libdir}/evolution/libecontactlisteditor.so
|
||||||
|
%{_libdir}/evolution/libecontactprint.so
|
||||||
|
%{_libdir}/evolution/libedomutils.so
|
||||||
%{_libdir}/evolution/libemail-engine.so
|
%{_libdir}/evolution/libemail-engine.so
|
||||||
%{_libdir}/evolution/libevolution-mail-formatter.so
|
%{_libdir}/evolution/libevolution-mail-formatter.so
|
||||||
%{_libdir}/evolution/libevolution-shell.so
|
%{_libdir}/evolution/libevolution-shell.so
|
||||||
@ -431,10 +418,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/evolution/libgnomecanvas.so
|
%{_libdir}/evolution/libgnomecanvas.so
|
||||||
|
|
||||||
# WebKit2 Extensions
|
# WebKit2 Extensions
|
||||||
%{_libdir}/evolution/web-extensions/libedomutils.so
|
|
||||||
%{_libdir}/evolution/web-extensions/libewebextension.so
|
%{_libdir}/evolution/web-extensions/libewebextension.so
|
||||||
%{_libdir}/evolution/web-extensions/libmoduleitipformatterwebextension.so
|
%{_libdir}/evolution/web-extensions/module-itip-formatter-webextension.so
|
||||||
%{_libdir}/evolution/web-extensions/webkit-editor/libewebkiteditorwebextension.so
|
%{_libdir}/evolution/web-extensions/webkit-editor/module-webkit-editor-webextension.so
|
||||||
|
|
||||||
# Various libexec programs:
|
# Various libexec programs:
|
||||||
%dir %{_libexecdir}/evolution
|
%dir %{_libexecdir}/evolution
|
||||||
@ -505,8 +491,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc %{_datadir}/gtk-doc/html/evolution-util
|
%doc %{_datadir}/gtk-doc/html/evolution-util
|
||||||
|
|
||||||
%if %{with_docs}
|
%if %{with_docs}
|
||||||
%files help -f help.lang
|
%files help -f _build/help.lang
|
||||||
%dir %{_datadir}/help/*/evolution
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%files bogofilter
|
%files bogofilter
|
||||||
@ -529,6 +514,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 24 2016 Milan Crha <mcrha@redhat.com> - 3.23.1-1
|
||||||
|
- Update to 3.23.1
|
||||||
|
|
||||||
* Thu Oct 13 2016 Milan Crha <mcrha@redhat.com> - 3.22.1-2
|
* Thu Oct 13 2016 Milan Crha <mcrha@redhat.com> - 3.22.1-2
|
||||||
- Add patch for GNOME bug #772803 (Inline images cause busy loop on Reply in WebKitWebProcess)
|
- Add patch for GNOME bug #772803 (Inline images cause busy loop on Reply in WebKitWebProcess)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user