- Update to 3.11.2
- Conditionally build help subpackage - Disable compiler warnings about deprecated symbols
This commit is contained in:
parent
15ce829748
commit
b131ef23e6
1
.gitignore
vendored
1
.gitignore
vendored
@ -65,3 +65,4 @@ evolution-2.31.5.tar.bz2
|
||||
/evolution-3.10.0.tar.xz
|
||||
/evolution-3.10.1.tar.xz
|
||||
/evolution-3.11.1.tar.xz
|
||||
/evolution-3.11.2.tar.xz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up evolution-3.11.1/addressbook/gui/contact-editor/e-contact-editor.c.help-contents evolution-3.11.1/addressbook/gui/contact-editor/e-contact-editor.c
|
||||
--- evolution-3.11.1/addressbook/gui/contact-editor/e-contact-editor.c.help-contents 2013-10-20 16:23:21.000000000 +0200
|
||||
+++ evolution-3.11.1/addressbook/gui/contact-editor/e-contact-editor.c 2013-11-11 21:39:21.984600383 +0100
|
||||
@@ -4182,6 +4182,11 @@ e_contact_editor_init (EContactEditor *e
|
||||
diff -up evolution-3.11.2/addressbook/gui/contact-editor/e-contact-editor.c.help-contents evolution-3.11.2/addressbook/gui/contact-editor/e-contact-editor.c
|
||||
--- evolution-3.11.2/addressbook/gui/contact-editor/e-contact-editor.c.help-contents 2013-11-17 01:24:01.000000000 +0100
|
||||
+++ evolution-3.11.2/addressbook/gui/contact-editor/e-contact-editor.c 2013-11-18 11:09:00.373861447 +0100
|
||||
@@ -4178,6 +4178,11 @@ e_contact_editor_init (EContactEditor *e
|
||||
g_signal_connect (
|
||||
widget, "clicked",
|
||||
G_CALLBACK (show_help_cb), e_contact_editor);
|
||||
@ -13,10 +13,10 @@ diff -up evolution-3.11.1/addressbook/gui/contact-editor/e-contact-editor.c.help
|
||||
widget = e_builder_get_widget (
|
||||
e_contact_editor->builder, "button-web-expand");
|
||||
g_signal_connect_swapped (
|
||||
diff -up evolution-3.11.1/calendar/gui/dialogs/comp-editor.c.help-contents evolution-3.11.1/calendar/gui/dialogs/comp-editor.c
|
||||
--- evolution-3.11.1/calendar/gui/dialogs/comp-editor.c.help-contents 2013-10-20 16:23:34.000000000 +0200
|
||||
+++ evolution-3.11.1/calendar/gui/dialogs/comp-editor.c 2013-11-11 21:39:21.986600383 +0100
|
||||
@@ -2152,6 +2152,12 @@ comp_editor_init (CompEditor *editor)
|
||||
diff -up evolution-3.11.2/calendar/gui/dialogs/comp-editor.c.help-contents evolution-3.11.2/calendar/gui/dialogs/comp-editor.c
|
||||
--- evolution-3.11.2/calendar/gui/dialogs/comp-editor.c.help-contents 2013-11-17 01:24:01.000000000 +0100
|
||||
+++ evolution-3.11.2/calendar/gui/dialogs/comp-editor.c 2013-11-18 11:09:00.374861447 +0100
|
||||
@@ -2149,6 +2149,12 @@ comp_editor_init (CompEditor *editor)
|
||||
G_BINDING_SYNC_CREATE);
|
||||
}
|
||||
|
||||
@ -29,10 +29,10 @@ diff -up evolution-3.11.1/calendar/gui/dialogs/comp-editor.c.help-contents evolu
|
||||
action_group = gtk_action_group_new ("individual");
|
||||
gtk_action_group_set_translation_domain (
|
||||
action_group, GETTEXT_PACKAGE);
|
||||
diff -up evolution-3.11.1/e-util/e-misc-utils.c.help-contents evolution-3.11.1/e-util/e-misc-utils.c
|
||||
--- evolution-3.11.1/e-util/e-misc-utils.c.help-contents 2013-10-20 16:23:09.000000000 +0200
|
||||
+++ evolution-3.11.1/e-util/e-misc-utils.c 2013-11-11 21:39:21.987600383 +0100
|
||||
@@ -2097,3 +2097,20 @@ e_binding_transform_uid_to_source (GBind
|
||||
diff -up evolution-3.11.2/e-util/e-misc-utils.c.help-contents evolution-3.11.2/e-util/e-misc-utils.c
|
||||
--- evolution-3.11.2/e-util/e-misc-utils.c.help-contents 2013-11-17 01:24:01.000000000 +0100
|
||||
+++ evolution-3.11.2/e-util/e-misc-utils.c 2013-11-18 11:09:00.374861447 +0100
|
||||
@@ -2099,3 +2099,20 @@ e_binding_transform_uid_to_source (GBind
|
||||
|
||||
return success;
|
||||
}
|
||||
@ -53,9 +53,9 @@ diff -up evolution-3.11.1/e-util/e-misc-utils.c.help-contents evolution-3.11.1/e
|
||||
+
|
||||
+ return is_installed;
|
||||
+}
|
||||
diff -up evolution-3.11.1/e-util/e-misc-utils.h.help-contents evolution-3.11.1/e-util/e-misc-utils.h
|
||||
--- evolution-3.11.1/e-util/e-misc-utils.h.help-contents 2013-10-20 16:23:08.000000000 +0200
|
||||
+++ evolution-3.11.1/e-util/e-misc-utils.h 2013-11-11 21:39:21.987600383 +0100
|
||||
diff -up evolution-3.11.2/e-util/e-misc-utils.h.help-contents evolution-3.11.2/e-util/e-misc-utils.h
|
||||
--- evolution-3.11.2/e-util/e-misc-utils.h.help-contents 2013-10-30 23:08:03.000000000 +0100
|
||||
+++ evolution-3.11.2/e-util/e-misc-utils.h 2013-11-18 11:09:00.375861447 +0100
|
||||
@@ -185,6 +185,8 @@ gboolean e_binding_transform_uid_to_sour
|
||||
GValue *target_value,
|
||||
ESourceRegistry *registry);
|
||||
@ -65,9 +65,9 @@ diff -up evolution-3.11.1/e-util/e-misc-utils.h.help-contents evolution-3.11.1/e
|
||||
G_END_DECLS
|
||||
|
||||
#endif /* E_MISC_UTILS_H */
|
||||
diff -up evolution-3.11.1/e-util/e-preferences-window.c.help-contents evolution-3.11.1/e-util/e-preferences-window.c
|
||||
--- evolution-3.11.1/e-util/e-preferences-window.c.help-contents 2013-10-20 16:23:14.000000000 +0200
|
||||
+++ evolution-3.11.1/e-util/e-preferences-window.c 2013-11-11 21:39:21.987600383 +0100
|
||||
diff -up evolution-3.11.2/e-util/e-preferences-window.c.help-contents evolution-3.11.2/e-util/e-preferences-window.c
|
||||
--- evolution-3.11.2/e-util/e-preferences-window.c.help-contents 2013-10-30 23:08:07.000000000 +0100
|
||||
+++ evolution-3.11.2/e-util/e-preferences-window.c 2013-11-18 11:09:00.375861447 +0100
|
||||
@@ -385,6 +385,11 @@ e_preferences_window_init (EPreferencesW
|
||||
GTK_BUTTON_BOX (container), widget, TRUE);
|
||||
gtk_widget_show (widget);
|
||||
@ -80,9 +80,9 @@ diff -up evolution-3.11.1/e-util/e-preferences-window.c.help-contents evolution-
|
||||
widget = gtk_button_new_from_stock (GTK_STOCK_CLOSE);
|
||||
g_signal_connect_swapped (
|
||||
widget, "clicked",
|
||||
diff -up evolution-3.11.1/e-util/e-send-options.c.help-contents evolution-3.11.1/e-util/e-send-options.c
|
||||
--- evolution-3.11.1/e-util/e-send-options.c.help-contents 2013-10-20 16:22:51.000000000 +0200
|
||||
+++ evolution-3.11.1/e-util/e-send-options.c 2013-11-11 21:39:21.988600383 +0100
|
||||
diff -up evolution-3.11.2/e-util/e-send-options.c.help-contents evolution-3.11.2/e-util/e-send-options.c
|
||||
--- evolution-3.11.2/e-util/e-send-options.c.help-contents 2013-11-17 01:24:01.000000000 +0100
|
||||
+++ evolution-3.11.2/e-util/e-send-options.c 2013-11-18 11:09:00.375861447 +0100
|
||||
@@ -440,6 +440,7 @@ get_widgets (ESendOptionsDialog *sod)
|
||||
{
|
||||
ESendOptionsDialogPrivate *priv;
|
||||
@ -104,9 +104,9 @@ diff -up evolution-3.11.1/e-util/e-send-options.c.help-contents evolution-3.11.1
|
||||
return (priv->priority
|
||||
&& priv->security
|
||||
&& priv->status
|
||||
diff -up evolution-3.11.1/plugins/email-custom-header/email-custom-header.c.help-contents evolution-3.11.1/plugins/email-custom-header/email-custom-header.c
|
||||
--- evolution-3.11.1/plugins/email-custom-header/email-custom-header.c.help-contents 2013-10-20 16:22:22.000000000 +0200
|
||||
+++ evolution-3.11.1/plugins/email-custom-header/email-custom-header.c 2013-11-11 21:39:21.988600383 +0100
|
||||
diff -up evolution-3.11.2/plugins/email-custom-header/email-custom-header.c.help-contents evolution-3.11.2/plugins/email-custom-header/email-custom-header.c
|
||||
--- evolution-3.11.2/plugins/email-custom-header/email-custom-header.c.help-contents 2013-11-17 01:24:01.000000000 +0100
|
||||
+++ evolution-3.11.2/plugins/email-custom-header/email-custom-header.c 2013-11-18 11:09:00.375861447 +0100
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <string.h>
|
||||
#include <glib/gi18n.h>
|
||||
@ -138,9 +138,9 @@ diff -up evolution-3.11.1/plugins/email-custom-header/email-custom-header.c.help
|
||||
#undef EMAIL_CUSTOM_HEADER
|
||||
|
||||
return (priv->page
|
||||
diff -up evolution-3.11.1/shell/e-shell-window-actions.c.help-contents evolution-3.11.1/shell/e-shell-window-actions.c
|
||||
--- evolution-3.11.1/shell/e-shell-window-actions.c.help-contents 2013-10-20 16:23:24.000000000 +0200
|
||||
+++ evolution-3.11.1/shell/e-shell-window-actions.c 2013-11-11 21:39:21.989600383 +0100
|
||||
diff -up evolution-3.11.2/shell/e-shell-window-actions.c.help-contents evolution-3.11.2/shell/e-shell-window-actions.c
|
||||
--- evolution-3.11.2/shell/e-shell-window-actions.c.help-contents 2013-10-30 23:08:15.000000000 +0100
|
||||
+++ evolution-3.11.2/shell/e-shell-window-actions.c 2013-11-18 11:09:00.376861447 +0100
|
||||
@@ -1414,6 +1414,11 @@ e_shell_window_actions_init (EShellWindo
|
||||
if (path == NULL)
|
||||
gtk_action_set_visible (ACTION (SUBMIT_BUG), FALSE);
|
||||
|
@ -25,13 +25,16 @@
|
||||
%define libpst_support 1
|
||||
%define krb5_support 1
|
||||
|
||||
# Coverity scan can override this to 0, to skip checking in gtk-doc generated code
|
||||
%{!?with_docs: %define with_docs 1}
|
||||
|
||||
%define evo_plugin_dir %{_libdir}/evolution/%{evo_base_version}/plugins
|
||||
|
||||
### Abstract ###
|
||||
|
||||
Name: evolution
|
||||
Version: 3.11.1
|
||||
Release: 2%{?dist}
|
||||
Version: 3.11.2
|
||||
Release: 1%{?dist}
|
||||
Group: Applications/Productivity
|
||||
Summary: Mail and calendar client for GNOME
|
||||
License: GPLv2+ and GFDL
|
||||
@ -148,6 +151,7 @@ BuildArch: noarch
|
||||
%description devel-docs
|
||||
This package contains developer documentation for Evolution.
|
||||
|
||||
%if %{with_docs}
|
||||
%package help
|
||||
Group: Applications/Productivity
|
||||
Summary: Help files for %{name}
|
||||
@ -157,6 +161,7 @@ BuildArch: noarch
|
||||
|
||||
%description help
|
||||
This package contains user documentation for %{name}.
|
||||
%endif
|
||||
|
||||
%package bogofilter
|
||||
Group: Applications/Productivity
|
||||
@ -232,8 +237,14 @@ if ! pkg-config --exists nss; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
%if %{with_docs}
|
||||
%define gtkdoc_flags --enable-gtk-doc
|
||||
%else
|
||||
%define gtkdoc_flags --disable-gtk-doc
|
||||
%endif
|
||||
|
||||
CPPFLAGS="-I%{_includedir}/et"; export CPPFLAGS
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC -DLDAP_DEPRECATED -I%{_includedir}/et -Wno-sign-compare"; export CFLAGS
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC -DLDAP_DEPRECATED -I%{_includedir}/et -Wno-sign-compare -Wno-deprecated-declarations"; export CFLAGS
|
||||
|
||||
# Regenerate configure to pick up configure.ac changes
|
||||
aclocal -I m4
|
||||
@ -245,13 +256,14 @@ autoconf
|
||||
|
||||
%configure \
|
||||
--disable-maintainer-mode \
|
||||
--enable-gtk-doc \
|
||||
--with-sub-version=" (%{version}-%{release})" \
|
||||
%ldap_flags %krb5_flags %ssl_flags \
|
||||
%ldap_flags %krb5_flags %ssl_flags %gtkdoc_flags \
|
||||
--enable-plugins=all
|
||||
export tagname=CC
|
||||
make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool CFLAGS="$CFLAGS -fno-strict-aliasing"
|
||||
|
||||
%if %{with_docs}
|
||||
|
||||
# Strip unneeded translations from .mo files.
|
||||
# This reduces the RPM size by several megabytes.
|
||||
cd po
|
||||
@ -281,6 +293,8 @@ for f in $helpdir/C/figures/*.png; do
|
||||
done
|
||||
done
|
||||
|
||||
# %{with_docs}
|
||||
%endif
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -506,9 +520,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc %{_datadir}/gtk-doc/html/evolution-shell
|
||||
%doc %{_datadir}/gtk-doc/html/evolution-util
|
||||
|
||||
%if %{with_docs}
|
||||
%files help -f help.lang
|
||||
%defattr(-, root, root)
|
||||
%dir %{_datadir}/help/*/evolution
|
||||
%endif
|
||||
|
||||
%files bogofilter
|
||||
%defattr(-, root, root)
|
||||
@ -530,6 +546,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Nov 18 2013 Milan Crha <mcrha@redhat.com> - 3.11.2-1
|
||||
- Update to 3.11.2
|
||||
- Conditionally build help subpackage
|
||||
- Disable compiler warnings about deprecated symbols
|
||||
|
||||
* Mon Nov 11 2013 Milan Crha <mcrha@redhat.com> - 3.11.1-2
|
||||
- Hide more help-related widgets when evolution-help is not installed
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user