diff --git a/evolution-2.10.1-fix-uri-handling.patch b/evolution-2.10.1-fix-uri-handling.patch
index 6df1026..53fbe39 100644
--- a/evolution-2.10.1-fix-uri-handling.patch
+++ b/evolution-2.10.1-fix-uri-handling.patch
@@ -1,45 +1,14 @@
---- evolution-2.10.1/shell/e-shell.c.fix-uri-handling 2007-04-22 20:19:39.000000000 -0400
-+++ evolution-2.10.1/shell/e-shell.c 2007-04-22 20:20:25.000000000 -0400
-@@ -257,8 +257,8 @@
- {
- EShell *shell = E_SHELL (bonobo_object_from_servant (servant));
- EComponentInfo *component_info;
-+ GtkWidget *shell_window;
- char *schema, *p;
-- int show = FALSE;
+--- evolution-2.10.1/calendar/gui/GNOME_Evolution_Calendar.server.in.in.fix-uri-handling 2007-04-09 09:10:33.000000000 -0400
++++ evolution-2.10.1/calendar/gui/GNOME_Evolution_Calendar.server.in.in 2007-05-14 14:11:59.000000000 -0400
+@@ -50,9 +50,11 @@
+
+
- schema = g_alloca(strlen(uri)+1);
- strcpy(schema, uri);
-@@ -267,26 +267,20 @@
- *p = 0;
++
- component_info = e_component_registry_peek_info(shell->priv->component_registry, ECR_FIELD_SCHEMA, schema);
-- if (component_info == NULL) {
-- show = TRUE;
-+ if (component_info == NULL)
- component_info = e_component_registry_peek_info(shell->priv->component_registry, ECR_FIELD_ALIAS, schema);
-- }
+
- if (component_info == NULL) {
- CORBA_exception_set (ev, CORBA_USER_EXCEPTION, ex_GNOME_Evolution_Shell_UnsupportedSchema, NULL);
- return;
- }
-
-- if (show) {
-- GtkWidget *shell_window;
--
-- shell_window = (GtkWidget *)e_shell_create_window (shell, component_info->id, NULL);
-- if (shell_window == NULL) {
-- CORBA_exception_set (ev, CORBA_USER_EXCEPTION, ex_GNOME_Evolution_Shell_ComponentNotFound, NULL);
-- return;
-- }
-+ shell_window = (GtkWidget *)e_shell_create_window (shell, component_info->id, NULL);
-+ if (shell_window == NULL) {
-+ CORBA_exception_set (ev, CORBA_USER_EXCEPTION, ex_GNOME_Evolution_Shell_ComponentNotFound, NULL);
-+ return;
- }
--
-+
- GNOME_Evolution_Component_handleURI (component_info->iface, uri, ev);
- /* not an error not to implement it */
- if (ev->_id != NULL && strcmp(ev->_id, ex_CORBA_NO_IMPLEMENT) == 0)
diff --git a/evolution.spec b/evolution.spec
index 15df3f4..0128f0c 100644
--- a/evolution.spec
+++ b/evolution.spec
@@ -47,7 +47,7 @@
Name: evolution
Version: 2.10.1
-Release: 14%{?dist}
+Release: 15%{?dist}
License: GPL
Group: Applications/Productivity
Summary: GNOME's next-generation groupware suite
@@ -755,6 +755,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/evolution/%{evo_major}/libmenus.so
%changelog
+* Mon May 14 2007 Matthew Barnes - 2.10.1-15.fc7
+- Revise patch for RH bug #236860 to match upstream's solution.
+
* Mon May 14 2007 Matthew Barnes - 2.10.1-14.fc7
- Revise patch for RH bug #238155 (crash on startup).