- Remove some obsolete configure options:
--enable-file-chooser, --enable-file-locking, --enable-dot-locking - Remove gnome-doc-utils work-around for GNOME bug #427939 (fixed upstream). - Remove patch for RH bug #215478 (fixed upstream).
This commit is contained in:
parent
1b6e71608a
commit
ad50da6175
@ -1,51 +0,0 @@
|
||||
--- evolution-2.7.2.1/calendar/gui/alarm-notify/alarm-queue.c.notification-cleanups 2006-04-22 00:39:20.000000000 -0400
|
||||
+++ evolution-2.7.2.1/calendar/gui/alarm-notify/alarm-queue.c 2006-05-23 16:04:23.000000000 -0400
|
||||
@@ -1566,10 +1566,11 @@
|
||||
const char *summary, *location;
|
||||
GtkTooltips *tooltips;
|
||||
ECalComponentText text;
|
||||
- char *str, *start_str, *end_str, *alarm_str, *time_str;
|
||||
+ char *start_str, *end_str, *alarm_str, *time_str;
|
||||
icaltimezone *current_zone;
|
||||
ECalComponentOrganizer organiser;
|
||||
char *body;
|
||||
+ NotifyNotification *n;
|
||||
|
||||
d(printf("%s:%d (popup_notification)\n",__FILE__, __LINE__));
|
||||
|
||||
@@ -1601,9 +1602,6 @@
|
||||
end_str = timet_to_str_with_zone (qa->instance->occur_end, current_zone);
|
||||
time_str = calculate_time (qa->instance->occur_start, qa->instance->occur_end);
|
||||
|
||||
- str = g_strdup_printf ("%s %s",
|
||||
- start_str, time_str);
|
||||
-
|
||||
if (organiser.cn) {
|
||||
if (location)
|
||||
body = g_strdup_printf ("<b>%s</b>\n%s %s\n%s %s", organiser.cn, _("Location:"), location, start_str, time_str);
|
||||
@@ -1617,16 +1615,21 @@
|
||||
body = g_strdup_printf ("%s %s", start_str, time_str);
|
||||
}
|
||||
|
||||
- NotifyNotification *n = notify_notification_new (summary, body, "stock_appointment-reminder", NULL);
|
||||
- if (!notify_notification_show(n, NULL))
|
||||
+ n = notify_notification_new (summary, body, "stock_appointment-reminder", NULL);
|
||||
+
|
||||
+ /* Notifications don't timeout: require explicit user action: */
|
||||
+ notify_notification_set_timeout (n, NOTIFY_EXPIRES_NEVER);
|
||||
+
|
||||
+ if (!notify_notification_show (n, NULL))
|
||||
g_warning ("Could not send notification to daemon\n");
|
||||
|
||||
- /* create the private structure */
|
||||
+ g_object_unref (n);
|
||||
+
|
||||
+ g_free (body);
|
||||
g_free (start_str);
|
||||
g_free (end_str);
|
||||
g_free (alarm_str);
|
||||
g_free (time_str);
|
||||
- g_free (str);
|
||||
|
||||
|
||||
}
|
@ -1,19 +0,0 @@
|
||||
--- evolution-2.9.3/mail/mail-config.glade.source-path-entry 2006-12-08 20:15:16.000000000 -0500
|
||||
+++ evolution-2.9.3/mail/mail-config.glade 2006-12-08 20:16:13.000000000 -0500
|
||||
@@ -1343,7 +1343,7 @@
|
||||
<widget class="GtkFileChooserButton" id="source_path_entry">
|
||||
<property name="visible">True</property>
|
||||
<property name="title" translatable="yes">Mailbox location</property>
|
||||
- <property name="action">GTK_FILE_CHOOSER_ACTION_OPEN</property>
|
||||
+ <property name="action">GTK_FILE_CHOOSER_ACTION_SELECT_FOLDER</property>
|
||||
<property name="local_only">True</property>
|
||||
<property name="show_hidden">False</property>
|
||||
<property name="do_overwrite_confirmation">False</property>
|
||||
@@ -1354,7 +1354,6 @@
|
||||
<property name="right_attach">2</property>
|
||||
<property name="top_attach">2</property>
|
||||
<property name="bottom_attach">3</property>
|
||||
- <property name="x_options">fill</property>
|
||||
<property name="y_options"></property>
|
||||
</packing>
|
||||
</child>
|
@ -46,7 +46,7 @@
|
||||
|
||||
Name: evolution
|
||||
Version: 2.21.90
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: GPLv2 and GFDL+
|
||||
Group: Applications/Productivity
|
||||
Summary: GNOME's next-generation groupware suite
|
||||
@ -78,19 +78,14 @@ Patch13: evolution-2.5.4-fix-conduit-dir.patch
|
||||
# We do not ship gnome-common (or at least we're not supposed to).
|
||||
Patch14: evolution-2.7.1-no-gnome-common.patch
|
||||
|
||||
#Patch15: evolution-2.7.1-notification-cleanups.patch
|
||||
|
||||
# RH bug #176400
|
||||
Patch17: evolution-2.9.1-im-context-reset.patch
|
||||
|
||||
# RH bug #215478 / GNOME bug #383842
|
||||
Patch18: evolution-2.9.3-source-path-entry.patch
|
||||
Patch15: evolution-2.9.1-im-context-reset.patch
|
||||
|
||||
# GNOME bug #240073
|
||||
Patch19: evolution-2.21.90-click-to-add.patch
|
||||
Patch16: evolution-2.21.90-click-to-add.patch
|
||||
|
||||
# Deal with recent G_GNUC_FUNCTION deprecation
|
||||
Patch20: evolution-2.21.90-no-gnuc-function.patch
|
||||
Patch17: evolution-2.21.90-no-gnuc-function.patch
|
||||
|
||||
## Dependencies ###
|
||||
|
||||
@ -233,11 +228,9 @@ This package contains the plugin to filter junk mail using SpamAssassin.
|
||||
#patch12 -p1 -b .fix-conduits # leave commented
|
||||
%patch13 -p1 -b .fix-conduit-dir
|
||||
%patch14 -p1 -b .no-gnome-common
|
||||
#patch15 -p1 -b .notification-cleanups
|
||||
%patch17 -p1 -b .im-context-reset
|
||||
%patch18 -p1 -b .source-path-entry
|
||||
%patch19 -p1 -b .click-to-add
|
||||
%patch20 -p1 -b .no-gnuc-function
|
||||
%patch15 -p1 -b .im-context-reset
|
||||
%patch16 -p1 -b .click-to-add
|
||||
%patch17 -p1 -b .no-gnuc-function
|
||||
|
||||
mkdir -p krb5-fakeprefix/include
|
||||
mkdir -p krb5-fakeprefix/lib
|
||||
@ -321,18 +314,11 @@ CFLAGS="$CFLAGS \
|
||||
# TODO: Make -DCAMEL_DISABLE_DEPRECATED work.
|
||||
%endif
|
||||
|
||||
# Temporary work-around for a bad gnome-doc-utils.make.
|
||||
# See GNOME bug #427939. Should be fixed in evolution-2.10.2.
|
||||
sed -i -e 's/@ENABLE_SK_TRUE@_s/_s/' help/Makefile.in
|
||||
|
||||
%configure \
|
||||
--disable-scrollkeeper \
|
||||
--enable-gtk-doc \
|
||||
--enable-ipv6 \
|
||||
--enable-file-locking=fcntl --enable-dot-locking=no \
|
||||
--with-sub-version=" (%{version}-%{release})" \
|
||||
--with-kde-applnk-path=no \
|
||||
--enable-file-chooser=yes \
|
||||
%ldap_flags %pilot_flags %krb5_flags %nntp_flags %ssl_flags %exchange_flags \
|
||||
--enable-plugins=all
|
||||
export tagname=CC
|
||||
@ -672,6 +658,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{evo_plugin_dir}/liborg-gnome-sa-junk-plugin.so
|
||||
|
||||
%changelog
|
||||
* Sat Feb 02 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.90-4.fc9
|
||||
- Remove some obsolete configure options:
|
||||
--enable-file-chooser, --enable-file-locking, --enable-dot-locking
|
||||
- Remove gnome-doc-utils work-around for GNOME bug #427939 (fixed upstream).
|
||||
- Remove patch for RH bug #215478 (fixed upstream).
|
||||
|
||||
* Tue Jan 29 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.90-3.fc9
|
||||
- Add patch to address the recent deprecation of G_GNUC_FUNCTION.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user