- Update to 2.21.4
- Expunge unused patches. - Bump eds_version to 2.21.4 for new Camel functions.
This commit is contained in:
parent
23a28c0189
commit
ab1faa09f2
@ -1,31 +0,0 @@
|
|||||||
--- evolution-2.10.0/mail/mail-session.c.e-passwords 2007-03-12 23:41:06.000000000 -0400
|
|
||||||
+++ evolution-2.10.0/mail/mail-session.c 2007-03-12 23:41:35.000000000 -0400
|
|
||||||
@@ -679,8 +679,6 @@
|
|
||||||
|
|
||||||
d(printf ("Gone non-interactive, checking for outstanding interactive tasks\n"));
|
|
||||||
|
|
||||||
- e_passwords_cancel();
|
|
||||||
-
|
|
||||||
/* flush/cancel pending user messages */
|
|
||||||
while ((um = (struct _user_message_msg *) e_dlist_remhead (&message_list))) {
|
|
||||||
d(printf ("Flusing message request: %s\n", um->prompt));
|
|
||||||
--- evolution-2.10.0/shell/main.c.e-passwords 2007-03-12 23:39:38.000000000 -0400
|
|
||||||
+++ evolution-2.10.0/shell/main.c 2007-03-12 23:39:54.000000000 -0400
|
|
||||||
@@ -565,7 +565,6 @@
|
|
||||||
glade_init ();
|
|
||||||
e_cursors_init ();
|
|
||||||
e_icon_factory_init ();
|
|
||||||
- e_passwords_init();
|
|
||||||
|
|
||||||
gtk_window_set_default_icon_name ("evolution");
|
|
||||||
|
|
||||||
--- evolution-2.10.0/calendar/gui/alarm-notify/notify-main.c.e-passwords 2007-03-12 23:40:22.000000000 -0400
|
|
||||||
+++ evolution-2.10.0/calendar/gui/alarm-notify/notify-main.c 2007-03-12 23:40:36.000000000 -0400
|
|
||||||
@@ -169,7 +169,6 @@
|
|
||||||
|
|
||||||
alarm_done ();
|
|
||||||
|
|
||||||
- e_passwords_shutdown ();
|
|
||||||
gnome_sound_shutdown ();
|
|
||||||
|
|
||||||
return 0;
|
|
12
evolution-2.21.4-too-noisy.patch
Normal file
12
evolution-2.21.4-too-noisy.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up evolution-2.21.4/plugins/mail-notification/mail-notification.c.too-noisy evolution-2.21.4/plugins/mail-notification/mail-notification.c
|
||||||
|
--- evolution-2.21.4/plugins/mail-notification/mail-notification.c.too-noisy 2007-12-15 10:58:55.000000000 -0500
|
||||||
|
+++ evolution-2.21.4/plugins/mail-notification/mail-notification.c 2007-12-17 12:41:26.000000000 -0500
|
||||||
|
@@ -581,7 +581,7 @@ static void
|
||||||
|
new_notify_sound (EMEventTargetFolder *t)
|
||||||
|
{
|
||||||
|
time_t last_newmail;
|
||||||
|
- struct _SoundNotifyData data = {0, 0};
|
||||||
|
+ static struct _SoundNotifyData data = {0, 0};
|
||||||
|
|
||||||
|
time (&last_newmail);
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
--- evolution-2.4.1/shell/apps_evolution_shell.schemas.in.hide-switcher-buttons-by-default 2005-10-26 16:21:15.000000000 -0400
|
|
||||||
+++ evolution-2.4.1/shell/apps_evolution_shell.schemas.in 2005-10-26 16:21:22.000000000 -0400
|
|
||||||
@@ -99,7 +99,7 @@
|
|
||||||
<applyto>/apps/evolution/shell/view_defaults/buttons_visible</applyto>
|
|
||||||
<owner>evolution</owner>
|
|
||||||
<type>bool</type>
|
|
||||||
- <default>TRUE</default>
|
|
||||||
+ <default>FALSE</default>
|
|
||||||
<locale name="C">
|
|
||||||
<short>Window buttons are visible</short>
|
|
||||||
<long>Whether the window buttons should be visible.</long>
|
|
File diff suppressed because it is too large
Load Diff
@ -1,46 +0,0 @@
|
|||||||
--- evolution-2.9.3/mail/mail-ops.c.view-attachment-uri 2006-12-06 10:26:24.000000000 -0500
|
|
||||||
+++ evolution-2.9.3/mail/mail-ops.c 2006-12-06 11:16:46.000000000 -0500
|
|
||||||
@@ -2089,21 +2089,23 @@
|
|
||||||
save_part_save (struct _mail_msg *mm)
|
|
||||||
{
|
|
||||||
struct _save_part_msg *m = (struct _save_part_msg *)mm;
|
|
||||||
+ mode_t mode = S_IRUSR | S_IRGRP | S_IROTH;
|
|
||||||
+ int flags = O_WRONLY | O_CREAT | O_TRUNC;
|
|
||||||
CamelDataWrapper *content;
|
|
||||||
CamelStream *stream;
|
|
||||||
-
|
|
||||||
- if(!m->readonly){
|
|
||||||
- if (!(stream = camel_stream_vfs_new_with_uri (m->path, O_WRONLY | O_CREAT | O_TRUNC, 0644))) {
|
|
||||||
- camel_exception_setv (&mm->ex, CAMEL_EXCEPTION_SYSTEM,
|
|
||||||
- _("Cannot create output file: %s:\n %s"),
|
|
||||||
- m->path, g_strerror (errno));
|
|
||||||
- return;
|
|
||||||
- }
|
|
||||||
- } else if (!(stream = camel_stream_vfs_new_with_uri (m->path, O_WRONLY | O_CREAT | O_TRUNC, 0444))) {
|
|
||||||
+ gchar *uri;
|
|
||||||
+
|
|
||||||
+ uri = g_filename_to_uri (m->path, NULL, NULL);
|
|
||||||
+
|
|
||||||
+ if (!m->readonly)
|
|
||||||
+ mode |= S_IWUSR;
|
|
||||||
+
|
|
||||||
+ stream = camel_stream_vfs_new_with_uri (uri, flags, mode);
|
|
||||||
+ if (stream == NULL) {
|
|
||||||
camel_exception_setv (&mm->ex, CAMEL_EXCEPTION_SYSTEM,
|
|
||||||
_("Cannot create output file: %s:\n %s"),
|
|
||||||
m->path, g_strerror (errno));
|
|
||||||
- return;
|
|
||||||
+ goto exit;
|
|
||||||
}
|
|
||||||
|
|
||||||
content = camel_medium_get_content_object (CAMEL_MEDIUM (m->part));
|
|
||||||
@@ -2115,6 +2117,9 @@
|
|
||||||
g_strerror (errno));
|
|
||||||
|
|
||||||
camel_object_unref (stream);
|
|
||||||
+
|
|
||||||
+exit:
|
|
||||||
+ g_free (uri);
|
|
||||||
}
|
|
||||||
|
|
||||||
static void
|
|
@ -1,6 +1,6 @@
|
|||||||
%define dbus_glib_version 0.70
|
%define dbus_glib_version 0.70
|
||||||
%define dbus_version 1.0
|
%define dbus_version 1.0
|
||||||
%define eds_version 2.21.3
|
%define eds_version 2.21.4
|
||||||
%define gnome_doc_utils_version 0.8.0
|
%define gnome_doc_utils_version 0.8.0
|
||||||
%define gnome_icon_theme_version 2.19.91
|
%define gnome_icon_theme_version 2.19.91
|
||||||
%define gnome_pilot_version 2.0.15
|
%define gnome_pilot_version 2.0.15
|
||||||
@ -44,8 +44,8 @@
|
|||||||
### Abstract ###
|
### Abstract ###
|
||||||
|
|
||||||
Name: evolution
|
Name: evolution
|
||||||
Version: 2.21.3
|
Version: 2.21.4
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2 and GFDL+
|
License: GPLv2 and GFDL+
|
||||||
Group: Applications/Productivity
|
Group: Applications/Productivity
|
||||||
Summary: GNOME's next-generation groupware suite
|
Summary: GNOME's next-generation groupware suite
|
||||||
@ -66,50 +66,42 @@ Patch11: evolution-2.5.5.1-commit-enter-on-calendar.patch
|
|||||||
# Fix for RH bug 164957 (was for 145552):
|
# Fix for RH bug 164957 (was for 145552):
|
||||||
Patch12: evolution-2.0.2-fix-145552.patch
|
Patch12: evolution-2.0.2-fix-145552.patch
|
||||||
|
|
||||||
# Part of RH bug 170799:
|
|
||||||
# XXX Revert this for Fedora 9
|
|
||||||
#Patch13: evolution-2.4.1-hide-switcher-buttons-by-default.patch
|
|
||||||
|
|
||||||
# Patches for conduits, based upon
|
# Patches for conduits, based upon
|
||||||
# rh-161817-attach-116019-conduit_pilot_link_updates.diff
|
# rh-161817-attach-116019-conduit_pilot_link_updates.diff
|
||||||
# (the latter patch was originally by Mark G. Adams):
|
# (the latter patch was originally by Mark G. Adams):
|
||||||
# Patch14: evolution-2.5.4-fix-conduits.patch
|
# Patch13: evolution-2.5.4-fix-conduits.patch
|
||||||
|
|
||||||
# Move .conduit files from share to lib (for the sake of multilib)
|
# Move .conduit files from share to lib (for the sake of multilib)
|
||||||
# This patch effects other parts of evolution.spec and so is necessary
|
# This patch effects other parts of evolution.spec and so is necessary
|
||||||
# for a successful build.
|
# for a successful build.
|
||||||
Patch15: evolution-2.5.4-fix-conduit-dir.patch
|
Patch14: evolution-2.5.4-fix-conduit-dir.patch
|
||||||
|
|
||||||
# Remove gnome-common macros from configure.in.
|
# Remove gnome-common macros from configure.in.
|
||||||
# We do not ship gnome-common (or at least we're not supposed to).
|
# We do not ship gnome-common (or at least we're not supposed to).
|
||||||
Patch16: evolution-2.7.1-no-gnome-common.patch
|
Patch15: evolution-2.7.1-no-gnome-common.patch
|
||||||
|
|
||||||
#Patch17: evolution-2.7.1-notification-cleanups.patch
|
#Patch16: evolution-2.7.1-notification-cleanups.patch
|
||||||
|
|
||||||
# RH bug #166231 / GNOME bug #264485
|
# RH bug #166231 / GNOME bug #264485
|
||||||
Patch20: evolution-2.7.3-replicated-cjk-input.patch
|
Patch17: evolution-2.7.3-replicated-cjk-input.patch
|
||||||
|
|
||||||
# RH bug #178295 / GNOME bug #348638
|
# RH bug #178295 / GNOME bug #348638
|
||||||
Patch21: evolution-2.7.4-deleting-preedit-buffer.patch
|
Patch18: evolution-2.7.4-deleting-preedit-buffer.patch
|
||||||
|
|
||||||
# GNOME bug #362638
|
# GNOME bug #362638
|
||||||
Patch25: evolution-2.8.1-kill-ethread.patch
|
Patch19: evolution-2.8.1-kill-ethread.patch
|
||||||
|
|
||||||
# GNOME bug #363695
|
# GNOME bug #363695
|
||||||
Patch26: evolution-2.9.1-kill-ememory.patch
|
Patch20: evolution-2.9.1-kill-ememory.patch
|
||||||
|
|
||||||
# RH bug #176400
|
# RH bug #176400
|
||||||
Patch27: evolution-2.9.1-im-context-reset.patch
|
Patch21: evolution-2.9.1-im-context-reset.patch
|
||||||
|
|
||||||
# RH bug #216537 / GNOME bug #383047
|
|
||||||
#Patch29: evolution-2.9.3-view-attachment-uri.patch
|
|
||||||
|
|
||||||
# RH bug #215478 / GNOME bug #383842
|
# RH bug #215478 / GNOME bug #383842
|
||||||
Patch30: evolution-2.9.3-source-path-entry.patch
|
Patch22: evolution-2.9.3-source-path-entry.patch
|
||||||
|
|
||||||
# GNOME bug #376991
|
# GNOME bug #504030
|
||||||
# XXX Disabled due to outstanding issues.
|
Patch23: evolution-2.21.4-too-noisy.patch
|
||||||
#Patch33: evolution-2.10.0-e-passwords.patch
|
|
||||||
|
|
||||||
## Dependencies ###
|
## Dependencies ###
|
||||||
|
|
||||||
@ -249,19 +241,17 @@ This package contains the plugin to filter junk mail using SpamAssassin.
|
|||||||
%patch10 -p1 -b .ldaphack
|
%patch10 -p1 -b .ldaphack
|
||||||
%patch11 -p1 -b .commit-enter-on-calendar
|
%patch11 -p1 -b .commit-enter-on-calendar
|
||||||
%patch12 -p1 -b .fix-164957
|
%patch12 -p1 -b .fix-164957
|
||||||
#patch13 -p1 -b .hide-switcher-buttons-by-default
|
#patch13 -p1 -b .fix-conduits # leave commented
|
||||||
#patch14 -p1 -b .fix-conduits # leave commented
|
%patch14 -p1 -b .fix-conduit-dir
|
||||||
%patch15 -p1 -b .fix-conduit-dir
|
%patch15 -p1 -b .no-gnome-common
|
||||||
%patch16 -p1 -b .no-gnome-common
|
#patch16 -p1 -b .notification-cleanups
|
||||||
#patch17 -p1 -b .notification-cleanups
|
%patch17 -p1 -b .replicated-cjk-input
|
||||||
%patch20 -p1 -b .replicated-cjk-input
|
%patch18 -p1 -b .deleting-preedit-buffer
|
||||||
%patch21 -p1 -b .deleting-preedit-buffer
|
%patch19 -p1 -b .kill-ethread
|
||||||
%patch25 -p1 -b .kill-ethread
|
%patch20 -p1 -b .kill-ememory
|
||||||
%patch26 -p1 -b .kill-ememory
|
%patch21 -p1 -b .im-context-reset
|
||||||
%patch27 -p1 -b .im-context-reset
|
%patch22 -p1 -b .source-path-entry
|
||||||
#%patch29 -p1 -b .view-attachment-uri
|
%patch23 -p1 -b .too-noisy
|
||||||
%patch30 -p1 -b .source-path-entry
|
|
||||||
#%patch33 -p1 -b .e-passwords
|
|
||||||
|
|
||||||
mkdir -p krb5-fakeprefix/include
|
mkdir -p krb5-fakeprefix/include
|
||||||
mkdir -p krb5-fakeprefix/lib
|
mkdir -p krb5-fakeprefix/lib
|
||||||
@ -694,6 +684,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{evo_plugin_dir}/liborg-gnome-sa-junk-plugin.so
|
%{evo_plugin_dir}/liborg-gnome-sa-junk-plugin.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 17 2007 Matthew Barnes <mbarnes@redhat.com> - 2.21.4-1.fc9
|
||||||
|
- Update to 2.21.4
|
||||||
|
- Expunge unused patches.
|
||||||
|
- Bump eds_version to 2.21.4 for new Camel functions.
|
||||||
|
|
||||||
* Mon Dec 10 2007 Matthew Barnes <mbarnes@redhat.com> - 2.21.3-4.fc9
|
* Mon Dec 10 2007 Matthew Barnes <mbarnes@redhat.com> - 2.21.3-4.fc9
|
||||||
- Split junk filtering plugins into evolution-bogofilter and
|
- Split junk filtering plugins into evolution-bogofilter and
|
||||||
evolution-spamassassin subpackages, each of which requires the
|
evolution-spamassassin subpackages, each of which requires the
|
||||||
|
Loading…
Reference in New Issue
Block a user