Add patch by Philip Withnall to build against libgdata-0.9.0

This commit is contained in:
Milan Crha 2011-06-14 07:25:08 +02:00
parent 7e093eea45
commit a00837c9f6
2 changed files with 63 additions and 0 deletions

View File

@ -0,0 +1,59 @@
diff --git a/configure.ac b/configure.ac
index 1078197..903e50e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1283,10 +1283,14 @@ EVO_SET_COMPILE_FLAGS(LIBSOUP, libsoup-gnome-2.4 >= libsoup_minimum_version)
AC_SUBST(LIBSOUP_CFLAGS)
AC_SUBST(LIBSOUP_LIBS)
-EVO_SET_COMPILE_FLAGS(GDATA, libgdata >= 0.4.0)
+EVO_SET_COMPILE_FLAGS(GDATA, libgdata >= 0.7.0)
AC_SUBST(GDATA_CFLAGS)
AC_SUBST(GDATA_LIBS)
+if `$PKG_CONFIG --atleast-version=0.9 libgdata`; then
+ AC_DEFINE(HAVE_LIBGDATA_0_9,1,[libgdata is 0.9 or higher])
+fi
+
EVO_SET_COMPILE_FLAGS(EVOLUTION_CALENDAR, libgtkhtml-4.0 libebook-1.2 libecal-1.2 libedataserverui-3.0 libebackend-1.2 $libnotify gtkhtml-editor-4.0)
AC_SUBST(EVOLUTION_CALENDAR_CFLAGS)
AC_SUBST(EVOLUTION_CALENDAR_LIBS)
diff --git a/plugins/google-account-setup/google-source.c b/plugins/google-account-setup/google-source.c
index 1fce985..1e54362 100644
--- a/plugins/google-account-setup/google-source.c
+++ b/plugins/google-account-setup/google-source.c
@@ -418,6 +418,9 @@ static void
retrieve_list_clicked (GtkButton *button, GtkComboBox *combo)
{
ESource *source;
+ #ifdef HAVE_LIBGDATA_0_9
+ GDataClientLoginAuthorizer *authorizer;
+ #endif
GDataCalendarService *service;
GDataFeed *feed;
gchar *user, *password, *tmp;
@@ -448,8 +451,14 @@ retrieve_list_clicked (GtkButton *button, GtkComboBox *combo)
return;
}
+ #ifdef HAVE_LIBGDATA_0_9
+ authorizer = gdata_client_login_authorizer_new ("evolution-client-0.1.0", GDATA_TYPE_CALENDAR_SERVICE);
+ service = gdata_calendar_service_new (GDATA_AUTHORIZER (authorizer));
+ if (!gdata_client_login_authorizer_authenticate (authorizer, user, password, NULL, &error)) {
+ #else
service = gdata_calendar_service_new ("evolution-client-0.1.0");
if (!gdata_service_authenticate (GDATA_SERVICE (service), user, password, NULL, &error)) {
+ #endif
/* Error! */
claim_error (parent, error->message);
g_error_free (error);
@@ -559,6 +568,9 @@ retrieve_list_clicked (GtkButton *button, GtkComboBox *combo)
}
g_object_unref (service);
+ #ifdef HAVE_LIBGDATA_0_9
+ g_object_unref (authorizer);
+ #endif
g_free (user);
}

View File

@ -47,6 +47,8 @@ Patch10: evolution-1.4.4-ldap-x86_64-hack.patch
# RH bug #589555
Patch13: evolution-2.30.1-help-contents.patch
Patch14: evolution-3.1.2-libgdata_0_9.patch
## Dependencies ###
Requires(pre): GConf2
@ -202,6 +204,7 @@ This package contains the plugin to import Microsoft Personal Storage Table
%setup -q -n evolution-%{version}
%patch10 -p1 -b .ldaphack
%patch13 -p1 -b .help-contents
%patch14 -p1 -b .libgdata_0_9
mkdir -p krb5-fakeprefix/include
mkdir -p krb5-fakeprefix/lib
@ -626,6 +629,7 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Jun 14 2011 Milan Crha <mcrha@redhat.com> - 3.1.2-1
- Update to 3.1.2
- Add patch by Philip Withnall to build against libgdata-0.9.0
* Tue May 17 2011 Milan Crha <mcrha@redhat.com> - 3.1.1-3
- Keep libevolution-mail-settings.so* from the previous change,