Update to 3.21.90
This commit is contained in:
parent
88dcc2bbb4
commit
89372a60e2
1
.gitignore
vendored
1
.gitignore
vendored
@ -110,3 +110,4 @@ evolution-2.31.5.tar.bz2
|
|||||||
/evolution-3.21.2.tar.xz
|
/evolution-3.21.2.tar.xz
|
||||||
/evolution-3.21.3.tar.xz
|
/evolution-3.21.3.tar.xz
|
||||||
/evolution-3.21.4.tar.xz
|
/evolution-3.21.4.tar.xz
|
||||||
|
/evolution-3.21.90.tar.xz
|
||||||
|
46
evolution-3.21.90-ldflags.patch
Normal file
46
evolution-3.21.90-ldflags.patch
Normal file
@ -0,0 +1,46 @@
|
|||||||
|
diff --git a/modules/itip-formatter/web-extension/Makefile.am b/modules/itip-formatter/web-extension/Makefile.am
|
||||||
|
index a519744..87df8e6 100644
|
||||||
|
--- a/modules/itip-formatter/web-extension/Makefile.am
|
||||||
|
+++ b/modules/itip-formatter/web-extension/Makefile.am
|
||||||
|
@@ -21,6 +21,6 @@ libmoduleitipformatterwebextension_la_LIBADD = \
|
||||||
|
$(WEB_EXTENSIONS_LIBS)
|
||||||
|
|
||||||
|
libmoduleitipformatterwebextension_la_LDFLAGS = \
|
||||||
|
- -module -avoid-version -no-undefined
|
||||||
|
+ -module -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
|
||||||
|
|
||||||
|
-include $(top_srcdir)/git.mk
|
||||||
|
diff --git a/modules/webkit-editor/web-extension/Makefile.am b/modules/webkit-editor/web-extension/Makefile.am
|
||||||
|
index f2a7b02..2d31253 100644
|
||||||
|
--- a/modules/webkit-editor/web-extension/Makefile.am
|
||||||
|
+++ b/modules/webkit-editor/web-extension/Makefile.am
|
||||||
|
@@ -33,6 +33,6 @@ libewebkiteditorwebextension_la_LIBADD = \
|
||||||
|
$(WEB_EXTENSIONS_LIBS)
|
||||||
|
|
||||||
|
libewebkiteditorwebextension_la_LDFLAGS = \
|
||||||
|
- -module -avoid-version -no-undefined
|
||||||
|
+ -module -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
|
||||||
|
|
||||||
|
-include $(top_srcdir)/git.mk
|
||||||
|
diff --git a/web-extensions/Makefile.am b/web-extensions/Makefile.am
|
||||||
|
index 07854c2..d98f361 100644
|
||||||
|
--- a/web-extensions/Makefile.am
|
||||||
|
+++ b/web-extensions/Makefile.am
|
||||||
|
@@ -16,6 +16,8 @@ libedomutils_la_LIBADD = \
|
||||||
|
$(EVOLUTION_DATA_SERVER_LIBS) \
|
||||||
|
$(GNOME_PLATFORM_LIBS)
|
||||||
|
|
||||||
|
+libedomutils_la_LDFLAGS = -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
|
||||||
|
+
|
||||||
|
libewebextension_la_SOURCES = \
|
||||||
|
e-web-extension.h \
|
||||||
|
e-web-extension-names.h \
|
||||||
|
@@ -38,7 +40,6 @@ libewebextension_la_LIBADD = \
|
||||||
|
$(GNOME_PLATFORM_LIBS) \
|
||||||
|
$(WEB_EXTENSIONS_LIBS)
|
||||||
|
|
||||||
|
-libewebextension_la_LDFLAGS = \
|
||||||
|
- -module -avoid-version -no-undefined
|
||||||
|
+libewebextension_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
|
||||||
|
|
||||||
|
-include $(top_srcdir)/git.mk
|
@ -8,7 +8,7 @@
|
|||||||
%define libgdata_version 0.10.0
|
%define libgdata_version 0.10.0
|
||||||
%define libgweather_version 3.5.0
|
%define libgweather_version 3.5.0
|
||||||
%define libsoup_version 2.42
|
%define libsoup_version 2.42
|
||||||
%define webkit_version 2.2.0
|
%define webkit2gtk_version 2.13.0
|
||||||
|
|
||||||
%define evo_base_version 3.22
|
%define evo_base_version 3.22
|
||||||
|
|
||||||
@ -28,7 +28,7 @@
|
|||||||
### Abstract ###
|
### Abstract ###
|
||||||
|
|
||||||
Name: evolution
|
Name: evolution
|
||||||
Version: 3.21.4
|
Version: 3.21.90
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Group: Applications/Productivity
|
Group: Applications/Productivity
|
||||||
Summary: Mail and calendar client for GNOME
|
Summary: Mail and calendar client for GNOME
|
||||||
@ -46,6 +46,8 @@ Obsoletes: evolution-NetworkManager < %{last_evo_nm_version}
|
|||||||
# RH bug #
|
# RH bug #
|
||||||
#Patch01: evolution-3.17.1-doc-e-cell-renderer-color.patch
|
#Patch01: evolution-3.17.1-doc-e-cell-renderer-color.patch
|
||||||
|
|
||||||
|
Patch01: evolution-3.21.90-ldflags.patch
|
||||||
|
|
||||||
## Dependencies ###
|
## Dependencies ###
|
||||||
|
|
||||||
Requires: gvfs
|
Requires: gvfs
|
||||||
@ -94,7 +96,7 @@ BuildRequires: pkgconfig(libxml-2.0)
|
|||||||
BuildRequires: pkgconfig(nspr)
|
BuildRequires: pkgconfig(nspr)
|
||||||
BuildRequires: pkgconfig(nss)
|
BuildRequires: pkgconfig(nss)
|
||||||
BuildRequires: pkgconfig(shared-mime-info)
|
BuildRequires: pkgconfig(shared-mime-info)
|
||||||
BuildRequires: pkgconfig(webkitgtk-3.0) >= %{webkit_version}
|
BuildRequires: pkgconfig(webkit2gtk-4.0) >= %{webkit2gtk_version}
|
||||||
|
|
||||||
%if %{ldap_support}
|
%if %{ldap_support}
|
||||||
BuildRequires: openldap-devel >= 2.0.11
|
BuildRequires: openldap-devel >= 2.0.11
|
||||||
@ -200,6 +202,7 @@ the functionality of the installed %{name} package.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n evolution-%{version}
|
%setup -q -n evolution-%{version}
|
||||||
#%patch01 -p1 -b .doc-e-cell-renderer-color
|
#%patch01 -p1 -b .doc-e-cell-renderer-color
|
||||||
|
%patch01 -p1 -b .ldflags
|
||||||
|
|
||||||
# Remove the welcome email from Novell
|
# Remove the welcome email from Novell
|
||||||
for inbox in mail/default/*/Inbox; do
|
for inbox in mail/default/*/Inbox; do
|
||||||
@ -294,6 +297,9 @@ find $RPM_BUILD_ROOT/%{_libdir}/evolution -name '*.la' -exec rm {} \;
|
|||||||
# remove statically built libraries:
|
# remove statically built libraries:
|
||||||
find $RPM_BUILD_ROOT/%{_libdir}/evolution -name '*.a' -exec rm {} \;
|
find $RPM_BUILD_ROOT/%{_libdir}/evolution -name '*.a' -exec rm {} \;
|
||||||
|
|
||||||
|
# remove test GIO modules directory
|
||||||
|
rm -r $RPM_BUILD_ROOT/%{_libdir}/evolution/test-gio-modules
|
||||||
|
|
||||||
%find_lang evolution-%{evo_base_version} --all-name --with-gnome
|
%find_lang evolution-%{evo_base_version} --all-name --with-gnome
|
||||||
|
|
||||||
grep "/usr/share/locale" evolution-%{evo_base_version}.lang > translations.lang
|
grep "/usr/share/locale" evolution-%{evo_base_version}.lang > translations.lang
|
||||||
@ -402,7 +408,8 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/evolution/modules/module-startup-wizard.so
|
%{_libdir}/evolution/modules/module-startup-wizard.so
|
||||||
%{_libdir}/evolution/modules/module-text-highlight.so
|
%{_libdir}/evolution/modules/module-text-highlight.so
|
||||||
%{_libdir}/evolution/modules/module-vcard-inline.so
|
%{_libdir}/evolution/modules/module-vcard-inline.so
|
||||||
%{_libdir}/evolution/modules/module-web-inspector.so
|
%{_libdir}/evolution/modules/module-webkit-editor.so
|
||||||
|
%{_libdir}/evolution/modules/module-webkit-inspector.so
|
||||||
|
|
||||||
# Shared libraries:
|
# Shared libraries:
|
||||||
%{_libdir}/evolution/libevolution-mail-composer.so
|
%{_libdir}/evolution/libevolution-mail-composer.so
|
||||||
@ -422,6 +429,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/evolution/libevolution-smime.so
|
%{_libdir}/evolution/libevolution-smime.so
|
||||||
%{_libdir}/evolution/libgnomecanvas.so
|
%{_libdir}/evolution/libgnomecanvas.so
|
||||||
|
|
||||||
|
# WebKit2 Extensions
|
||||||
|
%{_libdir}/evolution/web-extensions/libedomutils.so
|
||||||
|
%{_libdir}/evolution/web-extensions/libewebextension.so
|
||||||
|
%{_libdir}/evolution/web-extensions/libmoduleitipformatterwebextension.so
|
||||||
|
%{_libdir}/evolution/web-extensions/webkit-editor/libewebkiteditorwebextension.so
|
||||||
|
|
||||||
# Various libexec programs:
|
# Various libexec programs:
|
||||||
%dir %{_libexecdir}/evolution
|
%dir %{_libexecdir}/evolution
|
||||||
%{_libexecdir}/evolution/evolution-alarm-notify
|
%{_libexecdir}/evolution/evolution-alarm-notify
|
||||||
@ -515,6 +528,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 15 2016 Milan Crha <mcrha@redhat.com> - 3.21.90-1
|
||||||
|
- Update to 3.21.90
|
||||||
|
|
||||||
* Mon Jul 18 2016 Milan Crha <mcrha@redhat.com> - 3.21.4-1
|
* Mon Jul 18 2016 Milan Crha <mcrha@redhat.com> - 3.21.4-1
|
||||||
- Update to 3.21.4
|
- Update to 3.21.4
|
||||||
- Remove the "perl" subpackage (code moved to the evolution-data-server)
|
- Remove the "perl" subpackage (code moved to the evolution-data-server)
|
||||||
|
Loading…
Reference in New Issue
Block a user