- Update to 2.8.1
- Use stricter build settings. - Make .desktop symlinks absolute (RH bug #209322). - Add patch for RH bug #202751 (printing of indic languages). - Add patch for Gnome.org bug #357970 (deprecated GLib / GDK symbols). - Add patch for Gnome.org bug #359236 (search state crash). - Add patch for Gnome.org bug #360240 ("unused variable" warnings). - Add patch for Gnome.org bug #360619 ("incompatible pointer type" warnings). - Add patch for Gnome.org bug #360946 (improved "about" dialog). - Add patch for Gnome.org bug #362638 (deprecate EThread). - Update patch for RH bug #211058 (partially fixed upstream). - Remove patch for RH bug #201307 (fixed upstream). - Remove patch for RH bug #205576 (fixed upstream). - Remove patch for Gnome.org bug #351332 (fixed upstream). - Remove patch for Gnome.org bug #352450 (fixed upstream). - Remove patch for Gnome.org bug #353472 (fixed upstream). - Remove patch for Gnome.org bug #356811 (fixed upstream).
This commit is contained in:
parent
599d12e300
commit
829392f14f
@ -1 +1 @@
|
||||
evolution-2.8.0.tar.bz2
|
||||
evolution-2.8.1.tar.bz2
|
||||
|
@ -176,253 +176,3 @@ diff -ur evolution-2.7.3/filter/filter-datespec.h my-evolution-2.7.3/filter/filt
|
||||
*/
|
||||
|
||||
time_t value;
|
||||
diff -ur evolution-2.7.3/filter/filter.glade my-evolution-2.7.3/filter/filter.glade
|
||||
--- evolution-2.7.3/filter/filter.glade 2005-12-20 11:21:51.000000000 -0700
|
||||
+++ my-evolution-2.7.3/filter/filter.glade 2006-06-28 17:26:00.000000000 -0600
|
||||
@@ -12,6 +12,13 @@
|
||||
<property name="modal">False</property>
|
||||
<property name="resizable">True</property>
|
||||
<property name="destroy_with_parent">False</property>
|
||||
+ <property name="decorated">True</property>
|
||||
+ <property name="skip_taskbar_hint">False</property>
|
||||
+ <property name="skip_pager_hint">False</property>
|
||||
+ <property name="type_hint">GDK_WINDOW_TYPE_HINT_NORMAL</property>
|
||||
+ <property name="gravity">GDK_GRAVITY_NORTH_WEST</property>
|
||||
+ <property name="focus_on_map">True</property>
|
||||
+ <property name="urgency_hint">False</property>
|
||||
|
||||
<child>
|
||||
<widget class="GtkVBox" id="rule_editor">
|
||||
@@ -21,7 +28,7 @@
|
||||
<property name="spacing">6</property>
|
||||
|
||||
<child>
|
||||
- <widget class="GtkLabel" id="label17">
|
||||
+ <widget class="GtkLabel" id="label17">
|
||||
<property name="visible">True</property>
|
||||
<property name="label" translatable="yes">Show filters for mail:</property>
|
||||
<property name="use_underline">False</property>
|
||||
@@ -33,6 +40,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
@@ -86,6 +97,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
@@ -113,6 +128,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
@@ -162,6 +181,7 @@
|
||||
<property name="label">gtk-add</property>
|
||||
<property name="use_stock">True</property>
|
||||
<property name="relief">GTK_RELIEF_NORMAL</property>
|
||||
+ <property name="focus_on_click">True</property>
|
||||
</widget>
|
||||
</child>
|
||||
|
||||
@@ -173,6 +193,7 @@
|
||||
<property name="label" translatable="yes">_Edit</property>
|
||||
<property name="use_underline">True</property>
|
||||
<property name="relief">GTK_RELIEF_NORMAL</property>
|
||||
+ <property name="focus_on_click">True</property>
|
||||
</widget>
|
||||
</child>
|
||||
|
||||
@@ -184,6 +205,7 @@
|
||||
<property name="label">gtk-remove</property>
|
||||
<property name="use_stock">True</property>
|
||||
<property name="relief">GTK_RELIEF_NORMAL</property>
|
||||
+ <property name="focus_on_click">True</property>
|
||||
</widget>
|
||||
</child>
|
||||
|
||||
@@ -195,6 +217,7 @@
|
||||
<property name="label">gtk-goto-top</property>
|
||||
<property name="use_stock">True</property>
|
||||
<property name="relief">GTK_RELIEF_NORMAL</property>
|
||||
+ <property name="focus_on_click">True</property>
|
||||
</widget>
|
||||
</child>
|
||||
|
||||
@@ -206,6 +229,7 @@
|
||||
<property name="label">gtk-go-up</property>
|
||||
<property name="use_stock">True</property>
|
||||
<property name="relief">GTK_RELIEF_NORMAL</property>
|
||||
+ <property name="focus_on_click">True</property>
|
||||
</widget>
|
||||
</child>
|
||||
|
||||
@@ -217,6 +241,7 @@
|
||||
<property name="label">gtk-go-down</property>
|
||||
<property name="use_stock">True</property>
|
||||
<property name="relief">GTK_RELIEF_NORMAL</property>
|
||||
+ <property name="focus_on_click">True</property>
|
||||
</widget>
|
||||
</child>
|
||||
|
||||
@@ -228,6 +253,7 @@
|
||||
<property name="label">gtk-goto-bottom</property>
|
||||
<property name="use_stock">True</property>
|
||||
<property name="relief">GTK_RELIEF_NORMAL</property>
|
||||
+ <property name="focus_on_click">True</property>
|
||||
</widget>
|
||||
</child>
|
||||
</widget>
|
||||
@@ -278,6 +304,13 @@
|
||||
<property name="modal">False</property>
|
||||
<property name="resizable">True</property>
|
||||
<property name="destroy_with_parent">False</property>
|
||||
+ <property name="decorated">True</property>
|
||||
+ <property name="skip_taskbar_hint">False</property>
|
||||
+ <property name="skip_pager_hint">False</property>
|
||||
+ <property name="type_hint">GDK_WINDOW_TYPE_HINT_NORMAL</property>
|
||||
+ <property name="gravity">GDK_GRAVITY_NORTH_WEST</property>
|
||||
+ <property name="focus_on_map">True</property>
|
||||
+ <property name="urgency_hint">False</property>
|
||||
|
||||
<child>
|
||||
<widget class="GtkVBox" id="filter_datespec">
|
||||
@@ -305,6 +338,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
@@ -403,6 +440,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
@@ -430,6 +471,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="type">tab</property>
|
||||
@@ -456,6 +501,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
@@ -496,6 +545,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="type">tab</property>
|
||||
@@ -522,6 +575,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
@@ -631,18 +688,32 @@
|
||||
</child>
|
||||
|
||||
<child>
|
||||
- <widget class="GtkLabel" id="label8">
|
||||
+ <widget class="GtkOptionMenu" id="option_past_future">
|
||||
<property name="visible">True</property>
|
||||
- <property name="label" translatable="yes">ago</property>
|
||||
- <property name="use_underline">False</property>
|
||||
- <property name="use_markup">False</property>
|
||||
- <property name="justify">GTK_JUSTIFY_CENTER</property>
|
||||
- <property name="wrap">False</property>
|
||||
- <property name="selectable">False</property>
|
||||
- <property name="xalign">7.45058e-09</property>
|
||||
- <property name="yalign">0.5</property>
|
||||
- <property name="xpad">0</property>
|
||||
- <property name="ypad">0</property>
|
||||
+ <property name="can_focus">True</property>
|
||||
+ <property name="history">0</property>
|
||||
+
|
||||
+ <child internal-child="menu">
|
||||
+ <widget class="GtkMenu" id="convertwidget31">
|
||||
+ <property name="visible">True</property>
|
||||
+
|
||||
+ <child>
|
||||
+ <widget class="GtkMenuItem" id="convertwidget32">
|
||||
+ <property name="visible">True</property>
|
||||
+ <property name="label" translatable="yes">ago</property>
|
||||
+ <property name="use_underline">True</property>
|
||||
+ </widget>
|
||||
+ </child>
|
||||
+
|
||||
+ <child>
|
||||
+ <widget class="GtkMenuItem" id="convertwidget33">
|
||||
+ <property name="visible">True</property>
|
||||
+ <property name="label" translatable="yes">in the future</property>
|
||||
+ <property name="use_underline">True</property>
|
||||
+ </widget>
|
||||
+ </child>
|
||||
+ </widget>
|
||||
+ </child>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
@@ -677,6 +748,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
<property name="ypad">0</property>
|
||||
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
|
||||
+ <property name="width_chars">-1</property>
|
||||
+ <property name="single_line_mode">False</property>
|
||||
+ <property name="angle">0</property>
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="type">tab</property>
|
||||
|
82
evolution-2.8.0-fix-indic-printing.patch
Normal file
82
evolution-2.8.0-fix-indic-printing.patch
Normal file
@ -0,0 +1,82 @@
|
||||
--- evolution-2.8.1/plugins/print-message/print-message.c.fix-indic-printing 2005-08-23 23:14:10.000000000 -0400
|
||||
+++ evolution-2.8.1/plugins/print-message/print-message.c 2006-10-10 10:35:17.000000000 -0400
|
||||
@@ -83,7 +83,8 @@
|
||||
data->config = e_print_load_config ();
|
||||
data->preview = 0;
|
||||
|
||||
- data->msg = e_msg_composer_get_message (composer, 1);
|
||||
+ data->msg = e_msg_composer_get_message_print (composer, TRUE);
|
||||
+
|
||||
dialog = (GtkDialog *)e_print_get_dialog_with_config (_("Print Message"), GNOME_PRINT_DIALOG_COPIES, data->config);
|
||||
gtk_dialog_set_default_response(dialog, GNOME_PRINT_DIALOG_RESPONSE_PRINT);
|
||||
e_dialog_set_transient_for ((GtkWindow *) dialog, (GtkWidget *) composer);
|
||||
@@ -104,7 +105,7 @@
|
||||
data->config = e_print_load_config ();
|
||||
data->preview = 0;
|
||||
|
||||
- data->msg = e_msg_composer_get_message (composer, 1);
|
||||
+ data->msg = e_msg_composer_get_message_print (composer, TRUE);
|
||||
|
||||
print_response(NULL, GNOME_PRINT_DIALOG_RESPONSE_PREVIEW, data);
|
||||
}
|
||||
--- evolution-2.8.1/composer/e-msg-composer.h.fix-indic-printing 2005-12-07 03:29:51.000000000 -0500
|
||||
+++ evolution-2.8.1/composer/e-msg-composer.h 2006-10-10 10:35:17.000000000 -0400
|
||||
@@ -94,6 +94,8 @@
|
||||
const char *filename);
|
||||
void e_msg_composer_add_inline_image_from_mime_part (EMsgComposer *composer,
|
||||
CamelMimePart *part);
|
||||
+CamelMimeMessage *e_msg_composer_get_message_print (EMsgComposer *composer,
|
||||
+ gboolean save_html_object_data);
|
||||
CamelMimeMessage *e_msg_composer_get_message (EMsgComposer *composer,
|
||||
gboolean save_html_object_data);
|
||||
CamelMimeMessage *e_msg_composer_get_message_draft (EMsgComposer *composer);
|
||||
--- evolution-2.8.1/composer/e-msg-composer.c.fix-indic-printing 2006-10-10 10:34:38.000000000 -0400
|
||||
+++ evolution-2.8.1/composer/e-msg-composer.c 2006-10-10 10:35:17.000000000 -0400
|
||||
@@ -5162,6 +5162,38 @@
|
||||
}
|
||||
}
|
||||
|
||||
+/* Stub for helping in printing of mails */
|
||||
+CamelMimeMessage *
|
||||
+e_msg_composer_get_message_print (EMsgComposer *composer, gboolean save_html_object_data)
|
||||
+{
|
||||
+ CamelMimeMessage *msg;
|
||||
+ gboolean old_flags[4];
|
||||
+ gboolean old_send_html;
|
||||
+ EMsgComposerPrivate *p = composer->priv;
|
||||
+
|
||||
+ /* create printable mail as HTML */
|
||||
+ old_send_html = p->send_html;
|
||||
+ p->send_html = TRUE;
|
||||
+ old_flags[0] = p->pgp_sign;
|
||||
+ p->pgp_sign = FALSE;
|
||||
+ old_flags[1] = p->pgp_encrypt;
|
||||
+ p->pgp_encrypt = FALSE;
|
||||
+ old_flags[2] = p->smime_sign;
|
||||
+ p->smime_sign = FALSE;
|
||||
+ old_flags[3] = p->smime_encrypt;
|
||||
+ p->smime_encrypt = FALSE;
|
||||
+
|
||||
+ msg = build_message (composer, save_html_object_data);
|
||||
+
|
||||
+ /* Revert back message's original settings */
|
||||
+ p->send_html = old_send_html;
|
||||
+ p->pgp_sign = old_flags[0];
|
||||
+ p->pgp_encrypt = old_flags[1];
|
||||
+ p->smime_sign = old_flags[2];
|
||||
+ p->smime_encrypt = old_flags[3];
|
||||
+
|
||||
+ return msg;
|
||||
+}
|
||||
|
||||
/**
|
||||
* e_msg_composer_get_message:
|
||||
@@ -5183,7 +5215,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
- return build_message (composer, save_html_object_data);
|
||||
+ return e_msg_composer_get_message_print (composer, save_html_object_data);
|
||||
}
|
||||
|
||||
CamelMimeMessage *
|
125
evolution.spec
125
evolution.spec
@ -34,18 +34,16 @@
|
||||
%endif
|
||||
%define use_mozilla_nss 1
|
||||
|
||||
# Upstream tarballs often contain instances of undeclared functions; these tend
|
||||
# to work on i386 but fail on 64-bit architectures. Leave this on to trap the
|
||||
# warnings as errors (and ideally get the flag into the upstream build):
|
||||
%define require_function_declarations 1
|
||||
# Use stricter build settings than required by upstream.
|
||||
%define strict_build_settings 1
|
||||
|
||||
%define evo_plugin_dir %{_libdir}/evolution/%{evo_major}/plugins
|
||||
|
||||
### Abstract ###
|
||||
|
||||
Name: evolution
|
||||
Version: 2.8.0
|
||||
Release: 7%{?dist}
|
||||
Version: 2.8.1
|
||||
Release: 1%{?dist}
|
||||
License: GPL
|
||||
Group: Applications/Productivity
|
||||
Summary: GNOME's next-generation groupware suite
|
||||
@ -105,32 +103,37 @@ Patch24: evolution-2.7.3-replicated-cjk-input.patch
|
||||
# RH bug #178295 / Gnome.org bug #348638
|
||||
Patch25: evolution-2.7.4-deleting-preedit-buffer.patch
|
||||
|
||||
# Gnome.org bug #352450 (2 patches)
|
||||
Patch26: evolution-2.7.92-deprecated-glib.patch
|
||||
Patch27: evolution-2.7.92-deprecated-gdk.patch
|
||||
|
||||
# RH bug #202289
|
||||
Patch28: evolution-2.7.92-fix-prgname.patch
|
||||
|
||||
# Gnome.org bug #353472
|
||||
Patch29: evolution-2.7.92-chain-finalize.patch
|
||||
|
||||
# Gnome.org bug #351332
|
||||
Patch30: evolution-2.8.0-fix-missing-declarations.patch
|
||||
|
||||
# RH bug #201307 / Gnome.org bug #350565
|
||||
Patch31: evolution-2.8.0-search-on-folder-change.patch
|
||||
Patch26: evolution-2.7.92-fix-prgname.patch
|
||||
|
||||
# RH bug #161885 / Gnome.org bug #309166
|
||||
Patch32: evolution-2.8.0-indic-cursor-movement.patch
|
||||
Patch27: evolution-2.8.0-indic-cursor-movement.patch
|
||||
|
||||
# Gnome.org bug #356811
|
||||
Patch33: evolution-2.8.0-uninstall.patch
|
||||
# Gnome.org bug #357216
|
||||
Patch28: evolution-2.8.0-deprecated-gdk-font.patch
|
||||
|
||||
# RH bug #205576 / Gnome.org bug #352982
|
||||
Patch34: evolution-2.8.0-fix-message-deletion.patch
|
||||
# Gnome.org bug #357970
|
||||
Patch29: evolution-2.8.0-more-deprecated.patch
|
||||
|
||||
### Dependencies ###
|
||||
# RH bug #202751 / Gnome.org bug #355766
|
||||
Patch30: evolution-2.8.0-fix-indic-printing.patch
|
||||
|
||||
# Gnome.org bug #359236
|
||||
Patch31: evolution-2.8.1-fix-search-state-crash.patch
|
||||
|
||||
# Gnome.org bug #360240
|
||||
Patch32: evolution-2.8.1-warn-unused-variable.patch
|
||||
|
||||
# Gnome.org bug #360619
|
||||
Patch33: evolution-2.8.1-warn-incompatible-pointer-type.patch
|
||||
|
||||
# Gnome.org bug #360946
|
||||
Patch34: evolution-2.8.1-about-dialog.patch
|
||||
|
||||
# Gnome.org bug #362638
|
||||
Patch35: evolution-2.8.1-ethread.patch
|
||||
|
||||
## Dependencies ###
|
||||
|
||||
Requires: ORBit2 >= %{orbit2_version}
|
||||
Requires: dbus >= %{dbus_version}
|
||||
@ -257,15 +260,16 @@ Development files needed for building things which link against evolution.
|
||||
%patch23 -p1 -b .filter-datespec
|
||||
%patch24 -p1 -b .replicated-cjk-input
|
||||
%patch25 -p1 -b .deleting-preedit-buffer
|
||||
%patch26 -p1 -b .deprecated-glib
|
||||
%patch27 -p1 -b .deprecated-gdk
|
||||
%patch28 -p1 -b .fix-prgname
|
||||
%patch29 -p1 -b .chain-finalize
|
||||
%patch30 -p1 -b .fix-missing-declarations
|
||||
%patch31 -p1 -b .search-on-folder-change
|
||||
%patch32 -p1 -b .indic-cursor-movement
|
||||
%patch33 -p1 -b .uninstall
|
||||
%patch34 -p1 -b .fix-message-deletion
|
||||
%patch26 -p1 -b .fix-prgname
|
||||
%patch27 -p1 -b .indic-cursor-movement
|
||||
%patch28 -p1 -b .deprecated-gdk-font
|
||||
%patch29 -p1 -b .more-deprecated
|
||||
%patch30 -p1 -b .fix-indic-printing
|
||||
%patch31 -p1 -b .fix-search-state-crash
|
||||
%patch32 -p1 -b .warn-unused-variable
|
||||
%patch33 -p1 -b .warn-incompatible-pointer-type
|
||||
%patch34 -p1 -b .about-dialog
|
||||
%patch35 -p1 -b .ethread
|
||||
|
||||
mkdir -p krb5-fakeprefix/include
|
||||
mkdir -p krb5-fakeprefix/lib
|
||||
@ -325,6 +329,21 @@ if pkg-config openssl ; then
|
||||
fi
|
||||
%endif
|
||||
|
||||
# Add stricter build settings here as the source code gets cleaned up.
|
||||
# We want to make sure things like compiler warnings and avoiding deprecated
|
||||
# functions in the GNOME/GTK+ libraries stay fixed.
|
||||
#
|
||||
# Please file a bug report at bugzilla.gnome.org if these settings break
|
||||
# compilation, and encourage the upstream developers to use them.
|
||||
|
||||
%if %{strict_build_settings}
|
||||
CFLAGS="$CFLAGS \
|
||||
-DG_DISABLE_DEPRECATED=1 \
|
||||
-DGDK_PIXBUF_DISABLE_DEPRECATED=1 \
|
||||
-DGDK_DISABLE_DEPRECATED=1 \
|
||||
-Werror-implicit-function-declaration"
|
||||
%endif
|
||||
|
||||
# Rerun the GNU Autotools since we patched some of the input files.
|
||||
aclocal
|
||||
autoheader
|
||||
@ -343,13 +362,7 @@ autoconf
|
||||
%ldap_flags %pilot_flags %krb5_flags %nntp_flags %ssl_flags %exchange_flags \
|
||||
--enable-plugins=all
|
||||
export tagname=CC
|
||||
|
||||
# Do the make, with various flags:
|
||||
%if %{require_function_declarations}
|
||||
make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool CFLAGS="$CFLAGS -Werror-implicit-function-declaration -UGNOME_DISABLE_DEPRECATED"
|
||||
%else
|
||||
make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool CFLAGS="$CFLAGS -UGNOME_DISABLE_DEPRECATED"
|
||||
%endif
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -378,14 +391,9 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-pilot/conduits/*.la
|
||||
rm -rf $RPM_BUILD_ROOT/var/scrollkeeper
|
||||
|
||||
# evolution is the preferred email app
|
||||
ln -sf ../desktop-menu-patches/redhat-evolution-mail.desktop \
|
||||
$RPM_BUILD_ROOT/%{_datadir}/applications/
|
||||
ln -sf ../desktop-menu-patches/redhat-evolution-calendar.desktop \
|
||||
$RPM_BUILD_ROOT/%{_datadir}/applications/
|
||||
ln -sf ../desktop-menu-patches/redhat-evolution-contacts.desktop \
|
||||
$RPM_BUILD_ROOT/%{_datadir}/applications/
|
||||
ln -sf ../desktop-menu-patches/redhat-evolution-tasks.desktop \
|
||||
$RPM_BUILD_ROOT/%{_datadir}/applications/
|
||||
for desktopfile in %{_datadir}/desktop-menu-patches/*-evolution-*.desktop; do
|
||||
ln -sf $desktopfile $RPM_BUILD_ROOT/%{_datadir}/applications/
|
||||
done
|
||||
|
||||
# remove upstream desktop file; use the symlinks from above (#103826)
|
||||
rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/evolution-%{evo_major}.desktop
|
||||
@ -656,6 +664,25 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/evolution/%{evo_major}/libmenus.so
|
||||
|
||||
%changelog
|
||||
* Mon Oct 4 2006 Matthew Barnes <mbarnes@redhat.com> - 2.8.1-1.fc7
|
||||
- Update to 2.8.1
|
||||
- Use stricter build settings.
|
||||
- Make .desktop symlinks absolute (RH bug #209322).
|
||||
- Add patch for RH bug #202751 (printing of indic languages).
|
||||
- Add patch for Gnome.org bug #357970 (deprecated GLib / GDK symbols).
|
||||
- Add patch for Gnome.org bug #359236 (search state crash).
|
||||
- Add patch for Gnome.org bug #360240 ("unused variable" warnings).
|
||||
- Add patch for Gnome.org bug #360619 ("incompatible pointer type" warnings).
|
||||
- Add patch for Gnome.org bug #360946 (improved "about" dialog).
|
||||
- Add patch for Gnome.org bug #362638 (deprecate EThread).
|
||||
- Update patch for RH bug #211058 (partially fixed upstream).
|
||||
- Remove patch for RH bug #201307 (fixed upstream).
|
||||
- Remove patch for RH bug #205576 (fixed upstream).
|
||||
- Remove patch for Gnome.org bug #351332 (fixed upstream).
|
||||
- Remove patch for Gnome.org bug #352450 (fixed upstream).
|
||||
- Remove patch for Gnome.org bug #353472 (fixed upstream).
|
||||
- Remove patch for Gnome.org bug #356811 (fixed upstream).
|
||||
|
||||
* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.8.0-7.fc6
|
||||
- rebuilt for unwind info generation, broken in gcc-4.1.1-21
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user