- Update BuildRoot, License, Source and URL tags.

- Require gnome-common so we don't have to patch it out.
This commit is contained in:
Matthew Barnes 2009-02-06 05:59:41 +00:00
parent 82a15cec2e
commit 6fe408a9b7
5 changed files with 15 additions and 924 deletions

View File

@ -1,155 +0,0 @@
diff -up evolution-2.25.2/mail/mail-config.c.broken-account-uris evolution-2.25.2/mail/mail-config.c
--- evolution-2.25.2/mail/mail-config.c.broken-account-uris 2008-11-27 04:41:49.000000000 -0500
+++ evolution-2.25.2/mail/mail-config.c 2008-12-09 11:28:35.000000000 -0500
@@ -800,53 +800,64 @@ mail_config_get_account_by_uid (const ch
return (EAccount *) e_account_list_find (config->accounts, E_ACCOUNT_FIND_UID, uid);
}
+static gboolean
+mail_config_account_url_equal (const CamelURL *u1,
+ const CamelURL *u2)
+{
+ /* For the purpose of matching a URL to an EAccount, only compare
+ * the protocol, user, host and port and disregard the rest. */
+
+ if (g_strcmp0 (u1->protocol, u2->protocol) != 0)
+ return FALSE;
+
+ if (g_strcmp0 (u1->user, u2->user) != 0)
+ return FALSE;
+
+ if (g_strcmp0 (u1->host, u2->host) != 0)
+ return FALSE;
+
+ return (u1->port == u2->port);
+}
+
EAccount *
mail_config_get_account_by_source_url (const char *source_url)
{
EAccount *account = NULL;
EIterator *iter;
+ CamelURL *url;
g_return_val_if_fail (source_url != NULL, NULL);
+ url = camel_url_new (source_url, NULL);
+ g_return_val_if_fail (url != NULL, NULL);
+
iter = e_list_get_iterator ((EList *) config->accounts);
- while (e_iterator_is_valid (iter)) {
- CamelURL *url;
- gchar *string;
+ while (account == NULL && e_iterator_is_valid (iter)) {
+ CamelURL *account_url;
account = (EAccount *) e_iterator_get (iter);
e_iterator_next (iter);
- if (account->source == NULL)
- continue;
-
- else if (account->source->url == NULL)
- continue;
-
- else if (*account->source->url == '\0')
+ if ( !account || (account->source == NULL) ||
+ (account->source->url == NULL) || (*account->source->url == '\0')) {
+ account = NULL;
continue;
+ }
- url = camel_url_new (account->source->url, NULL);
- if (url == NULL)
+ account_url = camel_url_new (account->source->url, NULL);
+ if (account_url == NULL)
continue;
- /* Simplify the account URL for comparison. */
- string = camel_url_to_string (url, CAMEL_URL_HIDE_ALL);
- if (string == NULL || strcmp (string, source_url) != 0)
+ if (!mail_config_account_url_equal (url, account_url))
account = NULL; /* not a match */
- camel_url_free (url);
- g_free (string);
-
- if (account != NULL) {
- g_object_unref (iter);
- return account;
- }
+ camel_url_free (account_url);
}
g_object_unref (iter);
- return NULL;
+ return account;
}
EAccount *
@@ -854,48 +865,40 @@ mail_config_get_account_by_transport_url
{
EAccount *account = NULL;
EIterator *iter;
+ CamelURL *url;
g_return_val_if_fail (transport_url != NULL, NULL);
+ url = camel_url_new (transport_url, NULL);
+ g_return_val_if_fail (url != NULL, NULL);
+
iter = e_list_get_iterator ((EList *) config->accounts);
- while (e_iterator_is_valid (iter)) {
- CamelURL *url;
- gchar *string;
+ while (account == NULL && e_iterator_is_valid (iter)) {
+ CamelURL *account_url;
account = (EAccount *) e_iterator_get (iter);
e_iterator_next (iter);
- if (account->transport == NULL)
- continue;
-
- else if (account->transport->url == NULL)
- continue;
-
- else if (*account->transport->url == '\0')
- continue;
+ if ( !account || (account->transport == NULL) ||
+ (account->transport->url == NULL) || (*account->transport->url == '\0')) {
+ account = NULL;
+ continue;
+ }
- url = camel_url_new (account->transport->url, NULL);
- if (url == NULL)
+ account_url = camel_url_new (account->transport->url, NULL);
+ if (account_url == NULL)
continue;
- /* Simplify the account URL for comparison. */
- string = camel_url_to_string (url, CAMEL_URL_HIDE_ALL);
- if (string == NULL || strcmp (string, transport_url) != 0)
+ if (!mail_config_account_url_equal (url, account_url))
account = NULL; /* not a match */
camel_url_free (url);
- g_free (string);
-
- if (account != NULL) {
- g_object_unref (iter);
- return account;
- }
}
g_object_unref (iter);
- return NULL;
+ return account;
}
int

View File

@ -1,73 +0,0 @@
diff -up evolution-2.25.3.1/configure.in.libgweather evolution-2.25.3.1/configure.in
--- evolution-2.25.3.1/configure.in.libgweather 2008-12-15 11:50:21.000000000 -0500
+++ evolution-2.25.3.1/configure.in 2008-12-15 11:50:57.000000000 -0500
@@ -43,7 +43,7 @@ m4_define([dbus_minimum_version], [1.0.0
m4_define([hal_minimum_version], [0.5.4])
m4_define([libnotify_minimum_version], [0.3.0])
m4_define([gnome_pilot_minimum_version], [2.0.15])
-m4_define([gweather_minimum_version], [2.25.3])
+m4_define([gweather_minimum_version], [2.25.2])
# GNOME Documentation
GNOME_DOC_INIT
diff -up evolution-2.25.3.1/configure.libgweather evolution-2.25.3.1/configure
--- evolution-2.25.3.1/configure.libgweather 2008-12-15 11:50:26.000000000 -0500
+++ evolution-2.25.3.1/configure 2008-12-15 11:52:43.000000000 -0500
@@ -32935,11 +32935,11 @@ if test -n "$LIBGWEATHER_CFLAGS"; then
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gweather >= 2.25.3\"") >&5
- ($PKG_CONFIG --exists --print-errors "gweather >= 2.25.3") 2>&5
+ ($PKG_CONFIG --exists --print-errors "gweather >= 2.25.2") 2>&5
ac_status=$?
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_LIBGWEATHER_CFLAGS=`$PKG_CONFIG --cflags "gweather >= 2.25.3" 2>/dev/null`
+ pkg_cv_LIBGWEATHER_CFLAGS=`$PKG_CONFIG --cflags "gweather >= 2.25.2" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -32950,12 +32950,12 @@ if test -n "$LIBGWEATHER_LIBS"; then
pkg_cv_LIBGWEATHER_LIBS="$LIBGWEATHER_LIBS"
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
- { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gweather >= 2.25.3\"") >&5
- ($PKG_CONFIG --exists --print-errors "gweather >= 2.25.3") 2>&5
+ { ($as_echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"gweather >= 2.25.2\"") >&5
+ ($PKG_CONFIG --exists --print-errors "gweather >= 2.25.2") 2>&5
ac_status=$?
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_LIBGWEATHER_LIBS=`$PKG_CONFIG --libs "gweather >= 2.25.3" 2>/dev/null`
+ pkg_cv_LIBGWEATHER_LIBS=`$PKG_CONFIG --libs "gweather >= 2.25.2" 2>/dev/null`
else
pkg_failed=yes
fi
@@ -32973,21 +32973,21 @@ else
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
- LIBGWEATHER_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gweather >= 2.25.3" 2>&1`
+ LIBGWEATHER_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gweather >= 2.25.2" 2>&1`
else
- LIBGWEATHER_PKG_ERRORS=`$PKG_CONFIG --print-errors "gweather >= 2.25.3" 2>&1`
+ LIBGWEATHER_PKG_ERRORS=`$PKG_CONFIG --print-errors "gweather >= 2.25.2" 2>&1`
fi
# Put the nasty error message in config.log where it belongs
echo "$LIBGWEATHER_PKG_ERRORS" >&5
{ $as_echo "$as_me:$LINENO: result: no" >&5
$as_echo "no" >&6; }
- { { $as_echo "$as_me:$LINENO: error: The weather calendar setup plugin requires GWeather >= 2.25.3. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&5
-$as_echo "$as_me: error: The weather calendar setup plugin requires GWeather >= 2.25.3. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&2;}
+ { { $as_echo "$as_me:$LINENO: error: The weather calendar setup plugin requires GWeather >= 2.25.2. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&5
+$as_echo "$as_me: error: The weather calendar setup plugin requires GWeather >= 2.25.2. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&2;}
{ (exit 1); exit 1; }; }
elif test $pkg_failed = untried; then
- { { $as_echo "$as_me:$LINENO: error: The weather calendar setup plugin requires GWeather >= 2.25.3. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&5
-$as_echo "$as_me: error: The weather calendar setup plugin requires GWeather >= 2.25.3. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&2;}
+ { { $as_echo "$as_me:$LINENO: error: The weather calendar setup plugin requires GWeather >= 2.25.2. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&5
+$as_echo "$as_me: error: The weather calendar setup plugin requires GWeather >= 2.25.2. Alternatively, you may specify --without-weather as a configure option to avoid building the plugin." >&2;}
{ (exit 1); exit 1; }; }
else
LIBGWEATHER_CFLAGS=$pkg_cv_LIBGWEATHER_CFLAGS

View File

@ -1,515 +0,0 @@
--- evolution-2.5.4/addressbook/conduit/address-conduit.c.fix-conduits 2005-12-08 03:15:02.000000000 -0500
+++ evolution-2.5.4/addressbook/conduit/address-conduit.c 2006-01-10 19:33:44.000000000 -0500
@@ -462,14 +462,19 @@
{
static char buff[ 4096 ];
struct Address addr;
+ pi_buffer_t piBuf;
if (remote == NULL) {
sprintf (buff, "[NULL]");
return buff;
}
+ piBuf.data = remote->record;
+ piBuf.allocated = remote->length;
+ piBuf.used = remote->length;
+
memset (&addr, 0, sizeof (struct Address));
- unpack_Address (&addr, remote->record, remote->length);
+ unpack_Address (&addr, &piBuf, address_v1);
g_snprintf (buff, 4096, "['%s' '%s' '%s']",
addr.entry[entryLastname] ?
@@ -791,7 +796,8 @@
EAddrConduitContext *ctxt)
{
GnomePilotRecord p;
- static char record[0xffff];
+ static unsigned char record[0xffff];
+ pi_buffer_t piBuf;
g_assert (local->addr != NULL );
@@ -803,9 +809,17 @@
p.archived = local->local.archived;
p.secret = local->local.secret;
+ memset (&piBuf, 0, sizeof (piBuf));
+ memset (record, 0, sizeof (record));
+ pack_Address (local->addr, &piBuf, address_v1);
+
/* Generate pilot record structure */
+ if (piBuf.used > 0)
+ memcpy (record, piBuf.data, piBuf.used);
p.record = record;
- p.length = pack_Address (local->addr, p.record, 0xffff);
+ p.length = piBuf.used;
+ if (piBuf.data)
+ free (piBuf.data);
return p;
}
@@ -834,16 +848,16 @@
*/
if (local->local.ID != 0) {
struct Address addr;
- char record[0xffff];
+ pi_buffer_t *buffer = pi_buffer_new (0xffff);
int cat = 0;
if (dlp_ReadRecordById (ctxt->dbi->pilot_socket,
ctxt->dbi->db_handle,
- local->local.ID, &record,
- NULL, NULL, NULL, &cat) > 0) {
+ local->local.ID, buffer,
+ NULL, NULL, &cat) > 0) {
local->local.category = cat;
memset (&addr, 0, sizeof (struct Address));
- unpack_Address (&addr, record, 0xffff);
+ unpack_Address (&addr, buffer, address_v1);
for (i = 0; i < 5; i++) {
if (addr.entry[entryPhone1 + i])
local->addr->entry[entryPhone1 + i] =
@@ -858,6 +872,8 @@
}
free_Address (&addr);
}
+
+ pi_buffer_free (buffer);
}
local->addr->entry[entryFirstname] = e_pilot_utf8_to_pchar (e_contact_get_const (contact, E_CONTACT_GIVEN_NAME));
@@ -1019,10 +1035,16 @@
EContactField next_mail, next_home, next_work, next_fax;
EContactField next_other, next_main, next_pager, next_mobile;
int i;
+ pi_buffer_t piBuf;
g_return_val_if_fail(remote!=NULL,NULL);
memset (&address, 0, sizeof (struct Address));
- unpack_Address (&address, remote->record, remote->length);
+
+ piBuf.data = remote->record;
+ piBuf.allocated = remote->length;
+ piBuf.used = remote->length;
+
+ unpack_Address (&address, &piBuf, address_v1);
if (in_contact == NULL)
contact = e_contact_new ();
@@ -1212,7 +1234,7 @@
EBookQuery *query;
GList *l;
int len;
- unsigned char *buf;
+ pi_buffer_t *buffer;
char *filename;
char *change_id;
char *auth;
@@ -1302,9 +1324,9 @@
gnome_pilot_conduit_sync_abs_set_num_updated_local_records (abs_conduit, mod_records);
gnome_pilot_conduit_sync_abs_set_num_deleted_local_records(abs_conduit, del_records);
- buf = (unsigned char*)g_malloc (0xffff);
+ buffer = pi_buffer_new (0xffff);
len = dlp_ReadAppBlock (dbi->pilot_socket, dbi->db_handle, 0,
- (unsigned char *)buf, 0xffff);
+ -1, buffer);
if (len < 0) {
WARN (_("Could not read pilot's Address application block"));
@@ -1313,8 +1335,8 @@
_("Could not read pilot's Address application block"));
return -1;
}
- unpack_AddressAppInfo (&(ctxt->ai), buf, len);
- g_free (buf);
+ unpack_AddressAppInfo (&(ctxt->ai), buffer->data, len);
+ pi_buffer_free (buffer);
check_for_slow_setting (conduit, ctxt);
if (ctxt->cfg->sync_type == GnomePilotConduitSyncTypeCopyToPilot
--- evolution-2.5.4/calendar/conduits/calendar/calendar-conduit.c.fix-conduits 2006-01-02 06:38:57.000000000 -0500
+++ evolution-2.5.4/calendar/conduits/calendar/calendar-conduit.c 2006-01-10 19:33:44.000000000 -0500
@@ -413,14 +413,20 @@
{
static char buff[ 4096 ];
struct Appointment appt;
+ pi_buffer_t piBuf;
if (remote == NULL) {
sprintf (buff, "[NULL]");
return buff;
}
+
+ piBuf.data = remote->record;
+ piBuf.allocated = remote->length;
+ piBuf.used = remote->length;
+
memset (&appt, 0, sizeof (struct Appointment));
- unpack_Appointment (&appt, remote->record, remote->length);
+ unpack_Appointment (&appt, &piBuf, datebook_v1);
g_snprintf (buff, 4096, "[%ld %ld '%s' '%s']",
mktime (&appt.begin),
@@ -818,7 +824,8 @@
ECalConduitContext *ctxt)
{
GnomePilotRecord p;
- static char record[0xffff];
+ static unsigned char record[0xffff];
+ pi_buffer_t piBuf;
g_assert (local->comp != NULL);
g_assert (local->appt != NULL );
@@ -829,9 +836,17 @@
p.archived = local->local.archived;
p.secret = local->local.secret;
+ memset (&piBuf, 0, sizeof (piBuf));
+ memset (record, 0, sizeof (record));
+ pack_Appointment (local->appt, &piBuf, datebook_v1);
+
/* Generate pilot record structure */
+ if (piBuf.used > 0)
+ memcpy (record, piBuf.data, piBuf.used);
p.record = record;
- p.length = pack_Appointment (local->appt, p.record, 0xffff);
+ p.length = piBuf.used;
+ if (piBuf.data)
+ free (piBuf.data);
return p;
}
@@ -867,22 +882,24 @@
* we don't overwrite them
*/
if (local->local.ID != 0) {
- struct Appointment appt;
- char record[0xffff];
+ struct Appointment appt;
+ pi_buffer_t *buffer = pi_buffer_new (0xffff);
int cat = 0;
if (dlp_ReadRecordById (ctxt->dbi->pilot_socket,
ctxt->dbi->db_handle,
- local->local.ID, &record,
- NULL, NULL, NULL, &cat) > 0) {
+ local->local.ID, buffer,
+ NULL, NULL, &cat) > 0) {
local->local.category = cat;
memset (&appt, 0, sizeof (struct Appointment));
- unpack_Appointment (&appt, record, 0xffff);
+ unpack_Appointment (&appt, buffer, datebook_v1);
local->appt->alarm = appt.alarm;
local->appt->advance = appt.advance;
local->appt->advanceUnits = appt.advanceUnits;
free_Appointment (&appt);
}
+
+ pi_buffer_free (buffer);
}
/* STOP: don't replace these with g_strdup, since free_Appointment
@@ -1140,11 +1157,17 @@
GSList *edl = NULL;
char *txt;
int pos, i;
+ pi_buffer_t piBuf;
g_return_val_if_fail (remote != NULL, NULL);
+
+ piBuf.data = remote->record;
+ piBuf.allocated = remote->length;
+ piBuf.used = remote->length;
+
memset (&appt, 0, sizeof (struct Appointment));
- unpack_Appointment (&appt, remote->record, remote->length);
+ unpack_Appointment (&appt, &piBuf, datebook_v1);
if (in_comp == NULL) {
comp = e_cal_component_new ();
@@ -1409,7 +1432,7 @@
GnomePilotConduitSyncAbs *abs_conduit;
GList *removed = NULL, *added = NULL, *l;
int len;
- unsigned char *buf;
+ pi_buffer_t *buffer;
char *filename, *change_id;
icalcomponent *icalcomp;
gint num_records, add_records = 0, mod_records = 0, del_records = 0;
@@ -1521,9 +1544,9 @@
gnome_pilot_conduit_sync_abs_set_num_updated_local_records (abs_conduit, mod_records);
gnome_pilot_conduit_sync_abs_set_num_deleted_local_records(abs_conduit, del_records);
- buf = (unsigned char*)g_malloc (0xffff);
+ buffer = pi_buffer_new (0xffff);
len = dlp_ReadAppBlock (dbi->pilot_socket, dbi->db_handle, 0,
- (unsigned char *)buf, 0xffff);
+ -1, buffer);
if (len < 0) {
WARN (_("Could not read pilot's Calendar application block"));
@@ -1532,8 +1555,8 @@
_("Could not read pilot's Calendar application block"));
return -1;
}
- unpack_AppointmentAppInfo (&(ctxt->ai), buf, len);
- g_free (buf);
+ unpack_AppointmentAppInfo (&(ctxt->ai), buffer->data, len);
+ pi_buffer_free (buffer);
check_for_slow_setting (conduit, ctxt);
if (ctxt->cfg->sync_type == GnomePilotConduitSyncTypeCopyToPilot
--- evolution-2.5.4/calendar/conduits/todo/todo-conduit.c.fix-conduits 2005-12-08 03:15:03.000000000 -0500
+++ evolution-2.5.4/calendar/conduits/todo/todo-conduit.c 2006-01-10 19:33:44.000000000 -0500
@@ -402,14 +402,19 @@
{
static char buff[ 4096 ];
struct ToDo todo;
+ pi_buffer_t piBuf;
if (remote == NULL) {
sprintf (buff, "[NULL]");
return buff;
}
+ piBuf.data = remote->record;
+ piBuf.allocated = remote->length;
+ piBuf.used = remote->length;
+
memset (&todo, 0, sizeof (struct ToDo));
- unpack_ToDo (&todo, remote->record, remote->length);
+ unpack_ToDo (&todo, &piBuf, todo_v1);
g_snprintf (buff, 4096, "[%d %ld %d %d '%s' '%s' %d]",
todo.indefinite,
@@ -594,7 +599,8 @@
EToDoConduitContext *ctxt)
{
GnomePilotRecord p;
- static char record[0xffff];
+ static unsigned char record[0xffff];
+ pi_buffer_t piBuf;
g_assert (local->comp != NULL);
g_assert (local->todo != NULL );
@@ -607,9 +613,17 @@
p.archived = local->local.archived;
p.secret = local->local.secret;
+ memset (&piBuf, 0, sizeof (piBuf));
+ memset (record, 0, sizeof (record));
+ pack_ToDo (local->todo, &piBuf, todo_v1);
+
/* Generate pilot record structure */
+ if (piBuf.used > 0)
+ memcpy (record, piBuf.data, piBuf.used);
p.record = record;
- p.length = pack_ToDo (local->todo, p.record, 0xffff);
+ p.length = piBuf.used;
+ if (piBuf.data)
+ free (piBuf.data);
return p;
}
@@ -696,15 +710,17 @@
/* Don't overwrite the category */
if (local->local.ID != 0) {
- char record[0xffff];
+ pi_buffer_t *buffer = pi_buffer_new (0xffff);
int cat = 0;
if (dlp_ReadRecordById (ctxt->dbi->pilot_socket,
ctxt->dbi->db_handle,
- local->local.ID, &record,
- NULL, NULL, NULL, &cat) > 0) {
+ local->local.ID, buffer,
+ NULL, NULL, &cat) > 0) {
local->local.category = cat;
}
+
+ pi_buffer_free (buffer);
}
/*
@@ -859,12 +875,17 @@
icaltimezone *utc_zone;
int priority;
char *txt;
+ pi_buffer_t piBuf;
char *category;
g_return_val_if_fail (remote != NULL, NULL);
+ piBuf.data = remote->record;
+ piBuf.allocated = remote->length;
+ piBuf.used = remote->length;
+
memset (&todo, 0, sizeof (struct ToDo));
- unpack_ToDo (&todo, remote->record, remote->length);
+ unpack_ToDo (&todo, &piBuf, todo_v1);
utc_zone = icaltimezone_get_utc_timezone ();
now = icaltime_from_timet_with_zone (time (NULL), FALSE,
@@ -1014,7 +1035,7 @@
GnomePilotConduitSyncAbs *abs_conduit;
GList *l;
int len;
- unsigned char *buf;
+ pi_buffer_t *buffer;
char *filename, *change_id;
icalcomponent *icalcomp;
gint num_records, add_records = 0, mod_records = 0, del_records = 0;
@@ -1104,9 +1125,9 @@
g_message("num_records: %d\nadd_records: %d\nmod_records: %d\ndel_records: %d\n",
num_records, add_records, mod_records, del_records);
- buf = (unsigned char*)g_malloc (0xffff);
+ buffer = pi_buffer_new (0xffff);
len = dlp_ReadAppBlock (dbi->pilot_socket, dbi->db_handle, 0,
- (unsigned char *)buf, 0xffff);
+ -1, buffer);
if (len < 0) {
WARN (_("Could not read pilot's ToDo application block"));
@@ -1115,8 +1136,8 @@
_("Could not read pilot's ToDo application block"));
return -1;
}
- unpack_ToDoAppInfo (&(ctxt->ai), buf, len);
- g_free (buf);
+ unpack_ToDoAppInfo (&(ctxt->ai), buffer->data, len);
+ pi_buffer_free (buffer);
lastDesktopUniqueID = 128;
--- evolution-2.5.4/calendar/conduits/memo/memo-conduit.c.fix-conduits 2006-01-10 22:52:28.000000000 -0500
+++ evolution-2.5.4/calendar/conduits/memo/memo-conduit.c 2006-01-10 23:11:47.000000000 -0500
@@ -331,14 +331,19 @@
{
static char buff[ 64 ];
struct Memo memo;
+ pi_buffer_t piBuf;
if (remote == NULL) {
sprintf (buff, "[NULL]");
return buff;
}
+ piBuf.data = remote->record;
+ piBuf.allocated = remote->length;
+ piBuf.used = remote->length;
+
memset (&memo, 0, sizeof (struct Memo));
- unpack_Memo (&memo, remote->record, remote->length);
+ unpack_Memo (&memo, &piBuf, memo_v1);
g_snprintf (buff, 64, "['%s']",
memo.text ?
@@ -451,7 +456,8 @@
EMemoConduitContext *ctxt)
{
GnomePilotRecord p;
- static char record[0xffff];
+ static unsigned char record[0xffff];
+ pi_buffer_t piBuf;
g_assert (local->comp != NULL);
g_assert (local->memo != NULL );
@@ -466,8 +472,14 @@
/* Generate pilot record structure */
p.record = record;
- p.length = pack_Memo (local->memo, p.record, 0xffff);
-
+ memset (&piBuf, 0, sizeof (piBuf));
+ memset (record, 0, sizeof (record));
+ p.length = pack_Memo (local->memo, &piBuf, memo_v1);
+ if (piBuf.used > 0)
+ memcpy (record, piBuf.data, piBuf.used);
+ p.length = piBuf.used;
+ if (piBuf.data)
+ free (piBuf.data);
return p;
}
@@ -568,16 +580,17 @@
/* Don't overwrite the category */
if (local->local.ID != 0) {
- char record[0xffff];
+ pi_buffer_t *buffer = pi_buffer_new (0xffff);
int cat = 0;
LOG(fprintf(stderr, "local_record_from_comp: calling dlp_ReadRecordById\n"));
if (dlp_ReadRecordById (ctxt->dbi->pilot_socket,
ctxt->dbi->db_handle,
- local->local.ID, &record,
- NULL, NULL, NULL, &cat) > 0) {
+ local->local.ID, buffer,
+ NULL, NULL, &cat) > 0) {
local->local.category = cat;
}
+ pi_buffer_free (buffer);
LOG(fprintf(stderr, "local_record_from_comp: done calling dlp_ReadRecordById\n"));
}
@@ -699,6 +712,7 @@
{
ECalComponent *comp;
struct Memo memo;
+ pi_buffer_t piBuf;
struct icaltimetype now;
icaltimezone *utc_zone;
char *txt, *txt2, *txt3;
@@ -707,8 +721,12 @@
g_return_val_if_fail (remote != NULL, NULL);
+ piBuf.data = remote->record;
+ piBuf.allocated = remote->length;
+ piBuf.used = remote->length;
+
memset (&memo, 0, sizeof (struct Memo));
- unpack_Memo (&memo, remote->record, remote->length);
+ unpack_Memo (&memo, &piBuf, memo_v1);
utc_zone = icaltimezone_get_utc_timezone ();
now = icaltime_from_timet_with_zone (time (NULL), FALSE,
@@ -836,7 +854,7 @@
GnomePilotConduitSyncAbs *abs_conduit;
GList *l;
int len;
- unsigned char *buf;
+ pi_buffer_t *buffer;
char *filename, *change_id;
icalcomponent *icalcomp;
gint num_records, add_records = 0, mod_records = 0, del_records = 0;
@@ -929,9 +947,9 @@
g_message("num_records: %d\nadd_records: %d\nmod_records: %d\ndel_records: %d\n",
num_records, add_records, mod_records, del_records);
- buf = (unsigned char*)g_malloc (0xffff);
+ buffer = pi_buffer_new (0xffff);
len = dlp_ReadAppBlock (dbi->pilot_socket, dbi->db_handle, 0,
- (unsigned char *)buf, 0xffff);
+ -1, buffer);
if (len < 0) {
WARN (_("Could not read pilot's Memo application block"));
@@ -940,8 +958,8 @@
_("Could not read pilot's Memo application block"));
return -1;
}
- unpack_MemoAppInfo (&(ctxt->ai), buf, len);
- g_free (buf);
+ unpack_MemoAppInfo (&(ctxt->ai), buffer->data, len);
+ pi_buffer_free (buffer);
lastDesktopUniqueID = 128;

View File

@ -1,155 +0,0 @@
diff -up evolution-2.24.1/configure.in.no-gnome-common evolution-2.24.1/configure.in
--- evolution-2.24.1/configure.in.no-gnome-common 2008-10-19 23:27:24.000000000 -0400
+++ evolution-2.24.1/configure.in 2008-10-21 13:16:54.000000000 -0400
@@ -1332,9 +1332,6 @@ AC_SUBST_FILE(EVO_MARSHAL_RULE)
dnl *************************
dnl CFLAGS and LIBS and stuff
dnl *************************
-
-GNOME_COMPILE_WARNINGS(yes)
-CFLAGS="$CFLAGS $WARN_CFLAGS"
case $CFLAGS in
*-Wall*)
# Turn off the annoying "comparison between signed and unsigned"
diff -up evolution-2.24.1/configure.no-gnome-common evolution-2.24.1/configure
--- evolution-2.24.1/configure.no-gnome-common 2008-10-21 13:16:54.000000000 -0400
+++ evolution-2.24.1/configure 2008-10-21 13:17:55.000000000 -0400
@@ -33230,138 +33230,6 @@ EVO_MARSHAL_RULE=$srcdir/marshal.mk
- # Check whether --enable-compile-warnings was given.
-if test "${enable_compile_warnings+set}" = set; then
- enableval=$enable_compile_warnings;
-else
- enable_compile_warnings="yes"
-fi
-
-
- warnCFLAGS=
- if test "x$GCC" != xyes; then
- enable_compile_warnings=no
- fi
-
- warning_flags=
- realsave_CFLAGS="$CFLAGS"
-
- case "$enable_compile_warnings" in
- no)
- warning_flags=
- ;;
- minimum)
- warning_flags="-Wall"
- ;;
- yes)
- warning_flags="-Wall -Wmissing-prototypes"
- ;;
- maximum|error)
- warning_flags="-Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith"
- CFLAGS="$warning_flags $CFLAGS"
- for option in -Wno-sign-compare; do
- SAVE_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $option"
- { $as_echo "$as_me:$LINENO: checking whether gcc understands $option" >&5
-$as_echo_n "checking whether gcc understands $option... " >&6; }
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-rm -f conftest.$ac_objext
-if { (ac_try="$ac_compile"
-case "(($ac_try" in
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
- *) ac_try_echo=$ac_try;;
-esac
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-$as_echo "$ac_try_echo") >&5
- (eval "$ac_compile") 2>conftest.er1
- ac_status=$?
- grep -v '^ *+' conftest.er1 >conftest.err
- rm -f conftest.er1
- cat conftest.err >&5
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && {
- test -z "$ac_c_werror_flag" ||
- test ! -s conftest.err
- } && test -s conftest.$ac_objext; then
- has_option=yes
-else
- $as_echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
- has_option=no
-fi
-
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$SAVE_CFLAGS"
- { $as_echo "$as_me:$LINENO: result: $has_option" >&5
-$as_echo "$has_option" >&6; }
- if test $has_option = yes; then
- warning_flags="$warning_flags $option"
- fi
- unset has_option
- unset SAVE_CFLAGS
- done
- unset option
- if test "$enable_compile_warnings" = "error" ; then
- warning_flags="$warning_flags -Werror"
- fi
- ;;
- *)
- { { $as_echo "$as_me:$LINENO: error: Unknown argument '$enable_compile_warnings' to --enable-compile-warnings" >&5
-$as_echo "$as_me: error: Unknown argument '$enable_compile_warnings' to --enable-compile-warnings" >&2;}
- { (exit 1); exit 1; }; }
- ;;
- esac
- CFLAGS="$realsave_CFLAGS"
- { $as_echo "$as_me:$LINENO: checking what warning flags to pass to the C compiler" >&5
-$as_echo_n "checking what warning flags to pass to the C compiler... " >&6; }
- { $as_echo "$as_me:$LINENO: result: $warning_flags" >&5
-$as_echo "$warning_flags" >&6; }
-
- # Check whether --enable-iso-c was given.
-if test "${enable_iso_c+set}" = set; then
- enableval=$enable_iso_c;
-else
- enable_iso_c=no
-fi
-
-
- { $as_echo "$as_me:$LINENO: checking what language compliance flags to pass to the C compiler" >&5
-$as_echo_n "checking what language compliance flags to pass to the C compiler... " >&6; }
- complCFLAGS=
- if test "x$enable_iso_c" != "xno"; then
- if test "x$GCC" = "xyes"; then
- case " $CFLAGS " in
- *\ \ -ansi\ \ *) ;;
- *) complCFLAGS="$complCFLAGS -ansi" ;;
- esac
- case " $CFLAGS " in
- *\ \ -pedantic\ \ *) ;;
- *) complCFLAGS="$complCFLAGS -pedantic" ;;
- esac
- fi
- fi
- { $as_echo "$as_me:$LINENO: result: $complCFLAGS" >&5
-$as_echo "$complCFLAGS" >&6; }
-
- WARN_CFLAGS="$warning_flags $complCFLAGS"
-
-
-CFLAGS="$CFLAGS $WARN_CFLAGS"
case $CFLAGS in
*-Wall*)
# Turn off the annoying "comparison between signed and unsigned"

View File

@ -45,13 +45,13 @@
Name: evolution Name: evolution
Version: 2.25.90 Version: 2.25.90
Release: 1%{?dist} Release: 2%{?dist}
License: GPLv2 and GFDL
Group: Applications/Productivity Group: Applications/Productivity
Summary: Mail and calendar client for GNOME Summary: Mail and calendar client for GNOME
URL: http://www.gnome.org/projects/evolution/ License: GPLv2+ and GFDL
BuildRoot: %{_tmppath}/%{name}-%{version}-root URL: http://projects.gnome.org/evolution/
Source: evolution-%{version}.tar.bz2 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
Source: http://download.gnome.org/sources/%{name}/2.25/%{name}-%{version}.tar.bz2
Obsoletes: libgal2 <= %{last_libgal2_version} Obsoletes: libgal2 <= %{last_libgal2_version}
@ -60,26 +60,13 @@ Obsoletes: libgal2 <= %{last_libgal2_version}
# bad hack # bad hack
Patch10: evolution-1.4.4-ldap-x86_64-hack.patch Patch10: evolution-1.4.4-ldap-x86_64-hack.patch
# Patches for conduits, based upon # Move .conduit files from share to lib (for the sake of multilib).
# rh-161817-attach-116019-conduit_pilot_link_updates.diff
# (the latter patch was originally by Mark G. Adams):
# Patch11: evolution-2.5.4-fix-conduits.patch
# Move .conduit files from share to lib (for the sake of multilib)
# This patch effects other parts of evolution.spec and so is necessary # This patch effects other parts of evolution.spec and so is necessary
# for a successful build. # for a successful build.
Patch12: evolution-2.5.4-fix-conduit-dir.patch Patch11: evolution-2.5.4-fix-conduit-dir.patch
# Remove gnome-common macros from configure.in.
# We do not ship gnome-common (or at least we're not supposed to).
Patch13: evolution-2.7.1-no-gnome-common.patch
# RH bug #176400 # RH bug #176400
Patch14: evolution-2.9.1-im-context-reset.patch Patch12: evolution-2.9.1-im-context-reset.patch
# Back off the bleeding edge libgweather requirement.
# We can get by with libgweather-2.25.2 for now.
Patch15: evolution-2.25.3.1-libgweather.patch
## Dependencies ### ## Dependencies ###
@ -109,6 +96,7 @@ BuildRequires: evolution-data-server-devel >= %{version}
BuildRequires: flex BuildRequires: flex
BuildRequires: gettext BuildRequires: gettext
BuildRequires: glib2-devel >= %{glib2_version} BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: gnome-common
BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version} BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
BuildRequires: gnutls-devel BuildRequires: gnutls-devel
BuildRequires: gtk-doc BuildRequires: gtk-doc
@ -232,11 +220,8 @@ This package contains supplemental utilities for %{name} that require Perl.
%prep %prep
%setup -q -n evolution-%{version} %setup -q -n evolution-%{version}
%patch10 -p1 -b .ldaphack %patch10 -p1 -b .ldaphack
#patch11 -p1 -b .fix-conduits # leave commented %patch11 -p1 -b .fix-conduit-dir
%patch12 -p1 -b .fix-conduit-dir %patch12 -p1 -b .im-context-reset
%patch13 -p1 -b .no-gnome-common
%patch14 -p1 -b .im-context-reset
%patch15 -p1 -b .libgweather
mkdir -p krb5-fakeprefix/include mkdir -p krb5-fakeprefix/include
mkdir -p krb5-fakeprefix/lib mkdir -p krb5-fakeprefix/lib
@ -703,6 +688,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-clean %{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-clean
%changelog %changelog
* Fri Feb 06 2009 Matthew Barnes <mbarnes@redhat.com> - 2.25.90-2.fc11
- Update BuildRoot, License, Source and URL tags.
- Require gnome-common so we don't have to patch it out.
* Mon Feb 02 2009 Matthew Barnes <mbarnes@redhat.com> - 2.25.90-1.fc11 * Mon Feb 02 2009 Matthew Barnes <mbarnes@redhat.com> - 2.25.90-1.fc11
- Update to 2.25.90 - Update to 2.25.90