- 2.5.5.1
- update patch 106 to track upstream, renaming from evolution-2.2.2-commit-enter-on-calendar.patch to evolution-2.5.5.1-commit-enter-on-calendar.patch - update patch 805 to track upstream - added patch to fix some newly missing declarations (patch 808) - replace evolution-2.5.4-port-to-new-libnotify-api.patch with evolution-2.5.5.1-notification-cleanups.patch, since much of this was duplicated by another patch that landed upstream; removing the actions code as it was crashing deep inside DBus (patch 806, #177666) - explicitly list various files to reduce reliance on globbing; organized the files into logical groups; comment them - added -Wno-sign-compare to CFLAGS - enabled parallel make - introduced require_function_declarations macro to make -Werror-implicit-function-declaration flag optional; turn it off for now - include the new CalDAV and mail-attachments-import plugins in the file list; add an XML UI file for the mail-to-task plugin. - use "sed -i -e" rather than "sed -ie" to avoid getting severe bonobo files
This commit is contained in:
parent
8fad5ce212
commit
61d27c7e15
@ -1 +1 @@
|
||||
evolution-2.5.4.tar.bz2
|
||||
evolution-2.5.5.1.tar.bz2
|
||||
|
242
evolution-2.5.5.1-commit-enter-on-calendar.patch
Normal file
242
evolution-2.5.5.1-commit-enter-on-calendar.patch
Normal file
@ -0,0 +1,242 @@
|
||||
--- evolution-2.5.5.1/calendar/gui/e-day-view.c.commit-enter-on-calendar 2006-01-16 09:42:17.000000000 -0500
|
||||
+++ evolution-2.5.5.1/calendar/gui/e-day-view.c 2006-01-25 23:48:24.000000000 -0500
|
||||
@@ -334,6 +334,10 @@
|
||||
gint event_num,
|
||||
gchar *initial_text);
|
||||
static void e_day_view_stop_editing_event (EDayView *day_view);
|
||||
+static gboolean e_day_view_text_keypress (GnomeCanvasItem *item,
|
||||
+ guint keyval,
|
||||
+ guint state,
|
||||
+ EDayView *day_view);
|
||||
static gboolean e_day_view_on_text_item_event (GnomeCanvasItem *item,
|
||||
GdkEvent *event,
|
||||
EDayView *day_view);
|
||||
@@ -4484,6 +4488,8 @@
|
||||
G_CALLBACK (e_day_view_on_text_item_event), day_view);
|
||||
g_signal_emit_by_name (G_OBJECT(day_view),
|
||||
"event_added", event);
|
||||
+ g_signal_connect (event->canvas_item, "keypress",
|
||||
+ G_CALLBACK (e_day_view_text_keypress), day_view);
|
||||
|
||||
e_day_view_update_long_event_label (day_view, event_num);
|
||||
}
|
||||
@@ -4667,6 +4673,8 @@
|
||||
G_CALLBACK (e_day_view_on_text_item_event), day_view);
|
||||
g_signal_emit_by_name (G_OBJECT(day_view),
|
||||
"event_added", event);
|
||||
+ g_signal_connect (event->canvas_item, "keypress",
|
||||
+ G_CALLBACK (e_day_view_text_keypress), day_view);
|
||||
|
||||
e_day_view_update_event_label (day_view, day, event_num);
|
||||
}
|
||||
@@ -5824,46 +5832,74 @@
|
||||
}
|
||||
|
||||
static gboolean
|
||||
+e_day_view_text_keypress (GnomeCanvasItem *item,
|
||||
+ guint keyval,
|
||||
+ guint state,
|
||||
+ EDayView *day_view)
|
||||
+{
|
||||
+ gboolean retval = FALSE;
|
||||
+
|
||||
+ tooltip_destroy (day_view, item);
|
||||
+
|
||||
+ if (keyval == GDK_Return) {
|
||||
+ EText *text = E_TEXT (item);
|
||||
+ gint new_pos = 0;
|
||||
+
|
||||
+ /*
|
||||
+ * HACK: last character which should be \n needs to be deleted
|
||||
+ * here so that GDK_Return was already processed on EText
|
||||
+ * before E_TEXT_KEYPRESS event is emitted.
|
||||
+ */
|
||||
+ if (text->selection_end >= 1)
|
||||
+ new_pos = text->selection_end - 1;
|
||||
+
|
||||
+ text->selection_end = e_text_model_validate_position (text->model, new_pos);
|
||||
+ e_text_delete_selection (text);
|
||||
+
|
||||
+ day_view->resize_event_num = -1;
|
||||
+
|
||||
+ /* We set the keyboard focus to the EDayView, so the
|
||||
+ EText item loses it and stops the edit. */
|
||||
+ gtk_widget_grab_focus (GTK_WIDGET (day_view));
|
||||
+
|
||||
+ /* Stop the signal last or we will also stop any
|
||||
+ other events getting to the EText item. */
|
||||
+ gtk_signal_emit_stop_by_name (GTK_OBJECT (item),
|
||||
+ "event");
|
||||
+
|
||||
+ retval = TRUE;
|
||||
+ } else if (keyval == GDK_Escape) {
|
||||
+ cancel_editing (day_view);
|
||||
+ gtk_signal_emit_stop_by_name (GTK_OBJECT (item), "event");
|
||||
+ /* focus should go to day view when stop editing */
|
||||
+ gtk_widget_grab_focus (GTK_WIDGET (day_view));
|
||||
+
|
||||
+ retval = TRUE;
|
||||
+ } else if ((keyval == GDK_Up)
|
||||
+ && (state & GDK_SHIFT_MASK)
|
||||
+ && (state & GDK_CONTROL_MASK)
|
||||
+ && !(state & GDK_MOD1_MASK)) {
|
||||
+ e_day_view_change_event_end_time_up (day_view);
|
||||
+
|
||||
+ retval = TRUE;
|
||||
+ } else if ((keyval == GDK_Down)
|
||||
+ && (state & GDK_SHIFT_MASK)
|
||||
+ && (state & GDK_CONTROL_MASK)
|
||||
+ && !(state & GDK_MOD1_MASK)) {
|
||||
+ e_day_view_change_event_end_time_down (day_view);
|
||||
+
|
||||
+ retval = TRUE;
|
||||
+ }
|
||||
+
|
||||
+ return retval;
|
||||
+}
|
||||
+
|
||||
+static gboolean
|
||||
e_day_view_on_text_item_event (GnomeCanvasItem *item,
|
||||
GdkEvent *event,
|
||||
EDayView *day_view)
|
||||
{
|
||||
switch (event->type) {
|
||||
- case GDK_KEY_PRESS:
|
||||
- tooltip_destroy (day_view, item);
|
||||
- if (event && event->key.keyval == GDK_Return) {
|
||||
- day_view->resize_event_num = -1;
|
||||
- day_view->resize_event_num = -1;
|
||||
-
|
||||
- /* We set the keyboard focus to the EDayView, so the
|
||||
- EText item loses it and stops the edit. */
|
||||
- gtk_widget_grab_focus (GTK_WIDGET (day_view));
|
||||
-
|
||||
- /* Stop the signal last or we will also stop any
|
||||
- other events getting to the EText item. */
|
||||
- gtk_signal_emit_stop_by_name (GTK_OBJECT (item),
|
||||
- "event");
|
||||
- return TRUE;
|
||||
- } else if (event->key.keyval == GDK_Escape) {
|
||||
- cancel_editing (day_view);
|
||||
- gtk_signal_emit_stop_by_name (GTK_OBJECT (item), "event");
|
||||
- /* focus should go to day view when stop editing */
|
||||
- gtk_widget_grab_focus (GTK_WIDGET (day_view));
|
||||
- return TRUE;
|
||||
- } else if ((event->key.keyval == GDK_Up)
|
||||
- && (event->key.state & GDK_SHIFT_MASK)
|
||||
- && (event->key.state & GDK_CONTROL_MASK)
|
||||
- && !(event->key.state & GDK_MOD1_MASK)) {
|
||||
- e_day_view_change_event_end_time_up (day_view);
|
||||
- return TRUE;
|
||||
- } else if ((event->key.keyval == GDK_Down)
|
||||
- && (event->key.state & GDK_SHIFT_MASK)
|
||||
- && (event->key.state & GDK_CONTROL_MASK)
|
||||
- && !(event->key.state & GDK_MOD1_MASK)) {
|
||||
- e_day_view_change_event_end_time_down (day_view);
|
||||
- return TRUE;
|
||||
- }
|
||||
- break;
|
||||
case GDK_2BUTTON_PRESS:
|
||||
#if 0
|
||||
g_print ("Item got double-click\n");
|
||||
--- evolution-2.5.5.1/calendar/gui/e-week-view.c.commit-enter-on-calendar 2006-01-16 09:42:17.000000000 -0500
|
||||
+++ evolution-2.5.5.1/calendar/gui/e-week-view.c 2006-01-25 23:46:43.000000000 -0500
|
||||
@@ -175,6 +175,10 @@
|
||||
const gchar *uid,
|
||||
EWeekViewForeachEventCallback callback,
|
||||
gpointer data);
|
||||
+static gboolean e_week_view_text_keypress (GnomeCanvasItem *item,
|
||||
+ guint keyval,
|
||||
+ guint state,
|
||||
+ EWeekView *week_view);
|
||||
static gboolean e_week_view_on_text_item_event (GnomeCanvasItem *item,
|
||||
GdkEvent *event,
|
||||
EWeekView *week_view);
|
||||
@@ -2771,6 +2775,8 @@
|
||||
week_view);
|
||||
g_signal_emit_by_name (G_OBJECT(week_view),
|
||||
"event_added", event);
|
||||
+ g_signal_connect (span->text_item, "keypress",
|
||||
+ G_CALLBACK (e_week_view_text_keypress), week_view);
|
||||
|
||||
}
|
||||
|
||||
@@ -3028,6 +3034,51 @@
|
||||
}
|
||||
|
||||
static gboolean
|
||||
+e_week_view_text_keypress (GnomeCanvasItem *item,
|
||||
+ guint keyval,
|
||||
+ guint state,
|
||||
+ EWeekView *week_view)
|
||||
+{
|
||||
+ gboolean retval = FALSE;
|
||||
+
|
||||
+ tooltip_destroy (week_view, item);
|
||||
+
|
||||
+ if (keyval == GDK_Return) {
|
||||
+ EText *text = E_TEXT (item);
|
||||
+ gint new_pos = 0;
|
||||
+
|
||||
+ /*
|
||||
+ * HACK: last charater which should be \n needs to be deleted
|
||||
+ * here so that GDK_Return was already processed on EText
|
||||
+ * before E_TEXT_KEYPRESS event is emitted.
|
||||
+ */
|
||||
+ if (text->selection_end >= 1)
|
||||
+ new_pos = text->selection_end - 1;
|
||||
+
|
||||
+ text->selection_end = e_text_model_validate_position (text->model, new_pos);
|
||||
+ e_text_delete_selection (text);
|
||||
+
|
||||
+ /* We set the keyboard focus to the EDayView, so the
|
||||
+ EText item loses it and stops the edit. */
|
||||
+ gtk_widget_grab_focus (GTK_WIDGET (week_view));
|
||||
+
|
||||
+ /* Stop the signal last or we will also stop any
|
||||
+ other events getting to the EText item. */
|
||||
+ gtk_signal_emit_stop_by_name (GTK_OBJECT (item),
|
||||
+ "event");
|
||||
+ retval = TRUE;
|
||||
+ } else if (keyval == GDK_Escape) {
|
||||
+ cancel_editing (week_view);
|
||||
+ gtk_signal_emit_stop_by_name (GTK_OBJECT (item), "event");
|
||||
+ /* focus should go to week view when stop editing */
|
||||
+ gtk_widget_grab_focus (GTK_WIDGET (week_view));
|
||||
+ retval = TRUE;
|
||||
+ }
|
||||
+
|
||||
+ return retval;
|
||||
+}
|
||||
+
|
||||
+static gboolean
|
||||
e_week_view_on_text_item_event (GnomeCanvasItem *item,
|
||||
GdkEvent *gdkevent,
|
||||
EWeekView *week_view)
|
||||
@@ -3044,26 +3095,6 @@
|
||||
#endif
|
||||
|
||||
switch (gdkevent->type) {
|
||||
- case GDK_KEY_PRESS:
|
||||
- tooltip_destroy (week_view, item);
|
||||
- if (gdkevent && gdkevent->key.keyval == GDK_Return) {
|
||||
- /* We set the keyboard focus to the EDayView, so the
|
||||
- EText item loses it and stops the edit. */
|
||||
- gtk_widget_grab_focus (GTK_WIDGET (week_view));
|
||||
-
|
||||
- /* Stop the signal last or we will also stop any
|
||||
- other events getting to the EText item. */
|
||||
- gtk_signal_emit_stop_by_name (GTK_OBJECT (item),
|
||||
- "event");
|
||||
- return TRUE;
|
||||
- } else if (gdkevent->key.keyval == GDK_Escape) {
|
||||
- cancel_editing (week_view);
|
||||
- gtk_signal_emit_stop_by_name (GTK_OBJECT (item), "event");
|
||||
- /* focus should go to week view when stop editing */
|
||||
- gtk_widget_grab_focus (GTK_WIDGET (week_view));
|
||||
- return TRUE;
|
||||
- }
|
||||
- break;
|
||||
case GDK_2BUTTON_PRESS:
|
||||
if (!e_week_view_find_event_from_item (week_view, item,
|
||||
&event_num, &span_num))
|
178
evolution.spec
178
evolution.spec
@ -27,13 +27,18 @@
|
||||
%define nm_support 1
|
||||
%define libnotify_support 1
|
||||
|
||||
# Upstream tarballs often contain instances of undeclared functions; these tend
|
||||
# to work on i386 but fail on 64-bit architectures. Leave this on to trap the
|
||||
# warnings as errors (and ideally get the flag into the upstream build):
|
||||
%define require_function_declarations 0
|
||||
|
||||
%define redhat_menus_version 5.0.4
|
||||
|
||||
%define evo_plugin_dir %{_libdir}/evolution/%{evo_major}/plugins
|
||||
|
||||
Name: evolution
|
||||
Version: 2.5.4
|
||||
Release: 10
|
||||
Version: 2.5.5.1
|
||||
Release: 1
|
||||
License: GPL
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
URL: http://www.ximian.com/
|
||||
@ -56,7 +61,7 @@ Patch101: evo-calendar-print-with-pango-6.patch
|
||||
#Patch104: evolution-2.2.0-port-to-pilot-link-0.12.patch
|
||||
|
||||
# Fix for RH bug #154360:
|
||||
Patch106: evolution-2.2.2-commit-enter-on-calendar.patch
|
||||
Patch106: evolution-2.5.5.1-commit-enter-on-calendar.patch
|
||||
|
||||
# Move autosave file
|
||||
Patch107: evolution-2.5.4-move-autosave-file.patch
|
||||
@ -92,8 +97,9 @@ Patch803: evolution-2.5.2-no-gnome-common.patch
|
||||
|
||||
Patch804: evolution-2.4.1-fix-missing-declarations.patch
|
||||
Patch805: evolution-2.5.4-fix-missing-declarations.patch
|
||||
Patch806: evolution-2.5.4-port-to-new-libnotify-api.patch
|
||||
Patch806: evolution-2.5.5.1-notification-cleanups.patch
|
||||
Patch807: evolution-2.5.4-fix-nm-multiple-init.patch
|
||||
Patch808: evolution-2.5.5.1-fix-missing-declarations-2.5.5.1.patch
|
||||
|
||||
Summary: GNOME's next-generation groupware suite
|
||||
Group: Applications/Productivity
|
||||
@ -234,8 +240,9 @@ cd ../..
|
||||
%patch803 -p1 -b .no-gnome-common
|
||||
%patch804 -p1 -b .fix-missing-declarations
|
||||
%patch805 -p1 -b .fix-missing-declarations-2-5-4
|
||||
%patch806 -p1 -b .port-to-new-libnotify-api
|
||||
%patch806 -p1 -b .notification-cleanups
|
||||
%patch807 -p1 -b .fix-nm-multiple-init
|
||||
%patch808 -p1 -b .fix-missing-declarations-2.5.5.1
|
||||
|
||||
mkdir -p krb5-fakeprefix/include
|
||||
mkdir -p krb5-fakeprefix/lib
|
||||
@ -287,7 +294,7 @@ fi
|
||||
%endif
|
||||
|
||||
CPPFLAGS="-I%{_includedir}/et"; export CPPFLAGS
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC -DLDAP_DEPRECATED -I%{_includedir}/et"; export CFLAGS
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC -DLDAP_DEPRECATED -I%{_includedir}/et -Wno-sign-compare"; export CFLAGS
|
||||
%if ! %{use_mozilla_nss}
|
||||
if pkg-config openssl ; then
|
||||
CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
|
||||
@ -303,6 +310,7 @@ libtoolize
|
||||
intltoolize --force
|
||||
autoconf
|
||||
|
||||
# Configuration:
|
||||
%configure \
|
||||
--enable-gtk-doc=yes \
|
||||
--enable-ipv6 \
|
||||
@ -313,7 +321,13 @@ autoconf
|
||||
%ldap_flags %pilot_flags %krb5_flags %nntp_flags %ssl_flags %exchange_flags \
|
||||
--enable-plugins=all
|
||||
export tagname=CC
|
||||
make LIBTOOL=%{_bindir}/libtool CFLAGS="$CFLAGS -Werror-implicit-function-declaration"
|
||||
|
||||
# Do the make, with various flags:
|
||||
%if %{require_function_declarations}
|
||||
make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool CFLAGS="$CFLAGS -Werror-implicit-function-declaration"
|
||||
%else
|
||||
make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool CFLAGS="$CFLAGS"
|
||||
%endif
|
||||
|
||||
#cat /dev/null > default_user/local/Inbox/mbox
|
||||
|
||||
@ -350,7 +364,7 @@ rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/evolution-%{evo_major}.desktop
|
||||
ln -sf ./evolution-%{evo_major} $RPM_BUILD_ROOT/%{_bindir}/evolution
|
||||
|
||||
for serverfile in $RPM_BUILD_ROOT%{_libdir}/bonobo/servers/*.server; do
|
||||
sed -ie 's|location *= *"/usr/lib\(64\)*/|location="/usr/$LIB/|' $serverfile
|
||||
sed -i -e 's|location *= *"/usr/lib\(64\)*/|location="/usr/$LIB/|' $serverfile
|
||||
done
|
||||
%find_lang %name-%{evo_major}
|
||||
|
||||
@ -373,39 +387,108 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%files -f %{name}-%{evo_major}.lang
|
||||
%defattr(-, root, root)
|
||||
%doc AUTHORS COPYING ChangeLog INSTALL NEWS README
|
||||
|
||||
# GConf schemas:
|
||||
%{_sysconfdir}/gconf/schemas/apps-evolution-mail-prompts-checkdefault-%{evo_major}.schemas
|
||||
%{_sysconfdir}/gconf/schemas/apps_evolution_addressbook-%{evo_major}.schemas
|
||||
%{_sysconfdir}/gconf/schemas/apps_evolution_calendar-%{evo_major}.schemas
|
||||
%{_sysconfdir}/gconf/schemas/apps_evolution_shell-%{evo_major}.schemas
|
||||
%{_sysconfdir}/gconf/schemas/evolution-mail-%{evo_major}.schemas
|
||||
%{_bindir}/*
|
||||
|
||||
# The main executable and a symlink:
|
||||
%{_bindir}/evolution-%{evo_major}
|
||||
%{_bindir}/evolution
|
||||
|
||||
# Desktop files:
|
||||
%{_datadir}/applications/redhat-evolution-mail.desktop
|
||||
%{_datadir}/applications/redhat-evolution-calendar.desktop
|
||||
%{_datadir}/applications/redhat-evolution-contacts.desktop
|
||||
%{_datadir}/applications/redhat-evolution-tasks.desktop
|
||||
|
||||
# Online help:
|
||||
%{_datadir}/gnome/help/evolution-%{evo_major}
|
||||
%{_datadir}/omf/evolution
|
||||
|
||||
# IDL files (should this be in devel subpackage?)
|
||||
%{_datadir}/idl/evolution-%{evo_major}
|
||||
%{_datadir}/mime-info/*
|
||||
|
||||
# mime-info data:
|
||||
%{_datadir}/mime-info/evolution-%{evo_major}.keys
|
||||
%{_datadir}/mime-info/evolution-%{evo_major}.mime
|
||||
|
||||
# The main data directory
|
||||
# (have not attempted to split this up into an explicit list)
|
||||
%dir %{_datadir}/evolution
|
||||
%{_datadir}/evolution/%{evo_major}
|
||||
%{_datadir}/omf/evolution
|
||||
%{_datadir}/pixmaps/*
|
||||
%{_libdir}/bonobo/servers/*
|
||||
|
||||
%{_datadir}/pixmaps/evolution-%{evo_major}.png
|
||||
|
||||
# Bonobo components:
|
||||
%{_libdir}/bonobo/servers/GNOME_Evolution_Addressbook_%{evo_major}.server
|
||||
%{_libdir}/bonobo/servers/GNOME_Evolution_Calendar_%{evo_major}.server
|
||||
%{_libdir}/bonobo/servers/GNOME_Evolution_Calendar_AlarmNotify_%{evo_major}.server
|
||||
%{_libdir}/bonobo/servers/GNOME_Evolution_Mail_%{evo_major}.server
|
||||
%{_libdir}/bonobo/servers/GNOME_Evolution_Shell_%{evo_major}.server
|
||||
%dir %{_libdir}/evolution
|
||||
%dir %{_libdir}/evolution/%{evo_major}
|
||||
%dir %{_libdir}/evolution/%{evo_major}/components
|
||||
%dir %{_libdir}/evolution/%{evo_major}/components/*.so
|
||||
%dir %{evo_plugin_dir}
|
||||
%{_libdir}/evolution/%{evo_major}/*.so.*
|
||||
%dir %{_libexecdir}/evolution
|
||||
%{_libexecdir}/evolution/%{evo_major}
|
||||
%{_libdir}/evolution/%{evo_major}/components/libevolution-addressbook.so
|
||||
%{_libdir}/evolution/%{evo_major}/components/libevolution-calendar.so
|
||||
%{_libdir}/evolution/%{evo_major}/components/libevolution-mail.so
|
||||
|
||||
# Shared libraries:
|
||||
%{_libdir}/evolution/%{evo_major}/libeabutil.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libeconduit.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libecontacteditor.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libecontactlisteditor.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libefilterbar.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libemiscwidgets.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libeshell.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libessmime.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libetable.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libetext.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libetimezonedialog.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libeutil.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-a11y.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-addressbook-a11y.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-addressbook-importers.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-calendar-a11y.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-calendar-importers.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-mail-importers.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-smime.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-widgets-a11y.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libfilter.so.*
|
||||
%{_libdir}/evolution/%{evo_major}/libmenus.so.*
|
||||
|
||||
# Various libexec programs:
|
||||
%dir %{_libexecdir}/evolution
|
||||
%dir %{_libexecdir}/evolution/%{evo_major}
|
||||
%{_libexecdir}/evolution/%{evo_major}/csv2vcard
|
||||
%{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-clean
|
||||
%{_libexecdir}/evolution/%{evo_major}/evolution-addressbook-export
|
||||
%{_libexecdir}/evolution/%{evo_major}/evolution-alarm-notify
|
||||
%{_libexecdir}/evolution/%{evo_major}/killev
|
||||
|
||||
# Various conduits for gnome-pilot:
|
||||
%if %{pilot_support}
|
||||
%dir %{_libdir}/evolution/%{evo_major}/conduits
|
||||
%{_libdir}/evolution/%{evo_major}/conduits/*.so
|
||||
%{_libdir}/gnome-pilot/conduits/*.conduit
|
||||
|
||||
%{_libdir}/evolution/%{evo_major}/conduits/libeaddress_conduit.so
|
||||
%{_libdir}/gnome-pilot/conduits/e-address-%{evo_major}.conduit
|
||||
|
||||
%{_libdir}/evolution/%{evo_major}/conduits/libecalendar_conduit.so
|
||||
%{_libdir}/gnome-pilot/conduits/e-calendar-%{evo_major}.conduit
|
||||
|
||||
%{_libdir}/evolution/%{evo_major}/conduits/libememo_conduit.so
|
||||
%{_libdir}/gnome-pilot/conduits/e-memo-%{evo_major}.conduit
|
||||
|
||||
%{_libdir}/evolution/%{evo_major}/conduits/libetodo_conduit.so
|
||||
%{_libdir}/gnome-pilot/conduits/e-todo-%{evo_major}.conduit
|
||||
%endif
|
||||
|
||||
# The plugin directory:
|
||||
%dir %{evo_plugin_dir}
|
||||
|
||||
# The various plugins follow; they are all part of the main package:
|
||||
# (note that there are various resources such as glade and pixmap files that
|
||||
# are built as part of specific plugins but which are currently packaged using
|
||||
@ -468,6 +551,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-mail-to-task.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-mail-to-task.so
|
||||
%{evo_plugin_dir}/org-gnome-mail-to-task.xml
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-mark-all-read.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-mark-all-read.so
|
||||
@ -506,14 +590,62 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{evo_plugin_dir}/org-gnome-publish-calendar.xml
|
||||
%{evo_plugin_dir}/publish-calendar.glade
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-evolution-caldav.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-evolution-caldav.so
|
||||
|
||||
%{evo_plugin_dir}/org-gnome-evolution-mail-attachments-import-ics.eplug
|
||||
%{evo_plugin_dir}/liborg-gnome-evolution-mail-attachments-import-ics.so
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root)
|
||||
%{_includedir}/evolution-%{evo_major}
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%{_libdir}/evolution/%{evo_major}/*.so
|
||||
%{_libdir}/pkgconfig/evolution-plugin-%{evo_major}.pc
|
||||
%{_libdir}/pkgconfig/evolution-shell-%{evo_major}.pc
|
||||
%{_libdir}/evolution/%{evo_major}/libeabutil.so
|
||||
%{_libdir}/evolution/%{evo_major}/libeconduit.so
|
||||
%{_libdir}/evolution/%{evo_major}/libecontacteditor.so
|
||||
%{_libdir}/evolution/%{evo_major}/libecontactlisteditor.so
|
||||
%{_libdir}/evolution/%{evo_major}/libefilterbar.so
|
||||
%{_libdir}/evolution/%{evo_major}/libemiscwidgets.so
|
||||
%{_libdir}/evolution/%{evo_major}/libeshell.so
|
||||
%{_libdir}/evolution/%{evo_major}/libessmime.so
|
||||
%{_libdir}/evolution/%{evo_major}/libetable.so
|
||||
%{_libdir}/evolution/%{evo_major}/libetext.so
|
||||
%{_libdir}/evolution/%{evo_major}/libetimezonedialog.so
|
||||
%{_libdir}/evolution/%{evo_major}/libeutil.so
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-a11y.so
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-addressbook-a11y.so
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-addressbook-importers.so
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-calendar-a11y.so
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-calendar-importers.so
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-mail-importers.so
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-smime.so
|
||||
%{_libdir}/evolution/%{evo_major}/libevolution-widgets-a11y.so
|
||||
%{_libdir}/evolution/%{evo_major}/libfilter.so
|
||||
%{_libdir}/evolution/%{evo_major}/libmenus.so
|
||||
|
||||
%changelog
|
||||
* Wed Jan 25 2006 David Malcolm <dmalcolm@redhat.com> - 2.5.5.1-1
|
||||
- 2.5.5.1
|
||||
- update patch 106 to track upstream, renaming from
|
||||
evolution-2.2.2-commit-enter-on-calendar.patch to
|
||||
evolution-2.5.5.1-commit-enter-on-calendar.patch
|
||||
- update patch 805 to track upstream
|
||||
- added patch to fix some newly missing declarations (patch 808)
|
||||
- replace evolution-2.5.4-port-to-new-libnotify-api.patch with
|
||||
evolution-2.5.5.1-notification-cleanups.patch, since much of this was
|
||||
duplicated by another patch that landed upstream; removing the actions code
|
||||
as it was crashing deep inside DBus (patch 806, #177666)
|
||||
- explicitly list various files to reduce reliance on globbing; organized the
|
||||
files into logical groups; comment them
|
||||
- added -Wno-sign-compare to CFLAGS
|
||||
- enabled parallel make
|
||||
- introduced require_function_declarations macro to make
|
||||
-Werror-implicit-function-declaration flag optional; turn it off for now
|
||||
- include the new CalDAV and mail-attachments-import plugins in the file list;
|
||||
add an XML UI file for the mail-to-task plugin.
|
||||
- use "sed -i -e" rather than "sed -ie" to avoid getting severe bonobo files
|
||||
|
||||
* Wed Jan 18 2006 Ray Strode <rstrode@redhat.com> - 2.5.4-10
|
||||
- fix fix for multilib issue with shlib bonobo components (bug 156982)
|
||||
|
||||
@ -522,7 +654,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
* Thu Jan 12 2006 David Malcolm <dmalcolm@redhat.com> - 2.5.4-8
|
||||
- avoid multiple initialization of NetworkManager connections (patch 807,
|
||||
gnome bug #326875)
|
||||
gnome bug #326785)
|
||||
|
||||
* Thu Jan 12 2006 David Malcolm <dmalcolm@redhat.com> - 2.5.4-7
|
||||
- updated alarm notification patch(patch 806, #177546, #177666, #177667,
|
||||
|
Loading…
Reference in New Issue
Block a user