import evolution-3.40.4-2.el9
This commit is contained in:
parent
6ccc37530d
commit
333882fc53
@ -1 +1,2 @@
|
||||
2ad33472d280d83737884a0e60a9236793653111 SOURCES/emoji.data
|
||||
2b480d7dd297d84c1b1321f5c90bd0e35d566433 SOURCES/evolution-3.40.4.tar.xz
|
||||
|
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
SOURCES/emoji.data
|
||||
SOURCES/evolution-3.40.4.tar.xz
|
||||
|
56
SOURCES/evolution-3.40.4-empty-emoji-picker.patch
Normal file
56
SOURCES/evolution-3.40.4-empty-emoji-picker.patch
Normal file
@ -0,0 +1,56 @@
|
||||
From e75c4faa36a9eb17b88128e45f9e5d91628149f9 Mon Sep 17 00:00:00 2001
|
||||
From: Milan Crha <mcrha@redhat.com>
|
||||
Date: Mon, 4 Oct 2021 17:18:35 +0200
|
||||
Subject: I#1646 - Emoji picker empty
|
||||
|
||||
Embed emoji.data as expected by the copy of the gtk+' emoji chooser dialog.
|
||||
|
||||
Closes https://gitlab.gnome.org/GNOME/evolution/-/issues/1646
|
||||
|
||||
diff --git a/data/org.gnome.Evolution.gresource.xml b/data/org.gnome.Evolution.gresource.xml
|
||||
new file mode 100644
|
||||
index 0000000000..783ed153b8
|
||||
--- /dev/null
|
||||
+++ b/data/org.gnome.Evolution.gresource.xml
|
||||
@@ -0,0 +1,6 @@
|
||||
+<?xml version='1.0' encoding='UTF-8'?>
|
||||
+<gresources>
|
||||
+ <gresource prefix="org.gnome.Evolution">
|
||||
+ <file>emoji.data</file>
|
||||
+ </gresource>
|
||||
+</gresources>
|
||||
diff --git a/src/e-util/CMakeLists.txt b/src/e-util/CMakeLists.txt
|
||||
index 03b60d8e4b..6f63f29858 100644
|
||||
--- a/src/e-util/CMakeLists.txt
|
||||
+++ b/src/e-util/CMakeLists.txt
|
||||
@@ -30,6 +30,8 @@ if(WIN32)
|
||||
)
|
||||
endif(WIN32)
|
||||
|
||||
+glib_compile_resources(${CMAKE_SOURCE_DIR}/data/ ${CMAKE_CURRENT_BINARY_DIR}/org.gnome.Evolution.gresource org_gnome_evolution ../../data/org.gnome.Evolution.gresource.xml ${CMAKE_SOURCE_DIR}/data/emoji.data)
|
||||
+
|
||||
# Main libevolution-util
|
||||
|
||||
set(DEPENDENCIES
|
||||
@@ -309,6 +311,8 @@ set(SOURCES
|
||||
${PLATFORM_SOURCES}
|
||||
${CMAKE_CURRENT_BINARY_DIR}/e-marshal.c
|
||||
${CMAKE_CURRENT_BINARY_DIR}/e-util-enumtypes.c
|
||||
+ ${CMAKE_CURRENT_BINARY_DIR}/org.gnome.Evolution.gresource.c
|
||||
+ ${CMAKE_CURRENT_BINARY_DIR}/org.gnome.Evolution.gresource.h
|
||||
)
|
||||
|
||||
set(HEADERS
|
||||
diff --git a/src/e-util/e-gtkemojichooser.c b/src/e-util/e-gtkemojichooser.c
|
||||
index ba4d15ecee..7d8aae3039 100644
|
||||
--- a/src/e-util/e-gtkemojichooser.c
|
||||
+++ b/src/e-util/e-gtkemojichooser.c
|
||||
@@ -444,7 +444,7 @@ populate_emoji_chooser (gpointer data)
|
||||
|
||||
if (!chooser->data)
|
||||
{
|
||||
- bytes = g_resources_lookup_data ("/org/gtk/libgtk/emoji/emoji.data", 0, NULL);
|
||||
+ bytes = g_resources_lookup_data ("/org.gnome.Evolution/emoji.data", 0, NULL);
|
||||
chooser->data = g_variant_ref_sink (g_variant_new_from_bytes (G_VARIANT_TYPE ("a(auss)"), bytes, TRUE));
|
||||
}
|
||||
|
@ -43,13 +43,16 @@
|
||||
|
||||
Name: evolution
|
||||
Version: 3.40.4
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Mail and calendar client for GNOME
|
||||
License: GPLv2+ and GFDL
|
||||
URL: https://wiki.gnome.org/Apps/Evolution
|
||||
Source: http://download.gnome.org/sources/%{name}/3.40/%{name}-%{version}.tar.xz
|
||||
Source1: flatpak-evolution-fix-service-names.sh
|
||||
Source2: flatpak-evolution-wrapper.sh.in
|
||||
Source3: emoji.data
|
||||
|
||||
Patch01: evolution-3.40.4-empty-emoji-picker.patch
|
||||
|
||||
# Approximate version number
|
||||
Provides: bundled(libgnomecanvas) = 2.30.0
|
||||
@ -241,6 +244,8 @@ the functionality of the installed %{name} package.
|
||||
%prep
|
||||
%autosetup -p1 -S gendiff
|
||||
|
||||
cp %{S:3} data/
|
||||
|
||||
# Remove the welcome email from Novell
|
||||
for inbox in src/mail/default/*/Inbox; do
|
||||
echo -n "" > $inbox
|
||||
@ -563,6 +568,9 @@ grep -v "%{_datadir}/locale" evolution.lang > help.lang
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Oct 11 2021 Milan Crha <mcrha@redhat.com> - 3.40.4-2
|
||||
- Resolves: #2012701 (Empty emoji picker with gtk3 3.24.30)
|
||||
|
||||
* Fri Aug 13 2021 Milan Crha <mcrha@redhat.com> - 3.40.4-1
|
||||
- Related: #1992450 (Update to 3.40.4)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user