- Don't ship the unfinished "Custom Header" plugin.
This commit is contained in:
parent
ff68de7581
commit
1d0a55f759
@ -1,26 +0,0 @@
|
|||||||
--- evolution-2.0.2/mail/em-utils.c.fix-145552 2004-09-24 11:49:29.000000000 -0400
|
|
||||||
+++ evolution-2.0.2/mail/em-utils.c 2005-08-02 22:42:04.000000000 -0400
|
|
||||||
@@ -2176,10 +2176,22 @@
|
|
||||||
* try to do better with the filename check.
|
|
||||||
*/
|
|
||||||
|
|
||||||
+ /* RH bug 145552: code based on _gnome_vfs_get_mime_type_internal:
|
|
||||||
+ * So many file types come compressed by gzip
|
|
||||||
+ * that extensions are more reliable than magic
|
|
||||||
+ * typing. If the file has a suffix, then use
|
|
||||||
+ * the type from the suffix:
|
|
||||||
+ */
|
|
||||||
if (magic_type) {
|
|
||||||
if (name_type
|
|
||||||
&& (!strcmp(magic_type, "text/plain")
|
|
||||||
- || !strcmp(magic_type, "application/octet-stream")))
|
|
||||||
+ || !strcmp(magic_type, "application/octet-stream")
|
|
||||||
+ || !strcmp(magic_type, "application/octet-stream")
|
|
||||||
+ || !strcmp(magic_type, "application/x-ole-storage")
|
|
||||||
+ || !strcmp(magic_type, "text/xml")
|
|
||||||
+ || !strcmp(magic_type, "application/x-bzip")
|
|
||||||
+ || !strcmp(magic_type, "application/x-gzip")
|
|
||||||
+ || !strcmp(magic_type, "application/zip")))
|
|
||||||
return name_type;
|
|
||||||
else
|
|
||||||
return magic_type;
|
|
@ -1,48 +0,0 @@
|
|||||||
diff -up evolution-2.21.92/mail/em-format.c.CVE-2008-0072 evolution-2.21.92/mail/em-format.c
|
|
||||||
--- evolution-2.21.92/mail/em-format.c.CVE-2008-0072 2008-01-27 22:59:48.000000000 -0500
|
|
||||||
+++ evolution-2.21.92/mail/em-format.c 2008-03-04 15:40:29.000000000 -0500
|
|
||||||
@@ -1193,7 +1193,7 @@ emf_application_xpkcs7mime(EMFormat *emf
|
|
||||||
opart = camel_mime_part_new();
|
|
||||||
valid = camel_cipher_decrypt(context, part, opart, ex);
|
|
||||||
if (valid == NULL) {
|
|
||||||
- em_format_format_error(emf, stream, ex->desc?ex->desc:_("Could not parse S/MIME message: Unknown error"));
|
|
||||||
+ em_format_format_error(emf, stream, "%s", ex->desc?ex->desc:_("Could not parse S/MIME message: Unknown error"));
|
|
||||||
em_format_part_as(emf, stream, part, NULL);
|
|
||||||
} else {
|
|
||||||
if (emfc == NULL)
|
|
||||||
@@ -1350,7 +1350,7 @@ emf_multipart_encrypted(EMFormat *emf, C
|
|
||||||
if (valid == NULL) {
|
|
||||||
em_format_format_error(emf, stream, ex->desc?_("Could not parse PGP/MIME message"):_("Could not parse PGP/MIME message: Unknown error"));
|
|
||||||
if (ex->desc)
|
|
||||||
- em_format_format_error(emf, stream, ex->desc);
|
|
||||||
+ em_format_format_error(emf, stream, "%s", ex->desc);
|
|
||||||
em_format_part_as(emf, stream, part, "multipart/mixed");
|
|
||||||
} else {
|
|
||||||
if (emfc == NULL)
|
|
||||||
@@ -1515,7 +1515,7 @@ emf_multipart_signed(EMFormat *emf, Came
|
|
||||||
if (valid == NULL) {
|
|
||||||
em_format_format_error(emf, stream, ex->desc?_("Error verifying signature"):_("Unknown error verifying signature"));
|
|
||||||
if (ex->desc)
|
|
||||||
- em_format_format_error(emf, stream, ex->desc);
|
|
||||||
+ em_format_format_error(emf, stream, "%s", ex->desc);
|
|
||||||
em_format_part_as(emf, stream, part, "multipart/mixed");
|
|
||||||
} else {
|
|
||||||
if (emfc == NULL)
|
|
||||||
@@ -1586,7 +1586,7 @@ emf_inlinepgp_signed(EMFormat *emf, Came
|
|
||||||
if (!valid) {
|
|
||||||
em_format_format_error(emf, stream, ex->desc?_("Error verifying signature"):_("Unknown error verifying signature"));
|
|
||||||
if (ex->desc)
|
|
||||||
- em_format_format_error(emf, stream, ex->desc);
|
|
||||||
+ em_format_format_error(emf, stream, "%s", ex->desc);
|
|
||||||
em_format_format_source(emf, stream, ipart);
|
|
||||||
/* I think this will loop: em_format_part_as(emf, stream, part, "text/plain"); */
|
|
||||||
camel_exception_free(ex);
|
|
||||||
@@ -1658,7 +1658,7 @@ emf_inlinepgp_encrypted(EMFormat *emf, C
|
|
||||||
if (!valid) {
|
|
||||||
em_format_format_error(emf, stream, ex->desc?_("Could not parse PGP message"):_("Could not parse PGP message: Unknown error"));
|
|
||||||
if (ex->desc)
|
|
||||||
- em_format_format_error(emf, stream, ex->desc);
|
|
||||||
+ em_format_format_error(emf, stream, "%s", ex->desc);
|
|
||||||
em_format_format_source(emf, stream, ipart);
|
|
||||||
/* I think this will loop: em_format_part_as(emf, stream, part, "text/plain"); */
|
|
||||||
camel_exception_free(ex);
|
|
38
evolution-2.23.4-experimental-plugins.patch
Normal file
38
evolution-2.23.4-experimental-plugins.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
diff -up evolution-2.23.4/configure.experimental-plugins evolution-2.23.4/configure
|
||||||
|
--- evolution-2.23.4/configure.experimental-plugins 2008-06-19 08:34:44.000000000 -0400
|
||||||
|
+++ evolution-2.23.4/configure 2008-06-19 08:35:07.000000000 -0400
|
||||||
|
@@ -38556,13 +38556,13 @@ plugins_base_always="calendar-file calen
|
||||||
|
plugins_base="$plugins_base_always $SA_JUNK_PLUGIN $BF_JUNK_PLUGIN $EXCHANGE_PLUGIN $MONO_PLUGIN "
|
||||||
|
all_plugins_base="$plugins_base_always sa-junk-plugin bogo-junk-plugin exchange-operations mono"
|
||||||
|
|
||||||
|
-plugins_standard_always="bbdb subject-thread save-calendar select-one-source copy-tool mail-to-task mark-calendar-offline audio-inline mailing-list-actions default-mailer import-ics-attachments prefer-plain mail-notification attachment-reminder face backup-restore email-custom-header"
|
||||||
|
+plugins_standard_always="bbdb subject-thread save-calendar select-one-source copy-tool mail-to-task mark-calendar-offline audio-inline mailing-list-actions default-mailer import-ics-attachments prefer-plain mail-notification attachment-reminder face backup-restore"
|
||||||
|
|
||||||
|
plugins_standard="$plugins_standard_always"
|
||||||
|
all_plugins_standard="$plugins_standard"
|
||||||
|
|
||||||
|
plugins_experimental_always="folder-unsubscribe mail-to-meeting save-attachments external-editor"
|
||||||
|
-plugins_experimental="$plugins_experimental_always $IPOD_SYNC $TNEF_ATTACHMENTS $PYTHON_PLUGIN"
|
||||||
|
+plugins_experimental="$plugins_experimental_always $IPOD_SYNC $TNEF_ATTACHMENTS $PYTHON_PLUGIN email-custom-header"
|
||||||
|
all_plugins_experimental="$plugins_experimental_always ipod-sync tnef-attachments"
|
||||||
|
|
||||||
|
case x"$enable_plugins" in
|
||||||
|
diff -up evolution-2.23.4/configure.in.experimental-plugins evolution-2.23.4/configure.in
|
||||||
|
--- evolution-2.23.4/configure.in.experimental-plugins 2008-06-19 08:34:01.000000000 -0400
|
||||||
|
+++ evolution-2.23.4/configure.in 2008-06-19 08:34:35.000000000 -0400
|
||||||
|
@@ -1732,13 +1732,13 @@ plugins_base_always="calendar-file calen
|
||||||
|
plugins_base="$plugins_base_always $SA_JUNK_PLUGIN $BF_JUNK_PLUGIN $EXCHANGE_PLUGIN $MONO_PLUGIN "
|
||||||
|
all_plugins_base="$plugins_base_always sa-junk-plugin bogo-junk-plugin exchange-operations mono"
|
||||||
|
|
||||||
|
-plugins_standard_always="bbdb subject-thread save-calendar select-one-source copy-tool mail-to-task mark-calendar-offline audio-inline mailing-list-actions default-mailer import-ics-attachments prefer-plain mail-notification attachment-reminder face backup-restore email-custom-header"
|
||||||
|
+plugins_standard_always="bbdb subject-thread save-calendar select-one-source copy-tool mail-to-task mark-calendar-offline audio-inline mailing-list-actions default-mailer import-ics-attachments prefer-plain mail-notification attachment-reminder face backup-restore"
|
||||||
|
|
||||||
|
plugins_standard="$plugins_standard_always"
|
||||||
|
all_plugins_standard="$plugins_standard"
|
||||||
|
|
||||||
|
plugins_experimental_always="folder-unsubscribe mail-to-meeting save-attachments external-editor"
|
||||||
|
-plugins_experimental="$plugins_experimental_always $IPOD_SYNC $TNEF_ATTACHMENTS $PYTHON_PLUGIN"
|
||||||
|
+plugins_experimental="$plugins_experimental_always $IPOD_SYNC $TNEF_ATTACHMENTS $PYTHON_PLUGIN email-custom-header"
|
||||||
|
all_plugins_experimental="$plugins_experimental_always ipod-sync tnef-attachments"
|
||||||
|
|
||||||
|
case x"$enable_plugins" in
|
@ -45,7 +45,7 @@
|
|||||||
|
|
||||||
Name: evolution
|
Name: evolution
|
||||||
Version: 2.23.4
|
Version: 2.23.4
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2 and GFDL+
|
License: GPLv2 and GFDL+
|
||||||
Group: Applications/Productivity
|
Group: Applications/Productivity
|
||||||
Summary: Mail and calendar client for GNOME
|
Summary: Mail and calendar client for GNOME
|
||||||
@ -77,6 +77,9 @@ Patch13: evolution-2.7.1-no-gnome-common.patch
|
|||||||
# RH bug #176400
|
# RH bug #176400
|
||||||
Patch14: evolution-2.9.1-im-context-reset.patch
|
Patch14: evolution-2.9.1-im-context-reset.patch
|
||||||
|
|
||||||
|
# Don't ship broken plugins as stable
|
||||||
|
Patch15: evolution-2.23.4-experimental-plugins.patch
|
||||||
|
|
||||||
## Dependencies ###
|
## Dependencies ###
|
||||||
|
|
||||||
Requires(post): GConf2
|
Requires(post): GConf2
|
||||||
@ -220,6 +223,7 @@ This package contains the plugin to filter junk mail using SpamAssassin.
|
|||||||
%patch12 -p1 -b .fix-conduit-dir
|
%patch12 -p1 -b .fix-conduit-dir
|
||||||
%patch13 -p1 -b .no-gnome-common
|
%patch13 -p1 -b .no-gnome-common
|
||||||
%patch14 -p1 -b .im-context-reset
|
%patch14 -p1 -b .im-context-reset
|
||||||
|
%patch15 -p1 -b .experimental-plugins
|
||||||
|
|
||||||
mkdir -p krb5-fakeprefix/include
|
mkdir -p krb5-fakeprefix/include
|
||||||
mkdir -p krb5-fakeprefix/lib
|
mkdir -p krb5-fakeprefix/lib
|
||||||
@ -356,7 +360,6 @@ scrollkeeper-update -q
|
|||||||
touch --no-create %{_datadir}/icons/hicolor || :
|
touch --no-create %{_datadir}/icons/hicolor || :
|
||||||
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
|
||||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||||
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_evolution_email_custom_header.schemas > /dev/null
|
|
||||||
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps-evolution-mail-notification.schemas > /dev/null
|
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps-evolution-mail-notification.schemas > /dev/null
|
||||||
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps-evolution-mail-prompts-checkdefault.schemas > /dev/null
|
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps-evolution-mail-prompts-checkdefault.schemas > /dev/null
|
||||||
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_evolution_addressbook.schemas > /dev/null
|
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/apps_evolution_addressbook.schemas > /dev/null
|
||||||
@ -383,7 +386,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc AUTHORS COPYING ChangeLog NEWS README
|
%doc AUTHORS COPYING ChangeLog NEWS README
|
||||||
|
|
||||||
# GConf schemas:
|
# GConf schemas:
|
||||||
%{_sysconfdir}/gconf/schemas/apps_evolution_email_custom_header.schemas
|
|
||||||
%{_sysconfdir}/gconf/schemas/apps-evolution-attachment-reminder.schemas
|
%{_sysconfdir}/gconf/schemas/apps-evolution-attachment-reminder.schemas
|
||||||
%{_sysconfdir}/gconf/schemas/apps-evolution-mail-notification.schemas
|
%{_sysconfdir}/gconf/schemas/apps-evolution-mail-notification.schemas
|
||||||
%{_sysconfdir}/gconf/schemas/apps-evolution-mail-prompts-checkdefault.schemas
|
%{_sysconfdir}/gconf/schemas/apps-evolution-mail-prompts-checkdefault.schemas
|
||||||
@ -506,9 +508,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{evo_plugin_dir}/org-gnome-default-source.eplug
|
%{evo_plugin_dir}/org-gnome-default-source.eplug
|
||||||
%{evo_plugin_dir}/liborg-gnome-default-source.so
|
%{evo_plugin_dir}/liborg-gnome-default-source.so
|
||||||
|
|
||||||
%{evo_plugin_dir}/org-gnome-email-custom-header.eplug
|
|
||||||
%{evo_plugin_dir}/liborg-gnome-email-custom-header.so
|
|
||||||
|
|
||||||
%{evo_plugin_dir}/org-gnome-evolution-bbdb.eplug
|
%{evo_plugin_dir}/org-gnome-evolution-bbdb.eplug
|
||||||
%{evo_plugin_dir}/liborg-gnome-evolution-bbdb.so
|
%{evo_plugin_dir}/liborg-gnome-evolution-bbdb.so
|
||||||
|
|
||||||
@ -647,6 +646,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{evo_plugin_dir}/liborg-gnome-sa-junk-plugin.so
|
%{evo_plugin_dir}/liborg-gnome-sa-junk-plugin.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 19 2008 Matthew Barnes <mbarnes@redhat.com> - 2.23.4-2.fc10
|
||||||
|
- Don't ship the unfinished "Custom Header" plugin.
|
||||||
|
|
||||||
* Mon Jun 16 2008 Matthew Barnes <mbarnes@redhat.com> - 2.23.4-1.fc10
|
* Mon Jun 16 2008 Matthew Barnes <mbarnes@redhat.com> - 2.23.4-1.fc10
|
||||||
- Update to 2.23.4
|
- Update to 2.23.4
|
||||||
- Remove patches for RH bug #449925 (fixed upstream).
|
- Remove patches for RH bug #449925 (fixed upstream).
|
||||||
|
Loading…
Reference in New Issue
Block a user