Update to 3.21.91
This commit is contained in:
parent
89372a60e2
commit
1c2228543d
1
.gitignore
vendored
1
.gitignore
vendored
@ -111,3 +111,4 @@ evolution-2.31.5.tar.bz2
|
|||||||
/evolution-3.21.3.tar.xz
|
/evolution-3.21.3.tar.xz
|
||||||
/evolution-3.21.4.tar.xz
|
/evolution-3.21.4.tar.xz
|
||||||
/evolution-3.21.90.tar.xz
|
/evolution-3.21.90.tar.xz
|
||||||
|
/evolution-3.21.91.tar.xz
|
||||||
|
@ -1,46 +0,0 @@
|
|||||||
diff --git a/modules/itip-formatter/web-extension/Makefile.am b/modules/itip-formatter/web-extension/Makefile.am
|
|
||||||
index a519744..87df8e6 100644
|
|
||||||
--- a/modules/itip-formatter/web-extension/Makefile.am
|
|
||||||
+++ b/modules/itip-formatter/web-extension/Makefile.am
|
|
||||||
@@ -21,6 +21,6 @@ libmoduleitipformatterwebextension_la_LIBADD = \
|
|
||||||
$(WEB_EXTENSIONS_LIBS)
|
|
||||||
|
|
||||||
libmoduleitipformatterwebextension_la_LDFLAGS = \
|
|
||||||
- -module -avoid-version -no-undefined
|
|
||||||
+ -module -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
|
|
||||||
|
|
||||||
-include $(top_srcdir)/git.mk
|
|
||||||
diff --git a/modules/webkit-editor/web-extension/Makefile.am b/modules/webkit-editor/web-extension/Makefile.am
|
|
||||||
index f2a7b02..2d31253 100644
|
|
||||||
--- a/modules/webkit-editor/web-extension/Makefile.am
|
|
||||||
+++ b/modules/webkit-editor/web-extension/Makefile.am
|
|
||||||
@@ -33,6 +33,6 @@ libewebkiteditorwebextension_la_LIBADD = \
|
|
||||||
$(WEB_EXTENSIONS_LIBS)
|
|
||||||
|
|
||||||
libewebkiteditorwebextension_la_LDFLAGS = \
|
|
||||||
- -module -avoid-version -no-undefined
|
|
||||||
+ -module -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
|
|
||||||
|
|
||||||
-include $(top_srcdir)/git.mk
|
|
||||||
diff --git a/web-extensions/Makefile.am b/web-extensions/Makefile.am
|
|
||||||
index 07854c2..d98f361 100644
|
|
||||||
--- a/web-extensions/Makefile.am
|
|
||||||
+++ b/web-extensions/Makefile.am
|
|
||||||
@@ -16,6 +16,8 @@ libedomutils_la_LIBADD = \
|
|
||||||
$(EVOLUTION_DATA_SERVER_LIBS) \
|
|
||||||
$(GNOME_PLATFORM_LIBS)
|
|
||||||
|
|
||||||
+libedomutils_la_LDFLAGS = -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
|
|
||||||
+
|
|
||||||
libewebextension_la_SOURCES = \
|
|
||||||
e-web-extension.h \
|
|
||||||
e-web-extension-names.h \
|
|
||||||
@@ -38,7 +40,6 @@ libewebextension_la_LIBADD = \
|
|
||||||
$(GNOME_PLATFORM_LIBS) \
|
|
||||||
$(WEB_EXTENSIONS_LIBS)
|
|
||||||
|
|
||||||
-libewebextension_la_LDFLAGS = \
|
|
||||||
- -module -avoid-version -no-undefined
|
|
||||||
+libewebextension_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
|
|
||||||
|
|
||||||
-include $(top_srcdir)/git.mk
|
|
@ -28,7 +28,7 @@
|
|||||||
### Abstract ###
|
### Abstract ###
|
||||||
|
|
||||||
Name: evolution
|
Name: evolution
|
||||||
Version: 3.21.90
|
Version: 3.21.91
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Group: Applications/Productivity
|
Group: Applications/Productivity
|
||||||
Summary: Mail and calendar client for GNOME
|
Summary: Mail and calendar client for GNOME
|
||||||
@ -46,8 +46,6 @@ Obsoletes: evolution-NetworkManager < %{last_evo_nm_version}
|
|||||||
# RH bug #
|
# RH bug #
|
||||||
#Patch01: evolution-3.17.1-doc-e-cell-renderer-color.patch
|
#Patch01: evolution-3.17.1-doc-e-cell-renderer-color.patch
|
||||||
|
|
||||||
Patch01: evolution-3.21.90-ldflags.patch
|
|
||||||
|
|
||||||
## Dependencies ###
|
## Dependencies ###
|
||||||
|
|
||||||
Requires: gvfs
|
Requires: gvfs
|
||||||
@ -202,7 +200,6 @@ the functionality of the installed %{name} package.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n evolution-%{version}
|
%setup -q -n evolution-%{version}
|
||||||
#%patch01 -p1 -b .doc-e-cell-renderer-color
|
#%patch01 -p1 -b .doc-e-cell-renderer-color
|
||||||
%patch01 -p1 -b .ldflags
|
|
||||||
|
|
||||||
# Remove the welcome email from Novell
|
# Remove the welcome email from Novell
|
||||||
for inbox in mail/default/*/Inbox; do
|
for inbox in mail/default/*/Inbox; do
|
||||||
@ -528,6 +525,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 29 2016 Milan Crha <mcrha@redhat.com> - 3.21.91-1
|
||||||
|
- Update to 3.21.91
|
||||||
|
|
||||||
* Mon Aug 15 2016 Milan Crha <mcrha@redhat.com> - 3.21.90-1
|
* Mon Aug 15 2016 Milan Crha <mcrha@redhat.com> - 3.21.90-1
|
||||||
- Update to 3.21.90
|
- Update to 3.21.90
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user