- Revise evolution-data-server-1.8.0-no-gnome-common.patch so that we no

longer have to run autoconf before building.
This commit is contained in:
Matthew Barnes 2007-01-22 03:35:03 +00:00
parent 48692f7f9d
commit ea2bb07e7e
2 changed files with 152 additions and 14 deletions

View File

@ -1,6 +1,150 @@
--- evolution-data-server-1.5.4/configure.in.make_imap4_optional 2006-01-09 17:24:10.000000000 -0500
+++ evolution-data-server-1.5.4/configure.in 2006-01-09 17:24:12.000000000 -0500
@@ -1093,8 +1103,6 @@
--- evolution-data-server-1.9.5/configure.no-gnome-common 2007-01-21 21:49:28.000000000 -0500
+++ evolution-data-server-1.9.5/configure 2007-01-21 21:50:44.000000000 -0500
@@ -29801,141 +29801,6 @@
- # Check whether --enable-compile-warnings or --disable-compile-warnings was given.
-if test "${enable_compile_warnings+set}" = set; then
- enableval="$enable_compile_warnings"
-
-else
- enable_compile_warnings="yes"
-fi;
-
- warnCFLAGS=
- if test "x$GCC" != xyes; then
- enable_compile_warnings=no
- fi
-
- warning_flags=
- realsave_CFLAGS="$CFLAGS"
-
- case "$enable_compile_warnings" in
- no)
- warning_flags=
- ;;
- minimum)
- warning_flags="-Wall"
- ;;
- yes)
- warning_flags="-Wall -Wmissing-prototypes"
- ;;
- maximum|error)
- warning_flags="-Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith"
- CFLAGS="$warning_flags $CFLAGS"
- for option in -Wno-sign-compare; do
- SAVE_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $option"
- echo "$as_me:$LINENO: checking whether gcc understands $option" >&5
-echo $ECHO_N "checking whether gcc understands $option... $ECHO_C" >&6
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
-_ACEOF
-cat confdefs.h >>conftest.$ac_ext
-cat >>conftest.$ac_ext <<_ACEOF
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-rm -f conftest.$ac_objext
-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
- (eval $ac_compile) 2>conftest.er1
- ac_status=$?
- grep -v '^ *+' conftest.er1 >conftest.err
- rm -f conftest.er1
- cat conftest.err >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } &&
- { ac_try='test -z "$ac_c_werror_flag"
- || test ! -s conftest.err'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; } &&
- { ac_try='test -s conftest.$ac_objext'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
- has_option=yes
-else
- echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-has_option=no
-fi
-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS="$SAVE_CFLAGS"
- echo "$as_me:$LINENO: result: $has_option" >&5
-echo "${ECHO_T}$has_option" >&6
- if test $has_option = yes; then
- warning_flags="$warning_flags $option"
- fi
- unset has_option
- unset SAVE_CFLAGS
- done
- unset option
- if test "$enable_compile_warnings" = "error" ; then
- warning_flags="$warning_flags -Werror"
- fi
- ;;
- *)
- { { echo "$as_me:$LINENO: error: Unknown argument '$enable_compile_warnings' to --enable-compile-warnings" >&5
-echo "$as_me: error: Unknown argument '$enable_compile_warnings' to --enable-compile-warnings" >&2;}
- { (exit 1); exit 1; }; }
- ;;
- esac
- CFLAGS="$realsave_CFLAGS"
- echo "$as_me:$LINENO: checking what warning flags to pass to the C compiler" >&5
-echo $ECHO_N "checking what warning flags to pass to the C compiler... $ECHO_C" >&6
- echo "$as_me:$LINENO: result: $warning_flags" >&5
-echo "${ECHO_T}$warning_flags" >&6
-
- # Check whether --enable-iso-c or --disable-iso-c was given.
-if test "${enable_iso_c+set}" = set; then
- enableval="$enable_iso_c"
-
-else
- enable_iso_c=no
-fi;
-
- echo "$as_me:$LINENO: checking what language compliance flags to pass to the C compiler" >&5
-echo $ECHO_N "checking what language compliance flags to pass to the C compiler... $ECHO_C" >&6
- complCFLAGS=
- if test "x$enable_iso_c" != "xno"; then
- if test "x$GCC" = "xyes"; then
- case " $CFLAGS " in
- *\ \ -ansi\ \ *) ;;
- *) complCFLAGS="$complCFLAGS -ansi" ;;
- esac
- case " $CFLAGS " in
- *\ \ -pedantic\ \ *) ;;
- *) complCFLAGS="$complCFLAGS -pedantic" ;;
- esac
- fi
- fi
- echo "$as_me:$LINENO: result: $complCFLAGS" >&5
-echo "${ECHO_T}$complCFLAGS" >&6
-
- WARN_CFLAGS="$warning_flags $complCFLAGS"
-
-
-CFLAGS="$CFLAGS $WARN_CFLAGS"
case $CFLAGS in
*-Wall*)
# Turn off the annoying "comparison between signed and unsigned"
--- evolution-data-server-1.9.5/configure.in.no-gnome-common 2007-01-08 11:49:57.000000000 -0500
+++ evolution-data-server-1.9.5/configure.in 2007-01-21 21:49:01.000000000 -0500
@@ -1206,8 +1206,6 @@
dnl CFLAGS and LIBS and stuff
dnl *************************

View File

@ -25,7 +25,7 @@
Name: evolution-data-server
Version: 1.9.5
Release: 3%{?dist}
Release: 4%{?dist}
License: LGPL
Group: System Environment/Libraries
Summary: Backend data server for Evolution
@ -246,16 +246,6 @@ CFLAGS="$CFLAGS \
-Werror-implicit-function-declaration"
%endif
# Rerun automake since we patched some Makefile.am files:
aclocal
autoheader
automake
libtoolize
intltoolize --force
# Rerun autoconf since we patched configure.in:
autoconf
# See Ross Burton's blog entry for why we want --with-libdb.
# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
@ -384,6 +374,10 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/pkgconfig/libexchange-storage-%{eds_api_version}.pc
%changelog
* Sun Jan 21 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.5-4.fc7
- Revise evolution-data-server-1.8.0-no-gnome-common.patch so that we no
longer have to run autoconf before building.
* Wed Jan 10 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.5-3.fc7
- Add patch for GNOME bug #359979 (change EMsgPort semantics).