- Update to 2.23.2
- Add files for new libebackend library. - Remove patch for RH bug #202309 (fixed upstream).
This commit is contained in:
parent
d970f4fce2
commit
dc9cf95622
@ -1 +1 @@
|
||||
evolution-data-server-2.23.1.tar.bz2
|
||||
evolution-data-server-2.23.2.tar.bz2
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -up evolution-data-server-2.21.3/camel/providers/imap/camel-imap-search.c.maybe-fix-crash evolution-data-server-2.21.3/camel/providers/imap/camel-imap-search.c
|
||||
--- evolution-data-server-2.21.3/camel/providers/imap/camel-imap-search.c.maybe-fix-crash 2007-11-29 07:53:34.000000000 -0500
|
||||
+++ evolution-data-server-2.21.3/camel/providers/imap/camel-imap-search.c 2007-12-03 11:51:26.000000000 -0500
|
||||
@@ -344,7 +344,6 @@ sync_match(CamelImapSearch *is, struct _
|
||||
}
|
||||
g_string_append_c (search, '"');
|
||||
}
|
||||
- camel_search_words_free (words);
|
||||
|
||||
/* We only try search using utf8 if its non us-ascii text? */
|
||||
if ((words->type & CAMEL_SEARCH_WORD_8BIT) && (store->capabilities & IMAP_CAPABILITY_utf8_search)) {
|
||||
@@ -354,6 +353,8 @@ sync_match(CamelImapSearch *is, struct _
|
||||
if (response == NULL)
|
||||
store->capabilities &= ~IMAP_CAPABILITY_utf8_search;
|
||||
}
|
||||
+ camel_search_words_free (words);
|
||||
+
|
||||
if (response == NULL)
|
||||
response = camel_imap_command (store, folder, NULL,
|
||||
"UID SEARCH %s", search->str);
|
@ -27,7 +27,7 @@
|
||||
### Abstract ###
|
||||
|
||||
Name: evolution-data-server
|
||||
Version: 2.23.1
|
||||
Version: 2.23.2
|
||||
Release: 1%{?dist}
|
||||
License: LGPL
|
||||
Group: System Environment/Libraries
|
||||
@ -41,17 +41,14 @@ Source: %{name}-%{version}.tar.bz2
|
||||
# Remove gnome-common macros from configure.in.
|
||||
Patch10: evolution-data-server-1.8.0-no-gnome-common.patch
|
||||
|
||||
# RH bug #202309
|
||||
Patch11: evolution-data-server-1.7.91-maybe-fix-crash.patch
|
||||
|
||||
# RH bug #215702 / GNOME bug #487988
|
||||
Patch12: evolution-data-server-1.8.0-fix-ldap-query.patch
|
||||
Patch11: evolution-data-server-1.8.0-fix-ldap-query.patch
|
||||
|
||||
# GNOME bug #373146
|
||||
Patch13: evolution-data-server-1.10.1-camel-folder-summary-crash.patch
|
||||
Patch12: evolution-data-server-1.10.1-camel-folder-summary-crash.patch
|
||||
|
||||
# RH bug #243296
|
||||
Patch14: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
|
||||
Patch13: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
|
||||
|
||||
### Build Dependencies ###
|
||||
|
||||
@ -126,10 +123,9 @@ This package contains developer documentation for %{name}.
|
||||
%setup -q
|
||||
|
||||
%patch10 -p1 -b .no-gnome-common
|
||||
%patch11 -p1 -b .maybe-fix-crash
|
||||
%patch12 -p1 -b .fix-ldap-query
|
||||
%patch13 -p1 -b .camel-folder-summary-crash
|
||||
%patch14 -p1 -b .fix-64bit-acinclude
|
||||
%patch11 -p1 -b .fix-ldap-query
|
||||
%patch12 -p1 -b .camel-folder-summary-crash
|
||||
%patch13 -p1 -b .fix-64bit-acinclude
|
||||
|
||||
mkdir -p krb5-fakeprefix/include
|
||||
mkdir -p krb5-fakeprefix/lib
|
||||
@ -268,6 +264,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/bonobo/servers/GNOME_Evolution_DataServer_%{eds_api_version}.server
|
||||
%{_libdir}/libcamel-%{eds_api_version}.so.*
|
||||
%{_libdir}/libcamel-provider-%{eds_api_version}.so.*
|
||||
%{_libdir}/libebackend-%{eds_api_version}.so.*
|
||||
%{_libdir}/libebook-%{eds_api_version}.so.*
|
||||
%{_libdir}/libecal-%{eds_api_version}.so.*
|
||||
%{_libdir}/libedata-book-%{eds_api_version}.so.*
|
||||
@ -337,6 +334,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/evolution-data-server-%{eds_base_version}
|
||||
%{_libdir}/libcamel-%{eds_api_version}.so
|
||||
%{_libdir}/libcamel-provider-%{eds_api_version}.so
|
||||
%{_libdir}/libebackend-%{eds_api_version}.so
|
||||
%{_libdir}/libebook-%{eds_api_version}.so
|
||||
%{_libdir}/libecal-%{eds_api_version}.so
|
||||
%{_libdir}/libedata-book-%{eds_api_version}.so
|
||||
@ -350,6 +348,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/pkgconfig/camel-%{eds_api_version}.pc
|
||||
%{_libdir}/pkgconfig/camel-provider-%{eds_api_version}.pc
|
||||
%{_libdir}/pkgconfig/evolution-data-server-%{eds_api_version}.pc
|
||||
%{_libdir}/pkgconfig/libebackend-%{eds_api_version}.pc
|
||||
%{_libdir}/pkgconfig/libebook-%{eds_api_version}.pc
|
||||
%{_libdir}/pkgconfig/libecal-%{eds_api_version}.pc
|
||||
%{_libdir}/pkgconfig/libedata-book-%{eds_api_version}.pc
|
||||
@ -364,6 +363,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%files doc
|
||||
%defattr(-,root,root,-)
|
||||
%{_datadir}/gtk-doc/html/camel
|
||||
%{_datadir}/gtk-doc/html/libebackend
|
||||
%{_datadir}/gtk-doc/html/libebook
|
||||
%{_datadir}/gtk-doc/html/libecal
|
||||
%{_datadir}/gtk-doc/html/libedata-book
|
||||
@ -372,6 +372,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/gtk-doc/html/libedataserverui
|
||||
|
||||
%changelog
|
||||
* Mon May 12 2008 Matthew Barnes <mbarnes@redhat.com> - 2.23.2-1.fc10
|
||||
- Update to 2.23.2
|
||||
- Add files for new libebackend library.
|
||||
- Remove patch for RH bug #202309 (fixed upstream).
|
||||
|
||||
* Mon Apr 21 2008 Matthew Barnes <mbarnes@redhat.com> - 2.23.1-1.fc10
|
||||
- Update to 2.23.1
|
||||
- Bump eds_base_version to 2.24.
|
||||
|
Loading…
Reference in New Issue
Block a user