import evolution-data-server-3.40.4-3.el9
This commit is contained in:
commit
b8c9cded4b
1
.evolution-data-server.metadata
Normal file
1
.evolution-data-server.metadata
Normal file
@ -0,0 +1 @@
|
||||
0c5875d6617a7e3a4614494fe2359a8ebb321c4b SOURCES/evolution-data-server-3.40.4.tar.xz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/evolution-data-server-3.40.4.tar.xz
|
49
SOURCES/evolution-data-server-3.40.4-icalcompiter.patch
Normal file
49
SOURCES/evolution-data-server-3.40.4-icalcompiter.patch
Normal file
@ -0,0 +1,49 @@
|
||||
diff --git a/src/calendar/backends/file/e-cal-backend-file.c b/src/calendar/backends/file/e-cal-backend-file.c
|
||||
index f40bf807c..79ae53632 100644
|
||||
--- a/src/calendar/backends/file/e-cal-backend-file.c
|
||||
+++ b/src/calendar/backends/file/e-cal-backend-file.c
|
||||
@@ -904,6 +904,7 @@ scan_vcalendar (ECalBackendFile *cbfile)
|
||||
if (e_cal_component_set_icalcomponent (comp, icomp)) {
|
||||
/* Thus it's not freed while being used in the 'comp' */
|
||||
g_object_ref (icomp);
|
||||
+ i_cal_object_set_owner (I_CAL_OBJECT (icomp), G_OBJECT (priv->vcalendar));
|
||||
|
||||
check_dup_uid (cbfile, comp);
|
||||
|
||||
diff --git a/src/calendar/backends/http/e-cal-backend-http.c b/src/calendar/backends/http/e-cal-backend-http.c
|
||||
index a7e930ca0..bfe9b4554 100644
|
||||
--- a/src/calendar/backends/http/e-cal-backend-http.c
|
||||
+++ b/src/calendar/backends/http/e-cal-backend-http.c
|
||||
@@ -477,13 +477,18 @@ ecb_http_get_changes_sync (ECalMetaBackend *meta_backend,
|
||||
} else {
|
||||
iter = i_cal_component_begin_component (maincomp, I_CAL_VCALENDAR_COMPONENT);
|
||||
subcomp = i_cal_comp_iter_deref (iter);
|
||||
+ if (subcomp)
|
||||
+ i_cal_object_set_owner (I_CAL_OBJECT (subcomp), G_OBJECT (maincomp));
|
||||
}
|
||||
|
||||
while (subcomp && success) {
|
||||
ICalComponent *next_subcomp = NULL;
|
||||
|
||||
- if (iter)
|
||||
+ if (iter) {
|
||||
next_subcomp = i_cal_comp_iter_next (iter);
|
||||
+ if (next_subcomp)
|
||||
+ i_cal_object_set_owner (I_CAL_OBJECT (next_subcomp), G_OBJECT (maincomp));
|
||||
+ }
|
||||
|
||||
if (i_cal_component_isa (subcomp) == I_CAL_VCALENDAR_COMPONENT) {
|
||||
success = e_cal_meta_backend_gather_timezones_sync (meta_backend, subcomp, TRUE, cancellable, error);
|
||||
diff --git a/src/calendar/libecal/e-cal-component.c b/src/calendar/libecal/e-cal-component.c
|
||||
index a3dddcc8f..c7629813a 100644
|
||||
--- a/src/calendar/libecal/e-cal-component.c
|
||||
+++ b/src/calendar/libecal/e-cal-component.c
|
||||
@@ -95,6 +95,8 @@ foreach_subcomponent (ICalComponent *icalcomp,
|
||||
while (subcomp) {
|
||||
ICalComponent *next_subcomp;
|
||||
|
||||
+ i_cal_object_set_owner (I_CAL_OBJECT (subcomp), G_OBJECT (icalcomp));
|
||||
+
|
||||
next_subcomp = i_cal_comp_iter_next (iter);
|
||||
|
||||
if (!func (icalcomp, subcomp, user_data)) {
|
@ -0,0 +1,21 @@
|
||||
diff -up evolution-data-server-3.28.5/src/modules/secret-monitor/module-secret-monitor.c.secret-monitor-warnings evolution-data-server-3.28.5/src/modules/secret-monitor/module-secret-monitor.c
|
||||
--- evolution-data-server-3.28.5/src/modules/secret-monitor/module-secret-monitor.c.secret-monitor-warnings 2018-07-30 15:17:06.000000000 +0200
|
||||
+++ evolution-data-server-3.28.5/src/modules/secret-monitor/module-secret-monitor.c 2021-11-22 12:52:08.683986536 +0100
|
||||
@@ -167,7 +167,7 @@ secret_monitor_scan_secrets_thread (gpoi
|
||||
g_list_free_full (list, (GDestroyNotify) g_object_unref);
|
||||
|
||||
if (local_error != NULL) {
|
||||
- g_warning ("%s: %s", G_STRFUNC, local_error->message);
|
||||
+ e_source_registry_debug_print ("%s: %s", G_STRFUNC, local_error->message);
|
||||
g_error_free (local_error);
|
||||
}
|
||||
|
||||
@@ -206,7 +206,7 @@ secret_monitor_scan_secrets_timeout_cb (
|
||||
g_thread_unref (thread);
|
||||
|
||||
if (local_error != NULL) {
|
||||
- g_warning ("%s: %s", G_STRFUNC, local_error->message);
|
||||
+ e_source_registry_debug_print ("%s: %s", G_STRFUNC, local_error->message);
|
||||
g_error_free (local_error);
|
||||
g_object_unref (server);
|
||||
}
|
2400
SPECS/evolution-data-server.spec
Normal file
2400
SPECS/evolution-data-server.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user