Update to 3.47.1; Require libical 3.0.16 for added new API
This commit is contained in:
parent
3e80a0e41e
commit
8abec8d1b5
@ -27,7 +27,7 @@
|
|||||||
%define goa_version 3.8
|
%define goa_version 3.8
|
||||||
%define libsecret_version 0.5
|
%define libsecret_version 0.5
|
||||||
%define libgweather_version 4.0
|
%define libgweather_version 4.0
|
||||||
%define libical_version 3.0.7
|
%define libical_version 3.0.16
|
||||||
%define libsoup_version 3.1.1
|
%define libsoup_version 3.1.1
|
||||||
%define nss_version 3.14
|
%define nss_version 3.14
|
||||||
%define sqlite_version 3.7.17
|
%define sqlite_version 3.7.17
|
||||||
@ -57,16 +57,12 @@
|
|||||||
### Abstract ###
|
### Abstract ###
|
||||||
|
|
||||||
Name: evolution-data-server
|
Name: evolution-data-server
|
||||||
Version: 3.46.2
|
Version: 3.47.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Backend data server for Evolution
|
Summary: Backend data server for Evolution
|
||||||
License: LGPL-2.0-or-later
|
License: LGPL-2.0-or-later
|
||||||
URL: https://wiki.gnome.org/Apps/Evolution
|
URL: https://wiki.gnome.org/Apps/Evolution
|
||||||
Source: http://download.gnome.org/sources/%{name}/3.46/%{name}-%{version}.tar.xz
|
Source: http://download.gnome.org/sources/%{name}/3.47/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# https://gitlab.gnome.org/GNOME/evolution-data-server/-/merge_requests/107
|
|
||||||
# https://gitlab.gnome.org/GNOME/evolution-data-server/-/merge_requests/108
|
|
||||||
Patch0: webkitgtk-6.0.patch
|
|
||||||
|
|
||||||
Provides: evolution-webcal = %{version}
|
Provides: evolution-webcal = %{version}
|
||||||
Obsoletes: evolution-webcal < 2.24.0
|
Obsoletes: evolution-webcal < 2.24.0
|
||||||
@ -134,6 +130,9 @@ BuildRequires: boost-devel
|
|||||||
BuildRequires: abseil-cpp-devel
|
BuildRequires: abseil-cpp-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# libical 3.0.16 added new API, this ensures to bring it in
|
||||||
|
Requires: libical-glib >= %{libical_version}
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The %{name} package provides a unified backend for programs that work
|
The %{name} package provides a unified backend for programs that work
|
||||||
with contacts, tasks, and calendar information.
|
with contacts, tasks, and calendar information.
|
||||||
@ -489,6 +488,10 @@ find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 06 2023 Milan Crha <mcrha@redhat.com> - 3.47.1-1
|
||||||
|
- Update to 3.47.1
|
||||||
|
- Require libical 3.0.16 for added new API
|
||||||
|
|
||||||
* Sat Dec 31 2022 Pete Walter <pwalter@fedoraproject.org> - 3.46.2-3
|
* Sat Dec 31 2022 Pete Walter <pwalter@fedoraproject.org> - 3.46.2-3
|
||||||
- Rebuild for ICU 72
|
- Rebuild for ICU 72
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (evolution-data-server-3.46.2.tar.xz) = 570a14ea21c18be8626530562483c1f112c6f773b4502c7c16005abe516dd35d810985ed3cd4c89b993e5169474791ff3694999ef41a6fe53e2309450c7c7341
|
SHA512 (evolution-data-server-3.47.1.tar.xz) = b4014cdc6a2c1f654b961db281b313ab869dea9ef19af44833e7d4eb2c33f77a9cc15e6dbf456996039004560a7edbcd9636b5398c6b4cac0ee3e75895fa0227
|
||||||
|
@ -1,72 +0,0 @@
|
|||||||
From cdb16f26f63f5093479a43cab32012845bcf33ed Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Catanzaro <mcatanzaro@gnome.org>
|
|
||||||
Date: Tue, 15 Nov 2022 08:58:38 +0000
|
|
||||||
Subject: [PATCH] M!107 - Use webkitgtk-6.0 API version
|
|
||||||
|
|
||||||
In WebKitGTK 2.39.1, the GTK 4 API version has been renamed from webkit2gtk-5.0 to webkitgtk-6.0.
|
|
||||||
|
|
||||||
Closes https://gitlab.gnome.org/GNOME/evolution-data-server/-/merge_requests/107
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index a3ce7c1dd..c575acd3e 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -426,7 +426,7 @@ if(ENABLE_GTK4)
|
|
||||||
|
|
||||||
if(ENABLE_OAUTH2_WEBKITGTK4)
|
|
||||||
pkg_check_modules_for_option(ENABLE_OAUTH2_WEBKITGTK4 "WebKitGTK gtk4 for built-in OAuth2 authentications" OAUTH2_WEBKITGTK4
|
|
||||||
- webkit2gtk-5.0>=${webkit2gtk4_minimum_version}
|
|
||||||
+ webkitgtk-6.0>=${webkit2gtk4_minimum_version}
|
|
||||||
)
|
|
||||||
endif(ENABLE_OAUTH2_WEBKITGTK4)
|
|
||||||
endif(ENABLE_GTK4)
|
|
||||||
--
|
|
||||||
GitLab
|
|
||||||
|
|
||||||
From 8d29b0bded2e4e3700ce08e9db2eaeac4400528a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Catanzaro <mcatanzaro@gnome.org>
|
|
||||||
Date: Mon, 21 Nov 2022 17:49:29 +0000
|
|
||||||
Subject: [PATCH] M!108 - Try harder to support webkitgtk-6.0
|
|
||||||
|
|
||||||
The cdb16f26f63f5093479a43cab32012845bcf33ed attempted to handle WebKitGTK
|
|
||||||
API changes, but I forgot the header file name changed as well.
|
|
||||||
|
|
||||||
Closes https://gitlab.gnome.org/GNOME/evolution-data-server/-/merge_requests/108
|
|
||||||
---
|
|
||||||
src/libedataserverui/e-credentials-prompter-impl-oauth2.c | 6 ++----
|
|
||||||
1 file changed, 2 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/libedataserverui/e-credentials-prompter-impl-oauth2.c b/src/libedataserverui/e-credentials-prompter-impl-oauth2.c
|
|
||||||
index 2415947c3..b99ac4e60 100644
|
|
||||||
--- a/src/libedataserverui/e-credentials-prompter-impl-oauth2.c
|
|
||||||
+++ b/src/libedataserverui/e-credentials-prompter-impl-oauth2.c
|
|
||||||
@@ -32,21 +32,19 @@
|
|
||||||
#if GTK_CHECK_VERSION(4, 0, 0)
|
|
||||||
#ifdef ENABLE_OAUTH2_WEBKITGTK4
|
|
||||||
#define WITH_WEBKITGTK 1
|
|
||||||
+#include <webkit/webkit.h>
|
|
||||||
#else
|
|
||||||
#undef WITH_WEBKITGTK
|
|
||||||
#endif
|
|
||||||
#else
|
|
||||||
#ifdef ENABLE_OAUTH2_WEBKITGTK
|
|
||||||
#define WITH_WEBKITGTK 1
|
|
||||||
+#include <webkit2/webkit2.h>
|
|
||||||
#else
|
|
||||||
#undef WITH_WEBKITGTK
|
|
||||||
#endif
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#ifdef WITH_WEBKITGTK
|
|
||||||
-#include <webkit2/webkit2.h>
|
|
||||||
-#endif /* WITH_WEBKITGTK */
|
|
||||||
-
|
|
||||||
struct _ECredentialsPrompterImplOAuth2Private {
|
|
||||||
GMutex property_lock;
|
|
||||||
|
|
||||||
--
|
|
||||||
GitLab
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user