Backport upstream patch to fix C issue in CMake probing
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
1da70c08e0
commit
68be1c4af7
19
evolution-data-server-cmake-c99.patch
Normal file
19
evolution-data-server-cmake-c99.patch
Normal file
@ -0,0 +1,19 @@
|
||||
commit 55558d3c23e68aada59c5deb59a664aea263f075
|
||||
Author: Milan Crha <mcrha@redhat.com>
|
||||
Date: Fri Dec 1 09:52:57 2023 +0100
|
||||
|
||||
build: Correct incompatible type warning from check for I_CAL_EMAIL_PARAMETER
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index e7d376add97ef493..6173c0fc39d7688f 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -963,7 +963,7 @@ set(CMAKE_REQUIRED_LIBRARIES ${CALENDAR_LDFLAGS})
|
||||
CHECK_C_SOURCE_COMPILES("#define LIBICAL_GLIB_UNSTABLE_API 1
|
||||
#include <libical-glib/libical-glib.h>
|
||||
int main(void) {
|
||||
- icalparameter *param;
|
||||
+ ICalParameter *param;
|
||||
param = i_cal_property_get_first_parameter (NULL, I_CAL_EMAIL_PARAMETER);
|
||||
i_cal_parameter_get_email (param);
|
||||
i_cal_parameter_new_email (NULL);
|
@ -60,11 +60,12 @@
|
||||
|
||||
Name: evolution-data-server
|
||||
Version: 3.50.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Backend data server for Evolution
|
||||
License: LGPL-2.0-or-later
|
||||
URL: https://wiki.gnome.org/Apps/Evolution
|
||||
Source: http://download.gnome.org/sources/%{name}/3.50/%{name}-%{version}.tar.xz
|
||||
Patch0: evolution-data-server-cmake-c99.patch
|
||||
|
||||
Provides: evolution-webcal = %{version}
|
||||
Obsoletes: evolution-webcal < 2.24.0
|
||||
@ -503,6 +504,9 @@ find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
|
||||
%{_datadir}/installed-tests
|
||||
|
||||
%changelog
|
||||
* Tue Dec 19 2023 Florian Weimer <fweimer@redhat.com> - 3.50.2-2
|
||||
- Backport upstream patch to fix C issue in CMake probing
|
||||
|
||||
* Fri Dec 01 2023 Milan Crha <mcrha@redhat.com> - 3.50.2-1
|
||||
- Update to 3.50.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user