Update to 3.23.1

This commit is contained in:
Milan Crha 2016-10-24 16:20:52 +02:00
parent 8398366b37
commit 5e05ee8e29
4 changed files with 43 additions and 113 deletions

1
.gitignore vendored
View File

@ -110,3 +110,4 @@ evolution-data-server-2.31.5.tar.bz2
/evolution-data-server-3.21.92.tar.xz /evolution-data-server-3.21.92.tar.xz
/evolution-data-server-3.22.0.tar.xz /evolution-data-server-3.22.0.tar.xz
/evolution-data-server-3.22.1.tar.xz /evolution-data-server-3.22.1.tar.xz
/evolution-data-server-3.23.1.tar.xz

View File

@ -1,56 +0,0 @@
diff -up evolution-data-server-2.27.91/m4/evo_ldap_check.m4.fix-64bit-acinclude evolution-data-server-2.27.91/m4/evo_ldap_check.m4
--- evolution-data-server-2.27.91/m4/evo_ldap_check.m4.fix-64bit-acinclude 2009-08-24 12:45:52.000000000 +0200
+++ evolution-data-server-2.27.91/m4/evo_ldap_check.m4 2009-08-24 12:48:08.000000000 +0200
@@ -14,6 +14,18 @@ AC_DEFUN([EVO_LDAP_CHECK],[
[AS_HELP_STRING([--with-static-ldap],
[Link LDAP support statically into evolution])])
AC_CACHE_CHECK([for OpenLDAP], [ac_cv_with_openldap], [ac_cv_with_openldap="${with_openldap:=$default}"])
+
+ AC_MSG_CHECKING(for multilib subdirectory)
+ if test "$GCC" = "yes" ; then
+ multilibsubdir=`$CC -print-multi-os-directory 2> /dev/null`
+ fi
+ multilibsubdir=${multilibsubdir:-.}
+ AC_MSG_RESULT($multilibsubdir)
+ AC_MSG_CHECKING(for lib subdirectory)
+ libsubdir=`echo lib/${multilibsubdir} | sed -re 's,lib/../([[^/]]*),\1,g'`
+ libsubdir=${libsubdir:-lib}
+ AC_MSG_RESULT($libsubdir)
+
case $ac_cv_with_openldap in
no|"")
with_openldap=no
@@ -24,7 +36,7 @@ AC_DEFUN([EVO_LDAP_CHECK],[
*)
with_openldap=$ac_cv_with_openldap
LDAP_CFLAGS="-I$ac_cv_with_openldap/include"
- LDAP_LDFLAGS="-L$ac_cv_with_openldap/lib"
+ LDAP_LDFLAGS="-L$ac_cv_with_openldap/$libsubdir"
;;
esac
@@ -60,20 +72,20 @@ AC_DEFUN([EVO_LDAP_CHECK],[
AC_CHECK_LIB(nsl, gethostbyaddr, [LDAP_LIBS="$LDAP_LIBS -lnsl"])
AC_CHECK_LIB(lber, ber_get_tag, [
if test "$with_static_ldap" = "yes"; then
- LDAP_LIBS="$with_openldap/lib/liblber.a $LDAP_LIBS"
+ LDAP_LIBS="$with_openldap/$libsubdir/liblber.a $LDAP_LIBS"
# libldap might depend on OpenSSL... We need to pull
# in the dependency libs explicitly here since we're
# not using libtool for the configure test.
- if test -f $with_openldap/lib/libldap.la; then
- LDAP_LIBS="`. $with_openldap/lib/libldap.la; echo $dependency_libs` $LDAP_LIBS"
+ if test -f $with_openldap/$libsubdir/libldap.la; then
+ LDAP_LIBS="`. $with_openldap/$libsubdir/libldap.la; echo $dependency_libs` $LDAP_LIBS"
fi
else
LDAP_LIBS="-llber $LDAP_LIBS"
fi
AC_CHECK_LIB(ldap, ldap_open, [
if test $with_static_ldap = "yes"; then
- LDAP_LIBS="$with_openldap/lib/libldap.a $LDAP_LIBS"
+ LDAP_LIBS="$with_openldap/$libsubdir/libldap.a $LDAP_LIBS"
else
LDAP_LIBS="-lldap $LDAP_LIBS"
fi],

View File

@ -1,7 +1,6 @@
%define ldap_support 1 %define ldap_support 1
%define static_ldap 0 %define static_ldap 0
%define krb5_support 1 %define krb5_support 1
%define nntp_support 1
%define largefile_support 1 %define largefile_support 1
# Coverity scan can override this to 0, to skip checking in gtk-doc generated code # Coverity scan can override this to 0, to skip checking in gtk-doc generated code
@ -33,14 +32,14 @@
### Abstract ### ### Abstract ###
Name: evolution-data-server Name: evolution-data-server
Version: 3.22.1 Version: 3.23.1
Release: 1%{?dist} Release: 1%{?dist}
Group: System Environment/Libraries Group: System Environment/Libraries
Summary: Backend data server for Evolution Summary: Backend data server for Evolution
License: LGPLv2+ License: LGPLv2+
URL: https://wiki.gnome.org/Apps/Evolution URL: https://wiki.gnome.org/Apps/Evolution
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX) BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
Source: http://download.gnome.org/sources/%{name}/3.22/%{name}-%{version}.tar.xz Source: http://download.gnome.org/sources/%{name}/3.23/%{name}-%{version}.tar.xz
Provides: evolution-webcal = %{version} Provides: evolution-webcal = %{version}
Obsoletes: evolution-webcal < 2.24.0 Obsoletes: evolution-webcal < 2.24.0
@ -53,7 +52,7 @@ Obsoletes: compat-evolution-data-server310-libcamel < 3.12
### Patches ### ### Patches ###
# RH bug #243296 # RH bug #243296
Patch01: evolution-data-server-1.11.5-fix-64bit-acinclude.patch # Patch01: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
### Dependencies ### ### Dependencies ###
@ -61,14 +60,16 @@ Requires: dconf
### Build Dependencies ### ### Build Dependencies ###
BuildRequires: cmake
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: gettext BuildRequires: gettext
BuildRequires: gnome-common
BuildRequires: gperf BuildRequires: gperf
BuildRequires: gtk-doc >= %{gtk_doc_version} BuildRequires: gtk-doc >= %{gtk_doc_version}
BuildRequires: intltool >= %{intltool_version} BuildRequires: intltool >= %{intltool_version}
BuildRequires: libdb-devel BuildRequires: libdb-devel
BuildRequires: libtool
BuildRequires: perl-generators BuildRequires: perl-generators
BuildRequires: python3
BuildRequires: vala BuildRequires: vala
BuildRequires: vala-tools BuildRequires: vala-tools
BuildRequires: systemd BuildRequires: systemd
@ -164,13 +165,17 @@ the functionality of the installed %{name} package.
%prep %prep
%setup -q %setup -q
%patch01 -p1 -b .fix-64bit-acinclude # %patch01 -p1 -b .fix-64bit-acinclude
%build %build
mkdir -p _build
cd _build
%if %{ldap_support} %if %{ldap_support}
%if %{static_ldap} %if %{static_ldap}
%define ldap_flags --with-openldap=yes --with-static-ldap %define ldap_flags -DWITH_OPENLDAP=ON -DWITH_STATIC_LDAP=ON
# Set LIBS so that configure will be able to link with static LDAP libraries, # Set LIBS so that configure will be able to link with static LDAP libraries,
# which depend on Cyrus SASL and OpenSSL. XXX Is the "else" clause necessary? # which depend on Cyrus SASL and OpenSSL. XXX Is the "else" clause necessary?
if pkg-config openssl ; then if pkg-config openssl ; then
@ -186,37 +191,31 @@ else
export LIBS="$LIBS -lssl3 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4" export LIBS="$LIBS -lssl3 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4"
fi fi
%else %else
%define ldap_flags --with-openldap=yes %define ldap_flags -DWITH_OPENLDAP=ON
%endif %endif
%else %else
%define ldap_flags --without-openldap %define ldap_flags -DWITH_OPENLDAP=OFF
%endif %endif
%if %{krb5_support} %if %{krb5_support}
%define krb5_flags --with-krb5 %define krb5_flags -DWITH_KRB5=ON
%else %else
%define krb5_flags --without-krb5 %define krb5_flags -DWITH_KRB5=OFF
%endif
%if %{nntp_support}
%define nntp_flags --enable-nntp=yes
%else
%define nntp_flags --enable-nntp=no
%endif %endif
%if %{largefile_support} %if %{largefile_support}
%define largefile_flags --enable-largefile %define largefile_flags -DENABLE_LARGEFILE=ON
%else %else
%define largefile_flags --disable-largefile %define largefile_flags -DENABLE_LARGEFILE=OFF
%endif %endif
%define ssl_flags --enable-smime=yes %define ssl_flags -DENABLE_SMIME=ON
%if %{with_docs} %if %{with_docs}
%define gtkdoc_flags --enable-gtk-doc %define gtkdoc_flags -DENABLE_GTK_DOC=ON
%else %else
%define gtkdoc_flags --disable-gtk-doc %define gtkdoc_flags -DENABLE_GTK_DOC=OFF
%endif %endif
if ! pkg-config --exists nss; then if ! pkg-config --exists nss; then
@ -227,46 +226,29 @@ fi
export CPPFLAGS="-I%{_includedir}/et" export CPPFLAGS="-I%{_includedir}/et"
export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et -Wno-deprecated-declarations" export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et -Wno-deprecated-declarations"
# Regenerate configure to pick up configure.in and acinclude.m4 changes..
aclocal -I m4
autoheader
automake --add-missing
libtoolize
intltoolize --force
autoconf
# See Ross Burton's blog entry for why we want --with-libdb. # See Ross Burton's blog entry for why we want --with-libdb.
# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40 # http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
%configure \ %cmake -G "Unix Makefiles" \
--disable-maintainer-mode \ -DENABLE_MAINTAINER_MODE=OFF \
--disable-uoa \ -DENABLE_UOA=OFF \
--with-libdb=/usr \ -DWITH_LIBDB=/usr \
--enable-file-locking=fcntl \ -DENABLE_FILE_LOCKING=fcntl \
--enable-dot-locking=no \ -DENABLE_DOT_LOCKING=OFF \
--enable-introspection=yes \ -DENABLE_INTROSPECTION=ON \
--enable-vala-bindings \ -DENABLE_VALA_BINDINGS=ON \
--enable-installed-tests \ -DENABLE_INSTALLED_TESTS=ON \
%ldap_flags %krb5_flags %nntp_flags %ssl_flags \ %ldap_flags %krb5_flags %ssl_flags \
%largefile_flags %gtkdoc_flags %largefile_flags %gtkdoc_flags \
export tagname=CC ..
make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool make %{?_smp_mflags}
%install %install
cd _build
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
export tagname=CC
make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
# remove libtool archives for importers and the like make DESTDIR=$RPM_BUILD_ROOT install
find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/*.a
rm -f $RPM_BUILD_ROOT/%{credential_modules_dir}/*.a
rm -f $RPM_BUILD_ROOT/%{camel_provider_dir}/*.a
rm -f $RPM_BUILD_ROOT/%{ebook_backends_dir}/*.a
rm -f $RPM_BUILD_ROOT/%{ecal_backends_dir}/*.a
rm -f $RPM_BUILD_ROOT/%{modules_dir}/*.a
# give the libraries some executable bits # give the libraries some executable bits
find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \; find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
@ -287,7 +269,7 @@ fi
%posttrans %posttrans
glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || : glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
%files -f %{name}-%{eds_base_version}.lang %files -f _build/%{name}-%{eds_base_version}.lang
%doc README COPYING ChangeLog NEWS %doc README COPYING ChangeLog NEWS
%{_libdir}/libcamel-1.2.so.* %{_libdir}/libcamel-1.2.so.*
%{_libdir}/libebackend-1.2.so.* %{_libdir}/libebackend-1.2.so.*
@ -437,6 +419,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
%{_datadir}/installed-tests %{_datadir}/installed-tests
%changelog %changelog
* Mon Oct 24 2016 Milan Crha <mcrha@redhat.com> - 3.23.1-1
- Update to 3.23.1
* Mon Oct 10 2016 Milan Crha <mcrha@redhat.com> - 3.22.1-1 * Mon Oct 10 2016 Milan Crha <mcrha@redhat.com> - 3.22.1-1
- Update to 3.22.1 - Update to 3.22.1

View File

@ -1 +1 @@
e2fe485a91a64ec5ffb0b3ffa91ecc23 evolution-data-server-3.22.1.tar.xz 614b57d470b1d0b871e4983daf8bdc7f evolution-data-server-3.23.1.tar.xz