Contacts combo boxes don't work).
This commit is contained in:
parent
a99775f6a8
commit
4b9a6f6ddc
@ -1,5 +1,5 @@
|
||||
--- evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-dialog.glade.code-cleanup 2007-01-03 09:56:26.000000000 -0500
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-dialog.glade 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/libedataserverui/e-name-selector-dialog.glade.code-cleanup 2007-07-05 02:01:52.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/e-name-selector-dialog.glade 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -118,7 +118,10 @@
|
||||
<property name="yalign">0.5</property>
|
||||
<property name="xpad">0</property>
|
||||
@ -61,8 +61,8 @@
|
||||
</widget>
|
||||
<packing>
|
||||
<property name="padding">0</property>
|
||||
--- evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-list.c.code-cleanup 2007-07-31 16:14:53.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-list.c 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/libedataserverui/e-name-selector-list.c.code-cleanup 2007-08-09 02:45:35.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/e-name-selector-list.c 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -447,7 +447,7 @@ enl_tree_button_press_event (GtkWidget *
|
||||
|
||||
if (len > 1) {
|
||||
@ -72,9 +72,9 @@
|
||||
g_signal_connect (menu_item, "toggled", G_CALLBACK (destination_set_email), destination);
|
||||
} else {
|
||||
menu_item = gtk_menu_item_new_with_label (email);
|
||||
--- evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-entry.c.code-cleanup 2007-07-31 16:14:53.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-entry.c 2007-08-01 13:28:00.000000000 -0400
|
||||
@@ -2204,7 +2204,7 @@ populate_popup (ENameSelectorEntry *name
|
||||
--- evolution-data-server-1.11.90/libedataserverui/e-name-selector-entry.c.code-cleanup 2007-08-09 02:45:35.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/e-name-selector-entry.c 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -2208,7 +2208,7 @@ populate_popup (ENameSelectorEntry *name
|
||||
|
||||
if (len > 1) {
|
||||
menu_item = gtk_radio_menu_item_new_with_label (group, email);
|
||||
@ -83,8 +83,8 @@
|
||||
g_signal_connect (menu_item, "toggled", G_CALLBACK (destination_set_email), destination);
|
||||
} else {
|
||||
menu_item = gtk_menu_item_new_with_label (email);
|
||||
--- evolution-data-server-1.11.6.1/libedataserverui/test-source-option-menu.c.code-cleanup 2007-01-03 09:56:25.000000000 -0500
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/test-source-option-menu.c 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/libedataserverui/test-source-option-menu.c.code-cleanup 2007-07-05 02:01:52.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/test-source-option-menu.c 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -1,5 +1,5 @@
|
||||
/* -*- Mode: C; indent-tabs-mode: t; c-basic-offset: 8; tab-width: 8 -*- */
|
||||
-/* test-source-option-menu.c - Test for ESourceOptionMenu.
|
||||
@ -140,8 +140,8 @@
|
||||
gtk_widget_show_all (window);
|
||||
|
||||
g_object_unref (gconf_client);
|
||||
--- evolution-data-server-1.11.6.1/libedataserverui/e-source-option-menu.h.code-cleanup 2007-07-31 16:14:53.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/e-source-option-menu.h 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/libedataserverui/e-source-option-menu.h.code-cleanup 2007-08-09 02:45:35.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/e-source-option-menu.h 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -23,6 +23,8 @@
|
||||
#ifndef _E_SOURCE_OPTION_MENU_H_
|
||||
#define _E_SOURCE_OPTION_MENU_H_
|
||||
@ -158,8 +158,8 @@
|
||||
+#endif /* EDS_DISABLE_DEPRECATED */
|
||||
|
||||
#endif /* _E_SOURCE_OPTION_MENU_H_ */
|
||||
--- /dev/null 2007-07-31 17:57:56.110944649 -0400
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/e-source-combo-box.h 2007-08-01 13:28:00.000000000 -0400
|
||||
--- /dev/null 2007-08-20 18:12:02.086956713 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/e-source-combo-box.h 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -0,0 +1,79 @@
|
||||
+/* -*- Mode: C; indent-tabs-mode: t; c-basic-offset: 8; tab-width: 8 -*- */
|
||||
+/* e-source-combo-box.h
|
||||
@ -240,53 +240,8 @@
|
||||
+G_END_DECLS
|
||||
+
|
||||
+#endif /* _E_SOURCE_COMBO_BOX_H_ */
|
||||
--- evolution-data-server-1.11.6.1/libedataserverui/Makefile.in.code-cleanup 2007-07-31 18:18:45.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/Makefile.in 2007-08-01 13:28:50.000000000 -0400
|
||||
@@ -73,8 +73,8 @@ am_libedataserverui_1_2_la_OBJECTS = $(a
|
||||
e-name-selector-dialog.lo e-name-selector-entry.lo \
|
||||
e-name-selector-model.lo e-name-selector-list.lo \
|
||||
e-passwords.lo e-source-selector.lo \
|
||||
- e-source-selector-dialog.lo e-source-option-menu.lo \
|
||||
- e-tree-model-generator.lo
|
||||
+ e-source-selector-dialog.lo e-source-combo-box.lo \
|
||||
+ e-source-option-menu.lo e-tree-model-generator.lo
|
||||
libedataserverui_1_2_la_OBJECTS = \
|
||||
$(am_libedataserverui_1_2_la_OBJECTS)
|
||||
libedataserverui_1_2_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
|
||||
@@ -321,6 +321,7 @@ PTHREAD_LIB = @PTHREAD_LIB@
|
||||
PURIFY = @PURIFY@
|
||||
RANLIB = @RANLIB@
|
||||
REGEX_LIBS = @REGEX_LIBS@
|
||||
+SED = @SED@
|
||||
SENDMAIL = @SENDMAIL@
|
||||
SET_MAKE = @SET_MAKE@
|
||||
SHELL = @SHELL@
|
||||
@@ -424,6 +424,7 @@ libedataserverui_1_2_la_SOURCES = \
|
||||
e-passwords.c \
|
||||
e-source-selector.c \
|
||||
e-source-selector-dialog.c \
|
||||
+ e-source-combo-box.c \
|
||||
e-source-option-menu.c \
|
||||
e-tree-model-generator.c
|
||||
|
||||
@@ -449,6 +450,7 @@ libedataserveruiinclude_HEADERS = \
|
||||
e-passwords.h \
|
||||
e-source-selector.h \
|
||||
e-source-selector-dialog.h \
|
||||
+ e-source-combo-box.h \
|
||||
e-source-option-menu.h \
|
||||
e-tree-model-generator.h
|
||||
|
||||
@@ -587,6 +589,7 @@ distclean-compile:
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/e-name-selector-model.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/e-name-selector.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/e-passwords.Plo@am__quote@
|
||||
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/e-source-combo-box.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/e-source-option-menu.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/e-source-selector-dialog.Plo@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/e-source-selector.Plo@am__quote@
|
||||
--- evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-dialog.h.code-cleanup 2007-04-17 12:13:05.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-dialog.h 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/libedataserverui/e-name-selector-dialog.h.code-cleanup 2007-07-05 02:01:52.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/e-name-selector-dialog.h 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -58,7 +58,6 @@ struct _ENameSelectorDialog {
|
||||
/* Private */
|
||||
|
||||
@ -295,8 +250,8 @@
|
||||
ENameSelectorModel *name_selector_model;
|
||||
GtkTreeModelSort *contact_sort;
|
||||
|
||||
--- evolution-data-server-1.11.6.1/libedataserverui/Makefile.am.code-cleanup 2007-07-30 09:58:51.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/Makefile.am 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/libedataserverui/Makefile.am.code-cleanup 2007-07-05 02:01:52.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/Makefile.am 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -31,6 +31,7 @@ libedataserverui_1_2_la_SOURCES = \
|
||||
e-passwords.c \
|
||||
e-source-selector.c \
|
||||
@ -313,8 +268,8 @@
|
||||
e-source-option-menu.h \
|
||||
e-tree-model-generator.h
|
||||
|
||||
--- evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-dialog.c.code-cleanup 2007-07-31 16:14:53.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/e-name-selector-dialog.c 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/libedataserverui/e-name-selector-dialog.c.code-cleanup 2007-08-09 02:45:35.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/e-name-selector-dialog.c 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -32,7 +32,7 @@
|
||||
#include <gtk/gtkscrolledwindow.h>
|
||||
#include <gtk/gtkstock.h>
|
||||
@ -564,9 +519,9 @@
|
||||
}
|
||||
|
||||
static void
|
||||
--- /dev/null 2007-07-31 17:57:56.110944649 -0400
|
||||
+++ evolution-data-server-1.11.6.1/libedataserverui/e-source-combo-box.c 2007-08-01 13:28:00.000000000 -0400
|
||||
@@ -0,0 +1,457 @@
|
||||
--- /dev/null 2007-08-20 18:12:02.086956713 -0400
|
||||
+++ evolution-data-server-1.11.90/libedataserverui/e-source-combo-box.c 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -0,0 +1,456 @@
|
||||
+/* -*- Mode: C; indent-tabs-mode: t; c-basic-offset: 8; tab-width: 8 -*- */
|
||||
+/* e-source-option-menu.c
|
||||
+ *
|
||||
@ -599,7 +554,7 @@
|
||||
+
|
||||
+struct _ESourceComboBoxPrivate {
|
||||
+ ESourceList *source_list;
|
||||
+ GHashTable *uid_to_row_reference;
|
||||
+ GHashTable *uid_index;
|
||||
+ gulong handler_id;
|
||||
+};
|
||||
+
|
||||
@ -633,8 +588,8 @@
|
||||
+ const gchar *uid;
|
||||
+ gchar *indented_name;
|
||||
+
|
||||
+ priv = E_SOURCE_COMBO_BOX_GET_PRIVATE (source_combo_box);
|
||||
+ g_hash_table_remove_all (priv->uid_to_row_reference);
|
||||
+ priv = source_combo_box->priv;
|
||||
+ g_hash_table_remove_all (priv->uid_index);
|
||||
+
|
||||
+ combo_box = GTK_COMBO_BOX (source_combo_box);
|
||||
+ gtk_combo_box_set_active (combo_box, -1);
|
||||
@ -676,7 +631,7 @@
|
||||
+ uid = e_source_peek_uid (sources->data);
|
||||
+ path = gtk_tree_model_get_path (model, &iter);
|
||||
+ g_hash_table_insert (
|
||||
+ priv->uid_to_row_reference, g_strdup (uid),
|
||||
+ priv->uid_index, g_strdup (uid),
|
||||
+ gtk_tree_row_reference_new (model, path));
|
||||
+ gtk_tree_path_free (path);
|
||||
+ }
|
||||
@ -777,7 +732,7 @@
|
||||
+ priv->source_list = NULL;
|
||||
+ }
|
||||
+
|
||||
+ g_hash_table_remove_all (priv->uid_to_row_reference);
|
||||
+ g_hash_table_remove_all (priv->uid_index);
|
||||
+
|
||||
+ /* Chain up to parent's "dispose" method. */
|
||||
+ G_OBJECT_CLASS (parent_class)->dispose (object);
|
||||
@ -790,7 +745,7 @@
|
||||
+
|
||||
+ priv = E_SOURCE_COMBO_BOX_GET_PRIVATE (object);
|
||||
+
|
||||
+ g_hash_table_destroy (priv->uid_to_row_reference);
|
||||
+ g_hash_table_destroy (priv->uid_index);
|
||||
+
|
||||
+ /* Chain up to parent's "finalize" method. */
|
||||
+ G_OBJECT_CLASS (parent_class)->finalize (object);
|
||||
@ -825,14 +780,14 @@
|
||||
+static void
|
||||
+e_source_combo_box_init (ESourceComboBox *source_combo_box)
|
||||
+{
|
||||
+ ESourceComboBoxPrivate *priv;
|
||||
+ source_combo_box->priv =
|
||||
+ E_SOURCE_COMBO_BOX_GET_PRIVATE (source_combo_box);
|
||||
+
|
||||
+ priv = E_SOURCE_COMBO_BOX_GET_PRIVATE (source_combo_box);
|
||||
+
|
||||
+ priv->uid_to_row_reference = g_hash_table_new_full (
|
||||
+ g_str_hash, g_str_equal,
|
||||
+ (GDestroyNotify) g_free,
|
||||
+ (GDestroyNotify) gtk_tree_row_reference_free);
|
||||
+ source_combo_box->priv->uid_index =
|
||||
+ g_hash_table_new_full (
|
||||
+ g_str_hash, g_str_equal,
|
||||
+ (GDestroyNotify) g_free,
|
||||
+ (GDestroyNotify) gtk_tree_row_reference_free);
|
||||
+}
|
||||
+
|
||||
+GType
|
||||
@ -873,7 +828,7 @@
|
||||
+GtkWidget *
|
||||
+e_source_combo_box_new (ESourceList *source_list)
|
||||
+{
|
||||
+ g_return_val_if_fail (source_list != NULL, NULL);
|
||||
+ g_return_val_if_fail (E_IS_SOURCE_LIST (source_list), NULL);
|
||||
+
|
||||
+ return g_object_new (
|
||||
+ E_TYPE_SOURCE_COMBO_BOX,
|
||||
@ -894,7 +849,7 @@
|
||||
+{
|
||||
+ ESourceList *source_list;
|
||||
+
|
||||
+ g_return_val_if_fail (source_combo_box != NULL, NULL);
|
||||
+ g_return_val_if_fail (E_IS_SOURCE_COMBO_BOX (source_combo_box), NULL);
|
||||
+
|
||||
+ g_object_get (source_combo_box, "source-list", &source_list, NULL);
|
||||
+
|
||||
@ -913,8 +868,8 @@
|
||||
+e_source_combo_box_set_source_list (ESourceComboBox *source_combo_box,
|
||||
+ ESourceList *source_list)
|
||||
+{
|
||||
+ g_return_if_fail (source_combo_box != NULL);
|
||||
+ g_return_if_fail (source_list != NULL);
|
||||
+ g_return_if_fail (E_IS_SOURCE_COMBO_BOX (source_combo_box));
|
||||
+ g_return_if_fail (E_IS_SOURCE_LIST (source_list));
|
||||
+
|
||||
+ g_object_set (source_combo_box, "source-list", source_list, NULL);
|
||||
+}
|
||||
@ -935,7 +890,7 @@
|
||||
+ GtkTreeIter iter;
|
||||
+ ESource *source;
|
||||
+
|
||||
+ g_return_val_if_fail (source_combo_box != NULL, NULL);
|
||||
+ g_return_val_if_fail (E_IS_SOURCE_COMBO_BOX (source_combo_box), NULL);
|
||||
+
|
||||
+ combo_box = GTK_COMBO_BOX (source_combo_box);
|
||||
+
|
||||
@ -960,8 +915,8 @@
|
||||
+e_source_combo_box_set_active (ESourceComboBox *source_combo_box,
|
||||
+ ESource *source)
|
||||
+{
|
||||
+ g_return_if_fail (source_combo_box != NULL);
|
||||
+ g_return_if_fail (source != NULL);
|
||||
+ g_return_if_fail (E_IS_SOURCE_COMBO_BOX (source_combo_box));
|
||||
+ g_return_if_fail (E_IS_SOURCE (source));
|
||||
+
|
||||
+ e_source_combo_box_set_active_uid (
|
||||
+ source_combo_box, e_source_peek_uid (source));
|
||||
@ -981,7 +936,7 @@
|
||||
+{
|
||||
+ ESource *source;
|
||||
+
|
||||
+ g_return_val_if_fail (source_combo_box != NULL, NULL);
|
||||
+ g_return_val_if_fail (E_IS_SOURCE_COMBO_BOX (source_combo_box), NULL);
|
||||
+
|
||||
+ source = e_source_combo_box_get_active (source_combo_box);
|
||||
+ if (source == NULL)
|
||||
@ -1007,14 +962,13 @@
|
||||
+ GtkTreeIter iter;
|
||||
+ gboolean iter_was_set;
|
||||
+
|
||||
+ g_return_if_fail (source_combo_box != NULL);
|
||||
+ g_return_if_fail (E_IS_SOURCE_COMBO_BOX (source_combo_box));
|
||||
+ g_return_if_fail (uid != NULL);
|
||||
+
|
||||
+ priv = E_SOURCE_COMBO_BOX_GET_PRIVATE (source_combo_box);
|
||||
+
|
||||
+ priv = source_combo_box->priv;
|
||||
+ combo_box = GTK_COMBO_BOX (source_combo_box);
|
||||
+
|
||||
+ reference = g_hash_table_lookup (priv->uid_to_row_reference, uid);
|
||||
+ reference = g_hash_table_lookup (priv->uid_index, uid);
|
||||
+ g_return_if_fail (gtk_tree_row_reference_valid (reference));
|
||||
+
|
||||
+ iter_was_set = gtk_tree_model_get_iter (
|
||||
@ -1024,8 +978,8 @@
|
||||
+
|
||||
+ gtk_combo_box_set_active_iter (combo_box, &iter);
|
||||
+}
|
||||
--- evolution-data-server-1.11.6.1/docs/reference/libedataserverui/libedataserverui-docs.sgml.code-cleanup 2007-07-30 10:25:09.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/docs/reference/libedataserverui/libedataserverui-docs.sgml 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/docs/reference/libedataserverui/libedataserverui-docs.sgml.code-cleanup 2007-07-05 02:01:47.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/docs/reference/libedataserverui/libedataserverui-docs.sgml 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -19,6 +19,7 @@
|
||||
<xi:include href="xml/e-name-selector-list.xml"/>
|
||||
<xi:include href="xml/e-name-selector-model.xml"/>
|
||||
@ -1034,8 +988,8 @@
|
||||
<xi:include href="xml/e-source-option-menu.xml"/>
|
||||
<xi:include href="xml/e-source-selector.xml"/>
|
||||
<xi:include href="xml/e-source-selector-dialog.xml"/>
|
||||
--- evolution-data-server-1.11.6.1/docs/reference/libedataserverui/libedataserverui.types.code-cleanup 2007-07-30 10:25:09.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/docs/reference/libedataserverui/libedataserverui.types 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/docs/reference/libedataserverui/libedataserverui.types.code-cleanup 2007-07-05 02:01:47.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/docs/reference/libedataserverui/libedataserverui.types 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -6,6 +6,7 @@
|
||||
#include <libedataserverui/e-name-selector-entry.h>
|
||||
#include <libedataserverui/e-name-selector-list.h>
|
||||
@ -1052,8 +1006,8 @@
|
||||
e_source_option_menu_get_type
|
||||
e_source_selector_get_type
|
||||
e_source_selector_dialog_get_type
|
||||
--- evolution-data-server-1.11.6.1/docs/reference/libedataserverui/libedataserverui-sections.txt.code-cleanup 2007-07-30 10:25:09.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/docs/reference/libedataserverui/libedataserverui-sections.txt 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/docs/reference/libedataserverui/libedataserverui-sections.txt.code-cleanup 2007-07-05 02:01:47.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/docs/reference/libedataserverui/libedataserverui-sections.txt 2007-08-20 21:57:30.000000000 -0400
|
||||
@@ -25,6 +25,29 @@ e_tree_model_generator_get_type
|
||||
</SECTION>
|
||||
|
||||
@ -1084,18 +1038,8 @@
|
||||
<FILE>e-source-option-menu</FILE>
|
||||
<TITLE>ESourceOptionMenu</TITLE>
|
||||
ESourceOptionMenu
|
||||
--- evolution-data-server-1.11.6.1/calendar/libical/src/libicalss/icalssyacc.c.code-cleanup 2007-01-22 12:33:48.000000000 -0500
|
||||
+++ evolution-data-server-1.11.6.1/calendar/libical/src/libicalss/icalssyacc.c 2007-08-01 13:28:00.000000000 -0400
|
||||
@@ -160,6 +160,7 @@ static void ssyacc_add_select(struct ica
|
||||
static void ssyacc_add_from(struct icalgauge_impl* impl, char* str1);
|
||||
static void set_logic(struct icalgauge_impl* impl,icalgaugelogic l);
|
||||
void sserror(char *s); /* Don't know why I need this.... */
|
||||
+int sslex(void *YYPARSE_PARAM);
|
||||
|
||||
|
||||
|
||||
--- evolution-data-server-1.11.6.1/calendar/libical/src/libicalss/icalssyacc.y.code-cleanup 2007-01-22 12:29:24.000000000 -0500
|
||||
+++ evolution-data-server-1.11.6.1/calendar/libical/src/libicalss/icalssyacc.y 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/calendar/libical/src/libicalss/icalssyacc.y.code-cleanup 2007-08-20 22:42:08.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/calendar/libical/src/libicalss/icalssyacc.y 2007-08-20 22:42:35.000000000 -0400
|
||||
@@ -47,6 +47,7 @@ static void ssyacc_add_select(struct ica
|
||||
static void ssyacc_add_from(struct icalgauge_impl* impl, char* str1);
|
||||
static void set_logic(struct icalgauge_impl* impl,icalgaugelogic l);
|
||||
@ -1104,18 +1048,8 @@
|
||||
|
||||
%}
|
||||
|
||||
--- evolution-data-server-1.11.6.1/calendar/libical/src/libicalvcal/vcc.c.code-cleanup 2007-08-01 14:10:25.000000000 -0400
|
||||
+++ evolution-data-server-1.11.6.1/calendar/libical/src/libicalvcal/vcc.c 2007-08-01 14:11:02.000000000 -0400
|
||||
@@ -273,6 +273,7 @@ static void enterProps(const char *s);
|
||||
static void enterAttr(const char *s1, const char *s2);
|
||||
static void enterValues(const char *value);
|
||||
static void mime_error_(char *s);
|
||||
+static int mime_lex(void);
|
||||
|
||||
|
||||
|
||||
--- evolution-data-server-1.11.6.1/calendar/libical/src/libicalvcal/vcc.y.code-cleanup 2007-01-22 12:29:26.000000000 -0500
|
||||
+++ evolution-data-server-1.11.6.1/calendar/libical/src/libicalvcal/vcc.y 2007-08-01 13:28:00.000000000 -0400
|
||||
--- evolution-data-server-1.11.90/calendar/libical/src/libicalvcal/vcc.y.code-cleanup 2007-08-20 22:42:49.000000000 -0400
|
||||
+++ evolution-data-server-1.11.90/calendar/libical/src/libicalvcal/vcc.y 2007-08-20 22:43:12.000000000 -0400
|
||||
@@ -170,6 +170,7 @@ static void enterProps(const char *s);
|
||||
static void enterAttr(const char *s1, const char *s2);
|
||||
static void enterValues(const char *value);
|
||||
|
@ -26,7 +26,7 @@
|
||||
|
||||
Name: evolution-data-server
|
||||
Version: 1.11.90
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: LGPL
|
||||
Group: System Environment/Libraries
|
||||
Summary: Backend data server for Evolution
|
||||
@ -387,6 +387,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/pkgconfig/libexchange-storage-%{eds_api_version}.pc
|
||||
|
||||
%changelog
|
||||
* Mon Aug 20 2007 Matthew Barnes <mbarnes@redhat.com> - 1.11.90-3.fc8
|
||||
- Revise patch for GNOME bug #417999 to fix GNOME bug #447591
|
||||
(Automatic Contacts combo boxes don't work).
|
||||
|
||||
* Mon Aug 13 2007 Matthew Barnes <mbarnes@redhat.com> - 1.11.90-2.fc8
|
||||
- Re-enable the --with-libdb configure option.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user