evince/evince-settings-migration.patch
2010-05-22 00:35:05 +00:00

86 lines
3.6 KiB
Diff

diff -up evince-2.31.1/data/evince.convert.settings-migration evince-2.31.1/data/evince.convert
--- evince-2.31.1/data/evince.convert.settings-migration 2010-05-21 19:57:12.668695278 -0400
+++ evince-2.31.1/data/evince.convert 2010-05-21 19:57:12.668695278 -0400
@@ -0,0 +1,7 @@
+[org.gnome.Evince]
+override-restrictions = /apps/evince/override_restrictions
+
+[org.gnome.Evince.Default]
+show-toolbar = /apps/evince/default/show-toolbar
+show-sidebar = /apps/evince/default/show-sidebar
+# window-ratio = /apps/evince/default/window-ratio
diff -up evince-2.31.1/data/Makefile.am.settings-migration evince-2.31.1/data/Makefile.am
--- evince-2.31.1/data/Makefile.am.settings-migration 2010-05-04 04:22:35.000000000 -0400
+++ evince-2.31.1/data/Makefile.am 2010-05-21 19:57:12.669696745 -0400
@@ -54,15 +54,16 @@ endif
# gsettingsschemadir and gschema_compile are defined by the GLIB_GSETTINGS
# macro in configure.ac
gsettingsschema_in_files = org.gnome.Evince.gschema.xml.in
-gsettingsschema_DATA = $(gsettingsschema_in_files:.xml.in=.xml)
+gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
+
+.PRECIOUS: $(gsettings_SCHEMAS)
+
@INTLTOOL_XML_NOMERGE_RULE@
-# This rule will check your schemas for validity before installation
-# Uncomment when porting is done
-# GSETTINGS_CHECK_RULE
-if GSETTINGS_SCHEMAS_INSTALL
-install-data-hook:
- $(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --allow-any-name $(DESTDIR)$(gsettingsschemadir) --targetdir=$(DESTDIR)$(gsettingsschemadir)
-endif
+
+@GSETTINGS_RULES@
+
+gsettingsconvertdir = $(datadir)/GConf/gsettings
+gsettingsconvert_DATA = evince.convert
#
# GTK icon cache
@@ -94,6 +95,7 @@ EXTRA_DIST = \
org.gnome.evince.Daemon.service.in \
$(man_MANS) \
evince.ico \
+ evince.convert \
$(NULL)
#
diff -up evince-2.31.1/data/org.gnome.Evince.gschema.xml.in.settings-migration evince-2.31.1/data/org.gnome.Evince.gschema.xml.in
--- evince-2.31.1/data/org.gnome.Evince.gschema.xml.in.settings-migration 2010-05-04 04:56:03.000000000 -0400
+++ evince-2.31.1/data/org.gnome.Evince.gschema.xml.in 2010-05-21 19:57:12.670691157 -0400
@@ -1,6 +1,6 @@
<schemalist>
<schema id="org.gnome.Evince" path="/apps/evince/" gettext-domain="evince">
- <key name="override_restrictions" type="b">
+ <key name="override-restrictions" type="b">
<default>true</default>
<summary>Override document restrictions</summary>
<description>Override document restrictions, like restriction to copy or to print.</description>
diff -up evince-2.31.1/shell/ev-window.c.settings-migration evince-2.31.1/shell/ev-window.c
--- evince-2.31.1/shell/ev-window.c.settings-migration 2010-05-04 07:39:11.000000000 -0400
+++ evince-2.31.1/shell/ev-window.c 2010-05-21 19:57:12.676680262 -0400
@@ -229,7 +229,7 @@ struct _EvWindowPrivate {
#define GCONF_LOCKDOWN_PRINT_SETUP "/desktop/gnome/lockdown/disable_print_setup"
#define GS_SCHEMA_NAME "org.gnome.Evince"
-#define GS_OVERRIDE_RESTRICTIONS "override_restrictions"
+#define GS_OVERRIDE_RESTRICTIONS "override-restrictions"
#define SIDEBAR_DEFAULT_SIZE 132
#define LINKS_SIDEBAR_ID "links"
diff -up evince-2.31.1/shell/main.c.settings-migration evince-2.31.1/shell/main.c
--- evince-2.31.1/shell/main.c.settings-migration 2010-05-21 20:17:47.577682354 -0400
+++ evince-2.31.1/shell/main.c 2010-05-21 20:18:01.229682491 -0400
@@ -216,11 +216,6 @@ main (int argc, char *argv[])
GOptionContext *context;
GError *error = NULL;
-#ifdef WITH_GCONF
- /* Remove when porting is done */
- g_setenv ("GSETTINGS_BACKEND", "gconf", FALSE);
-#endif
-
#ifdef G_OS_WIN32
if (fileno (stdout) != -1 &&