Disable toggle-find action for documents not supporting find
Resolves: #1160376
This commit is contained in:
parent
d366a3d5ff
commit
bad7e33a81
@ -0,0 +1,26 @@
|
|||||||
|
From bfa59b72ed0c86192ca9b1f0882ca5119aa7fe12 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Carlos Garcia Campos <carlosgc@gnome.org>
|
||||||
|
Date: Sun, 19 Oct 2014 15:24:18 +0200
|
||||||
|
Subject: [PATCH] Disable toggle-find action for documents not supporting find
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=738262
|
||||||
|
---
|
||||||
|
shell/ev-window.c | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/shell/ev-window.c b/shell/ev-window.c
|
||||||
|
index c4f1f5d..4de4732 100644
|
||||||
|
--- a/shell/ev-window.c
|
||||||
|
+++ b/shell/ev-window.c
|
||||||
|
@@ -502,6 +502,8 @@ ev_window_update_actions_sensitivity (EvWindow *ev_window)
|
||||||
|
can_get_text && !recent_view_mode);
|
||||||
|
ev_window_set_action_enabled (ev_window, "find", can_find &&
|
||||||
|
!recent_view_mode);
|
||||||
|
+ ev_window_set_action_enabled (ev_window, "toggle-find", can_find &&
|
||||||
|
+ !recent_view_mode);
|
||||||
|
ev_window_set_action_enabled (ev_window, "rotate-left", has_pages &&
|
||||||
|
!recent_view_mode);
|
||||||
|
ev_window_set_action_enabled (ev_window, "rotate-right", has_pages &&
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
11
evince.spec
11
evince.spec
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
Name: evince
|
Name: evince
|
||||||
Version: 3.14.1
|
Version: 3.14.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Document viewer
|
Summary: Document viewer
|
||||||
|
|
||||||
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
||||||
@ -13,6 +13,9 @@ Group: Applications/Publishing
|
|||||||
URL: http://projects.gnome.org/evince/
|
URL: http://projects.gnome.org/evince/
|
||||||
Source0: http://download.gnome.org/sources/%{name}/3.14/%{name}-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/%{name}/3.14/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1160376
|
||||||
|
Patch0: 0001-Disable-toggle-find-action-for-documents-not-support.patch
|
||||||
|
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
BuildRequires: gtk3-devel >= %{gtk3_version}
|
BuildRequires: gtk3-devel >= %{gtk3_version}
|
||||||
BuildRequires: poppler-glib-devel >= %{poppler_version}
|
BuildRequires: poppler-glib-devel >= %{poppler_version}
|
||||||
@ -118,6 +121,8 @@ This package contains the evince web browser plugin.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
%patch0 -p1 -b .toggle-find
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
%configure \
|
%configure \
|
||||||
@ -245,6 +250,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null ||:
|
|||||||
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 5 2014 Marek Kasik <mkasik@redhat.com> - 3.14.1-2
|
||||||
|
- Disable toggle-find action for documents not supporting find
|
||||||
|
- Resolves: #1160376
|
||||||
|
|
||||||
* Tue Oct 14 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-1
|
* Tue Oct 14 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-1
|
||||||
- Update to 3.14.1
|
- Update to 3.14.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user