Update to 3.19.92
This commit is contained in:
parent
67bfc4efc7
commit
ab3ec9c8f5
1
.gitignore
vendored
1
.gitignore
vendored
@ -56,3 +56,4 @@ evince-3.0.0.tar.bz2
|
|||||||
/evince-3.18.0.tar.xz
|
/evince-3.18.0.tar.xz
|
||||||
/evince-3.18.1.tar.xz
|
/evince-3.18.1.tar.xz
|
||||||
/evince-3.18.2.tar.xz
|
/evince-3.18.2.tar.xz
|
||||||
|
/evince-3.19.92.tar.xz
|
||||||
|
@ -1,45 +0,0 @@
|
|||||||
From 7850b986cf3225369170cdec545844b025bfd12e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marek Kasik <mkasik@redhat.com>
|
|
||||||
Date: Tue, 16 Feb 2016 11:54:21 +0100
|
|
||||||
Subject: [PATCH] Recognize multipage DjVu MIME type
|
|
||||||
|
|
||||||
There is new image/vnd.djvu+multipage MIME type for DjVu documents
|
|
||||||
in shared-mime-info.
|
|
||||||
This MIME type is used if Evince has to guess type of the document.
|
|
||||||
Evince states that it doesn't support it in such case.
|
|
||||||
This is reproducible if the opened document doesn't have an extension.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=754467
|
|
||||||
---
|
|
||||||
browser-plugin/EvBrowserPluginMain.cpp | 1 +
|
|
||||||
configure.ac | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/browser-plugin/EvBrowserPluginMain.cpp b/browser-plugin/EvBrowserPluginMain.cpp
|
|
||||||
index fb749f4..a25bb2f 100644
|
|
||||||
--- a/browser-plugin/EvBrowserPluginMain.cpp
|
|
||||||
+++ b/browser-plugin/EvBrowserPluginMain.cpp
|
|
||||||
@@ -252,6 +252,7 @@ static const struct {
|
|
||||||
{ "application/x-cbt", "cbt" },
|
|
||||||
{ "application/x-ext-cbt", "cbt" },
|
|
||||||
{ "image/vnd.djvu", "djvu,djv" },
|
|
||||||
+ { "image/vnd.djvu+multipage", "djvu,djv" },
|
|
||||||
{ "application/x-ext-djv", "djv" },
|
|
||||||
{ "application/x-ext-djvu", "djvu" },
|
|
||||||
{ "application/oxps", "xps,oxps" },
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index e85e820..318cb70 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -756,7 +756,7 @@ AC_SUBST(DVI_MIME_TYPES)
|
|
||||||
AC_SUBST(APPDATA_DVI_MIME_TYPES)
|
|
||||||
AM_SUBST_NOTMAKE(APPDATA_DVI_MIME_TYPES)
|
|
||||||
if test "x$enable_djvu" = "xyes"; then
|
|
||||||
- DJVU_MIME_TYPES="image/vnd.djvu;application/x-ext-djv;application/x-ext-djvu"
|
|
||||||
+ DJVU_MIME_TYPES="image/vnd.djvu;image/vnd.djvu+multipage;application/x-ext-djv;application/x-ext-djvu"
|
|
||||||
APPDATA_DJVU_MIME_TYPES=$(echo "<mimetype>$DJVU_MIME_TYPES</mimetype>" | sed -e 's/;/<\/mimetype>\n <mimetype>/g')
|
|
||||||
if test -z "$EVINCE_MIME_TYPES"; then
|
|
||||||
EVINCE_MIME_TYPES="${DJVU_MIME_TYPES}"
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
@ -1,21 +0,0 @@
|
|||||||
From 3bd2709900526ab1a4b82123a8b62c887b30e8f4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Catanzaro <mcatanzaro@igalia.com>
|
|
||||||
Date: Wed, 18 Nov 2015 21:57:15 -0600
|
|
||||||
Subject: Fix installation of symbolic app icon
|
|
||||||
|
|
||||||
---
|
|
||||||
data/icons/scalable/apps/Makefile.am | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/data/icons/scalable/apps/Makefile.am b/data/icons/scalable/apps/Makefile.am
|
|
||||||
index 77e9a10..1dacc95 100644
|
|
||||||
--- a/data/icons/scalable/apps/Makefile.am
|
|
||||||
+++ b/data/icons/scalable/apps/Makefile.am
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-themedir = $(pkgdatadir)/icons/hicolor
|
|
||||||
+themedir = $(datadir)/icons/hicolor
|
|
||||||
size = scalable
|
|
||||||
context = apps
|
|
||||||
|
|
||||||
--
|
|
||||||
cgit v0.11.2
|
|
@ -1,42 +0,0 @@
|
|||||||
From c4130d229816c2bf4734df9535b021052678204b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marek Kasik <mkasik@redhat.com>
|
|
||||||
Date: Tue, 15 Dec 2015 17:41:33 +0100
|
|
||||||
Subject: [PATCH] Fix selection of text on Wayland
|
|
||||||
|
|
||||||
Do not clear selection if update of the primary selection failed.
|
|
||||||
This is expected to happen on Wayland and other platforms with no primary selection,
|
|
||||||
and just leads to the selected text being cleared after any attempt to change the
|
|
||||||
text selection itself through either mouse/keyboard.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=759506
|
|
||||||
---
|
|
||||||
libview/ev-view.c | 13 ++++++-------
|
|
||||||
1 file changed, 6 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/libview/ev-view.c b/libview/ev-view.c
|
|
||||||
index 9fa0546..f76eca8 100644
|
|
||||||
--- a/libview/ev-view.c
|
|
||||||
+++ b/libview/ev-view.c
|
|
||||||
@@ -9262,13 +9262,12 @@ ev_view_update_primary_selection (EvView *ev_view)
|
|
||||||
gtk_target_list_add_text_targets (target_list, 0);
|
|
||||||
targets = gtk_target_table_new_from_list (target_list, &n_targets);
|
|
||||||
gtk_target_list_unref (target_list);
|
|
||||||
-
|
|
||||||
- if (!gtk_clipboard_set_with_owner (clipboard,
|
|
||||||
- targets, n_targets,
|
|
||||||
- ev_view_primary_get_cb,
|
|
||||||
- ev_view_primary_clear_cb,
|
|
||||||
- G_OBJECT (ev_view)))
|
|
||||||
- ev_view_primary_clear_cb (clipboard, ev_view);
|
|
||||||
+
|
|
||||||
+ gtk_clipboard_set_with_owner (clipboard,
|
|
||||||
+ targets, n_targets,
|
|
||||||
+ ev_view_primary_get_cb,
|
|
||||||
+ ev_view_primary_clear_cb,
|
|
||||||
+ G_OBJECT (ev_view));
|
|
||||||
|
|
||||||
gtk_target_table_free (targets, n_targets);
|
|
||||||
} else {
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
20
evince.spec
20
evince.spec
@ -1,21 +1,18 @@
|
|||||||
%global poppler_version 0.24.0
|
%global poppler_version 0.33.0
|
||||||
%global glib2_version 2.36.0
|
%global glib2_version 2.36.0
|
||||||
%global gtk3_version 3.16.0
|
%global gtk3_version 3.16.0
|
||||||
%global gxps_version 0.2.1
|
%global gxps_version 0.2.1
|
||||||
|
|
||||||
Name: evince
|
Name: evince
|
||||||
Version: 3.18.2
|
Version: 3.19.92
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Document viewer
|
Summary: Document viewer
|
||||||
|
|
||||||
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
URL: https://wiki.gnome.org/Apps/Evince
|
URL: https://wiki.gnome.org/Apps/Evince
|
||||||
Source0: http://download.gnome.org/sources/%{name}/3.18/%{name}-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/%{name}/3.19/%{name}-%{version}.tar.xz
|
||||||
Patch1: evince-3.17.2-check-to-avoid-crash.patch
|
Patch1: evince-3.17.2-check-to-avoid-crash.patch
|
||||||
Patch2: evince-3.18.2-symbolic-app-icon.patch
|
|
||||||
Patch3: evince-3.18.2-text-selection.patch
|
|
||||||
Patch4: evince-3.18.2-multipage-djvu.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig(adwaita-icon-theme)
|
BuildRequires: pkgconfig(adwaita-icon-theme)
|
||||||
BuildRequires: pkgconfig(gio-unix-2.0) >= %{glib2_version}
|
BuildRequires: pkgconfig(gio-unix-2.0) >= %{glib2_version}
|
||||||
@ -34,7 +31,6 @@ BuildRequires: yelp-tools
|
|||||||
BuildRequires: intltool
|
BuildRequires: intltool
|
||||||
BuildRequires: /usr/bin/desktop-file-validate
|
BuildRequires: /usr/bin/desktop-file-validate
|
||||||
# For autoconf.sh
|
# For autoconf.sh
|
||||||
BuildRequires: gnome-common >= 2.26
|
|
||||||
BuildRequires: libappstream-glib
|
BuildRequires: libappstream-glib
|
||||||
|
|
||||||
# for the nautilus properties page
|
# for the nautilus properties page
|
||||||
@ -125,12 +121,8 @@ This package contains the evince web browser plugin.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .check-to-avoid-crash
|
%patch1 -p1 -b .check-to-avoid-crash
|
||||||
%patch2 -p1 -b .symbolic-app-icon
|
|
||||||
%patch3 -p1 -b .text-selection
|
|
||||||
%patch4 -p1 -b .multipage-djvu
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
|
||||||
%configure \
|
%configure \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
--enable-introspection \
|
--enable-introspection \
|
||||||
@ -206,6 +198,7 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null ||:
|
|||||||
%{_datadir}/glib-2.0/schemas/org.gnome.Evince.gschema.xml
|
%{_datadir}/glib-2.0/schemas/org.gnome.Evince.gschema.xml
|
||||||
%{_datadir}/GConf/gsettings/evince.convert
|
%{_datadir}/GConf/gsettings/evince.convert
|
||||||
%{_datadir}/thumbnailers/evince.thumbnailer
|
%{_datadir}/thumbnailers/evince.thumbnailer
|
||||||
|
%{_userunitdir}/evince.service
|
||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%doc README NEWS AUTHORS
|
%doc README NEWS AUTHORS
|
||||||
@ -270,6 +263,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null ||:
|
|||||||
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 16 2016 Kalev Lember <klember@redhat.com> - 3.19.92-1
|
||||||
|
- Update to 3.19.92
|
||||||
|
|
||||||
* Tue Mar 8 2016 Marek Kasik <mkasik@redhat.com> - 3.18.2-5
|
* Tue Mar 8 2016 Marek Kasik <mkasik@redhat.com> - 3.18.2-5
|
||||||
- Recognize multipage DjVu MIME type
|
- Recognize multipage DjVu MIME type
|
||||||
- Resolves: #1308628
|
- Resolves: #1308628
|
||||||
|
Loading…
Reference in New Issue
Block a user