Update to 3.15.4
This commit is contained in:
parent
ce814e6e32
commit
66758f769b
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@ evince-3.0.0.tar.bz2
|
|||||||
/evince-3.13.92.tar.xz
|
/evince-3.13.92.tar.xz
|
||||||
/evince-3.14.0.tar.xz
|
/evince-3.14.0.tar.xz
|
||||||
/evince-3.14.1.tar.xz
|
/evince-3.14.1.tar.xz
|
||||||
|
/evince-3.15.4.tar.xz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From bfa59b72ed0c86192ca9b1f0882ca5119aa7fe12 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Carlos Garcia Campos <carlosgc@gnome.org>
|
|
||||||
Date: Sun, 19 Oct 2014 15:24:18 +0200
|
|
||||||
Subject: [PATCH] Disable toggle-find action for documents not supporting find
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=738262
|
|
||||||
---
|
|
||||||
shell/ev-window.c | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/shell/ev-window.c b/shell/ev-window.c
|
|
||||||
index c4f1f5d..4de4732 100644
|
|
||||||
--- a/shell/ev-window.c
|
|
||||||
+++ b/shell/ev-window.c
|
|
||||||
@@ -502,6 +502,8 @@ ev_window_update_actions_sensitivity (EvWindow *ev_window)
|
|
||||||
can_get_text && !recent_view_mode);
|
|
||||||
ev_window_set_action_enabled (ev_window, "find", can_find &&
|
|
||||||
!recent_view_mode);
|
|
||||||
+ ev_window_set_action_enabled (ev_window, "toggle-find", can_find &&
|
|
||||||
+ !recent_view_mode);
|
|
||||||
ev_window_set_action_enabled (ev_window, "rotate-left", has_pages &&
|
|
||||||
!recent_view_mode);
|
|
||||||
ev_window_set_action_enabled (ev_window, "rotate-right", has_pages &&
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,27 +0,0 @@
|
|||||||
From 6709534cdc8824459e805c120c2f74b97670b769 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marek Kasik <mkasik@redhat.com>
|
|
||||||
Date: Wed, 19 Nov 2014 10:53:29 +0100
|
|
||||||
Subject: [PATCH] Fix configuration with ligbnome-desktop
|
|
||||||
|
|
||||||
A typo caused fail of configuration with enabled
|
|
||||||
support for libgnome-desktop.
|
|
||||||
---
|
|
||||||
configure.ac | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index dd4bcab..0ae92b1 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -313,7 +313,7 @@ if test "$enable_gnome_desktop" != "no"; then
|
|
||||||
PKG_CHECK_MODULES([LIBGNOME_DESKTOP], [gnome-desktop-3.0], has_libgnome_desktop=yes, has_libgnome_desktop=no)
|
|
||||||
else
|
|
||||||
PKG_CHECK_MODULES([LIBGNOME_DESKTOP], [gnome-desktop-3.0])
|
|
||||||
- has_libgnome_desktop = yes
|
|
||||||
+ has_libgnome_desktop=yes
|
|
||||||
fi
|
|
||||||
|
|
||||||
if test x$has_libgnome_desktop = xyes; then
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,36 +0,0 @@
|
|||||||
From 8875003da7f78a6fbba36fcc70d6ed2d372da7a6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Carlos Garcia Campos <carlosgc@gnome.org>
|
|
||||||
Date: Sun, 19 Oct 2014 16:01:38 +0200
|
|
||||||
Subject: [PATCH] Fix runtime critical warning when starting in fullscreen mode
|
|
||||||
|
|
||||||
The problem is that when running fullscreen mode we call
|
|
||||||
ev_window_update_links_model() to update the page action widget of the
|
|
||||||
fullscreen toolbar, but when running directly in fullscreen mode, this
|
|
||||||
can happen before the links have been loaded in the sidebar. Since
|
|
||||||
ev_window_update_links_model() is also called automatically when the
|
|
||||||
links model property changes, we can simply return early in
|
|
||||||
ev_window_update_links_model() when the model is NULL and it will be
|
|
||||||
called again with a valid model when the links job finishes.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=737864
|
|
||||||
---
|
|
||||||
shell/ev-window.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/shell/ev-window.c b/shell/ev-window.c
|
|
||||||
index 4de4732..e7f6a96 100644
|
|
||||||
--- a/shell/ev-window.c
|
|
||||||
+++ b/shell/ev-window.c
|
|
||||||
@@ -4024,6 +4024,9 @@ ev_window_update_links_model (EvWindow *window)
|
|
||||||
"model", &model,
|
|
||||||
NULL);
|
|
||||||
|
|
||||||
+ if (!model)
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
page_selector = ev_toolbar_get_page_selector (EV_TOOLBAR (window->priv->toolbar));
|
|
||||||
ev_page_action_widget_update_links_model (EV_PAGE_ACTION_WIDGET (page_selector), model);
|
|
||||||
if (window->priv->fs_toolbar) {
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,38 +0,0 @@
|
|||||||
From 5310e9e9bb7e29490c89e3e53243088d7ce5f518 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marek Kasik <mkasik@redhat.com>
|
|
||||||
Date: Mon, 19 May 2014 14:32:19 +0200
|
|
||||||
Subject: [PATCH 1/2] Scroll to the search result selected by user
|
|
||||||
|
|
||||||
Scroll to page on which is the search result selected by user
|
|
||||||
when not in continuous mode.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=730252
|
|
||||||
---
|
|
||||||
libview/ev-view.c | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/libview/ev-view.c b/libview/ev-view.c
|
|
||||||
index 5ed2d78..f3aa033 100644
|
|
||||||
--- a/libview/ev-view.c
|
|
||||||
+++ b/libview/ev-view.c
|
|
||||||
@@ -8158,6 +8158,9 @@ jump_to_find_page (EvView *view, EvViewFindDirection direction, gint shift)
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+ if (!view->continuous)
|
|
||||||
+ ev_document_model_set_page (view->model, view->find_page);
|
|
||||||
}
|
|
||||||
|
|
||||||
static void
|
|
||||||
@@ -8282,6 +8285,7 @@ ev_view_find_set_result (EvView *view, gint page, gint result)
|
|
||||||
{
|
|
||||||
view->find_page = page;
|
|
||||||
view->find_result = result;
|
|
||||||
+ jump_to_find_page (view, EV_VIEW_FIND_NEXT, 0);
|
|
||||||
jump_to_find_result (view);
|
|
||||||
gtk_widget_queue_draw (GTK_WIDGET (view));
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,41 +0,0 @@
|
|||||||
From d39c99cbb1c28a894b09f467b18e34754fd6842f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marek Kasik <mkasik@redhat.com>
|
|
||||||
Date: Tue, 18 Nov 2014 12:53:40 +0100
|
|
||||||
Subject: [PATCH 2/2] Show correct page when next search result requested
|
|
||||||
|
|
||||||
If there are more than 1 results on a page then requesting
|
|
||||||
next search result from the same page will not return you
|
|
||||||
to the page with the search results if you moved from the
|
|
||||||
page in the meantime (when you are not in continuous mode).
|
|
||||||
This applies also to previous results.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=730252
|
|
||||||
---
|
|
||||||
libview/ev-view.c | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/libview/ev-view.c b/libview/ev-view.c
|
|
||||||
index f3aa033..a9159cd 100644
|
|
||||||
--- a/libview/ev-view.c
|
|
||||||
+++ b/libview/ev-view.c
|
|
||||||
@@ -8250,6 +8250,8 @@ ev_view_find_next (EvView *view)
|
|
||||||
if (view->find_result >= n_results) {
|
|
||||||
view->find_result = 0;
|
|
||||||
jump_to_find_page (view, EV_VIEW_FIND_NEXT, 1);
|
|
||||||
+ } else if (view->find_page != view->current_page) {
|
|
||||||
+ jump_to_find_page (view, EV_VIEW_FIND_NEXT, 0);
|
|
||||||
}
|
|
||||||
|
|
||||||
jump_to_find_result (view);
|
|
||||||
@@ -8264,6 +8266,8 @@ ev_view_find_previous (EvView *view)
|
|
||||||
if (view->find_result < 0) {
|
|
||||||
jump_to_find_page (view, EV_VIEW_FIND_PREV, -1);
|
|
||||||
view->find_result = MAX (0, ev_view_find_get_n_results (view, view->find_page) - 1);
|
|
||||||
+ } else if (view->find_page != view->current_page) {
|
|
||||||
+ jump_to_find_page (view, EV_VIEW_FIND_PREV, 0);
|
|
||||||
}
|
|
||||||
|
|
||||||
jump_to_find_result (view);
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
25
evince.spec
25
evince.spec
@ -4,8 +4,8 @@
|
|||||||
%global gxps_version 0.2.1
|
%global gxps_version 0.2.1
|
||||||
|
|
||||||
Name: evince
|
Name: evince
|
||||||
Version: 3.14.1
|
Version: 3.15.4
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Document viewer
|
Summary: Document viewer
|
||||||
|
|
||||||
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
||||||
@ -13,18 +13,6 @@ Group: Applications/Publishing
|
|||||||
URL: http://projects.gnome.org/evince/
|
URL: http://projects.gnome.org/evince/
|
||||||
Source0: http://download.gnome.org/sources/%{name}/3.14/%{name}-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/%{name}/3.14/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1160376
|
|
||||||
Patch0: 0001-Disable-toggle-find-action-for-documents-not-support.patch
|
|
||||||
|
|
||||||
Patch1: 0001-Fix-runtime-critical-warning-when-starting-in-fullsc.patch
|
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1162254
|
|
||||||
Patch2: 0001-Scroll-to-the-search-result-selected-by-user.patch
|
|
||||||
Patch3: 0002-Show-correct-page-when-next-search-result-requested.patch
|
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1147270
|
|
||||||
Patch4: 0001-Fix-configuration-with-ligbnome-desktop.patch
|
|
||||||
|
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
BuildRequires: gtk3-devel >= %{gtk3_version}
|
BuildRequires: gtk3-devel >= %{gtk3_version}
|
||||||
BuildRequires: poppler-glib-devel >= %{poppler_version}
|
BuildRequires: poppler-glib-devel >= %{poppler_version}
|
||||||
@ -133,12 +121,6 @@ This package contains the evince web browser plugin.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1 -b .toggle-find
|
|
||||||
%patch1 -p1 -b .unref
|
|
||||||
%patch2 -p1 -b .scroll-to-search-result
|
|
||||||
%patch3 -p1 -b .scroll-to-search-result2
|
|
||||||
%patch4 -p1 -b .libgnome-desktop
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
%configure \
|
%configure \
|
||||||
@ -271,6 +253,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null ||:
|
|||||||
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
%{_libdir}/mozilla/plugins/libevbrowserplugin.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 20 2015 Marek Kasik <mkasik@redhat.com> - 3.15.4-1
|
||||||
|
- Update to 3.15.4
|
||||||
|
|
||||||
* Mon Dec 08 2014 Adam Jackson <ajax@redhat.com> 3.14.1-8
|
* Mon Dec 08 2014 Adam Jackson <ajax@redhat.com> 3.14.1-8
|
||||||
- Don't link against t1lib, freetype is sufficient (#852489)
|
- Don't link against t1lib, freetype is sufficient (#852489)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user