Fix the build by backporting a GIR generation fix

This commit is contained in:
Kalev Lember 2012-06-28 17:02:14 +03:00
parent fe8784bd2d
commit 6349309396
2 changed files with 45 additions and 1 deletions

View File

@ -0,0 +1,39 @@
From 0cad0892dfcd9e06b8671d1641662e33e52c0ad8 Mon Sep 17 00:00:00 2001
From: Robert Ancell <robert.ancell@canonical.com>
Date: Wed, 27 Jun 2012 16:06:49 +1200
Subject: [PATCH] libdocument, libview: Fix GIR generation
---
libdocument/Makefile.am | 2 +-
libview/Makefile.am | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/libdocument/Makefile.am b/libdocument/Makefile.am
index 59c369e..0a6000e 100644
--- a/libdocument/Makefile.am
+++ b/libdocument/Makefile.am
@@ -153,7 +153,7 @@ EXTRA_DIST = \
if ENABLE_INTROSPECTION
-EvinceDocument-$(EV_API_VERSION).gir: libevdocument3.la Makefile $(INST_H_FILES) $(filter %.c,$(libevdocument3_la_SOURCES))
+EvinceDocument-$(EV_API_VERSION).gir: libevdocument3.la Makefile $(INST_H_SRC_FILES) $(INST_H_BUILT_FILES) $(filter %.c,$(libevdocument3_la_SOURCES)) $(filter %.c,$(nodist_libevdocument3_la_SOURCES))
$(AM_V_GEN) PKG_CONFIG_PATH=$(top_builddir):$$PKG_CONFIG_PATH \
$(G_IR_SCANNER) -v --namespace EvinceDocument \
--strip-prefix=Ev \
diff --git a/libview/Makefile.am b/libview/Makefile.am
index 81b68a9..65b9f84 100644
--- a/libview/Makefile.am
+++ b/libview/Makefile.am
@@ -123,7 +123,7 @@ EXTRA_DIST = \
if ENABLE_INTROSPECTION
-EvinceView-$(EV_API_VERSION).gir: libevview3.la Makefile $(INST_H_FILES) $(filter %.c,$(libevview3_la_SOURCES))
+EvinceView-$(EV_API_VERSION).gir: libevview3.la Makefile $(INST_H_SRC_FILES) $(INST_H_BUILT_FILES) $(filter %.c,$(libevview3_la_SOURCES)) $(filter %.c,$(nodist_libevview3_la_SOURCES))
$(AM_V_GEN) PKG_CONFIG_PATH=$(top_builddir):$$PKG_CONFIG_PATH \
$(G_IR_SCANNER) -v --namespace EvinceView \
--add-include-path=$(top_builddir)/libdocument \
--
1.7.10.4

View File

@ -6,13 +6,14 @@
Name: evince Name: evince
Version: 3.5.3 Version: 3.5.3
Release: 1%{?dist} Release: 2%{?dist}
Summary: Document viewer Summary: Document viewer
License: GPLv2+ and GFDL License: GPLv2+ and GFDL
Group: Applications/Publishing Group: Applications/Publishing
URL: http://projects.gnome.org/evince/ URL: http://projects.gnome.org/evince/
Source0: http://download.gnome.org/sources/%{name}/3.5/%{name}-%{version}.tar.xz Source0: http://download.gnome.org/sources/%{name}/3.5/%{name}-%{version}.tar.xz
Patch0: 0001-libdocument-libview-Fix-GIR-generation.patch
BuildRequires: gtk3-devel BuildRequires: gtk3-devel
BuildRequires: glib2-devel >= %{glib2_version} BuildRequires: glib2-devel >= %{glib2_version}
@ -107,6 +108,7 @@ It adds an additional tab called "Document" to the file properties dialog.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .gir
%build %build
./autogen.sh ./autogen.sh
@ -223,6 +225,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null ||:
%{_libdir}/nautilus/extensions-3.0/libevince-properties-page.so %{_libdir}/nautilus/extensions-3.0/libevince-properties-page.so
%changelog %changelog
* Thu Jun 28 2012 Kalev Lember <kalevlember@gmail.com> - 3.5.3-2
- Fix the build by backporting a GIR generation fix
* Wed Jun 27 2012 Richard Hughes <hughsient@gmail.com> - 3.5.3-1 * Wed Jun 27 2012 Richard Hughes <hughsient@gmail.com> - 3.5.3-1
- Update to 3.5.3 - Update to 3.5.3