- Make sure dot_dir exists before creating last_settings file
- backported from upstream - Related: #586343
This commit is contained in:
parent
521672f7c7
commit
225546f44d
@ -0,0 +1,26 @@
|
|||||||
|
From 0ac70b958c575996f760fdd987718649398fd51b Mon Sep 17 00:00:00 2001
|
||||||
|
From: Carlos Garcia Campos <carlosgc@gnome.org>
|
||||||
|
Date: Thu, 29 Apr 2010 11:53:26 +0200
|
||||||
|
Subject: [PATCH] Make sure dot_dir exists before creating last_settings file
|
||||||
|
|
||||||
|
Fixes bug #617154.
|
||||||
|
---
|
||||||
|
shell/ev-window.c | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/shell/ev-window.c b/shell/ev-window.c
|
||||||
|
index fb40f70..4c4c460 100644
|
||||||
|
--- a/shell/ev-window.c
|
||||||
|
+++ b/shell/ev-window.c
|
||||||
|
@@ -6107,7 +6107,7 @@ ev_window_create_last_settings_metadata (EvWindow *window)
|
||||||
|
GFile *file;
|
||||||
|
gchar *path;
|
||||||
|
|
||||||
|
- path = g_build_filename (ev_application_get_dot_dir (EV_APP, FALSE), "last_settings", NULL);
|
||||||
|
+ path = g_build_filename (ev_application_get_dot_dir (EV_APP, TRUE), "last_settings", NULL);
|
||||||
|
file = g_file_new_for_path (path);
|
||||||
|
g_free (path);
|
||||||
|
|
||||||
|
--
|
||||||
|
1.6.5.2
|
||||||
|
|
10
evince.spec
10
evince.spec
@ -6,7 +6,7 @@
|
|||||||
|
|
||||||
Name: evince
|
Name: evince
|
||||||
Version: 2.30.1
|
Version: 2.30.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Document viewer
|
Summary: Document viewer
|
||||||
|
|
||||||
License: GPLv2+ and GFDL
|
License: GPLv2+ and GFDL
|
||||||
@ -15,6 +15,8 @@ URL: http://projects.gnome.org/evince/
|
|||||||
Source0: http://download.gnome.org/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
|
Source0: http://download.gnome.org/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=562648
|
# https://bugzilla.redhat.com/show_bug.cgi?id=562648
|
||||||
Patch2: evince-t1font-mapping.patch
|
Patch2: evince-t1font-mapping.patch
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=586343
|
||||||
|
Patch3: 0001-Make-sure-dot_dir-exists-before-creating-last_settin.patch
|
||||||
|
|
||||||
BuildRequires: gtk2-devel >= %{gtk2_version}
|
BuildRequires: gtk2-devel >= %{gtk2_version}
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
@ -112,6 +114,7 @@ It adds an additional tab called "Document" to the file properties dialog.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch2 -p1 -b .t1font-map
|
%patch2 -p1 -b .t1font-map
|
||||||
|
%patch3 -p1 -b .settings
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-static --disable-scrollkeeper --disable-schemas-install \
|
%configure --disable-static --disable-scrollkeeper --disable-schemas-install \
|
||||||
@ -234,6 +237,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
|
|||||||
%{_libdir}/nautilus/extensions-2.0/libevince-properties-page.so
|
%{_libdir}/nautilus/extensions-2.0/libevince-properties-page.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 29 2010 Marek Kasik <mkasik@redhat.com> - 2.30.1-2
|
||||||
|
- Make sure dot_dir exists before creating last_settings file
|
||||||
|
- backported from upstream
|
||||||
|
- Related: #586343
|
||||||
|
|
||||||
* Mon Apr 26 2010 Matthias Clasen <mclasen@redhat.com> - 2.30.1-1
|
* Mon Apr 26 2010 Matthias Clasen <mclasen@redhat.com> - 2.30.1-1
|
||||||
- Update to 2.30.1
|
- Update to 2.30.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user