Update to 40.1
This commit is contained in:
parent
ea33adab92
commit
16d036d695
1
.gitignore
vendored
1
.gitignore
vendored
@ -97,3 +97,4 @@ evince-3.0.0.tar.bz2
|
|||||||
/evince-3.39.1.tar.xz
|
/evince-3.39.1.tar.xz
|
||||||
/evince-3.39.2.tar.xz
|
/evince-3.39.2.tar.xz
|
||||||
/evince-40.0.tar.xz
|
/evince-40.0.tar.xz
|
||||||
|
/evince-40.1.tar.xz
|
||||||
|
@ -5,7 +5,7 @@
|
|||||||
%global synctex_version 1.19
|
%global synctex_version 1.19
|
||||||
|
|
||||||
Name: evince
|
Name: evince
|
||||||
Version: 40.0
|
Version: 40.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Document viewer
|
Summary: Document viewer
|
||||||
|
|
||||||
@ -13,10 +13,6 @@ License: GPLv2+ and GPLv3+ and LGPLv2+ and MIT and Afmparse
|
|||||||
URL: https://wiki.gnome.org/Apps/Evince
|
URL: https://wiki.gnome.org/Apps/Evince
|
||||||
Source0: https://download.gnome.org/sources/%{name}/40/%{name}-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/%{name}/40/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# Avoid changing soname
|
|
||||||
# https://gitlab.gnome.org/GNOME/evince/-/merge_requests/332
|
|
||||||
Patch0: soname.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
@ -260,6 +256,9 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/org.gnome.Evince-p
|
|||||||
%{_mandir}/man1/evince-thumbnailer.1*
|
%{_mandir}/man1/evince-thumbnailer.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 26 2021 Kalev Lember <klember@redhat.com> - 40.1-1
|
||||||
|
- Update to 40.1
|
||||||
|
|
||||||
* Fri Mar 26 2021 Kalev Lember <klember@redhat.com> - 40.0-1
|
* Fri Mar 26 2021 Kalev Lember <klember@redhat.com> - 40.0-1
|
||||||
- Update to 40.0
|
- Update to 40.0
|
||||||
- Tighten soname globs
|
- Tighten soname globs
|
||||||
|
66
soname.patch
66
soname.patch
@ -1,66 +0,0 @@
|
|||||||
From ca4b7aaff690095971de96370317fdf1bcd3af8f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kalev Lember <klember@redhat.com>
|
|
||||||
Date: Fri, 26 Mar 2021 14:48:51 +0100
|
|
||||||
Subject: [PATCH] Avoid changing soname
|
|
||||||
|
|
||||||
Bumping the major version to 40 in commit
|
|
||||||
288be740b5bbb59757db5038ab435ceb7a334dcf inadvertently changed the
|
|
||||||
soname for shared libevdocument and libevview.
|
|
||||||
|
|
||||||
Fix this by making the soname calculation independent from the project
|
|
||||||
version as the library ABI hasn't actually changed.
|
|
||||||
---
|
|
||||||
libdocument/meson.build | 2 +-
|
|
||||||
libview/meson.build | 2 +-
|
|
||||||
meson.build | 4 ++--
|
|
||||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/libdocument/meson.build b/libdocument/meson.build
|
|
||||||
index 74fe2fb1..e09de7fc 100644
|
|
||||||
--- a/libdocument/meson.build
|
|
||||||
+++ b/libdocument/meson.build
|
|
||||||
@@ -138,7 +138,7 @@ cflags = [
|
|
||||||
]
|
|
||||||
|
|
||||||
libevdocument = shared_library(
|
|
||||||
- 'evdocument' + ev_major_version.to_string(),
|
|
||||||
+ 'evdocument3',
|
|
||||||
version: ev_document_version,
|
|
||||||
sources: sources + enum_sources + [version_header],
|
|
||||||
include_directories: top_inc,
|
|
||||||
diff --git a/libview/meson.build b/libview/meson.build
|
|
||||||
index 20179aff..74c86d51 100644
|
|
||||||
--- a/libview/meson.build
|
|
||||||
+++ b/libview/meson.build
|
|
||||||
@@ -82,7 +82,7 @@ if enable_multimedia
|
|
||||||
endif
|
|
||||||
|
|
||||||
libevview = shared_library(
|
|
||||||
- 'evview' + ev_major_version.to_string(),
|
|
||||||
+ 'evview3',
|
|
||||||
version: ev_view_version,
|
|
||||||
sources: sources + marshal_sources + enum_sources,
|
|
||||||
include_directories: top_inc,
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index 1ed37e96..cafb9023 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -43,13 +43,13 @@ ev_document_version = '@0@.@1@.@2@'.format(ev_document_current, ev_document_revi
|
|
||||||
ev_document_current_minus_age = ev_document_current - ev_document_age
|
|
||||||
|
|
||||||
# Libtool version of the view library
|
|
||||||
-ev_view_current = ev_major_version
|
|
||||||
+ev_view_current = 3
|
|
||||||
ev_view_revision = 0
|
|
||||||
ev_view_age = 0
|
|
||||||
ev_view_version = '@0@.@1@.@2@'.format(ev_view_current, ev_view_revision, ev_view_age)
|
|
||||||
ev_view_current_minus_age = ev_view_current - ev_view_age
|
|
||||||
|
|
||||||
-ev_api_version = '@0@.0'.format(ev_major_version)
|
|
||||||
+ev_api_version = '3.0'
|
|
||||||
|
|
||||||
ev_include_subdir = join_paths(ev_name, ev_api_version)
|
|
||||||
|
|
||||||
--
|
|
||||||
2.30.2
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (evince-40.0.tar.xz) = 995693e4a6e1a3bb31e1d4f3538dc53519102a5a6afa58ba61454a1e2ca582df26bd368876210fce6fab8ff4e218305644fa7a7a88c99e1a1ca5bda8d8f1ece2
|
SHA512 (evince-40.1.tar.xz) = c688ee962cfff8b024b572161bae689d25b5b566ac623abeff38b4b8e6e541ce343023ed2c1ba0df1f65d6ec9a631aac3a748c940db556dbb89ab45ac565147d
|
||||||
|
Loading…
Reference in New Issue
Block a user