AlmaLinux changes

This commit is contained in:
eabdullin 2022-05-18 13:15:51 +03:00
parent 00a92d9395
commit b36f64560b
2 changed files with 128 additions and 2 deletions

View File

@ -0,0 +1,119 @@
diff -aruN eth-fast-fabric-11.1.0.1/CommonInstall/util_init.pl eth-fast-fabric-11.1.0.1.alma/CommonInstall/util_init.pl
--- eth-fast-fabric-11.1.0.1/CommonInstall/util_init.pl 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/CommonInstall/util_init.pl 2022-02-17 10:21:19.000000000 +0300
@@ -305,6 +305,8 @@
$CUR_DISTRO_VENDOR = "redhat";
} elsif ( -s "/etc/centos-release" ) {
$CUR_DISTRO_VENDOR = "redhat";
+ } elsif ( -s "/etc/almalinux-release" ) {
+ $CUR_DISTRO_VENDOR = "redhat";
} elsif ( -s "/etc/rocky-release" ) {
$CUR_DISTRO_VENDOR = "redhat";
} elsif ( -s "/etc/UnitedLinux-release" ) {
@@ -323,6 +325,7 @@
} elsif ( -e $os_release_file) {
my %distroVendor = (
"rhel" => "redhat",
+ "almalinux" => "redhat",
"centos" => "redhat",
"rocky" => "redhat",
"sles" => "SuSE",
@@ -330,6 +333,7 @@
);
my %network_conf_dir = (
"rhel" => $NETWORK_CONF_DIR,
+ "almalinux" => $NETWORK_CONF_DIR,
"centos" => $NETWORK_CONF_DIR,
"rocky" => $NETWORK_CONF_DIR,
"sles" => "/etc/sysconfig/network",
@@ -361,6 +365,8 @@
$NETWORK_CONF_DIR = "/etc/sysconfig/network";
} elsif ($CUR_DISTRO_VENDOR eq "centos") {
$CUR_DISTRO_VENDOR = "redhat";
+ } elsif ($CUR_DISTRO_VENDOR eq "almalinux") {
+ $CUR_DISTRO_VENDOR = "redhat";
} elsif ($CUR_DISTRO_VENDOR eq "rocky") {
$CUR_DISTRO_VENDOR = "redhat";
}
diff -aruN eth-fast-fabric-11.1.0.1/MakeTools/funcs-ext.sh eth-fast-fabric-11.1.0.1.alma/MakeTools/funcs-ext.sh
--- eth-fast-fabric-11.1.0.1/MakeTools/funcs-ext.sh 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/MakeTools/funcs-ext.sh 2022-02-17 10:23:59.000000000 +0300
@@ -725,6 +725,9 @@
centos)
rval=redhat
;;
+ almalinux)
+ rval=redhat
+ ;;
rocky)
rval=redhat
;;
@@ -759,6 +762,9 @@
elif [ $rval = 'centos' ]
then
rval=redhat
+ elif [ $rval = 'almalinux' ]
+ then
+ rval=redhat
elif [ $rval = 'rocky' ]
then
rval=redhat
@@ -836,6 +842,10 @@
then
# CentOS
rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
+ elif grep -qi almalinux /etc/redhat-release
+ then
+ # AlmaLinux
+ rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
elif grep -qi rocky /etc/redhat-release
then
# Rocky Linux
diff -aruN eth-fast-fabric-11.1.0.1/OpenIb_Host/update_mpi_spec.sh eth-fast-fabric-11.1.0.1.alma/OpenIb_Host/update_mpi_spec.sh
--- eth-fast-fabric-11.1.0.1/OpenIb_Host/update_mpi_spec.sh 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/OpenIb_Host/update_mpi_spec.sh 2022-02-17 10:24:56.000000000 +0300
@@ -33,7 +33,7 @@
id=$(./get_id_and_versionid.sh | cut -f1 -d' ')
versionid=$(./get_id_and_versionid.sh | cut -f2 -d' ')
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" ]
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" ]
then
GE_8_0=$(echo "$versionid >= 8.0" | bc)
sed -i "s/__RPM_REQ/Requires: openblas-devel/" mpi-apps.spec
diff -aruN eth-fast-fabric-11.1.0.1/get_id_and_versionid.sh eth-fast-fabric-11.1.0.1.alma/get_id_and_versionid.sh
--- eth-fast-fabric-11.1.0.1/get_id_and_versionid.sh 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/get_id_and_versionid.sh 2022-02-17 10:22:28.000000000 +0300
@@ -29,6 +29,9 @@
elif [ $rval = 'centos' ]
then
rval=redhat
+ elif [ $rval = 'almalinux' ]
+ then
+ rval=redhat
elif [ $rval = 'rocky' ]
then
rval=redhat
@@ -70,6 +73,10 @@
then
# CentOS
rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
+ elif grep -qi almalinux /etc/redhat-release
+ then
+ # AlmaLinux
+ rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
elif grep -qi rocky /etc/redhat-release
then
# Rocky Linux
diff -aruN eth-fast-fabric-11.1.0.1/update_eth_spec.sh eth-fast-fabric-11.1.0.1.alma/update_eth_spec.sh
--- eth-fast-fabric-11.1.0.1/update_eth_spec.sh 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/update_eth_spec.sh 2022-02-17 10:25:37.000000000 +0300
@@ -48,7 +48,7 @@
source ./OpenIb_Host/ff_filegroups.sh
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" ]
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" ]
then
# __RPM_REQ_BASIC -
sed -i "s/__RPM_REQ_BASIC1/expect%{?_isa}, tcl%{?_isa}, libibverbs-utils%{?_isa}, librdmacm-utils%{?_isa}, net-snmp-utils%{?_isa}/g" eth-tools.spec

View File

@ -1,11 +1,15 @@
Name: eth-tools
Version: 11.1.0.1
Release: 5%{?dist}
Release: 5%{?dist}.alma
Summary: Intel Ethernet Fabric Suite basic tools and libraries for fabric management
License: BSD
Url: https://github.com/intel/eth-fast-fabric
Source: %url/archive/%{version_no_tilde}/eth-fast-fabric-%{version_no_tilde}.tar.gz
# AlmaLinux patches
Patch0: eth-fast-fabric-11-almalinux_support.patch
ExclusiveArch: x86_64
# The Intel(R) Ethernet Fabric Suite product line is only available on x86_64 platforms at this time.
@ -40,7 +44,7 @@ Requires: perl cronie
Contains tools for managing fabric on a management node.
%prep
%autosetup -n eth-fast-fabric-%{version_no_tilde}
%autosetup -n eth-fast-fabric-%{version_no_tilde} -p 1
%build
cd OpenIb_Host
@ -85,6 +89,9 @@ BUILDDIR=%{_builddir} DESTDIR=%{buildroot} LIBDIR=%{_prefix}/lib DSAP_LIBDIR=%{_
%changelog
* Wed May 18 2022 Eduard Abdullin <eabdullin@almalinux.org> - 1:11.1.0.1-5.alma
- Add AlmaLinux support
* Tue Nov 09 2021 Honggang Li <honli@redhat.com> - 1:11.1.0.1-5
- Update to upstream release 11.1.0.1
- Fix annocheck issues