AlmaLinux changes

This commit is contained in:
eabdullin 2021-11-17 14:55:18 +03:00
parent c8a646759d
commit 6dcd14c7ee
2 changed files with 124 additions and 2 deletions

View File

@ -0,0 +1,118 @@
diff -Naur eth-fast-fabric-11.0.0.0/CommonInstall/util_init.pl eth-fast-fabric-11.0.0.0.alma/CommonInstall/util_init.pl
--- eth-fast-fabric-11.0.0.0/CommonInstall/util_init.pl 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/CommonInstall/util_init.pl 2021-10-09 19:45:35.929110144 +0000
@@ -299,6 +299,8 @@
$CUR_DISTRO_VENDOR = "redhat";
} elsif ( -s "/etc/centos-release" ) {
$CUR_DISTRO_VENDOR = "redhat";
+ } elsif ( -s "/etc/almalinux-release" ) {
+ $CUR_DISTRO_VENDOR = "redhat";
} elsif ( -s "/etc/UnitedLinux-release" ) {
$CUR_DISTRO_VENDOR = "UnitedLinux";
$NETWORK_CONF_DIR = "/etc/sysconfig/network";
@@ -315,12 +317,14 @@
} elsif ( -e $os_release_file) {
my %distroVendor = (
"rhel" => "redhat",
+ "almalinux" => "redhat",
"centos" => "redhat",
"sles" => "SuSE",
"sle_hpc" => "SuSE"
);
my %network_conf_dir = (
"rhel" => $NETWORK_CONF_DIR,
+ "almalinux" => $NETWORK_CONF_DIR,
"centos" => $NETWORK_CONF_DIR,
"sles" => "/etc/sysconfig/network",
"sle_hpc" => "/etc/sysconfig/network"
@@ -351,6 +355,8 @@
$NETWORK_CONF_DIR = "/etc/sysconfig/network";
} elsif ($CUR_DISTRO_VENDOR eq "centos") {
$CUR_DISTRO_VENDOR = "redhat";
+ } elsif ($CUR_DISTRO_VENDOR eq "almalinux") {
+ $CUR_DISTRO_VENDOR = "redhat";
}
}
if ( $CUR_DISTRO_VENDOR eq "SuSE" )
diff -Naur eth-fast-fabric-11.0.0.0/get_id_and_versionid.sh eth-fast-fabric-11.0.0.0.alma/get_id_and_versionid.sh
--- eth-fast-fabric-11.0.0.0/get_id_and_versionid.sh 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/get_id_and_versionid.sh 2021-10-09 19:40:49.431690828 +0000
@@ -29,6 +29,9 @@
elif [ $rval = 'centos' ]
then
rval=redhat
+ elif [ $rval = 'almalinux' ]
+ then
+ rval=redhat
elif [ $rval != 'os' ]
then
break
@@ -67,6 +70,10 @@
then
# CentOS
rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
+ elif grep -qi almalinux /etc/redhat-release
+ then
+ # AlmaLinux
+ rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
elif grep -qi scientific /etc/redhat-release
then
# Scientific Linux.
diff -Naur eth-fast-fabric-11.0.0.0/MakeTools/funcs-ext.sh eth-fast-fabric-11.0.0.0.alma/MakeTools/funcs-ext.sh
--- eth-fast-fabric-11.0.0.0/MakeTools/funcs-ext.sh 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/MakeTools/funcs-ext.sh 2021-10-09 19:42:39.018528761 +0000
@@ -725,6 +725,9 @@
centos)
rval=redhat
;;
+ almalinux)
+ rval=redhat
+ ;;
fedora)
rval=redhat
;;
@@ -756,6 +759,9 @@
elif [ $rval = 'centos' ]
then
rval=redhat
+ elif [ $rval = 'almalinux' ]
+ then
+ rval=redhat
elif [ $rval != 'os' ]
then
break
@@ -830,6 +836,10 @@
then
# CentOS
rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
+ elif grep -qi almalinux /etc/redhat-release
+ then
+ # AlmaLinux
+ rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
elif grep -qi scientific /etc/redhat-release
then
# Scientific Linux.
diff -Naur eth-fast-fabric-11.0.0.0/OpenIb_Host/update_mpi_spec.sh eth-fast-fabric-11.0.0.0.alma/OpenIb_Host/update_mpi_spec.sh
--- eth-fast-fabric-11.0.0.0/OpenIb_Host/update_mpi_spec.sh 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/OpenIb_Host/update_mpi_spec.sh 2021-10-09 19:41:22.127537540 +0000
@@ -33,7 +33,7 @@
id=$(./get_id_and_versionid.sh | cut -f1 -d' ')
versionid=$(./get_id_and_versionid.sh | cut -f2 -d' ')
-if [ "$id" = "rhel" -o "$id" = "centos" ]
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "almalinux" ]
then
GE_8_0=$(echo "$versionid >= 8.0" | bc)
sed -i "s/__RPM_REQ/Requires: openblas-devel/" mpi-apps.spec
diff -Naur eth-fast-fabric-11.0.0.0/update_eth_spec.sh eth-fast-fabric-11.0.0.0.alma/update_eth_spec.sh
--- eth-fast-fabric-11.0.0.0/update_eth_spec.sh 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/update_eth_spec.sh 2021-10-09 19:36:30.364981868 +0000
@@ -48,7 +48,7 @@
source ./OpenIb_Host/ff_filegroups.sh
-if [ "$id" = "rhel" -o "$id" = "centos" ]
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "almalinux" ]
then
# __RPM_REQ_BASIC -
sed -i "s/__RPM_REQ_BASIC1/expect%{?_isa}, tcl%{?_isa}, libibverbs-utils%{?_isa}, librdmacm-utils%{?_isa}, net-snmp-utils%{?_isa}/g" eth-tools.spec

View File

@ -1,11 +1,12 @@
Name: eth-tools
Version: 11.0.0.0
Release: 164%{?dist}
Release: 164%{?dist}.alma
Summary: Intel Ethernet Fabric Suite basic tools and libraries for fabric management
License: BSD
Url: https://github.com/intel/eth-fast-fabric
Source: %url/archive/%{version}/eth-fast-fabric-%{version}.tar.gz
Patch0: eth-fast-fabric-11-almalinux_support.patch
ExclusiveArch: x86_64
# The Intel(R) Ethernet Fabric Suite product line is only available on x86_64 platforms at this time.
@ -34,7 +35,7 @@ Requires: cronie
Contains tools for managing fabric on a management node.
%prep
%autosetup -n eth-fast-fabric-%{version}
%autosetup -n eth-fast-fabric-%{version} -p 1
%build
cd OpenIb_Host
@ -78,6 +79,9 @@ BUILDDIR=%{_builddir} DESTDIR=%{buildroot} LIBDIR=%{_prefix}/lib DSAP_LIBDIR=%{_
%changelog
* Sat Oct 09 2021 Andrew Lukoshko <alukoshko@almalinux.org> - 11.0.0.0-164.alma
- Add AlmaLinux support
* Thu Jul 08 2021 Honggang Li <honli@redhat.com> - 11.0.0.0-164
- Add osci gating test for RHEL8
- Related: rhbz#1919015