Update almalinux support patch

This commit is contained in:
Эдуард Абдуллин 2022-02-17 10:29:24 +03:00
parent 7b1c5c31d0
commit 627c36bcac
1 changed files with 57 additions and 56 deletions

View File

@ -1,66 +1,43 @@
diff -Naur eth-fast-fabric-11.0.0.0/CommonInstall/util_init.pl eth-fast-fabric-11.0.0.0.alma/CommonInstall/util_init.pl
--- eth-fast-fabric-11.0.0.0/CommonInstall/util_init.pl 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/CommonInstall/util_init.pl 2021-10-09 19:45:35.929110144 +0000
@@ -299,6 +299,8 @@
diff -aruN eth-fast-fabric-11.1.0.1/CommonInstall/util_init.pl eth-fast-fabric-11.1.0.1.alma/CommonInstall/util_init.pl
--- eth-fast-fabric-11.1.0.1/CommonInstall/util_init.pl 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/CommonInstall/util_init.pl 2022-02-17 10:21:19.000000000 +0300
@@ -305,6 +305,8 @@
$CUR_DISTRO_VENDOR = "redhat";
} elsif ( -s "/etc/centos-release" ) {
$CUR_DISTRO_VENDOR = "redhat";
+ } elsif ( -s "/etc/almalinux-release" ) {
+ $CUR_DISTRO_VENDOR = "redhat";
} elsif ( -s "/etc/rocky-release" ) {
$CUR_DISTRO_VENDOR = "redhat";
} elsif ( -s "/etc/UnitedLinux-release" ) {
$CUR_DISTRO_VENDOR = "UnitedLinux";
$NETWORK_CONF_DIR = "/etc/sysconfig/network";
@@ -315,12 +317,14 @@
@@ -323,6 +325,7 @@
} elsif ( -e $os_release_file) {
my %distroVendor = (
"rhel" => "redhat",
+ "almalinux" => "redhat",
"centos" => "redhat",
"rocky" => "redhat",
"sles" => "SuSE",
"sle_hpc" => "SuSE"
@@ -330,6 +333,7 @@
);
my %network_conf_dir = (
"rhel" => $NETWORK_CONF_DIR,
+ "almalinux" => $NETWORK_CONF_DIR,
"centos" => $NETWORK_CONF_DIR,
"rocky" => $NETWORK_CONF_DIR,
"sles" => "/etc/sysconfig/network",
"sle_hpc" => "/etc/sysconfig/network"
@@ -351,6 +355,8 @@
@@ -361,6 +365,8 @@
$NETWORK_CONF_DIR = "/etc/sysconfig/network";
} elsif ($CUR_DISTRO_VENDOR eq "centos") {
$CUR_DISTRO_VENDOR = "redhat";
+ } elsif ($CUR_DISTRO_VENDOR eq "almalinux") {
+ $CUR_DISTRO_VENDOR = "redhat";
} elsif ($CUR_DISTRO_VENDOR eq "rocky") {
$CUR_DISTRO_VENDOR = "redhat";
}
}
if ( $CUR_DISTRO_VENDOR eq "SuSE" )
diff -Naur eth-fast-fabric-11.0.0.0/get_id_and_versionid.sh eth-fast-fabric-11.0.0.0.alma/get_id_and_versionid.sh
--- eth-fast-fabric-11.0.0.0/get_id_and_versionid.sh 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/get_id_and_versionid.sh 2021-10-09 19:40:49.431690828 +0000
@@ -29,6 +29,9 @@
elif [ $rval = 'centos' ]
then
rval=redhat
+ elif [ $rval = 'almalinux' ]
+ then
+ rval=redhat
elif [ $rval != 'os' ]
then
break
@@ -67,6 +70,10 @@
then
# CentOS
rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
+ elif grep -qi almalinux /etc/redhat-release
+ then
+ # AlmaLinux
+ rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
elif grep -qi scientific /etc/redhat-release
then
# Scientific Linux.
diff -Naur eth-fast-fabric-11.0.0.0/MakeTools/funcs-ext.sh eth-fast-fabric-11.0.0.0.alma/MakeTools/funcs-ext.sh
--- eth-fast-fabric-11.0.0.0/MakeTools/funcs-ext.sh 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/MakeTools/funcs-ext.sh 2021-10-09 19:42:39.018528761 +0000
diff -aruN eth-fast-fabric-11.1.0.1/MakeTools/funcs-ext.sh eth-fast-fabric-11.1.0.1.alma/MakeTools/funcs-ext.sh
--- eth-fast-fabric-11.1.0.1/MakeTools/funcs-ext.sh 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/MakeTools/funcs-ext.sh 2022-02-17 10:23:59.000000000 +0300
@@ -725,6 +725,9 @@
centos)
rval=redhat
@ -68,20 +45,20 @@ diff -Naur eth-fast-fabric-11.0.0.0/MakeTools/funcs-ext.sh eth-fast-fabric-11.0.
+ almalinux)
+ rval=redhat
+ ;;
fedora)
rocky)
rval=redhat
;;
@@ -756,6 +759,9 @@
@@ -759,6 +762,9 @@
elif [ $rval = 'centos' ]
then
rval=redhat
+ elif [ $rval = 'almalinux' ]
+ then
+ rval=redhat
elif [ $rval != 'os' ]
elif [ $rval = 'rocky' ]
then
break
@@ -830,6 +836,10 @@
rval=redhat
@@ -836,6 +842,10 @@
then
# CentOS
rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
@ -89,30 +66,54 @@ diff -Naur eth-fast-fabric-11.0.0.0/MakeTools/funcs-ext.sh eth-fast-fabric-11.0.
+ then
+ # AlmaLinux
+ rval="ES"`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1\2/'`
elif grep -qi scientific /etc/redhat-release
elif grep -qi rocky /etc/redhat-release
then
# Scientific Linux.
diff -Naur eth-fast-fabric-11.0.0.0/OpenIb_Host/update_mpi_spec.sh eth-fast-fabric-11.0.0.0.alma/OpenIb_Host/update_mpi_spec.sh
--- eth-fast-fabric-11.0.0.0/OpenIb_Host/update_mpi_spec.sh 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/OpenIb_Host/update_mpi_spec.sh 2021-10-09 19:41:22.127537540 +0000
# Rocky Linux
diff -aruN eth-fast-fabric-11.1.0.1/OpenIb_Host/update_mpi_spec.sh eth-fast-fabric-11.1.0.1.alma/OpenIb_Host/update_mpi_spec.sh
--- eth-fast-fabric-11.1.0.1/OpenIb_Host/update_mpi_spec.sh 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/OpenIb_Host/update_mpi_spec.sh 2022-02-17 10:24:56.000000000 +0300
@@ -33,7 +33,7 @@
id=$(./get_id_and_versionid.sh | cut -f1 -d' ')
versionid=$(./get_id_and_versionid.sh | cut -f2 -d' ')
-if [ "$id" = "rhel" -o "$id" = "centos" ]
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "almalinux" ]
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" ]
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" ]
then
GE_8_0=$(echo "$versionid >= 8.0" | bc)
sed -i "s/__RPM_REQ/Requires: openblas-devel/" mpi-apps.spec
diff -Naur eth-fast-fabric-11.0.0.0/update_eth_spec.sh eth-fast-fabric-11.0.0.0.alma/update_eth_spec.sh
--- eth-fast-fabric-11.0.0.0/update_eth_spec.sh 2021-06-08 12:51:05.000000000 +0000
+++ eth-fast-fabric-11.0.0.0.alma/update_eth_spec.sh 2021-10-09 19:36:30.364981868 +0000
diff -aruN eth-fast-fabric-11.1.0.1/get_id_and_versionid.sh eth-fast-fabric-11.1.0.1.alma/get_id_and_versionid.sh
--- eth-fast-fabric-11.1.0.1/get_id_and_versionid.sh 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/get_id_and_versionid.sh 2022-02-17 10:22:28.000000000 +0300
@@ -29,6 +29,9 @@
elif [ $rval = 'centos' ]
then
rval=redhat
+ elif [ $rval = 'almalinux' ]
+ then
+ rval=redhat
elif [ $rval = 'rocky' ]
then
rval=redhat
@@ -70,6 +73,10 @@
then
# CentOS
rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
+ elif grep -qi almalinux /etc/redhat-release
+ then
+ # AlmaLinux
+ rval=`cat /etc/redhat-release | sed -r 's/^.+([[:digit:]])\.([[:digit:]]).+$/\1.\2/'`
elif grep -qi rocky /etc/redhat-release
then
# Rocky Linux
diff -aruN eth-fast-fabric-11.1.0.1/update_eth_spec.sh eth-fast-fabric-11.1.0.1.alma/update_eth_spec.sh
--- eth-fast-fabric-11.1.0.1/update_eth_spec.sh 2021-11-02 20:38:31.000000000 +0300
+++ eth-fast-fabric-11.1.0.1.alma/update_eth_spec.sh 2022-02-17 10:25:37.000000000 +0300
@@ -48,7 +48,7 @@
source ./OpenIb_Host/ff_filegroups.sh
-if [ "$id" = "rhel" -o "$id" = "centos" ]
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "almalinux" ]
-if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" ]
+if [ "$id" = "rhel" -o "$id" = "centos" -o "$id" = "rocky" -o "$id" = "almalinux" ]
then
# __RPM_REQ_BASIC -
sed -i "s/__RPM_REQ_BASIC1/expect%{?_isa}, tcl%{?_isa}, libibverbs-utils%{?_isa}, librdmacm-utils%{?_isa}, net-snmp-utils%{?_isa}/g" eth-tools.spec