esc/esc-1.1.0-fix18.patch
2014-04-17 17:27:32 -07:00

83 lines
3.4 KiB
Diff

diff -up ./esc/src/app/xpcom/Makefile.sdk.fix18 ./esc/src/app/xpcom/Makefile.sdk
--- ./esc/src/app/xpcom/Makefile.sdk.fix18 2014-04-17 11:34:54.889316425 -0700
+++ ./esc/src/app/xpcom/Makefile.sdk 2014-04-17 11:39:32.903840765 -0700
@@ -113,7 +113,7 @@ ifeq ($(OS_ARCH),Linux)
CPPFLAGS += -g -fno-rtti \
-DXPCOM_GLUE_USE_NSPR -fno-exceptions \
-fshort-wchar -fPIC -std=gnu++0x
-GECKO_LD_LIBS=-L$(GECKO_SDK_PATH)/lib -lnssutil3 -lnss3 -lcrmf -lssl3 -lsmime3 -lplds4 -lplc4 -lnspr4 -lpthread -ldl -L$(GECKO_SDK_PATH)/lib -lxpcomglue_s -lxpcom
+GECKO_LD_LIBS=-L$(GECKO_SDK_PATH)/lib -lnssutil3 -lnss3 -lcrmf -lssl3 -lsmime3 -lplds4 -lplc4 -lnspr4 -lpthread -ldl -L$(GECKO_SDK_PATH)/lib -lxpcomglue_s
endif
ifeq ($(OS_ARCH),WINNT)
@@ -127,7 +127,7 @@ endif
# #include "mozilla-config.h" to each of your .cpp files.
#GECKO_CONFIG_INCLUDE = -include mozilla-config.h
-GECKO_DEFINES = -DXPCOM_GLUE -DMOZILLA_CLIENT
+GECKO_DEFINES = -DMOZILLA_CLIENT
ifdef ESC_VERSION
GECKO_DEFINES += -DESC_VERSION=$(ESC_VERSION)
diff -up ./esc/src/app/xpcom/rhCoolKey.h.fix18 ./esc/src/app/xpcom/rhCoolKey.h
--- ./esc/src/app/xpcom/rhCoolKey.h.fix18 2014-04-17 15:48:24.466170548 -0700
+++ ./esc/src/app/xpcom/rhCoolKey.h 2014-04-17 15:49:25.319409778 -0700
@@ -17,7 +17,7 @@
#ifndef RH_COOLKEY_H
#define RH_COOLKEY_H
-
+#include <mozilla/Char16.h>
#include "rhICoolKey.h"
/*#include "nsIGenericFactory.h" */
#include "mozilla/ModuleUtils.h"
diff -up ./esc/src/app/xpcom/tray/Makefile.sdk.fix18 ./esc/src/app/xpcom/tray/Makefile.sdk
--- ./esc/src/app/xpcom/tray/Makefile.sdk.fix18 2014-04-17 11:24:58.080777558 -0700
+++ ./esc/src/app/xpcom/tray/Makefile.sdk 2014-04-17 11:34:28.394647654 -0700
@@ -167,7 +167,7 @@ endif
# #include "mozilla-config.h" to each of your .cpp files.
#GECKO_CONFIG_INCLUDE = -include mozilla-config.h
-GECKO_DEFINES = -DMOZILLA_CLIENT -DXPCOM_GLUE
+GECKO_DEFINES = -DMOZILLA_CLIENT
NSS_INCLUDE = /usr/include/nss3
NSPR_INCLUDE = /usr/include/nspr4
diff -up ./esc/src/app/xpcom/tray/rhTray.h.fix18 ./esc/src/app/xpcom/tray/rhTray.h
--- ./esc/src/app/xpcom/tray/rhTray.h.fix18 2014-04-17 11:04:33.578085948 -0700
+++ ./esc/src/app/xpcom/tray/rhTray.h 2014-04-17 11:05:10.798620628 -0700
@@ -17,7 +17,7 @@
#ifndef RH_TRAY_H
#define RH_TRAY_H
-
+#include <mozilla/Char16.h>
#include "rhITray.h"
//#include "nsIGenericFactory.h"
//#include mozilla/ModuleUtils.h
diff -up ./esc/src/app/xul/esc/application.ini.fix18 ./esc/src/app/xul/esc/application.ini
--- ./esc/src/app/xul/esc/application.ini.fix18 2014-04-17 15:35:13.854054559 -0700
+++ ./esc/src/app/xul/esc/application.ini 2014-04-17 15:35:45.278661698 -0700
@@ -25,11 +25,11 @@ Vendor=RedHat
Name=ESC
;
; This field specifies your application's version. This field is optional.
-Version=1.1.0-19
+Version=1.1.0-23
;
; This field specifies your application's build ID (timestamp). This field is
; required.
-BuildID=0000001019
+BuildID=0000001023
;
; This ID is just an example. Every XUL app ought to have it's own unique ID.
; You can use the microsoft "guidgen" or "uuidgen" tools, or go on
@@ -47,6 +47,6 @@ MinVersion=6.0.0
; application requires. It should be specified if your application uses
; unfrozen interfaces. Specifying 1.8 matches all releases with a version
; prefixed by 1.8 (e.g., 1.8a4, 1.8b, 1.8.2).
-MaxVersion=22.0.0
+MaxVersion=50.0.0
[Shell]