127 lines
4.3 KiB
Diff
127 lines
4.3 KiB
Diff
diff -up ./esc/coreconf/Linux3.9.mk.fix17 ./esc/coreconf/Linux3.9.mk
|
|
--- ./esc/coreconf/Linux3.9.mk.fix17 2013-06-17 18:52:29.341000000 -0400
|
|
+++ ./esc/coreconf/Linux3.9.mk 2013-06-17 18:52:48.988000000 -0400
|
|
@@ -0,0 +1,35 @@
|
|
+# BEGIN COPYRIGHT BLOCK
|
|
+# This Program is free software; you can redistribute it and/or modify it under
|
|
+# the terms of the GNU General Public License as published by the Free Software
|
|
+# Foundation; version 2 of the License.
|
|
+#
|
|
+# This Program is distributed in the hope that it will be useful, but WITHOUT
|
|
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
|
|
+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
|
|
+#
|
|
+# You should have received a copy of the GNU General Public License along with
|
|
+# this Program; if not, write to the Free Software Foundation, Inc., 59 Temple
|
|
+# Place, Suite 330, Boston, MA 02111-1307 USA.
|
|
+#
|
|
+# Copyright (C) 2005 Red Hat, Inc.
|
|
+# All rights reserved.
|
|
+# END COPYRIGHT BLOCK
|
|
+
|
|
+#
|
|
+# Config stuff for Linux 3.9 (ELF)
|
|
+#
|
|
+
|
|
+include $(CORE_DEPTH)/coreconf/Linux.mk
|
|
+
|
|
+OS_REL_CFLAGS += -DLINUX2_1
|
|
+MKSHLIB = $(CC) -shared -Wl,-soname -Wl,$(@:$(OBJDIR)/%.so=%.so)
|
|
+ifdef BUILD_OPT
|
|
+ OPTIMIZER = -O2
|
|
+endif
|
|
+
|
|
+ifdef MAPFILE
|
|
+ MKSHLIB += -Wl,--version-script,$(MAPFILE)
|
|
+endif
|
|
+PROCESS_MAP_FILE = grep -v ';-' $(LIBRARY_NAME).def | \
|
|
+ sed -e 's,;+,,' -e 's; DATA ;;' -e 's,;;,,' -e 's,;.*,;,' > $@
|
|
+
|
|
diff -up ./esc/src/app/xpcom/rhCoolKey.cpp.fix17 ./esc/src/app/xpcom/rhCoolKey.cpp
|
|
--- ./esc/src/app/xpcom/rhCoolKey.cpp.fix17 2013-06-17 18:48:27.263000000 -0400
|
|
+++ ./esc/src/app/xpcom/rhCoolKey.cpp 2013-06-17 18:48:27.328000000 -0400
|
|
@@ -1383,7 +1383,7 @@ NS_IMETHODIMP rhCoolKey::GetCoolKeyGetAp
|
|
|
|
*_retval = ver;
|
|
|
|
- return S_OK;
|
|
+ return NS_OK;
|
|
}
|
|
|
|
/* boolean rhCoolKeyIsEnrolled (in unsigned long aKeyType, in string aKeyID); */
|
|
diff -up ./esc/src/app/xpcom/tray/rhLinuxTray.cpp.fix17 ./esc/src/app/xpcom/tray/rhLinuxTray.cpp
|
|
--- ./esc/src/app/xpcom/tray/rhLinuxTray.cpp.fix17 2013-06-17 18:48:27.267000000 -0400
|
|
+++ ./esc/src/app/xpcom/tray/rhLinuxTray.cpp 2013-06-17 18:48:27.329000000 -0400
|
|
@@ -152,7 +152,10 @@ NS_IMETHODIMP rhTray::Unsetwindnotifycal
|
|
NS_IMETHODIMP rhTray::Add(nsIBaseWindow *aWindow)
|
|
{
|
|
char tBuff[56];
|
|
- NS_ENSURE_ARG(aWindow);
|
|
+
|
|
+ if ( aWindow == NULL) {
|
|
+ return NS_ERROR_FAILURE;
|
|
+ }
|
|
|
|
PR_LOG( trayLog, PR_LOG_DEBUG, ("%s rhTray::Add %p \n",GetTStamp(tBuff,56),aWindow));
|
|
HRESULT res = Initialize();
|
|
@@ -509,7 +512,7 @@ HRESULT rhTray::AddListener(nsIBaseWindo
|
|
nsresult rv;
|
|
|
|
PR_LOG( trayLog, PR_LOG_DEBUG, ("%s rhTray::AddListener %p \n",GetTStamp(tBuff,56),aWindow));
|
|
- NS_ENSURE_ARG(aWindow);
|
|
+ //NS_ENSURE_ARG(aWindow);
|
|
|
|
nativeWindow aNativeWindow;
|
|
rv = aWindow->GetParentNativeWindow( &aNativeWindow );
|
|
@@ -635,13 +638,13 @@ NS_IMETHODIMP rhTray::Setmenuitemtext(PR
|
|
PR_LOG( trayLog, PR_LOG_DEBUG, ("%s rhTray::Setmenuitemtext: index: %d text %s. \n",GetTStamp(tBuff,56),aIndex,aText));
|
|
|
|
if(!aText)
|
|
- return S_OK;
|
|
+ return NS_OK;
|
|
|
|
if(!mIconMenu)
|
|
- return S_OK;
|
|
+ return NS_OK;
|
|
|
|
if(aIndex < 0 || aIndex > 10)
|
|
- return S_OK;
|
|
+ return NS_OK;
|
|
|
|
GList *iterate = NULL;
|
|
|
|
@@ -670,7 +673,7 @@ NS_IMETHODIMP rhTray::Setmenuitemtext(PR
|
|
i++;
|
|
}
|
|
|
|
- return S_OK;
|
|
+ return NS_OK;
|
|
}
|
|
|
|
//rhTrayWindNotify methods
|
|
diff -up ./esc/src/app/xul/esc/application.ini.fix17 ./esc/src/app/xul/esc/application.ini
|
|
--- ./esc/src/app/xul/esc/application.ini.fix17 2013-06-17 18:48:27.243000000 -0400
|
|
+++ ./esc/src/app/xul/esc/application.ini 2013-06-17 18:48:27.330000000 -0400
|
|
@@ -25,11 +25,11 @@ Vendor=RedHat
|
|
Name=ESC
|
|
;
|
|
; This field specifies your application's version. This field is optional.
|
|
-Version=1.1.0-16
|
|
+Version=1.1.0-19
|
|
;
|
|
; This field specifies your application's build ID (timestamp). This field is
|
|
; required.
|
|
-BuildID=0000001017
|
|
+BuildID=0000001019
|
|
;
|
|
; This ID is just an example. Every XUL app ought to have it's own unique ID.
|
|
; You can use the microsoft "guidgen" or "uuidgen" tools, or go on
|
|
@@ -47,6 +47,6 @@ MinVersion=6.0.0
|
|
; application requires. It should be specified if your application uses
|
|
; unfrozen interfaces. Specifying 1.8 matches all releases with a version
|
|
; prefixed by 1.8 (e.g., 1.8a4, 1.8b, 1.8.2).
|
|
-MaxVersion=20.0.0
|
|
+MaxVersion=22.0.0
|
|
|
|
[Shell]
|