auto-import esc-1.0.1-2 on branch devel from esc-1.0.1-2.src.rpm
This commit is contained in:
parent
5e09c5bd40
commit
bc00a4f7a7
21
esc
21
esc
@ -1,4 +1,21 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# BEGIN COPYRIGHT BLOCK
|
||||
# This Program is free software; you can redistribute it and/or modify it under
|
||||
# the terms of the GNU General Public License as published by the Free Software
|
||||
# Foundation; version 2 of the License.
|
||||
#
|
||||
# This Program is distributed in the hope that it will be useful, but WITHOUT
|
||||
# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
|
||||
# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License along with
|
||||
# this Program; if not, write to the Free Software Foundation, Inc., 59 Temple
|
||||
# Place, Suite 330, Boston, MA 02111-1307 USA.
|
||||
#
|
||||
# Copyright (C) 2005 Red Hat, Inc.
|
||||
# All rights reserved.
|
||||
# END COPYRIGHT BLOCK
|
||||
|
||||
ESC_PROFILE_BASE=~/.redhat/esc
|
||||
ESC_LOG_FILE=esc.log
|
||||
@ -8,10 +25,6 @@ ESC_BIN_PATH=/usr/bin
|
||||
ESC_EXEC=esc
|
||||
ESCD_EXEC=escd
|
||||
|
||||
LD_LIBRARY_PATH=$ESC_PATH/xulrunner:$ESC_PATH/xulrunner/components:$ESC_PATH/xulrunner/plugins
|
||||
|
||||
export LD_LIBRARY_PATH
|
||||
|
||||
ESC_BIN=$ESC_PATH/xulrunner/xulrunner-bin
|
||||
ESCD_BIN=./$ESCD_EXEC
|
||||
|
||||
|
37
esc-1.0.1-admin-row-update.patch
Normal file
37
esc-1.0.1-admin-row-update.patch
Normal file
@ -0,0 +1,37 @@
|
||||
--- ./esc/src/app/xul/esc/chrome/content/esc/ESC.js.fix3 2007-04-03 11:00:47.000000000 -0700
|
||||
+++ ./esc/src/app/xul/esc/chrome/content/esc/ESC.js 2007-04-03 11:00:51.000000000 -0700
|
||||
@@ -2249,6 +2249,7 @@
|
||||
}
|
||||
function UpdateAdminListRow( keyType, keyID)
|
||||
{
|
||||
+
|
||||
if(!gAdminPage)
|
||||
return;
|
||||
|
||||
@@ -2527,6 +2528,7 @@
|
||||
{
|
||||
recordMessage("EnrollCoolKey failed.");
|
||||
}
|
||||
+
|
||||
if(gAdminPage)
|
||||
{
|
||||
UpdateAdminListRow(keyType,keyID);
|
||||
@@ -3778,11 +3780,14 @@
|
||||
UpdateEnrollmentArea(keyType,keyID,1);
|
||||
}
|
||||
|
||||
- if(gAdminPage)
|
||||
+
|
||||
+ var adminWnd = IsPageWindowPresent(ADMIN_WINDOW);
|
||||
+
|
||||
+ if(adminWnd)
|
||||
{
|
||||
- SelectRowByKeyID(keyType, keyID);
|
||||
- UpdateAdminListRow(keyType,keyID);
|
||||
- UpdateAdminKeyDetailsArea(keyType,keyID);
|
||||
+ adminWnd.SelectRowByKeyID(keyType, keyID);
|
||||
+ adminWnd.UpdateAdminListRow(keyType,keyID);
|
||||
+ adminWnd.UpdateAdminKeyDetailsArea(keyType,keyID);
|
||||
}
|
||||
}
|
||||
|
86
esc.spec
86
esc.spec
@ -1,6 +1,6 @@
|
||||
Name: esc
|
||||
Version: 1.0.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Enterprise Security Client Smart Card Client
|
||||
License: GPL
|
||||
URL: http://directory.fedora.redhat.com/wiki/CoolKey
|
||||
@ -8,40 +8,21 @@ Group: Applications/Internet
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
#Patch1: firefox-1.5.0.1-dumpstack.patch
|
||||
#Patch2: xulrunner-1.8.0.1-coreconf.patch
|
||||
Patch1: firefox-1.5-with-system-nss.patch
|
||||
Patch2: firefox-1.1-nss-system-nspr.patch
|
||||
#Patch5: esc-1.0.0-xul-sys-nss-nspr.patch
|
||||
#Patch6: esc-1.0.0-ui-enhance.patch
|
||||
#Patch7: esc-1.0.0-notify-icon-fixes.patch
|
||||
#Patch8: esc-1.0.0-strings-fix.patch
|
||||
#Patch9: esc-rhel4-nss-nspr.patch
|
||||
Patch3: esc-xulrunner-lin-64.patch
|
||||
Patch4: esc-rhel4-cool-build.patch
|
||||
#Patch11: esc-1.0.0.strings-1-fix.patch
|
||||
#Patch12: esc-1.0.0-ui-enhance-1.patch
|
||||
#Patch13: esc-1.0.0-pw-reset-fix.patch
|
||||
#Patch14: esc-1.0.0-escd.patch
|
||||
#Patch15: esc-1.0.0-escd1.patch
|
||||
#Patch16: esc-1.0.0-escd2.patch
|
||||
#Patch17: esc-1.0.0-build-fix.patch
|
||||
#Patch18: esc-1.0.0-diag-fix.patch
|
||||
#Patch19: esc-1.0.0-mac-win-fix.patch
|
||||
#Patch20: esc-1.0.0-mac-win-fix1.patch
|
||||
#Patch21: esc-1.0.0-mac-win-fix2.patch
|
||||
|
||||
|
||||
Patch3: esc-1.0.1-admin-row-update.patch
|
||||
|
||||
BuildRequires: doxygen fontconfig-devel freetype-devel >= 2.1
|
||||
BuildRequires: glib2-devel libIDL-devel atk-devel gtk2-devel libjpeg-devel
|
||||
BuildRequires: pango-devel libpng-devel pkgconfig zlib-devel
|
||||
BuildRequires: mozilla-nspr-devel mozilla-nss-devel
|
||||
#BuildRequires: autoconf213
|
||||
BuildRequires: nspr-devel nss-devel
|
||||
BuildRequires: autoconf213 libX11-devel libXt-devel
|
||||
|
||||
BuildRequires: pcsc-lite-devel coolkey-devel
|
||||
BuildRequires: desktop-file-utils zip binutils
|
||||
Requires: pcsc-lite ifd-egate coolkey mozilla-nss mozilla-nspr
|
||||
BuildRequires: desktop-file-utils zip binutils libnotify-devel
|
||||
BuildRequires: dbus-devel
|
||||
Requires: pcsc-lite ifd-egate coolkey nss nspr
|
||||
Requires: zip dbus >= 0.90 libnotify >= 0.4.2
|
||||
|
||||
# 390 does not have coolkey or smartCards
|
||||
# Xulrunner won't compile on ppc64 right now.
|
||||
@ -78,13 +59,10 @@ cryptographic smartcards.
|
||||
|
||||
%setup -q -c -n %{escname}
|
||||
|
||||
#patch esc
|
||||
#Perform esc patching
|
||||
|
||||
%ifarch x86_64 ppc64 ia64
|
||||
%patch3 -p1 -b .fix1
|
||||
%endif
|
||||
%patch3 -p1 -b .fix3
|
||||
|
||||
%patch4 -p1 -b .fix2
|
||||
|
||||
#Unpack xulrunner where esc expects it to be.
|
||||
|
||||
@ -99,12 +77,7 @@ cd mozilla
|
||||
|
||||
%build
|
||||
|
||||
MOZ_OFFSET=mozilla-1.7.3
|
||||
export MOZ_OFFSET
|
||||
|
||||
%ifarch x86_64 ppc64 ia64
|
||||
MOZ_OFFSET=mozilla-1.7.12
|
||||
export MOZ_OFFSET
|
||||
USE_64=1
|
||||
export USE_64
|
||||
%endif
|
||||
@ -113,7 +86,7 @@ export USE_64
|
||||
|
||||
cd ../..
|
||||
|
||||
make BUILD_OPT=1 NO_SYSTEM_NSS=1 ESC_VERSION=%{version}-%{release}
|
||||
make BUILD_OPT=1 HAVE_LIB_NOTIFY=1 ESC_VERSION=%{version}-%{release}
|
||||
|
||||
%install
|
||||
|
||||
@ -130,6 +103,7 @@ mkdir -p $RPM_BUILD_ROOT/%{docdir}
|
||||
sed -e 's;\$LIBDIR;'%{_libdir}';g' %{SOURCE1} > $RPM_BUILD_ROOT/%{escbindir}/%{name}
|
||||
|
||||
|
||||
|
||||
chmod 755 $RPM_BUILD_ROOT/%{escbindir}/esc
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT/%{escdir}
|
||||
@ -196,7 +170,41 @@ if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Sat Aug 22 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-8
|
||||
* Tue Apr 03 2007 Jack Magne <jmagne@redhat.com>- 1.0.0-2
|
||||
* Mon Mar 05 2007 Jack Magne <jmagne@redhat.com>- 1.0.0-1
|
||||
- Stability fixes
|
||||
* Fri Oct 27 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-19
|
||||
- More mac and win fixes.
|
||||
* Tue Oct 24 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-18
|
||||
-rebuilt on RHEL-5 branch
|
||||
* Sun Oct 4 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-17
|
||||
- Diagnostics display fixes, Mac and Window fixes.
|
||||
|
||||
* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-16
|
||||
- rebuilt for unwind info generation, broken in gcc-4.1.1-21
|
||||
|
||||
* Fri Sep 22 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-15
|
||||
- Fix to the build version
|
||||
|
||||
* Fri Sep 22 2006 Jack Magne <jmagne@redhat.com>= 1.0.0-14
|
||||
- Fix to compile error in daemon
|
||||
|
||||
* Fri Sep 22 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-13
|
||||
- Fix to include the new esc daemon.
|
||||
|
||||
* Sat Sep 16 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-12
|
||||
- Fix for Password Reset and minor UI revision.
|
||||
|
||||
* Fri Sep 15 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-11
|
||||
- Further UI enhancement bug fixes
|
||||
|
||||
* Thu Sep 7 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-10
|
||||
- Further strings revisions.
|
||||
|
||||
* Wed Aug 30 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-9
|
||||
- Revision of the strings used in ESC.
|
||||
|
||||
* Sat Aug 27 2006 Jack Magne <jmagne@redhat.com>- 1.0.0-8
|
||||
- Fixes to get libnotify working properly on FC6 systems.
|
||||
|
||||
* Tue Aug 22 2006 Jack Magne <jmagne@redhat.com> - 1.0.0-7
|
||||
|
Loading…
Reference in New Issue
Block a user