Added a patch to correct the wrong elif preprocessor statement
This commit is contained in:
parent
3b03e394ee
commit
8aaee8dad8
14
esc-1.0.1-elif.patch
Normal file
14
esc-1.0.1-elif.patch
Normal file
@ -0,0 +1,14 @@
|
||||
Patch by Robert Scheck <robert@fedoraproject.org> for esc >= 1.0.1, that corrects
|
||||
the preprocessor conditional from empty (wrong) elif to else.
|
||||
|
||||
--- mozilla/toolkit/xre/nsAppRunner.cpp 2006-04-06 19:27:00.000000000 +0200
|
||||
+++ mozilla/toolkit/xre/nsAppRunner.cpp.elif 2009-04-14 05:35:25.000000000 +0200
|
||||
@@ -1157,7 +1157,7 @@
|
||||
if (NS_FAILED(rv))
|
||||
return rv;
|
||||
|
||||
-#elif
|
||||
+#else
|
||||
#error Oops, you need platform-specific code here
|
||||
#endif
|
||||
|
7
esc.spec
7
esc.spec
@ -1,6 +1,6 @@
|
||||
Name: esc
|
||||
Version: 1.0.1
|
||||
Release: 13%{?dist}
|
||||
Release: 14%{?dist}
|
||||
Summary: Enterprise Security Client Smart Card Client
|
||||
License: GPL+
|
||||
URL: http://directory.fedora.redhat.com/wiki/CoolKey
|
||||
@ -19,6 +19,7 @@ Patch8: esc-1.0.1-misc.patch
|
||||
Patch9: esc-1.0.1-nss-devel-fix.patch
|
||||
Patch10: firefox.secalg.patch
|
||||
Patch11: esc-1.0.1-xulrunner-sparc-fixes.patch
|
||||
Patch12: esc-1.0.1-elif.patch
|
||||
|
||||
BuildRequires: doxygen fontconfig-devel freetype-devel >= 2.1
|
||||
BuildRequires: glib2-devel libIDL-devel atk-devel gtk2-devel libjpeg-devel
|
||||
@ -92,6 +93,7 @@ cd mozilla
|
||||
%patch2 -p1 -b .fix2
|
||||
%patch10 -p1 -b .secalg
|
||||
%patch11 -p1 -b .sparc
|
||||
%patch12 -p1 -b .elif
|
||||
|
||||
%build
|
||||
|
||||
@ -201,6 +203,9 @@ if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Tue Apr 14 2009 Robert Scheck <robert@fedoraproject.org> - 1.0.1-14
|
||||
- Added a patch to correct the wrong elif preprocessor statement
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user