Adjust for new xulrunner and fix minor linking issue.
This commit is contained in:
parent
18478d0e6c
commit
7f5f9a72ec
76
esc-1.1.0-fix8.patch
Normal file
76
esc-1.1.0-fix8.patch
Normal file
@ -0,0 +1,76 @@
|
||||
diff -up ./esc/src/app/daemon/manifest.mn.fix8 ./esc/src/app/daemon/manifest.mn
|
||||
--- ./esc/src/app/daemon/manifest.mn.fix8 2010-04-15 16:27:07.232078448 -0700
|
||||
+++ ./esc/src/app/daemon/manifest.mn 2010-04-15 14:24:46.297068110 -0700
|
||||
@@ -37,7 +37,7 @@ DEFINES += $(shell pkg-config --cflags x
|
||||
CPPFLAGS += $(DEFINES) -g
|
||||
|
||||
LDFLAGS += -lstdc++ -L$(CORE_DIST)/$(OBJDIR)/lib -L$(XULRUNNER_LIBS_LDFLAGS) -lnss3 -lnspr4 -lssl3 -lckyapplet $(shell pkg-config --libs xft)
|
||||
-LDFLAGS += -lckymanager -lhttpchunked
|
||||
+LDFLAGS += -lckymanager -lhttpchunked -lm -lnss3 -lplc4 -lplds4
|
||||
# MODULE public and private header directories are implicitly REQUIRED.
|
||||
|
||||
CPPSRCS = \
|
||||
diff -up ./esc/src/app/xpcom/rhCoolKey.cpp.fix8 ./esc/src/app/xpcom/rhCoolKey.cpp
|
||||
--- ./esc/src/app/xpcom/rhCoolKey.cpp.fix8 2010-04-15 14:45:37.907068106 -0700
|
||||
+++ ./esc/src/app/xpcom/rhCoolKey.cpp 2010-04-15 14:46:23.392066709 -0700
|
||||
@@ -30,7 +30,7 @@
|
||||
#else
|
||||
#include "nsServiceManagerUtils.h"
|
||||
#endif
|
||||
-#include "pipnss/nsICertOverrideService.h"
|
||||
+#include "nsICertOverrideService.h"
|
||||
#include "nsIPrefBranch.h"
|
||||
#include "nsIPrefService.h"
|
||||
#include "nsCOMPtr.h"
|
||||
@@ -41,7 +41,7 @@
|
||||
#include "prlink.h"
|
||||
#include "prthread.h"
|
||||
#include "nscore.h"
|
||||
-#include "content/nsCopySupport.h"
|
||||
+#include "nsCopySupport.h"
|
||||
#include <vector>
|
||||
#include <string>
|
||||
#include <time.h>
|
||||
diff -up ./esc/src/app/xpcom/tray/rhLinuxTray.cpp.fix8 ./esc/src/app/xpcom/tray/rhLinuxTray.cpp
|
||||
--- ./esc/src/app/xpcom/tray/rhLinuxTray.cpp.fix8 2010-04-15 14:43:35.271068664 -0700
|
||||
+++ ./esc/src/app/xpcom/tray/rhLinuxTray.cpp 2010-04-15 14:43:48.685066431 -0700
|
||||
@@ -21,7 +21,7 @@
|
||||
#include "nsIGenericFactory.h"
|
||||
#include <prlog.h>
|
||||
#include "notifytray.h"
|
||||
-#include "intl/nsIStringBundle.h"
|
||||
+#include "nsIStringBundle.h"
|
||||
#include <gdk/gdkx.h>
|
||||
#include <stdlib.h>
|
||||
|
||||
diff -up ./esc/src/app/xpcom/tray/rhTray.h.fix8 ./esc/src/app/xpcom/tray/rhTray.h
|
||||
--- ./esc/src/app/xpcom/tray/rhTray.h.fix8 2010-04-15 14:44:38.565066710 -0700
|
||||
+++ ./esc/src/app/xpcom/tray/rhTray.h 2010-04-15 14:45:02.118067548 -0700
|
||||
@@ -23,8 +23,8 @@
|
||||
#include "nsEmbedString.h"
|
||||
#include <list>
|
||||
#include "nsCOMPtr.h"
|
||||
-#include "widget/nsIBaseWindow.h"
|
||||
-#include "widget/nsIWidget.h"
|
||||
+#include "nsIBaseWindow.h"
|
||||
+#include "nsIWidget.h"
|
||||
#include <time.h>
|
||||
|
||||
extern "C" {
|
||||
diff -up ./esc/src/app/xul/esc/application.ini.fix8 ./esc/src/app/xul/esc/application.ini
|
||||
--- ./esc/src/app/xul/esc/application.ini.fix8 2010-04-15 14:47:59.377066710 -0700
|
||||
+++ ./esc/src/app/xul/esc/application.ini 2010-04-15 14:51:07.476068385 -0700
|
||||
@@ -25,11 +25,11 @@ Vendor=RedHat
|
||||
Name=ESC
|
||||
;
|
||||
; This field specifies your application's version. This field is optional.
|
||||
-Version=1.1.0-9
|
||||
+Version=1.1.0-12
|
||||
;
|
||||
; This field specifies your application's build ID (timestamp). This field is
|
||||
; required.
|
||||
-BuildID=0000001011
|
||||
+BuildID=0000001012
|
||||
;
|
||||
; This ID is just an example. Every XUL app ought to have it's own unique ID.
|
||||
; You can use the microsoft "guidgen" or "uuidgen" tools, or go on
|
16
esc.spec
16
esc.spec
@ -1,6 +1,6 @@
|
||||
Name: esc
|
||||
Version: 1.1.0
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
Summary: Enterprise Security Client Smart Card Client
|
||||
License: GPL
|
||||
URL: http://directory.fedora.redhat.com/wiki/CoolKey
|
||||
@ -15,6 +15,7 @@ Patch4: esc-1.1.0-fix4.patch
|
||||
Patch5: esc-1.1.0-fix5.patch
|
||||
Patch6: esc-1.1.0-fix6.patch
|
||||
Patch7: esc-1.1.0-fix7.patch
|
||||
Patch8: esc-1.1.0-fix8.patch
|
||||
|
||||
BuildRequires: doxygen fontconfig-devel freetype-devel >= 2.1
|
||||
BuildRequires: glib2-devel libIDL-devel atk-devel gtk2-devel libjpeg-devel
|
||||
@ -26,7 +27,7 @@ BuildRequires: xulrunner xulrunner-devel
|
||||
BuildRequires: pcsc-lite-devel coolkey-devel
|
||||
BuildRequires: desktop-file-utils zip binutils libnotify-devel
|
||||
BuildRequires: dbus-devel
|
||||
Requires: pcsc-lite coolkey nss nspr
|
||||
Requires: pcsc-lite coolkey nss nspr
|
||||
Requires: zip dbus >= 0.90 libnotify >= 0.4.2
|
||||
Requires: xulrunner
|
||||
|
||||
@ -76,12 +77,13 @@ cryptographic smartcards.
|
||||
%patch5 -p1 -b .fix5
|
||||
%patch6 -p1 -b .fix6
|
||||
%patch7 -p1 -b .fix7
|
||||
%patch8 -p1 -b .fix8
|
||||
|
||||
%build
|
||||
|
||||
GECKO_SDK_PATH=%{_libdir}/xulrunner-sdk-1.9.1/sdk
|
||||
GECKO_BIN_PATH=%{_libdir}/xulrunner-1.9.1
|
||||
GECKO_INCLUDE_PATH=%{_includedir}/xulrunner-sdk-1.9.1
|
||||
GECKO_SDK_PATH=%{_libdir}/xulrunner-sdk-1.9.2/sdk
|
||||
GECKO_BIN_PATH=%{_libdir}/xulrunner-1.9.2
|
||||
GECKO_INCLUDE_PATH=%{_includedir}/xulrunner-sdk-1.9.2
|
||||
|
||||
%ifarch x86_64 ppc64 ia64
|
||||
USE_64=1
|
||||
@ -193,8 +195,8 @@ if [ -x %{_bindir}/gtk-update-icon-cache ]; then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Mon Apr 05 2010 Jack Magne <jmagne@redhat.com>= 1.1.0-11
|
||||
- No longer require ifd-egate
|
||||
* Thu Apr 15 2010 Jack Magne <jmagne@redhat.com>= 1.1.0-11
|
||||
- Adjust for new linking rules.
|
||||
* Tue Sep 15 2009 Jack Magne <jmagne@redhat.com>= 1.1.0-10
|
||||
- Pick up latest improvements.
|
||||
* Mon Jun 22 2009 Jack Magne <jmagne@redhat.com>= 1.1.0-9
|
||||
|
Loading…
Reference in New Issue
Block a user