fix sparc

This commit is contained in:
Tom Callaway 2008-09-30 17:41:02 +00:00
parent 042f1c3eda
commit 307ced634d
2 changed files with 77 additions and 4 deletions

View File

@ -0,0 +1,69 @@
--- ./configure.in.sparc 2008-09-30 13:15:07.000000000 -0400
+++ ./configure.in 2008-09-30 13:17:36.000000000 -0400
@@ -1079,7 +1079,11 @@ Alpha | alpha | ALPHA)
CPU_ARCH=Alpha
;;
-x86_64 | sparc | ppc | ia64)
+sun4u | sparc*)
+ CPU_ARCH=sparc
+ ;;
+
+x86_64 | ia64)
CPU_ARCH="$CPU_ARCH_TEST"
;;
esac
@@ -1117,7 +1121,11 @@ if test "$GNU_CC"; then
# -Wbad-function-cast - warns when casting a function to a new return type
# -Wconversion - complained when char's or short's were used a function args
# -Wshadow - removed because it generates more noise than help --pete
- _WARNINGS_CFLAGS="${_WARNINGS_CFLAGS} -Wall -W -Wno-unused -Wpointer-arith -Wcast-align"
+ _WARNINGS_CFLAGS="${_WARNINGS_CFLAGS} -Wall -W -Wno-unused -Wpointer-arith"
+ if test "$CPU_ARCH" != "ia64" && test "$CPU_ARCH" != "sparc"; then
+ # don't use -Wcast-align on ia64 or sparc, it's noisy on those platforms
+ _WARNINGS_CFLAGS="${_WARNINGS_CFLAGS} -Wcast-align"
+ fi
dnl Turn pedantic on but disable the warnings for long long
_PEDANTIC=1
@@ -1136,7 +1144,11 @@ fi
if test "$GNU_CXX"; then
# Turn on GNU specific features
- _WARNINGS_CXXFLAGS="${_WARNINGS_CXXFLAGS} -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor"
+ _WARNINGS_CXXFLAGS="${_WARNINGS_CXXFLAGS} -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor"
+ if test "$CPU_ARCH" != "ia64" && test "$CPU_ARCH" != "sparc"; then
+ # don't use -Wcast-align on ia64 or sparc, it's noisy on those platforms
+ _WARNINGS_CXXFLAGS="${_WARNINGS_CXXFLAGS} -Wcast-align"
+ fi
_DEFINES_CXXFLAGS='-DMOZILLA_CLIENT -include $(DEPTH)/mozilla-config.h'
_USE_CPP_INCLUDE_FLAG=1
--- ./modules/oji/public/nsIJVMPlugin.h.sparc 2008-09-30 13:13:01.000000000 -0400
+++ ./modules/oji/public/nsIJVMPlugin.h 2008-09-30 13:13:57.000000000 -0400
@@ -51,6 +51,7 @@
#include "nsISupports.h"
#include "nsIPrincipal.h"
#include "jni.h"
+#include "jstypes.h"
class nsISecureEnv;
@@ -90,7 +91,7 @@ public:
GetClassPath(const char* *result) = 0;
NS_IMETHOD
-#if PR_BYTES_PER_LONG == 8
+#if JS_BYTES_PER_LONG == 8 || JS_BYTES_PER_WORD == 8
GetJavaWrapper(JNIEnv* jenv, jlong obj, jobject *jobj) = 0;
#else
GetJavaWrapper(JNIEnv* jenv, jint obj, jobject *jobj) = 0;
@@ -114,7 +115,7 @@ public:
SpendTime(PRUint32 timeMillis) = 0;
NS_IMETHOD
-#if PR_BYTES_PER_LONG == 8
+#if JS_BYTES_PER_LONG == 8 || JS_BYTES_PER_WORD == 8
UnwrapJavaWrapper(JNIEnv* jenv, jobject jobj, jlong* obj) = 0;
#else
UnwrapJavaWrapper(JNIEnv* jenv, jobject jobj, jint* obj) = 0;

View File

@ -1,6 +1,6 @@
Name: esc
Version: 1.0.1
Release: 9%{?dist}
Release: 10%{?dist}
Summary: Enterprise Security Client Smart Card Client
License: GPL+
URL: http://directory.fedora.redhat.com/wiki/CoolKey
@ -18,6 +18,7 @@ Patch7: esc-1.0.1-lic-fix.patch
Patch8: esc-1.0.1-misc.patch
Patch9: esc-1.0.1-nss-devel-fix.patch
Patch10: firefox.secalg.patch
Patch11: esc-1.0.1-xulrunner-sparc-fixes.patch
BuildRequires: doxygen fontconfig-devel freetype-devel >= 2.1
BuildRequires: glib2-devel libIDL-devel atk-devel gtk2-devel libjpeg-devel
@ -90,10 +91,11 @@ cd mozilla
%patch1 -p1 -b .fix1
%patch2 -p1 -b .fix2
%patch10 -p1 -b .secalg
%patch11 -p1 -b .sparc
%build
%ifarch x86_64 ppc64 ia64
%ifarch x86_64 ppc64 ia64 sparc64
USE_64=1
export USE_64
%endif
@ -126,7 +128,7 @@ chmod 755 $RPM_BUILD_ROOT/%{escbindir}/esc
mkdir -p $RPM_BUILD_ROOT/%{escdir}
%ifarch x86_64 ppc64 ia64
%ifarch x86_64 ppc64 ia64 sparc64
USE_64=1
export USE_64
%endif
@ -193,13 +195,15 @@ if [ -x %{_bindir}/gtk-update-icon-cache ]; then
fi
%changelog
* Tue Sep 30 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.1-10
- fix esc for sparc/sparc64
* Wed Feb 13 2008 Jack Magne <jmagne@redhat.com>
- Fix xulrunner build problem.
* Fri Jan 18 2008 Jack Magne <jmagne@redhat.com>
- Fix tray icon menu issue #253248.
* Thu Aug 30 2007 Jack Magne <jmagne@redhat.com>
- License field change- 1.0.1-7
* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.1-6
- Rebuild for selinux ppc32 issue.