try to fix a deadlock
This commit is contained in:
parent
3bd49aecbb
commit
fa59f2f5f7
9
eog.spec
9
eog.spec
@ -14,7 +14,7 @@
|
||||
Summary: Eye of GNOME image viewer
|
||||
Name: eog
|
||||
Version: 2.23.6
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
URL: http://www.gnome.org
|
||||
Source: http://download.gnome.org/sources/eog/2.23/%{name}-%{version}.tar.bz2
|
||||
# needs to be redone
|
||||
@ -54,6 +54,9 @@ Requires(preun): GConf2
|
||||
Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
|
||||
Requires(postun): scrollkeeper
|
||||
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=547373
|
||||
Patch0: lockup.patch
|
||||
|
||||
%description
|
||||
Eye of GNOME (EOG) is an image viewer.
|
||||
|
||||
@ -75,6 +78,7 @@ This package allows you to develop plugins to extend EOG.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .lockup
|
||||
|
||||
echo "NoDisplay=true" >> data/eog.desktop.in
|
||||
# just in case
|
||||
@ -155,6 +159,9 @@ fi
|
||||
%{_datadir}/gtk-doc/html/eog
|
||||
|
||||
%changelog
|
||||
* Tue Aug 12 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.6-2
|
||||
- Add a possible fix for a deadlock
|
||||
|
||||
* Tue Aug 5 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.6-1
|
||||
- Update to 2.23.6
|
||||
|
||||
|
21
lockup.patch
Normal file
21
lockup.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up eog-2.23.6/src/main.c.lockup eog-2.23.6/src/main.c
|
||||
--- eog-2.23.6/src/main.c.lockup 2008-08-12 00:55:08.000000000 -0400
|
||||
+++ eog-2.23.6/src/main.c 2008-08-12 00:55:24.000000000 -0400
|
||||
@@ -215,6 +215,8 @@ main (int argc, char **argv)
|
||||
eog_thumbnail_init ();
|
||||
eog_plugin_engine_init ();
|
||||
|
||||
+ gdk_threads_enter ();
|
||||
+
|
||||
/* Add application specific icons to search path */
|
||||
gtk_icon_theme_append_search_path (gtk_icon_theme_get_default (),
|
||||
EOG_DATA_DIR G_DIR_SEPARATOR_S "icons");
|
||||
@@ -224,8 +226,6 @@ main (int argc, char **argv)
|
||||
|
||||
load_files ();
|
||||
|
||||
- gdk_threads_enter ();
|
||||
-
|
||||
gtk_main ();
|
||||
|
||||
gdk_threads_leave ();
|
Loading…
Reference in New Issue
Block a user