Use Portals for the "Open With" right-click option too
Fixes rhbz#1822912
This commit is contained in:
parent
d2c36d3d5b
commit
c95e70e418
5
eog.spec
5
eog.spec
@ -7,7 +7,7 @@
|
||||
|
||||
Name: eog
|
||||
Version: 3.36.1
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Eye of GNOME image viewer
|
||||
|
||||
# The GFDL has an "or later version" clause embedded inside the license.
|
||||
@ -112,6 +112,9 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/org.gnome.eog.deskto
|
||||
%{_datadir}/installed-tests/
|
||||
|
||||
%changelog
|
||||
* Tue Apr 14 2020 Felipe Borges <feborges@redhat.com> - 3.36.1-3
|
||||
- Also use Portals for the right-click "Open with" option
|
||||
|
||||
* Fri Apr 03 2020 Felipe Borges <feborges@redhat.com> - 3.36.1-2
|
||||
- Use Portals for "open with"
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From b1cd7fed6abbbee9b97df0d458a05a52915e4232 Mon Sep 17 00:00:00 2001
|
||||
From 5757ab6a8a0af67413f19602a388cb1c2b115676 Mon Sep 17 00:00:00 2001
|
||||
From: Felipe Borges <felipeborges@gnome.org>
|
||||
Date: Fri, 20 Dec 2019 13:53:14 +0100
|
||||
Subject: [PATCH] EogWindow: Use Portals for "Open With" when possible
|
||||
@ -12,11 +12,11 @@ the user to pick an appliation.
|
||||
Fixes #98
|
||||
---
|
||||
data/eog-gear-menu.ui | 9 +--
|
||||
data/popup-menus.ui | 2 -
|
||||
data/popup-menus.ui | 7 +-
|
||||
src/eog-util.c | 180 ++++++++++++++++++++++++++++++++++++++++++
|
||||
src/eog-util.h | 6 ++
|
||||
src/eog-window.c | 140 +++++++++++---------------------
|
||||
5 files changed, 237 insertions(+), 100 deletions(-)
|
||||
5 files changed, 240 insertions(+), 102 deletions(-)
|
||||
|
||||
diff --git a/data/eog-gear-menu.ui b/data/eog-gear-menu.ui
|
||||
index 1e9cb4a3..724156b7 100644
|
||||
@ -39,18 +39,24 @@ index 1e9cb4a3..724156b7 100644
|
||||
<section>
|
||||
<item>
|
||||
diff --git a/data/popup-menus.ui b/data/popup-menus.ui
|
||||
index aae780c0..1f19461b 100644
|
||||
index aae780c0..ee629d74 100644
|
||||
--- a/data/popup-menus.ui
|
||||
+++ b/data/popup-menus.ui
|
||||
@@ -4,8 +4,6 @@
|
||||
@@ -2,11 +2,10 @@
|
||||
<interface>
|
||||
<menu id="view-popup-menu">
|
||||
<section>
|
||||
<submenu>
|
||||
- <submenu>
|
||||
+ <item>
|
||||
<attribute name="label" translatable="yes">Open _with</attribute>
|
||||
- <link name="submenu" id="open-with-menu">
|
||||
- </link>
|
||||
</submenu>
|
||||
- </submenu>
|
||||
+ <attribute name="action">win.open-with</attribute>
|
||||
+ </item>
|
||||
</section>
|
||||
<section>
|
||||
<item>
|
||||
diff --git a/src/eog-util.c b/src/eog-util.c
|
||||
index a6828a58..3e253dc9 100644
|
||||
--- a/src/eog-util.c
|
||||
@ -507,5 +513,5 @@ index d6fc3834..75d7c138 100644
|
||||
|
||||
if (window->priv->fullscreen_popup != NULL) {
|
||||
--
|
||||
2.25.1
|
||||
2.26.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user