Prevent a crash when queueing a new draw (GNOME #665897)
This commit is contained in:
parent
e1ba33eba1
commit
3eff877875
@ -0,0 +1,27 @@
|
||||
From 8169e0ac6447ebeb1d1e809213ce82b814b62550 Mon Sep 17 00:00:00 2001
|
||||
From: Debarshi Ray <debarshir@gnome.org>
|
||||
Date: Thu, 7 Apr 2016 20:13:16 +0200
|
||||
Subject: [PATCH] EogScrollView: Prevent a crash when queueing a new draw
|
||||
|
||||
Fall out from 88c4f54eb9cee69b1eebef462df27f76119bec62
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=665897
|
||||
---
|
||||
src/eog-scroll-view.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/eog-scroll-view.c b/src/eog-scroll-view.c
|
||||
index 4539498fb57f..f85d9d22cd69 100644
|
||||
--- a/src/eog-scroll-view.c
|
||||
+++ b/src/eog-scroll-view.c
|
||||
@@ -1260,6 +1260,7 @@ static gboolean _hq_redraw_cb (gpointer user_data)
|
||||
priv->force_unfiltered = FALSE;
|
||||
gtk_widget_queue_draw (GTK_WIDGET (priv->display));
|
||||
|
||||
+ priv->hq_redraw_timeout_source = NULL;
|
||||
return G_SOURCE_REMOVE;
|
||||
}
|
||||
|
||||
--
|
||||
2.5.0
|
||||
|
9
eog.spec
9
eog.spec
@ -8,11 +8,14 @@
|
||||
Summary: Eye of GNOME image viewer
|
||||
Name: eog
|
||||
Version: 3.20.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
URL: https://wiki.gnome.org/Apps/EyeOfGnome
|
||||
#VCS: git:git://git.gnome.org/eog
|
||||
Source: http://download.gnome.org/sources/%{name}/3.20/%{name}-%{version}.tar.xz
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=665897
|
||||
Patch0: 0001-EogScrollView-Prevent-a-crash-when-queueing-a-new-dr.patch
|
||||
|
||||
# The GFDL has an "or later version" clause embedded inside the license.
|
||||
# There is no need to add the + here.
|
||||
License: GPLv2+ and GFDL
|
||||
@ -74,6 +77,7 @@ the functionality of the installed %{name} package.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure --enable-installed-tests
|
||||
@ -142,6 +146,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null || :
|
||||
%{_datadir}/installed-tests/
|
||||
|
||||
%changelog
|
||||
* Fri Apr 08 2016 Debarshi Ray <rishi@fedoraproject.org> - 3.20.0-2
|
||||
- Prevent a crash when queueing a new draw (GNOME #665897)
|
||||
|
||||
* Tue Mar 22 2016 Kalev Lember <klember@redhat.com> - 3.20.0-1
|
||||
- Update to 3.20.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user