Fix libX11 linking
This commit is contained in:
parent
b4b6e354a7
commit
39e4983707
32
0001-Fix-linking-with-LCMS-support-enabled.patch
Normal file
32
0001-Fix-linking-with-LCMS-support-enabled.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
From 42e4973f8de4c5e2a02687797d4fc7262e7649ed Mon Sep 17 00:00:00 2001
|
||||||
|
From: Bastien Nocera <hadess@hadess.net>
|
||||||
|
Date: Wed, 10 Feb 2010 16:28:46 +0000
|
||||||
|
Subject: [PATCH] Fix linking with LCMS support enabled
|
||||||
|
|
||||||
|
We use libX11 functions, so we need to link against them.
|
||||||
|
|
||||||
|
/usr/bin/ld: ./.libs/libeog.a(libeog_la-eog-window.o): undefined reference to symbol 'XFree'
|
||||||
|
/usr/bin/ld: note: 'XFree' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
|
||||||
|
/usr/lib64/libX11.so.6: could not read symbols: Invalid operation
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=609553
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index a120bc5..1e011ec 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -147,7 +147,7 @@ AM_CONDITIONAL([HAVE_EXIF], [test "x$have_exif" = "xyes"])
|
||||||
|
AC_ARG_WITH([cms], AC_HELP_STRING([--without-cms], [disable colour management support]))
|
||||||
|
have_lcms=no
|
||||||
|
if test x$with_cms != xno; then
|
||||||
|
- PKG_CHECK_MODULES(LCMS, lcms, have_lcms=yes, have_lcms=no)
|
||||||
|
+ PKG_CHECK_MODULES(LCMS, lcms x11, have_lcms=yes, have_lcms=no)
|
||||||
|
fi
|
||||||
|
if test "x$have_lcms" = "xyes"; then
|
||||||
|
AC_DEFINE(HAVE_LCMS, 1, [Little CMS Support.])
|
||||||
|
--
|
||||||
|
1.6.6
|
||||||
|
|
1
eog.spec
1
eog.spec
@ -15,7 +15,6 @@ Version: 2.29.90
|
|||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://projects.gnome.org/eog/
|
URL: http://projects.gnome.org/eog/
|
||||||
Source: http://download.gnome.org/sources/eog/2.29/%{name}-%{version}.tar.bz2
|
Source: http://download.gnome.org/sources/eog/2.29/%{name}-%{version}.tar.bz2
|
||||||
Patch0: libxml.patch
|
|
||||||
# The GFDL has an "or later version" clause embedded inside the license.
|
# The GFDL has an "or later version" clause embedded inside the license.
|
||||||
# There is no need to add the + here.
|
# There is no need to add the + here.
|
||||||
License: GPLv2+ and GFDL
|
License: GPLv2+ and GFDL
|
||||||
|
11
libxml.patch
11
libxml.patch
@ -1,11 +0,0 @@
|
|||||||
diff -up eog-2.25.1/configure.ac.libxml eog-2.25.1/configure.ac
|
|
||||||
--- eog-2.25.1/configure.ac.libxml 2008-11-12 21:44:11.000000000 -0500
|
|
||||||
+++ eog-2.25.1/configure.ac 2008-11-12 21:44:30.000000000 -0500
|
|
||||||
@@ -96,6 +96,7 @@ EXEMPI_REQUIRED=1.99.5
|
|
||||||
EOG_MODULES="gtk+-2.0 >= $GTK_REQUIRED \
|
|
||||||
glib-2.0 >= $GLIB_REQUIRED \
|
|
||||||
gio-2.0 >= $GLIB_REQUIRED \
|
|
||||||
+ libxml-2.0 \
|
|
||||||
libgnomeui-2.0 >= $LIBGNOMEUI_REQUIRED \
|
|
||||||
gdk-pixbuf-2.0 >= $GDKPIXBUF_REQUIRED \
|
|
||||||
gconf-2.0 >= $GCONF_REQUIRED \
|
|
Loading…
Reference in New Issue
Block a user