RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/enscript#77586bf6837d2d505f568c4667db6e65b5cd3676
This commit is contained in:
parent
5563d25986
commit
f67354db69
4
.gitignore
vendored
4
.gitignore
vendored
@ -0,0 +1,4 @@
|
||||
enscript-php-1.6.4.st
|
||||
enscript-ruby-1.6.4.tar.gz
|
||||
enscript-1.6.5.2.tar.gz
|
||||
/enscript-1.6.6.tar.gz
|
2059
0001-enscript-newencodings.patch
Normal file
2059
0001-enscript-newencodings.patch
Normal file
File diff suppressed because it is too large
Load Diff
26
enscript-1.6.1-locale.patch
Normal file
26
enscript-1.6.1-locale.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- enscript-1.6.1/src/main.c.locale Mon Mar 18 11:23:14 2002
|
||||
+++ enscript-1.6.1/src/main.c Mon Mar 18 11:24:08 2002
|
||||
@@ -912,9 +912,8 @@
|
||||
* We want to change only messages (gs do not like decimals in 0,1
|
||||
* format ;)
|
||||
*/
|
||||
-#if HAVE_LC_MESSAGES
|
||||
- setlocale (LC_MESSAGES, "");
|
||||
-#endif
|
||||
+ setlocale (LC_ALL, "");
|
||||
+ setlocale (LC_NUMERIC, "C");
|
||||
#endif
|
||||
#if ENABLE_NLS
|
||||
bindtextdomain (PACKAGE, LOCALEDIR);
|
||||
--- enscript-1.6.1/src/psgen.c.locale Mon Mar 18 11:23:14 2002
|
||||
+++ enscript-1.6.1/src/psgen.c Mon Mar 18 11:23:14 2002
|
||||
@@ -1103,7 +1103,8 @@
|
||||
/* Get escape name. */
|
||||
for (i = 0; i < sizeof (escname) - 1 && (ch = is_getc (is)) != EOF; i++)
|
||||
{
|
||||
- if (!isalnum (ch))
|
||||
+ if (!((ch >= '0' && ch <= '9') || (ch >= 'A' && ch <= 'Z') ||
|
||||
+ (ch >= 'a' && ch <= 'z')))
|
||||
{
|
||||
is_ungetc (ch, is);
|
||||
break;
|
12
enscript-1.6.4-rh457720.patch
Normal file
12
enscript-1.6.4-rh457720.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up enscript-1.6.4/src/mkafmmap.c.rh457720 enscript-1.6.4/src/mkafmmap.c
|
||||
--- enscript-1.6.4/src/mkafmmap.c.rh457720 2008-08-08 11:33:47.000000000 +0200
|
||||
+++ enscript-1.6.4/src/mkafmmap.c 2008-08-08 11:33:58.000000000 +0200
|
||||
@@ -139,7 +139,7 @@ main (int argc, char *argv[])
|
||||
int option_index = 0;
|
||||
int c;
|
||||
|
||||
- c = getopt_long (argc, argv, "p:h", long_options, &option_index);
|
||||
+ c = getopt_long (argc, argv, "p:hV", long_options, &option_index);
|
||||
if (c == -1)
|
||||
break;
|
||||
|
15
enscript-CVE-vasnprintf.patch
Normal file
15
enscript-CVE-vasnprintf.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff --git a/intl/vasnprintf.c b/intl/vasnprintf.c
|
||||
index 4a8e7f0..65ade71 100644
|
||||
--- a/intl/vasnprintf.c
|
||||
+++ b/intl/vasnprintf.c
|
||||
@@ -758,7 +758,9 @@ convert_to_decimal (mpn_t a, size_t extra_zeroes)
|
||||
size_t a_len = a.nlimbs;
|
||||
/* 0.03345 is slightly larger than log(2)/(9*log(10)). */
|
||||
size_t c_len = 9 * ((size_t)(a_len * (GMP_LIMB_BITS * 0.03345f)) + 1);
|
||||
- char *c_ptr = (char *) malloc (xsum (c_len, extra_zeroes));
|
||||
+ /* We need extra_zeroes bytes for zeroes, followed by c_len bytes for the
|
||||
+ digits of a, followed by 1 byte for the terminating NUL. */
|
||||
+ char *c_ptr = (char *) malloc (xsum (xsum (extra_zeroes, c_len), 1));
|
||||
if (c_ptr != NULL)
|
||||
{
|
||||
char *d_ptr = c_ptr;
|
12
enscript-bufpos-crash.patch
Normal file
12
enscript-bufpos-crash.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up enscript-1.6.5.2/src/psgen.c.bufpos-crash enscript-1.6.5.2/src/psgen.c
|
||||
--- enscript-1.6.5.2/src/psgen.c.bufpos-crash 2013-05-13 16:18:05.119393660 +0100
|
||||
+++ enscript-1.6.5.2/src/psgen.c 2013-05-13 16:19:17.634739778 +0100
|
||||
@@ -1928,7 +1928,7 @@ get_next_token (InputStream *is, double
|
||||
bufpos--;
|
||||
}
|
||||
/* Check the octal notations "\\%03o". */
|
||||
- else if (bufpos - 2 > w
|
||||
+ else if (bufpos > 2 && bufpos - 2 > w
|
||||
&& ISOCTAL (buffer[bufpos])
|
||||
&& ISOCTAL (buffer[bufpos - 1])
|
||||
&& ISOCTAL (buffer[bufpos - 2])
|
11
enscript-build.patch
Normal file
11
enscript-build.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -up enscript-1.6.6/configure.ac.build enscript-1.6.6/configure.ac
|
||||
--- enscript-1.6.6/configure.ac.build 2012-09-25 21:22:49.000000000 +0200
|
||||
+++ enscript-1.6.6/configure.ac 2012-09-26 15:46:10.988041135 +0200
|
||||
@@ -11,7 +11,6 @@ AC_PROG_INSTALL
|
||||
AC_PROG_CC
|
||||
|
||||
AC_USE_SYSTEM_EXTENSIONS
|
||||
-AM_C_PROTOTYPES
|
||||
|
||||
AC_C_CONST
|
||||
AC_FUNC_ALLOCA
|
36
enscript-manfixes.patch
Normal file
36
enscript-manfixes.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff -up enscript-1.6.6/docs/enscript.man.manfixes enscript-1.6.6/docs/enscript.man
|
||||
--- enscript-1.6.6/docs/enscript.man.manfixes 2011-10-30 17:48:42.000000000 +0100
|
||||
+++ enscript-1.6.6/docs/enscript.man 2013-04-04 13:26:50.257945126 +0200
|
||||
@@ -394,6 +394,9 @@ generate RTF (Rich Text Format)
|
||||
generate ANSI terminal control codes
|
||||
.RE
|
||||
.TP 8
|
||||
+.B \-W, \-\-option=\f2app,option\f3
|
||||
+Pass option \f2option\f3 to helper application \f2app\f3
|
||||
+.TP 8
|
||||
.B \-X \f2name\f3, \-\-encoding=\f2name\f3
|
||||
Use the input encoding \f2name\f1. Currently \f3enscript\f1 supports
|
||||
the following encodings:
|
||||
@@ -471,6 +474,10 @@ cookies from the beginning of the file.
|
||||
.B \-\-color\f1[\f3=\f2bool\f1]\f3
|
||||
Use colors in the highlighting outputs.
|
||||
.TP 8
|
||||
+.B \-\-continuous\-page\-numbers
|
||||
+Count page numbers across input files. Don't restart numbering at
|
||||
+beginning of each file.
|
||||
+.TP 8
|
||||
.B \-\-download\-font=\f2fontname\f3
|
||||
Include the font description file (\f2.pfa\f1 or \f2.pfb\f1 file) of
|
||||
the font \f2fontname\f1 to the generated output.
|
||||
diff -up enscript-1.6.6/src/main.c.manfixes enscript-1.6.6/src/main.c
|
||||
--- enscript-1.6.6/src/main.c.manfixes 2013-04-04 13:21:31.926629557 +0200
|
||||
+++ enscript-1.6.6/src/main.c 2013-04-04 13:21:31.953629499 +0200
|
||||
@@ -2580,7 +2580,7 @@ Mandatory arguments to long options are
|
||||
-v, --verbose tell what we are doing\n\
|
||||
-V, --version print version number\n\
|
||||
-w, --language=LANG set output language to LANG\n\
|
||||
- -W, --options=APP,OPTION pass option OPTION to helper application APP\n\
|
||||
+ -W, --option=APP,OPTION pass option OPTION to helper application APP\n\
|
||||
-X, --encoding=NAME use input encoding NAME\n\
|
||||
-z, --no-formfeed do not interpret form feed characters\n\
|
||||
-Z, --pass-through pass through PostScript and PCL files\n\
|
40
enscript-rh477382.patch
Normal file
40
enscript-rh477382.patch
Normal file
@ -0,0 +1,40 @@
|
||||
diff -up enscript-1.6.6/afm/Makefile.am.rh477382 enscript-1.6.6/afm/Makefile.am
|
||||
--- enscript-1.6.6/afm/Makefile.am.rh477382 2012-09-20 00:17:34.000000000 +0200
|
||||
+++ enscript-1.6.6/afm/Makefile.am 2012-09-26 13:42:09.223974485 +0200
|
||||
@@ -29,9 +29,12 @@ hvnbo.afm hvno.afm hvo.afm ncb.afm ncbi.
|
||||
pobi.afm poi.afm por.afm sy.afm tib.afm tibi.afm tii.afm tir.afm \
|
||||
zcmi.afm zd.afm
|
||||
|
||||
-public_fonts = matrix.afm matrix.pfa
|
||||
+public_fonts = matrix.afm matrix.eps
|
||||
|
||||
afmdir = $(pkgdatadir)/afm
|
||||
dist_afm_DATA = font.map $(default_afm) $(public_fonts) MustRead.html
|
||||
|
||||
EXTRA_DIST = ChangeLog.old
|
||||
+
|
||||
+matrix.eps: matrix.pfa
|
||||
+ cp matrix.pfa matrix.eps
|
||||
diff -up enscript-1.6.6/src/util.c.rh477382 enscript-1.6.6/src/util.c
|
||||
--- enscript-1.6.6/src/util.c.rh477382 2011-10-30 17:48:42.000000000 +0100
|
||||
+++ enscript-1.6.6/src/util.c 2012-09-26 13:40:53.336866463 +0200
|
||||
@@ -1084,9 +1084,16 @@ download_font (char *name)
|
||||
buffer_append (&fname, ".pfb");
|
||||
if (stat (buffer_ptr (&fname), &stat_st) != 0)
|
||||
{
|
||||
- /* Couldn't find font description file, nothing to download. */
|
||||
- buffer_uninit (&fname);
|
||||
- return;
|
||||
+ /* .eps */
|
||||
+ buffer_clear (&fname);
|
||||
+ buffer_append (&fname, prefix);
|
||||
+ buffer_append (&fname, ".eps");
|
||||
+ if (stat (buffer_ptr (&fname), &stat_st) != 0)
|
||||
+ {
|
||||
+ /* Couldn't find font description file, nothing to download. */
|
||||
+ buffer_uninit (&fname);
|
||||
+ return;
|
||||
+ }
|
||||
}
|
||||
}
|
||||
|
50
enscript-wrap_header.patch
Normal file
50
enscript-wrap_header.patch
Normal file
@ -0,0 +1,50 @@
|
||||
diff -up enscript-1.6.5.1/lib/simple.hdr.wrap_header enscript-1.6.5.1/lib/simple.hdr
|
||||
--- enscript-1.6.5.1/lib/simple.hdr.wrap_header 2009-01-24 21:59:34.000000000 +0100
|
||||
+++ enscript-1.6.5.1/lib/simple.hdr 2010-05-21 13:04:28.070346832 +0200
|
||||
@@ -3,6 +3,10 @@
|
||||
% Copyright (c) 1995 Markku Rossi.
|
||||
% Author: Markku Rossi <mtr@iki.fi>
|
||||
%
|
||||
+% Modified: Chris Josefy, USA, MAY 2006
|
||||
+% + Added line wrapping to header to work more like AIX enscript
|
||||
+% + This assumes that one does not change the header font size from the default
|
||||
+% + This also assumes that the line only wraps once
|
||||
|
||||
%
|
||||
% This file is part of GNU Enscript.
|
||||
@@ -24,6 +28,7 @@
|
||||
% -- code follows this line --
|
||||
%Format: fmodstr $D{%a %b %d %H:%M:%S %Y}
|
||||
%Format: pagenumstr $V$%
|
||||
+%HeaderHeight: 44
|
||||
|
||||
/do_header { % print default simple header
|
||||
gsave
|
||||
@@ -39,10 +44,23 @@
|
||||
d_header_w user_header_right_str stringwidth pop sub 5 sub
|
||||
0 moveto user_header_right_str show
|
||||
} {
|
||||
- 5 0 moveto fname show
|
||||
- 45 0 rmoveto fmodstr show
|
||||
- 45 0 rmoveto pagenumstr show
|
||||
- } ifelse
|
||||
+ fname length fmodstr length add pagenumstr length add 95 6 idiv add d_header_w 6 idiv le{
|
||||
+ 5 0 moveto fname show
|
||||
+ 45 0 rmoveto fmodstr show
|
||||
+ 45 0 rmoveto pagenumstr show
|
||||
+ } {
|
||||
+ 5 0 moveto fmodstr show
|
||||
+ 45 0 rmoveto pagenumstr show
|
||||
+ fname length d_header_w 6 idiv idiv 1 add 10 mul 5 exch moveto
|
||||
+ 1 1 fname length d_header_w 6 idiv idiv
|
||||
+ {
|
||||
+ dup fname exch 1 sub d_header_w 6 idiv mul d_header_w 6 idiv getinterval show
|
||||
+ 5 exch 10 mul fname length d_header_w 6 idiv idiv 1 add 10 mul exch sub moveto
|
||||
+ } for
|
||||
+ 5 10 moveto
|
||||
+ fname fname length d_header_w 6 idiv idiv d_header_w 6 idiv mul dup fname length exch sub getinterval show
|
||||
+ }ifelse
|
||||
+ }ifelse
|
||||
|
||||
grestore
|
||||
} def
|
390
enscript.spec
Normal file
390
enscript.spec
Normal file
@ -0,0 +1,390 @@
|
||||
Summary: A plain ASCII to PostScript converter
|
||||
Name: enscript
|
||||
Version: 1.6.6
|
||||
Release: 24%{?dist}
|
||||
License: GPLv3+ and LGPLv2+ and GPLv2+
|
||||
URL: http://www.gnu.org/software/enscript
|
||||
# Tarball exists nowhere. You have to obtain it via:
|
||||
# $ git clone git://git.savannah.gnu.org/enscript.git
|
||||
# $ git archive --format=tar --prefix=enscript-1.6.4/ v1.6.4 |gzip > enscript-1.6.4.tar.gz
|
||||
Source0: enscript-%{version}.tar.gz
|
||||
Source1: enscript-ruby-1.6.4.tar.gz
|
||||
#http://neugierig.org/software/ruby/ruby-enscript.tar.gz
|
||||
Source2: enscript-php-1.6.4.st
|
||||
#http://home.raxnet.net/downloads/viewcvs/php.st
|
||||
|
||||
# RH #61294
|
||||
Patch3: enscript-1.6.1-locale.patch
|
||||
|
||||
# RH #224548
|
||||
Patch8: enscript-wrap_header.patch
|
||||
|
||||
Patch10:enscript-1.6.4-rh457720.patch
|
||||
Patch12:enscript-rh477382.patch
|
||||
Patch13:enscript-build.patch
|
||||
Patch14:enscript-manfixes.patch
|
||||
Patch15: enscript-bufpos-crash.patch
|
||||
# 1664367 - adding support for 2 other encodings, enscript cannot print f.e. euro symbol
|
||||
# without it
|
||||
# rhbz: https://bugzilla.redhat.com/show_bug.cgi?id=1664367
|
||||
# upstream patch: http://lists.gnu.org/archive/html/bug-enscript/2018-04/msg00008.html
|
||||
Patch16: 0001-enscript-newencodings.patch
|
||||
# enscript bundles some gnulib source files, so some issues or CVEs in gnulib can be
|
||||
# present in enscript
|
||||
# gnulib CVE: https://bugzilla.redhat.com/show_bug.cgi?id=1635896
|
||||
Patch17: enscript-CVE-vasnprintf.patch
|
||||
|
||||
# gcc is no longer in buildroot by default
|
||||
BuildRequires: gcc
|
||||
BuildRequires: autoconf, automake, gettext
|
||||
BuildRequires: gettext-devel
|
||||
|
||||
# our downstreamed gnulib bundles some gnulib files, so we need to provide
|
||||
# this one. I'm not sure why we have gnulib files there, because upstream
|
||||
# does not have these files. The correct way would be to extract these files,
|
||||
# fix Makefiles to link correct gnulib and requires gnulib-'something' in spec
|
||||
# file, but enscript is lowly used+low maintenance+mostly dead upstream package,
|
||||
# so there is a little merit of doing it...
|
||||
Provides: bundled(gnulib)
|
||||
|
||||
%description
|
||||
GNU enscript is a free replacement for Adobe's Enscript
|
||||
program. Enscript converts ASCII files to PostScript(TM) and spools
|
||||
generated PostScript output to the specified printer or saves it to a
|
||||
file. Enscript can be extended to handle different output media and
|
||||
includes many options for customizing printouts
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch3 -p1 -b .locale
|
||||
%patch8 -p1 -b .wrap_header
|
||||
%patch10 -p1 -b .rh457720
|
||||
%patch12 -p1 -b .rh477382
|
||||
%patch13 -p1 -b .build
|
||||
%patch14 -p1 -b .manfixes
|
||||
%patch15 -p1 -b .bufpos-crash
|
||||
# 1664367 - [RFE] Add support for 885915 encoding in enscript
|
||||
%patch16 -p1 -b .newencodings
|
||||
# CVE in gnulib
|
||||
%patch17 -p1 -b .vasnprintf
|
||||
|
||||
%{__tar} -C states/hl -zxf %{SOURCE1} ruby.st
|
||||
install -pm 644 %{SOURCE2} states/hl/php.st
|
||||
|
||||
%build
|
||||
autoreconf -fiv
|
||||
export CPPFLAGS='-DPROTOTYPES'
|
||||
%configure --with-media=Letter
|
||||
%make_build
|
||||
|
||||
|
||||
%install
|
||||
mkdir -p %{buildroot}%{_datadir}/locale/{de,es,fi,fr,nl,sl}/LC_MESSAGES
|
||||
%make_install
|
||||
rm -f %{buildroot}%{_datadir}/info/dir
|
||||
|
||||
%find_lang %name
|
||||
|
||||
# XXX note doubled %% in sed script below.
|
||||
(cd %{buildroot};find .%{_datadir}/enscript/* \! -type d) | \
|
||||
sed -e 's,^\.,,' | sed -e 's,*font.map,%%config &,' > share.list
|
||||
(cd %{buildroot};find .%{_datadir}/enscript/* -type d) | \
|
||||
sed -e 's,^\.,,' | sed -e 's,^,%dir ,' >> share.list
|
||||
|
||||
( cd %{buildroot}
|
||||
ln .%{_prefix}/bin/enscript .%{_prefix}/bin/nenscript
|
||||
)
|
||||
|
||||
%find_lang %{name} %{name}.lang
|
||||
|
||||
for all in README THANKS; do
|
||||
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
||||
touch -r $all $all.new
|
||||
mv $all.new $all
|
||||
done
|
||||
|
||||
%files -f %{name}.lang -f share.list
|
||||
%doc AUTHORS ChangeLog COPYING docs/FAQ.html NEWS README README.ESCAPES THANKS TODO
|
||||
%{_bindir}/*
|
||||
%{_mandir}/man1/*
|
||||
%dir %{_datadir}/enscript
|
||||
%{_infodir}/%{name}*
|
||||
%config(noreplace) %{_sysconfdir}/enscript.cfg
|
||||
|
||||
%changelog
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-24
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 1.6.6-23
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-22
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Jan 29 2019 Zdenek Dohnal <zdohnal@redhat.com> - 1.6.6-19
|
||||
- 1664367 - [RFE] Add support for 885915 encoding in enscript
|
||||
- remove old Obsoletes/Provides
|
||||
- fix gnulib CVE
|
||||
|
||||
* Tue Jul 24 2018 Zdenek Dohnal <zdohnal@redhat.com> - 1.6.6-18
|
||||
- correcting license
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Jun 18 2018 Zdenek Dohnal <zdohnal@redhat.com> - 1.6.6-16
|
||||
- remove install-info, info package does it now automatically when any package puts a file into %%_infodir
|
||||
|
||||
* Mon Feb 19 2018 Zdenek Dohnal <zdohnal@redhat.com> - 1.6.6-15
|
||||
- gcc is no longer in buildroot by default
|
||||
|
||||
* Thu Feb 08 2018 Zdenek Dohnal <zdohnal@redhat.com> - 1.6.6-14
|
||||
- remove old stuff https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/MRWOMRZ6KPCV25EFHJ2O67BCCP3L4Y6N/
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.6-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.6-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.6-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.6-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.6-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Mon May 13 2013 Tim Waugh <twaugh@redhat.com> - 1.6.6-4
|
||||
|
||||
- Fixed word-wrapping crash in tokenizer (bug #870639).
|
||||
* Thu Apr 04 2013 Adam Tkac <atkac redhat com> - 1.6.6-3
|
||||
- some manpage fixes
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Wed Sep 26 2012 Adam Tkac <atkac redhat com> - 1.6.6-1
|
||||
- update to 1.6.6
|
||||
- paches merged
|
||||
- enscript-1.6.4-hilight.patch
|
||||
- enscript-1.6.4-rh457719.patch
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.5.2-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.5.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.5.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Sep 08 2010 Adam Tkac <atkac redhat com> - 1.6.5.2-3
|
||||
- BR: s/gettext-autopoint/gettext-devel (#631147)
|
||||
|
||||
* Sat Jul 17 2010 Dan Horák <dan[at]danny.cz> - 1.6.5.2-2
|
||||
- add gettext-autopoint to BuildRequires
|
||||
|
||||
* Wed Jun 02 2010 Adam Tkac <atkac redhat com> - 1.6.5.2-1
|
||||
- update to 1.6.5.2
|
||||
|
||||
* Thu May 20 2010 Adam Tkac <atkac redhat com> - 1.6.5.1-1
|
||||
- update to 1.6.5.1
|
||||
- patches merged
|
||||
- enscript-1.6.1-config.patch
|
||||
- enscript-doublefree.patch
|
||||
- enscript-1.6.1-CAN-2004-1185.patch
|
||||
- enscript-1.6.1-CAN-2004-1186.patch
|
||||
- enscript-CVE-2008-3863+CVE-2008-4306.patch
|
||||
- license changed to GPLv3+
|
||||
- add gettext to BuildRequires
|
||||
|
||||
* Mon Dec 14 2009 Adam Tkac <atkac redhat com> - 1.6.4-16
|
||||
- merge review related fixes (#225729)
|
||||
|
||||
* Mon Nov 30 2009 Adam Tkac <atkac redhat com> - 1.6.4-15
|
||||
- ship postscript files with .eps extension (#505775)
|
||||
- merge review fixes (#225729)
|
||||
- improve enscript-1.6.1-config.patch
|
||||
|
||||
* Mon Aug 10 2009 Ville Skyttä <ville.skytta at iki.fi> - 1.6.4-14
|
||||
- Convert specfile to UTF-8.
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.4-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.4-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Mon Nov 03 2008 Adam Tkac <atkac redhat com> 1.6.4-11
|
||||
- fixed various buffer overflows (CVE-2008-3863, CVE-2008-4306)
|
||||
|
||||
* Fri Aug 08 2008 Adam Tkac <atkac redhat com> 1.6.4-10
|
||||
- updated patches due rpm 4.6
|
||||
- enscript -w is handled well (#457719)
|
||||
- mkafmmap -V is handled well (#457720)
|
||||
|
||||
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.6.4-9
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Wed Aug 22 2007 Adam Tkac <atkac redhat com> 1.6.4-8
|
||||
- rebuild (BuildID feature)
|
||||
- change license to GPLv2
|
||||
|
||||
* Mon Feb 12 2007 Adam Tkac <atkac redhat com> 1.6.4-7
|
||||
- wrap_header patch had problems with around 70 characters long headers
|
||||
|
||||
* Fri Jan 26 2007 Adam Tkac <atkac redhat com> 1.6.4-6
|
||||
- wrap_header patch has been improved
|
||||
|
||||
* Tue Dec 19 2006 Adam Tkac <atkac redhat com> 1.6.4-5
|
||||
- fixed long-header patch
|
||||
|
||||
* Fri Sep 01 2006 Jitka Kudrnacova <jkudrnac@redhat.com> - 1.6.4-4
|
||||
- enscript now wrapes long header instead of truncating
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.6.4-3.1
|
||||
- rebuild
|
||||
|
||||
* Tue Jun 27 2006 Florian La Roche <laroche@redhat.com> - 1.6.4-3
|
||||
- /sbin/install-info is required for scripts
|
||||
|
||||
*Fri Feb 17 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 1.6.4-2
|
||||
- added new highlighters (#177336)
|
||||
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.6.4-1.1.2
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.6.4-1.1.1
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Fri Jan 27 2006 Jitka Kudrnacova <jkudrnac@redhat.com> 1.6.4-1.1
|
||||
- fixed URL in the description (bug #178444)
|
||||
|
||||
* Fri Dec 23 2005 Tim Waugh <twaugh@redhat.com> 1.6.4-1
|
||||
- 1.6.4 (bug #176349). No longer need tmp, CAN-2004-1184, demunge patches.
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Tue Mar 8 2005 Tim Waugh <twaugh@redhat.com> 1.6.1-31
|
||||
- Fixed po files (bug #149859).
|
||||
|
||||
* Wed Mar 2 2005 Tim Waugh <twaugh@redhat.com> 1.6.1-30
|
||||
- Rebuild for new GCC.
|
||||
|
||||
* Sat Jan 29 2005 Tim Waugh <twaugh@redhat.com> 1.6.1-29
|
||||
- Applied patch to fix CAN-2004-1186 (bug #144684).
|
||||
- Applied patch to fix CAN-2004-1185 (bug #144684).
|
||||
- Backported patch to fix CAN-2004-1184 (bug #144684).
|
||||
|
||||
* Mon Sep 27 2004 Tim Waugh <twaugh@redhat.com> 1.6.1-28
|
||||
- Fixed double-free problem (bug #132964).
|
||||
|
||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Mon Nov 3 2003 Tim Waugh <twaugh@redhat.com>
|
||||
- Removed mail patch. It was included to be more compatible with an
|
||||
lpr we no longer ship. Fixes bug #108762.
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Nov 20 2002 Tim Powers <timp@redhat.com>
|
||||
- rebuild on all arches
|
||||
|
||||
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Sun May 26 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Wed May 22 2002 Tim Waugh <twaugh@redhat.com> 1.6.1-20
|
||||
- Fix URL (bug #65278).
|
||||
|
||||
* Wed Apr 3 2002 Tim Waugh <twaugh@redhat.com> 1.6.1-19
|
||||
- Fix license (bug #62573).
|
||||
|
||||
* Mon Mar 18 2002 Tim Waugh <twaugh@redhat.com> 1.6.1-18
|
||||
- Fix locale issues (bug #61294).
|
||||
|
||||
* Mon Feb 04 2002 Tim Waugh <twaugh@redhat.com> 1.6.1-17
|
||||
- Rebuild in new environment.
|
||||
|
||||
* Mon Jan 14 2002 Tim Waugh <twaugh@redhat.com> 1.6.1-16.2
|
||||
- Use tmpfile instead of tmpnam or tempnam (bug #57704).
|
||||
- Built for Red Hat Linux 7.x.
|
||||
|
||||
* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.6.1-16
|
||||
- automated rebuild
|
||||
|
||||
* Wed Dec 19 2001 Tim Waugh <twaugh@redhat.com> 1.6.1-15
|
||||
- Own %%{_datadir}/enscript directory (bug #56974).
|
||||
|
||||
* Mon Jun 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.6.1-14
|
||||
- add optional mail paramater, closing bug #17750
|
||||
- patch from marques@cs.cornell.edu
|
||||
|
||||
* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
|
||||
- Bump release + rebuild.
|
||||
|
||||
* Tue Feb 27 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- langify
|
||||
|
||||
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
|
||||
- automatic rebuild
|
||||
|
||||
* Mon Jun 12 2000 Preston Brown <pbrown@redhat.com>
|
||||
- FHS paths
|
||||
|
||||
* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
|
||||
- rebuild to gzip man pages
|
||||
|
||||
* Wed Mar 24 1999 Erik Troan <ewt@redhat.com>
|
||||
- marked /usr/share/enscript/font.map as a config file
|
||||
|
||||
* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
|
||||
- added documentation to the RPM
|
||||
|
||||
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||
- auto rebuild in the new build environment (release 5)
|
||||
|
||||
* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
|
||||
- strip binaries.
|
||||
- include i18n locales.
|
||||
|
||||
* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
|
||||
- Injected new description and group.
|
||||
|
||||
* Wed Nov 11 1998 Preston Brown <pbrown@redhat.com>
|
||||
- translations ripped out, slight cleanup to build section.
|
||||
|
||||
* Mon Nov 09 1998 Preston Brown <pbrown@redhat.com>
|
||||
- initial build of GNU enscript to replace nenscript.
|
Loading…
Reference in New Issue
Block a user