- ship postscript files with .eps extension (#505775)
- merge review fixes (#225729) - improve enscript-1.6.1-config.patch
This commit is contained in:
parent
6a5a907b52
commit
8e5fd6fa25
@ -1,6 +1,7 @@
|
|||||||
--- enscript-1.6.4/afm/Makefile.am.config 2003-03-05 07:26:16.000000000 +0000
|
diff -up enscript-1.6.4/afm/Makefile.am.config enscript-1.6.4/afm/Makefile.am
|
||||||
+++ enscript-1.6.4/afm/Makefile.am 2005-12-23 09:56:52.000000000 +0000
|
--- enscript-1.6.4/afm/Makefile.am.config 2003-03-05 08:26:16.000000000 +0100
|
||||||
@@ -36,11 +36,11 @@
|
+++ enscript-1.6.4/afm/Makefile.am 2009-11-30 14:38:34.410478926 +0100
|
||||||
|
@@ -36,11 +36,11 @@ public_fonts = matrix.afm matrix.pfa
|
||||||
EXTRA_DIST = font.map $(default_afm) $(public_fonts)
|
EXTRA_DIST = font.map $(default_afm) $(public_fonts)
|
||||||
|
|
||||||
install-data-local:
|
install-data-local:
|
||||||
@ -16,30 +17,10 @@
|
|||||||
uninstall-local:
|
uninstall-local:
|
||||||
- rm -rf $(datadir)/enscript/afm
|
- rm -rf $(datadir)/enscript/afm
|
||||||
+ rm -rf $(DESTDIR)/$(datadir)/enscript/afm
|
+ rm -rf $(DESTDIR)/$(datadir)/enscript/afm
|
||||||
--- enscript-1.6.4/afm/Makefile.in.config 2003-03-05 07:40:06.000000000 +0000
|
diff -up enscript-1.6.4/lib/Makefile.am.config enscript-1.6.4/lib/Makefile.am
|
||||||
+++ enscript-1.6.4/afm/Makefile.in 2005-12-23 09:56:52.000000000 +0000
|
--- enscript-1.6.4/lib/Makefile.am.config 2009-11-30 14:39:38.377977061 +0100
|
||||||
@@ -319,14 +319,14 @@
|
+++ enscript-1.6.4/lib/Makefile.am 2009-11-30 14:40:13.887977573 +0100
|
||||||
|
@@ -38,12 +38,12 @@ CLEANFILES = enscript.cfg
|
||||||
|
|
||||||
install-data-local:
|
|
||||||
- $(top_srcdir)/mkinstalldirs $(datadir)/enscript
|
|
||||||
- $(top_srcdir)/mkinstalldirs $(datadir)/enscript/afm
|
|
||||||
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/enscript
|
|
||||||
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/enscript/afm
|
|
||||||
for f in $(EXTRA_DIST); do \
|
|
||||||
- $(INSTALL_DATA) $(srcdir)/$$f $(datadir)/enscript/afm/$$f; \
|
|
||||||
+ $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)/$(datadir)/enscript/afm/$$f; \
|
|
||||||
done
|
|
||||||
|
|
||||||
uninstall-local:
|
|
||||||
- rm -rf $(datadir)/enscript/afm
|
|
||||||
+ rm -rf $(DESTDIR)/$(datadir)/enscript/afm
|
|
||||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
||||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
||||||
.NOEXPORT:
|
|
||||||
--- enscript-1.6.4/lib/Makefile.in.config 2003-03-05 07:40:07.000000000 +0000
|
|
||||||
+++ enscript-1.6.4/lib/Makefile.in 2005-12-23 09:56:52.000000000 +0000
|
|
||||||
@@ -345,15 +345,16 @@
|
|
||||||
all-local: enscript.cfg
|
all-local: enscript.cfg
|
||||||
|
|
||||||
install-data-local: enscript.cfg
|
install-data-local: enscript.cfg
|
||||||
@ -48,40 +29,20 @@
|
|||||||
- cp $(sysconfdir)/enscript.cfg $(sysconfdir)/enscript.cfg.old; \
|
- cp $(sysconfdir)/enscript.cfg $(sysconfdir)/enscript.cfg.old; \
|
||||||
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(sysconfdir)
|
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(sysconfdir)
|
||||||
+ if test -r $(DESTDIR)$(sysconfdir)/enscript.cfg; then \
|
+ if test -r $(DESTDIR)$(sysconfdir)/enscript.cfg; then \
|
||||||
+ cp $(DESTDIR)$(sysconfdir)/enscript.cfg \
|
+ cp $(DESTDIR)$(sysconfdir)/enscript.cfg $(DESTDIR)$(sysconfdir)/enscript.cfg.old; \
|
||||||
+ $(DESTDIR)$(sysconfdir)/enscript.cfg.old; \
|
|
||||||
else :; \
|
else :; \
|
||||||
fi
|
fi
|
||||||
- $(INSTALL_DATA) enscript.cfg $(sysconfdir)/enscript.cfg
|
- $(INSTALL_DATA) enscript.cfg $(sysconfdir)/enscript.cfg
|
||||||
+ $(INSTALL_DATA) enscript.cfg $(DESTDIR)$(sysconfdir)/enscript.cfg
|
+ $(INSTALL_DATA) enscript.cfg $(DESTDIR)$(sysconfdir)/enscript.cfg
|
||||||
|
|
||||||
uninstall-local:
|
uninstall-local:
|
||||||
- rm -f $(sysconfdir)/enscript.cfg
|
rm -f $(sysconfdir)/enscript.cfg
|
||||||
+ rm -f $(DESTDIR)$(sysconfdir)/enscript.cfg
|
diff -up enscript-1.6.4/states/hl/Makefile.am.config enscript-1.6.4/states/hl/Makefile.am
|
||||||
|
--- enscript-1.6.4/states/hl/Makefile.am.config 2003-03-05 08:26:33.000000000 +0100
|
||||||
enscript.cfg: $(srcdir)/enscript.cfg.in Makefile
|
+++ enscript-1.6.4/states/hl/Makefile.am 2009-11-30 14:38:34.410478926 +0100
|
||||||
sed 's%@DATADIR@%$(datadir)%g; s%@media@%@MEDIA@%g; s%@BINDIR@%$(bindir)%g; s%@spooler@%@SPOOLER@%g; s%@pslevel@%@PSLEVEL@%g' \
|
@@ -45,10 +45,10 @@ states = $(misc) $(styles) $(languages)
|
||||||
--- enscript-1.6.4/states/hl/Makefile.am.config 2005-12-23 09:59:55.000000000 +0000
|
|
||||||
+++ enscript-1.6.4/states/hl/Makefile.am 2005-12-23 10:00:09.000000000 +0000
|
|
||||||
@@ -45,10 +45,10 @@
|
|
||||||
EXTRA_DIST = $(states)
|
EXTRA_DIST = $(states)
|
||||||
|
|
||||||
install-data-local:
|
|
||||||
- $(top_srcdir)/mkinstalldirs $(datadir)/enscript
|
|
||||||
- $(top_srcdir)/mkinstalldirs $(datadir)/enscript/hl
|
|
||||||
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/enscript
|
|
||||||
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/enscript/hl
|
|
||||||
for f in $(states); do \
|
|
||||||
- $(INSTALL_DATA) $(srcdir)/$$f $(datadir)/enscript/hl/$$f; \
|
|
||||||
+ $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)/$(datadir)/enscript/hl/$$f; \
|
|
||||||
done
|
|
||||||
|
|
||||||
uninstall-local:
|
|
||||||
--- enscript-1.6.4/states/hl/Makefile.in.config 2005-12-23 10:00:13.000000000 +0000
|
|
||||||
+++ enscript-1.6.4/states/hl/Makefile.in 2005-12-23 10:00:34.000000000 +0000
|
|
||||||
@@ -330,10 +330,10 @@
|
|
||||||
|
|
||||||
|
|
||||||
install-data-local:
|
install-data-local:
|
||||||
- $(top_srcdir)/mkinstalldirs $(datadir)/enscript
|
- $(top_srcdir)/mkinstalldirs $(datadir)/enscript
|
||||||
- $(top_srcdir)/mkinstalldirs $(datadir)/enscript/hl
|
- $(top_srcdir)/mkinstalldirs $(datadir)/enscript/hl
|
||||||
|
47
enscript-rh477382.patch
Normal file
47
enscript-rh477382.patch
Normal file
@ -0,0 +1,47 @@
|
|||||||
|
diff -up enscript-1.6.4/afm/Makefile.am.rh477382 enscript-1.6.4/afm/Makefile.am
|
||||||
|
--- enscript-1.6.4/afm/Makefile.am.rh477382 2009-11-30 14:26:54.520478161 +0100
|
||||||
|
+++ enscript-1.6.4/afm/Makefile.am 2009-11-30 14:29:12.937976060 +0100
|
||||||
|
@@ -31,11 +31,11 @@ hvnbo.afm hvno.afm hvo.afm ncb.afm ncbi.
|
||||||
|
pobi.afm poi.afm por.afm sy.afm tib.afm tibi.afm tii.afm tir.afm \
|
||||||
|
zcmi.afm zd.afm
|
||||||
|
|
||||||
|
-public_fonts = matrix.afm matrix.pfa
|
||||||
|
+public_fonts = matrix.afm matrix.eps
|
||||||
|
|
||||||
|
EXTRA_DIST = font.map $(default_afm) $(public_fonts)
|
||||||
|
|
||||||
|
-install-data-local:
|
||||||
|
+install-data-local: $(EXTRA_DIST)
|
||||||
|
$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/enscript
|
||||||
|
$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/enscript/afm
|
||||||
|
for f in $(EXTRA_DIST); do \
|
||||||
|
@@ -44,3 +44,6 @@ install-data-local:
|
||||||
|
|
||||||
|
uninstall-local:
|
||||||
|
rm -rf $(DESTDIR)/$(datadir)/enscript/afm
|
||||||
|
+
|
||||||
|
+matrix.eps: matrix.pfa
|
||||||
|
+ mv matrix.pfa matrix.eps
|
||||||
|
diff -up enscript-1.6.4/src/util.c.rh477382 enscript-1.6.4/src/util.c
|
||||||
|
--- enscript-1.6.4/src/util.c.rh477382 2003-03-05 08:26:32.000000000 +0100
|
||||||
|
+++ enscript-1.6.4/src/util.c 2009-11-30 14:26:54.550489123 +0100
|
||||||
|
@@ -1081,9 +1081,16 @@ download_font (char *name)
|
||||||
|
buffer_append (&fname, ".pfb");
|
||||||
|
if (stat (buffer_ptr (&fname), &stat_st) != 0)
|
||||||
|
{
|
||||||
|
- /* Couldn't find font description file, nothing to download. */
|
||||||
|
- buffer_uninit (&fname);
|
||||||
|
- return;
|
||||||
|
+ /* .eps */
|
||||||
|
+ buffer_clear (&fname);
|
||||||
|
+ buffer_append (&fname, prefix);
|
||||||
|
+ buffer_append (&fname, ".eps");
|
||||||
|
+ if (stat (buffer_ptr (&fname), &stat_st) != 0)
|
||||||
|
+ {
|
||||||
|
+ /* Couldn't find font description file, nothing to download. */
|
||||||
|
+ buffer_uninit (&fname);
|
||||||
|
+ return;
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A plain ASCII to PostScript converter.
|
Summary: A plain ASCII to PostScript converter
|
||||||
Name: enscript
|
Name: enscript
|
||||||
Version: 1.6.4
|
Version: 1.6.4
|
||||||
Release: 14%{?dist}
|
Release: 15%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
Source0: http://www.iki.fi/mtr/genscript/enscript-%{version}.tar.gz
|
Source0: http://www.iki.fi/mtr/genscript/enscript-%{version}.tar.gz
|
||||||
@ -19,17 +19,21 @@ Patch8: enscript-wrap_header.patch
|
|||||||
Patch9: enscript-1.6.4-rh457719.patch
|
Patch9: enscript-1.6.4-rh457719.patch
|
||||||
Patch10:enscript-1.6.4-rh457720.patch
|
Patch10:enscript-1.6.4-rh457720.patch
|
||||||
Patch11:enscript-CVE-2008-3863+CVE-2008-4306.patch
|
Patch11:enscript-CVE-2008-3863+CVE-2008-4306.patch
|
||||||
|
Patch12:enscript-rh477382.patch
|
||||||
URL: http://www.codento.com/people/mtr/genscript/
|
URL: http://www.codento.com/people/mtr/genscript/
|
||||||
Prereq: /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
Requires(post): /sbin/install-info
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: nenscript
|
Obsoletes: nenscript
|
||||||
|
|
||||||
|
BuildRequires: autoconf, automake
|
||||||
|
|
||||||
%description
|
%description
|
||||||
GNU enscript is a free replacement for Adobe's Enscript
|
GNU enscript is a free replacement for Adobe's Enscript
|
||||||
program. Enscript converts ASCII files to PostScript(TM) and spools
|
program. Enscript converts ASCII files to PostScript(TM) and spools
|
||||||
generated PostScript output to the specified printer or saves it to a
|
generated PostScript output to the specified printer or saves it to a
|
||||||
file. Enscript can be extended to handle different output media and
|
file. Enscript can be extended to handle different output media and
|
||||||
includes many options for customizing printouts.
|
includes many options for customizing printouts
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
@ -43,12 +47,15 @@ includes many options for customizing printouts.
|
|||||||
%patch9 -p1 -b .rh457719
|
%patch9 -p1 -b .rh457719
|
||||||
%patch10 -p1 -b .rh457720
|
%patch10 -p1 -b .rh457720
|
||||||
%patch11 -p0 -b .CVE-2008-3863+CVE-2008-4306
|
%patch11 -p0 -b .CVE-2008-3863+CVE-2008-4306
|
||||||
|
%patch12 -p1 -b .rh477382
|
||||||
|
|
||||||
%{__tar} -C states/hl -zxf %{SOURCE1} ruby.st
|
%{__tar} -C states/hl -zxf %{SOURCE1} ruby.st
|
||||||
install -pm 644 %{SOURCE2} states/hl/php.st
|
install -pm 644 %{SOURCE2} states/hl/php.st
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
autoreconf -fiv
|
||||||
%configure --with-media=Letter
|
%configure --with-media=Letter
|
||||||
make
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -71,6 +78,12 @@ rm -f %{buildroot}%{_datadir}/info/dir
|
|||||||
|
|
||||||
cat %{name}.lang >> share.list
|
cat %{name}.lang >> share.list
|
||||||
|
|
||||||
|
for all in README THANKS; do
|
||||||
|
iconv -f ISO88591 -t UTF8 < $all > $all.new
|
||||||
|
touch -r $all $all.new
|
||||||
|
mv $all.new $all
|
||||||
|
done
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
@ -86,8 +99,8 @@ fi
|
|||||||
/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
|
/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
|
||||||
|
|
||||||
%files -f share.list
|
%files -f share.list
|
||||||
|
%defattr(-,root,root,-)
|
||||||
%doc AUTHORS ChangeLog docs/FAQ.html NEWS README README.ESCAPES THANKS TODO
|
%doc AUTHORS ChangeLog docs/FAQ.html NEWS README README.ESCAPES THANKS TODO
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
%{_mandir}/man1/*
|
%{_mandir}/man1/*
|
||||||
%dir %{_datadir}/enscript
|
%dir %{_datadir}/enscript
|
||||||
@ -96,6 +109,11 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 30 2009 Adam Tkac <atkac redhat com> - 1.6.4-15
|
||||||
|
- ship postscript files with .eps extension (#505775)
|
||||||
|
- merge review fixes (#225729)
|
||||||
|
- improve enscript-1.6.1-config.patch
|
||||||
|
|
||||||
* Mon Aug 10 2009 Ville Skyttä <ville.skytta at iki.fi> - 1.6.4-14
|
* Mon Aug 10 2009 Ville Skyttä <ville.skytta at iki.fi> - 1.6.4-14
|
||||||
- Convert specfile to UTF-8.
|
- Convert specfile to UTF-8.
|
||||||
|
|
||||||
@ -215,7 +233,7 @@ fi
|
|||||||
- automated rebuild
|
- automated rebuild
|
||||||
|
|
||||||
* Wed Dec 19 2001 Tim Waugh <twaugh@redhat.com> 1.6.1-15
|
* Wed Dec 19 2001 Tim Waugh <twaugh@redhat.com> 1.6.1-15
|
||||||
- Own %{_datadir}/enscript directory (bug #56974).
|
- Own %%{_datadir}/enscript directory (bug #56974).
|
||||||
|
|
||||||
* Mon Jun 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.6.1-14
|
* Mon Jun 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.6.1-14
|
||||||
- add optional mail paramater, closing bug #17750
|
- add optional mail paramater, closing bug #17750
|
||||||
|
Loading…
Reference in New Issue
Block a user