Update to 1.6.6
- paches merged - enscript-1.6.4-hilight.patch - enscript-1.6.4-rh457719.patch Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
2ce3195f64
commit
43289b234e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
enscript-php-1.6.4.st
|
enscript-php-1.6.4.st
|
||||||
enscript-ruby-1.6.4.tar.gz
|
enscript-ruby-1.6.4.tar.gz
|
||||||
enscript-1.6.5.2.tar.gz
|
enscript-1.6.5.2.tar.gz
|
||||||
|
/enscript-1.6.6.tar.gz
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -1,12 +0,0 @@
|
|||||||
diff -up enscript-1.6.4/src/main.c.rh457719 enscript-1.6.4/src/main.c
|
|
||||||
--- enscript-1.6.4/src/main.c.rh457719 2008-08-08 11:23:27.000000000 +0200
|
|
||||||
+++ enscript-1.6.4/src/main.c 2008-08-08 11:23:36.000000000 +0200
|
|
||||||
@@ -2001,7 +2001,7 @@ handle_options (int argc, char *argv[])
|
|
||||||
int i;
|
|
||||||
|
|
||||||
c = getopt_long (argc, argv,
|
|
||||||
- "#:123456789a:A:b:BcC::d:D:e::E::f:F:gGhH::i:I:jJ:kKlL:mM:n:N:o:Op:P:qrRs:S:t:T:u::U:vVW:X:zZ",
|
|
||||||
+ "#:123456789a:A:b:BcC::d:D:e::E::f:F:gGhH::i:I:jJ:kKlL:mM:n:N:o:Op:P:qrRs:S:t:T:u::U:vVw:W:X:zZ",
|
|
||||||
long_options, &option_index);
|
|
||||||
|
|
||||||
if (c == -1)
|
|
@ -1,6 +1,6 @@
|
|||||||
diff -up enscript-1.6.5.1/afm/Makefile.am.rh477382 enscript-1.6.5.1/afm/Makefile.am
|
diff -up enscript-1.6.6/afm/Makefile.am.rh477382 enscript-1.6.6/afm/Makefile.am
|
||||||
--- enscript-1.6.5.1/afm/Makefile.am.rh477382 2010-03-06 14:02:53.000000000 +0100
|
--- enscript-1.6.6/afm/Makefile.am.rh477382 2012-09-20 00:17:34.000000000 +0200
|
||||||
+++ enscript-1.6.5.1/afm/Makefile.am 2010-05-21 13:09:28.000346827 +0200
|
+++ enscript-1.6.6/afm/Makefile.am 2012-09-26 13:42:09.223974485 +0200
|
||||||
@@ -29,9 +29,12 @@ hvnbo.afm hvno.afm hvo.afm ncb.afm ncbi.
|
@@ -29,9 +29,12 @@ hvnbo.afm hvno.afm hvo.afm ncb.afm ncbi.
|
||||||
pobi.afm poi.afm por.afm sy.afm tib.afm tibi.afm tii.afm tir.afm \
|
pobi.afm poi.afm por.afm sy.afm tib.afm tibi.afm tii.afm tir.afm \
|
||||||
zcmi.afm zd.afm
|
zcmi.afm zd.afm
|
||||||
@ -9,16 +9,16 @@ diff -up enscript-1.6.5.1/afm/Makefile.am.rh477382 enscript-1.6.5.1/afm/Makefile
|
|||||||
+public_fonts = matrix.afm matrix.eps
|
+public_fonts = matrix.afm matrix.eps
|
||||||
|
|
||||||
afmdir = $(pkgdatadir)/afm
|
afmdir = $(pkgdatadir)/afm
|
||||||
dist_afm_DATA = font.map $(default_afm) $(public_fonts)
|
dist_afm_DATA = font.map $(default_afm) $(public_fonts) MustRead.html
|
||||||
|
|
||||||
EXTRA_DIST = ChangeLog.old
|
EXTRA_DIST = ChangeLog.old
|
||||||
+
|
+
|
||||||
+matrix.eps: matrix.pfa
|
+matrix.eps: matrix.pfa
|
||||||
+ cp matrix.pfa matrix.eps
|
+ cp matrix.pfa matrix.eps
|
||||||
diff -up enscript-1.6.5.1/src/util.c.rh477382 enscript-1.6.5.1/src/util.c
|
diff -up enscript-1.6.6/src/util.c.rh477382 enscript-1.6.6/src/util.c
|
||||||
--- enscript-1.6.5.1/src/util.c.rh477382 2009-12-28 00:57:12.000000000 +0100
|
--- enscript-1.6.6/src/util.c.rh477382 2011-10-30 17:48:42.000000000 +0100
|
||||||
+++ enscript-1.6.5.1/src/util.c 2010-05-21 13:08:10.920347803 +0200
|
+++ enscript-1.6.6/src/util.c 2012-09-26 13:40:53.336866463 +0200
|
||||||
@@ -1079,9 +1079,16 @@ download_font (char *name)
|
@@ -1084,9 +1084,16 @@ download_font (char *name)
|
||||||
buffer_append (&fname, ".pfb");
|
buffer_append (&fname, ".pfb");
|
||||||
if (stat (buffer_ptr (&fname), &stat_st) != 0)
|
if (stat (buffer_ptr (&fname), &stat_st) != 0)
|
||||||
{
|
{
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A plain ASCII to PostScript converter
|
Summary: A plain ASCII to PostScript converter
|
||||||
Name: enscript
|
Name: enscript
|
||||||
Version: 1.6.5.2
|
Version: 1.6.6
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
URL: http://www.gnu.org/software/enscript
|
URL: http://www.gnu.org/software/enscript
|
||||||
@ -14,15 +14,12 @@ Source1: enscript-ruby-1.6.4.tar.gz
|
|||||||
Source2: enscript-php-1.6.4.st
|
Source2: enscript-php-1.6.4.st
|
||||||
#http://home.raxnet.net/downloads/viewcvs/php.st
|
#http://home.raxnet.net/downloads/viewcvs/php.st
|
||||||
|
|
||||||
# RH #177336
|
|
||||||
Patch1: enscript-1.6.4-hilight.patch
|
|
||||||
# RH #61294
|
# RH #61294
|
||||||
Patch3: enscript-1.6.1-locale.patch
|
Patch3: enscript-1.6.1-locale.patch
|
||||||
|
|
||||||
# RH #224548
|
# RH #224548
|
||||||
Patch8: enscript-wrap_header.patch
|
Patch8: enscript-wrap_header.patch
|
||||||
|
|
||||||
Patch9: enscript-1.6.4-rh457719.patch
|
|
||||||
Patch10:enscript-1.6.4-rh457720.patch
|
Patch10:enscript-1.6.4-rh457720.patch
|
||||||
Patch12:enscript-rh477382.patch
|
Patch12:enscript-rh477382.patch
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
@ -43,10 +40,8 @@ includes many options for customizing printouts
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .hilight
|
|
||||||
%patch3 -p1 -b .locale
|
%patch3 -p1 -b .locale
|
||||||
%patch8 -p1 -b .wrap_header
|
%patch8 -p1 -b .wrap_header
|
||||||
%patch9 -p1 -b .rh457719
|
|
||||||
%patch10 -p1 -b .rh457720
|
%patch10 -p1 -b .rh457720
|
||||||
%patch12 -p1 -b .rh477382
|
%patch12 -p1 -b .rh477382
|
||||||
|
|
||||||
@ -109,6 +104,12 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/enscript.cfg
|
%config(noreplace) %{_sysconfdir}/enscript.cfg
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 26 2012 Adam Tkac <atkac redhat com> - 1.6.6-1
|
||||||
|
- update to 1.6.6
|
||||||
|
- paches merged
|
||||||
|
- enscript-1.6.4-hilight.patch
|
||||||
|
- enscript-1.6.4-rh457719.patch
|
||||||
|
|
||||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.5.2-6
|
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.5.2-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
f3a0083638ac3fddc493d44b6515182a enscript-php-1.6.4.st
|
f3a0083638ac3fddc493d44b6515182a enscript-php-1.6.4.st
|
||||||
fa9c837b2a258716411f6df827d36eb3 enscript-ruby-1.6.4.tar.gz
|
fa9c837b2a258716411f6df827d36eb3 enscript-ruby-1.6.4.tar.gz
|
||||||
c1d2a0d4b44ca30634742b299881b0e2 enscript-1.6.5.2.tar.gz
|
3acc242b829adacabcaf28533f049afd enscript-1.6.6.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user