Initial import
This commit is contained in:
parent
8c2a9e9520
commit
b0dc8d22b8
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/enchant-2.2.0.tar.gz
|
102
enchant2.spec
Normal file
102
enchant2.spec
Normal file
@ -0,0 +1,102 @@
|
||||
Name: enchant2
|
||||
Version: 2.2.0
|
||||
Release: 2%{?snap}%{?dist}
|
||||
Summary: An Enchanting Spell Checking Library
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/AbiWord/enchant
|
||||
Source0: https://github.com/AbiWord/enchant/releases/download/v%{version}/enchant-%{version}.tar.gz
|
||||
# Fix FSF addresses (https://github.com/AbiWord/enchant/pull/176)
|
||||
Patch0: enchant2_fsfaddr.patch
|
||||
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: aspell-devel
|
||||
BuildRequires: hunspell-devel
|
||||
BuildRequires: libvoikko-devel
|
||||
|
||||
Provides: bundled(gnulib)
|
||||
|
||||
|
||||
%description
|
||||
A library that wraps other spell checking backends.
|
||||
|
||||
|
||||
%package aspell
|
||||
Summary: Integration with aspell for libenchant
|
||||
Requires: enchant2%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description aspell
|
||||
Libraries necessary to integrate applications using libenchant with aspell.
|
||||
|
||||
%package voikko
|
||||
Summary: Integration with voikko for libenchant
|
||||
Requires: enchant2%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description voikko
|
||||
Libraries necessary to integrate applications using libenchant with voikko.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: enchant2%{?_isa} = %{version}-%{release}
|
||||
Requires: glib2-devel
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n enchant-%{version}
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--with-aspell \
|
||||
--with-hunspell-dir=%{_datadir}/myspell \
|
||||
--disable-static
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g;
|
||||
s|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
%make_build pkgdatadir=%{_datadir}/enchant-2
|
||||
|
||||
|
||||
%install
|
||||
%make_install pkgdatadir=%{_datadir}/enchant-2
|
||||
find %{buildroot} -name '*.la' -delete
|
||||
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
|
||||
%files
|
||||
%doc AUTHORS NEWS README
|
||||
%license COPYING.LIB
|
||||
%{_bindir}/enchant-2
|
||||
%{_bindir}/enchant-lsmod-2
|
||||
%{_libdir}/libenchant-2.so.*
|
||||
%dir %{_libdir}/enchant-2
|
||||
%{_libdir}/enchant-2/enchant_hunspell.so
|
||||
%{_mandir}/man1/*
|
||||
%{_datadir}/enchant-2
|
||||
|
||||
%files aspell
|
||||
%{_libdir}/enchant-2/enchant_aspell.so*
|
||||
|
||||
%files voikko
|
||||
%{_libdir}/enchant-2/enchant_voikko.so*
|
||||
|
||||
%files devel
|
||||
%{_libdir}/libenchant-2.so
|
||||
%{_libdir}/pkgconfig/enchant-2.pc
|
||||
%{_includedir}/enchant-2
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Dec 14 2017 Sandro Mani <manisandro@gmail.com> - 2.2.0-2
|
||||
- Add patch to fix FSF addresses
|
||||
- Kill rpath
|
||||
|
||||
* Wed Dec 13 2017 Sandro Mani <manisandro@gmail.com> - 2.2.0-1
|
||||
- Initial package
|
227
enchant2_fsfaddr.patch
Normal file
227
enchant2_fsfaddr.patch
Normal file
@ -0,0 +1,227 @@
|
||||
From adcb08292d4650a1c258f9b02c53cf1e26b47185 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?= <zebob.m@gmail.com>
|
||||
Date: Thu, 14 Dec 2017 15:32:58 +0100
|
||||
Subject: [PATCH] Fix FSF address
|
||||
|
||||
---
|
||||
COPYING.LIB | 4 ++--
|
||||
providers/applespell_checker.mm | 2 +-
|
||||
providers/enchant_aspell.c | 2 +-
|
||||
providers/enchant_hspell.c | 2 +-
|
||||
providers/enchant_hunspell.cpp | 2 +-
|
||||
providers/enchant_voikko.c | 2 +-
|
||||
providers/enchant_zemberek.cpp | 2 +-
|
||||
src/enchant++.h | 2 +-
|
||||
src/enchant-lsmod.c | 2 +-
|
||||
src/enchant-provider.h | 2 +-
|
||||
src/enchant.c | 2 +-
|
||||
src/enchant.h | 2 +-
|
||||
src/lib.c | 2 +-
|
||||
src/pwl.c | 2 +-
|
||||
src/pwl.h | 2 +-
|
||||
15 files changed, 16 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/COPYING.LIB b/COPYING.LIB
|
||||
index d74274e..ae23fcf 100644
|
||||
--- a/COPYING.LIB
|
||||
+++ b/COPYING.LIB
|
||||
@@ -2,7 +2,7 @@
|
||||
Version 2.1, February 1999
|
||||
|
||||
Copyright (C) 1991, 1999 Free Software Foundation, Inc.
|
||||
- 59 Temple Place, Suite 330, Boston, MA 02110-1301 USA
|
||||
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
Everyone is permitted to copy and distribute verbatim copies
|
||||
of this license document, but changing it is not allowed.
|
||||
|
||||
@@ -485,7 +485,7 @@ convey the exclusion of warranty; and each file should have at least the
|
||||
|
||||
You should have received a copy of the GNU Lesser General Public
|
||||
License along with this library; if not, write to the Free Software
|
||||
- Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
|
||||
Also add information on how to contact you by electronic and paper mail.
|
||||
|
||||
diff --git a/providers/applespell_checker.mm b/providers/applespell_checker.mm
|
||||
index 912e265..ed32705 100644
|
||||
--- a/providers/applespell_checker.mm
|
||||
+++ b/providers/applespell_checker.mm
|
||||
@@ -14,7 +14,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU General Public License
|
||||
* along with this program; if not, write to the Free Software
|
||||
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
|
||||
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
|
||||
* 02110-1301, USA.
|
||||
*/
|
||||
|
||||
diff --git a/providers/enchant_aspell.c b/providers/enchant_aspell.c
|
||||
index a3f1f62..b9083c3 100644
|
||||
--- a/providers/enchant_aspell.c
|
||||
+++ b/providers/enchant_aspell.c
|
||||
@@ -13,7 +13,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/providers/enchant_hspell.c b/providers/enchant_hspell.c
|
||||
index 0e5bbac..1e911ce 100644
|
||||
--- a/providers/enchant_hspell.c
|
||||
+++ b/providers/enchant_hspell.c
|
||||
@@ -14,7 +14,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz and Yaacov Zamir
|
||||
diff --git a/providers/enchant_hunspell.cpp b/providers/enchant_hunspell.cpp
|
||||
index 452d1b3..e72b861 100644
|
||||
--- a/providers/enchant_hunspell.cpp
|
||||
+++ b/providers/enchant_hunspell.cpp
|
||||
@@ -13,7 +13,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/providers/enchant_voikko.c b/providers/enchant_voikko.c
|
||||
index d6df8ba..4b82395 100644
|
||||
--- a/providers/enchant_voikko.c
|
||||
+++ b/providers/enchant_voikko.c
|
||||
@@ -16,7 +16,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/providers/enchant_zemberek.cpp b/providers/enchant_zemberek.cpp
|
||||
index 6b553b2..83a895a 100644
|
||||
--- a/providers/enchant_zemberek.cpp
|
||||
+++ b/providers/enchant_zemberek.cpp
|
||||
@@ -13,7 +13,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/src/enchant++.h b/src/enchant++.h
|
||||
index 58e3a7b..68ebaf9 100644
|
||||
--- a/src/enchant++.h
|
||||
+++ b/src/enchant++.h
|
||||
@@ -13,7 +13,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/src/enchant-lsmod.c b/src/enchant-lsmod.c
|
||||
index b23ac5f..0caea2c 100644
|
||||
--- a/src/enchant-lsmod.c
|
||||
+++ b/src/enchant-lsmod.c
|
||||
@@ -14,7 +14,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/src/enchant-provider.h b/src/enchant-provider.h
|
||||
index 65c827d..0c98646 100644
|
||||
--- a/src/enchant-provider.h
|
||||
+++ b/src/enchant-provider.h
|
||||
@@ -13,7 +13,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/src/enchant.c b/src/enchant.c
|
||||
index 6cf8b7c..c7e958e 100644
|
||||
--- a/src/enchant.c
|
||||
+++ b/src/enchant.c
|
||||
@@ -15,7 +15,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/src/enchant.h b/src/enchant.h
|
||||
index 9f00255..171f8a8 100644
|
||||
--- a/src/enchant.h
|
||||
+++ b/src/enchant.h
|
||||
@@ -13,7 +13,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/src/lib.c b/src/lib.c
|
||||
index 96f4390..7299301 100644
|
||||
--- a/src/lib.c
|
||||
+++ b/src/lib.c
|
||||
@@ -14,7 +14,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/src/pwl.c b/src/pwl.c
|
||||
index a048908..79ce01b 100644
|
||||
--- a/src/pwl.c
|
||||
+++ b/src/pwl.c
|
||||
@@ -13,7 +13,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
||||
diff --git a/src/pwl.h b/src/pwl.h
|
||||
index 17d435d..f713b29 100644
|
||||
--- a/src/pwl.h
|
||||
+++ b/src/pwl.h
|
||||
@@ -13,7 +13,7 @@
|
||||
*
|
||||
* You should have received a copy of the GNU Lesser General Public
|
||||
* License along with this library; if not, write to the
|
||||
- * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
|
||||
* Boston, MA 02110-1301, USA.
|
||||
*
|
||||
* In addition, as a special exception, Dom Lachowicz
|
Loading…
Reference in New Issue
Block a user