- update to 22.3 (#461448)
- emacs-22.1.50-sparc64.patch and emacs-22.1.50-regex.patch no longer needed - update rpm-spec-mode.el to look for fields at bol (#466407)
This commit is contained in:
parent
a631929c09
commit
ecfa7357eb
@ -1,4 +1 @@
|
||||
emacs-22.1.50.tar.gz
|
||||
php-mode-1.2.0.tgz
|
||||
emacs-23.0.60.tar.gz
|
||||
emacs-22.2.tar.gz
|
||||
emacs-22.3.tar.gz
|
||||
|
@ -1,55 +0,0 @@
|
||||
for src/ChangeLog
|
||||
from Alexandre Oliva <aoliva@redhat.com>
|
||||
|
||||
* regex.c (MOVE_BUFFER_POINTER, EXTEND_BUFFER): Don't compute
|
||||
offsets between unrelated pointers.
|
||||
|
||||
--- emacs-22.1.50.orig/src/regex.c 2007-09-10 15:46:20.000000000 -0300
|
||||
+++ emacs-22.1.50/src/regex.c 2008-03-22 08:07:06.000000000 -0300
|
||||
@@ -3,7 +3,7 @@
|
||||
internationalization features.)
|
||||
|
||||
Copyright (C) 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
|
||||
- 2002, 2003, 2004, 2005, 2006, 2007
|
||||
+ 2002, 2003, 2004, 2005, 2006, 2007, 2008
|
||||
Free Software Foundation, Inc.
|
||||
|
||||
This program is free software; you can redistribute it and/or modify
|
||||
@@ -1832,8 +1832,10 @@
|
||||
being larger than MAX_BUF_SIZE, then flag memory exhausted. */
|
||||
#if __BOUNDED_POINTERS__
|
||||
# define SET_HIGH_BOUND(P) (__ptrhigh (P) = __ptrlow (P) + bufp->allocated)
|
||||
-# define MOVE_BUFFER_POINTER(P) \
|
||||
- (__ptrlow (P) += incr, SET_HIGH_BOUND (P), __ptrvalue (P) += incr)
|
||||
+# define MOVE_BUFFER_POINTER(P) \
|
||||
+ (__ptrlow (P) = new_buffer + (__ptrlow (P) - old_buffer), \
|
||||
+ SET_HIGH_BOUND (P), \
|
||||
+ __ptrvalue (P) = new_buffer + (__ptrvalue (P) - old_buffer))
|
||||
# define ELSE_EXTEND_BUFFER_HIGH_BOUND \
|
||||
else \
|
||||
{ \
|
||||
@@ -1847,12 +1849,12 @@
|
||||
SET_HIGH_BOUND (pending_exact); \
|
||||
}
|
||||
#else
|
||||
-# define MOVE_BUFFER_POINTER(P) (P) += incr
|
||||
+# define MOVE_BUFFER_POINTER(P) ((P) = new_buffer + ((P) - old_buffer))
|
||||
# define ELSE_EXTEND_BUFFER_HIGH_BOUND
|
||||
#endif
|
||||
#define EXTEND_BUFFER() \
|
||||
do { \
|
||||
- re_char *old_buffer = bufp->buffer; \
|
||||
+ unsigned char *old_buffer = bufp->buffer; \
|
||||
if (bufp->allocated == MAX_BUF_SIZE) \
|
||||
return REG_ESIZE; \
|
||||
bufp->allocated <<= 1; \
|
||||
@@ -1864,7 +1866,7 @@
|
||||
/* If the buffer moved, move all the pointers into it. */ \
|
||||
if (old_buffer != bufp->buffer) \
|
||||
{ \
|
||||
- int incr = bufp->buffer - old_buffer; \
|
||||
+ unsigned char *new_buffer = bufp->buffer; \
|
||||
MOVE_BUFFER_POINTER (b); \
|
||||
MOVE_BUFFER_POINTER (begalt); \
|
||||
if (fixup_alt_jump) \
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- emacs-22.1.50/src/m/sparc.h.old 2008-02-11 01:26:36.000000000 -0600
|
||||
+++ emacs-22.1.50/src/m/sparc.h 2008-02-11 09:12:09.000000000 -0600
|
||||
@@ -93,6 +93,19 @@
|
||||
|
||||
#ifdef __arch64__ /* GCC, 64-bit ABI. */
|
||||
#define BITS_PER_LONG 64
|
||||
+#ifdef __linux__
|
||||
+#undef START_FILES
|
||||
+#define START_FILES pre-crt0.o /usr/lib64/crt1.o /usr/lib64/crti.o
|
||||
+
|
||||
+/* The duplicate -lgcc is intentional in the definition of LIB_STANDARD.
|
||||
+ The reason is that some functions in libgcc.a call functions from libc.a,
|
||||
+ and some libc.a functions need functions from libgcc.a. Since most
|
||||
+ versions of ld are one-pass linkers, we need to mention -lgcc twice,
|
||||
+ or else we risk getting unresolved externals. */
|
||||
+#undef LIB_STANDARD
|
||||
+#define LIB_STANDARD -lgcc -lc -lgcc /usr/lib64/crtn.o
|
||||
+#endif
|
||||
+
|
||||
#ifndef _LP64
|
||||
#define _LP64 /* Done on Alpha -- not sure if it
|
||||
should be here. -- fx */
|
13
emacs.spec
13
emacs.spec
@ -3,8 +3,8 @@
|
||||
Summary: GNU Emacs text editor
|
||||
Name: emacs
|
||||
Epoch: 1
|
||||
Version: 22.2
|
||||
Release: 4%{?dist}
|
||||
Version: 22.3
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/emacs/
|
||||
Group: Applications/Editors
|
||||
@ -27,8 +27,6 @@ Source21: igrep-init.el
|
||||
Patch0: glibc-open-macro.patch
|
||||
Patch1: rpm-spec-mode.patch
|
||||
Patch2: po-mode-auto-replace-date-71264.patch
|
||||
Patch3: emacs-22.1.50-sparc64.patch
|
||||
Patch4: emacs-22.1.50-regex.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: atk-devel, cairo-devel, freetype-devel, fontconfig-devel, giflib-devel, glibc-devel, gtk2-devel, libpng-devel
|
||||
BuildRequires: libjpeg-devel, libtiff-devel, libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel, libXt-devel
|
||||
@ -105,8 +103,6 @@ Emacs packages or see some elisp examples.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .glibc-open-macro
|
||||
%patch3 -p1 -b .sparc64-libdir
|
||||
%patch4 -p1 -b .regexp
|
||||
|
||||
# install rest of site-lisp files
|
||||
( cd site-lisp
|
||||
@ -313,6 +309,11 @@ alternatives --install %{_bindir}/etags emacs.etags %{_bindir}/etags.emacs 80 \
|
||||
%dir %{_datadir}/emacs/%{version}
|
||||
|
||||
%changelog
|
||||
* Sat Nov 8 2008 Jens Petersen <petersen@redhat.com> - 1:22.3-1
|
||||
- update to 22.3 (#461448)
|
||||
- emacs-22.1.50-sparc64.patch and emacs-22.1.50-regex.patch no longer needed
|
||||
- update rpm-spec-mode.el to look for fields at bol (#466407)
|
||||
|
||||
* Thu May 01 2008 Tom "spot" Callaway <tcallawa@redhat.com>
|
||||
- fix requires to include epoch
|
||||
|
||||
|
@ -1255,7 +1255,7 @@ See `search-forward-regexp'."
|
||||
(let ((str
|
||||
(progn
|
||||
(goto-char (point-min))
|
||||
(search-forward-regexp (concat
|
||||
(search-forward-regexp (concat "^"
|
||||
field ":[ \t]*\\(.*?\\)[ \t]*$") max)
|
||||
(match-string 1))))
|
||||
;; Try to expand macros
|
||||
|
Loading…
Reference in New Issue
Block a user