- revert back to emacs-22.2 (bz443639)
- update to php-mode-1.4.0 - update to rpm-spec-mode.el v0.12.1x (bz432209) - patch rpm-spec-mode to use compilation mode (bz227418) - fix the Release tag (bz440624) - drop superfluous configure options - move the new icons into the right destination directory
This commit is contained in:
parent
0a75a378b6
commit
dcc57fca80
@ -1,3 +1,4 @@
|
||||
emacs-22.1.50.tar.gz
|
||||
php-mode-1.2.0.tgz
|
||||
emacs-23.0.60.tar.gz
|
||||
emacs-22.2.tar.gz
|
||||
|
52
emacs.spec
52
emacs.spec
@ -2,29 +2,31 @@
|
||||
|
||||
Summary: GNU Emacs text editor
|
||||
Name: emacs
|
||||
Version: 23.0.60
|
||||
Release: 2%{?dist}
|
||||
License: GPL
|
||||
Version: 22.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/emacs/
|
||||
Group: Applications/Editors
|
||||
Source0: ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{version}.tar.gz
|
||||
Source0: ftp://ftp.gnu.org/gnu/emacs/emacs-%{version}.tar.gz
|
||||
Source1: emacs.desktop
|
||||
Source3: dotemacs.el
|
||||
Source4: site-start.el
|
||||
Source6: http://cvs.xemacs.org/viewcvs.cgi/XEmacs/packages/xemacs-packages/prog-modes/rpm-spec-mode.el
|
||||
Source7: http://download.sourceforge.net/php-mode/php-mode-1.2.0.tgz
|
||||
Source7: http://php-mode.svn.sourceforge.net/svnroot/php-mode/tags/php-mode-1.4.0/php-mode.el
|
||||
Source8: php-mode-init.el
|
||||
Source9: ssl.el
|
||||
# rpm-spec-mode from Xemacs
|
||||
Source10: http://cvs.xemacs.org/viewcvs.cgi/XEmacs/packages/xemacs-packages/prog-modes/rpm-spec-mode.el
|
||||
Source11: rpm-spec-mode-init.el
|
||||
Source13: focus-init.el
|
||||
Source14: po-mode.el
|
||||
Source15: po-mode-init.el
|
||||
Source16: po-mode-auto-replace-date-71264.patch
|
||||
Source18: default.el
|
||||
Source19: wrapper
|
||||
Source20: igrep.el
|
||||
Source21: igrep-init.el
|
||||
Patch0: glibc-open-macro.patch
|
||||
Patch1: rpm-spec-mode.patch
|
||||
Patch2: po-mode-auto-replace-date-71264.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: atk-devel, cairo-devel, freetype-devel, fontconfig-devel, giflib-devel, glibc-devel, gtk2-devel, libpng-devel
|
||||
BuildRequires: libjpeg-devel, libtiff-devel, libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel, libXt-devel
|
||||
@ -100,11 +102,13 @@ Emacs packages or see some elisp examples.
|
||||
%patch0 -p1 -b .glibc-open-macro
|
||||
|
||||
# install rest of site-lisp files
|
||||
( cd site-lisp
|
||||
cp %SOURCE6 %SOURCE9 %SOURCE14 %SOURCE20 .
|
||||
tar xfz %SOURCE7 # php-mode
|
||||
( ! [ -d site-lisp ] && mkdir site-lisp
|
||||
cd site-lisp
|
||||
cp %SOURCE7 %SOURCE9 %SOURCE10 %SOURCE14 %SOURCE20 .
|
||||
# rpm-spec-mode can use compilation-mode
|
||||
patch < %PATCH1
|
||||
# fix po-auto-replace-revision-date nil
|
||||
patch < %SOURCE16 )
|
||||
patch < %PATCH2 )
|
||||
|
||||
# we prefer our emacs.desktop file
|
||||
cp %SOURCE1 etc/emacs.desktop
|
||||
@ -121,7 +125,7 @@ rm -f etc/sex.6 etc/condom.1 etc/celibacy.1 etc/COOKIES etc/future-bug etc/JOKES
|
||||
%build
|
||||
export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
|
||||
|
||||
%configure --with-pop --with-sound --with-x-toolkit=gtk --enable-font-backend
|
||||
%configure --with-x-toolkit=gtk
|
||||
|
||||
%__make bootstrap
|
||||
%__make %{?_smp_mflags}
|
||||
@ -194,6 +198,17 @@ install -m 0644 emacs.pc %{buildroot}/%{pkgconfig}
|
||||
rm -f %{buildroot}%{_infodir}/dir
|
||||
rm %{buildroot}%{_localstatedir}/games/emacs/*
|
||||
|
||||
# Open desktop application
|
||||
mkdir -p %{buildroot}%{_datadir}/applications
|
||||
install -m 0644 %SOURCE1 %{buildroot}%{_datadir}/applications/emacs.desktop
|
||||
|
||||
# put the icons where they belong
|
||||
for i in 16 24 32 48 ; do
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
|
||||
cp %{buildroot}%{_datadir}/emacs/%{version}/etc/images/icons/emacs_${i}.png \
|
||||
%{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/emacs.png
|
||||
done
|
||||
|
||||
#
|
||||
# create file lists
|
||||
#
|
||||
@ -254,7 +269,7 @@ alternatives --install %{_bindir}/etags emacs.etags %{_bindir}/etags.emacs 80 \
|
||||
%dir %{_libexecdir}/emacs/%{version}
|
||||
%dir %{emacs_libexecdir}
|
||||
%{_datadir}/applications/emacs.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/emacs*.png
|
||||
%{_datadir}/icons/hicolor/*/apps/emacs.png
|
||||
|
||||
%files nox
|
||||
%defattr(-,root,root)
|
||||
@ -266,7 +281,7 @@ alternatives --install %{_bindir}/etags emacs.etags %{_bindir}/etags.emacs 80 \
|
||||
%files -f common-filelist common
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/skel/.emacs
|
||||
%doc etc/NEWS BUGS README
|
||||
%doc etc/NEWS BUGS README
|
||||
%exclude %{_bindir}/emacs-*
|
||||
%{_bindir}/*
|
||||
%{_mandir}/*/*
|
||||
@ -286,6 +301,15 @@ alternatives --install %{_bindir}/etags emacs.etags %{_bindir}/etags.emacs 80 \
|
||||
%dir %{_datadir}/emacs/%{version}
|
||||
|
||||
%changelog
|
||||
* Tue Apr 22 2008 Chip Coldwell <coldwell@redhat.com> 22.2-1
|
||||
- revert back to emacs-22.2 (bz443639)
|
||||
- update to php-mode-1.4.0
|
||||
- update to rpm-spec-mode.el v0.12.1x (bz432209)
|
||||
- patch rpm-spec-mode to use compilation mode (bz227418)
|
||||
- fix the Release tag (bz440624)
|
||||
- drop superfluous configure options
|
||||
- move the new icons into the right destination directory
|
||||
|
||||
* Fri Apr 18 2008 Chip Coldwell <coldwell@redhat.com> 23.0.60-2
|
||||
- New upstream tarball (fixes bz435767)
|
||||
- configure tweaks
|
||||
|
1121
php-mode.el
Normal file
1121
php-mode.el
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,4 +1,4 @@
|
||||
;; rpm-spec-mode for spec files
|
||||
|
||||
(autoload 'rpm-spec-mode "rpm-spec-mode" "RPM spec mode." t)
|
||||
(add-to-list 'auto-mode-alist '("\\.spec$" . rpm-spec-mode))
|
||||
(add-to-list 'auto-mode-alist '("\\.spec\\(\\.in\\)?$" . rpm-spec-mode))
|
||||
|
@ -63,7 +63,7 @@
|
||||
|
||||
;;; Code:
|
||||
|
||||
(defconst rpm-spec-mode-version "0.12x" "Version of `rpm-spec-mode'.")
|
||||
(defconst rpm-spec-mode-version "0.12.1x" "Version of `rpm-spec-mode'.")
|
||||
|
||||
(defgroup rpm-spec nil
|
||||
"RPM spec mode with Emacs/XEmacs enhancements."
|
||||
@ -1233,14 +1233,17 @@ command."
|
||||
(save-excursion
|
||||
(goto-char (point-min))
|
||||
(if (search-forward-regexp
|
||||
"^\\(Release[ \t]*:[ \t]*\\)\\([0-9]+\\)\\(.*\\)" nil t)
|
||||
(let ((release (1+ (string-to-int (match-string 2)))))
|
||||
(setq release (concat (int-to-string release) (match-string 3)))
|
||||
;; Try to find the last digit-only group of a dot-separated release string
|
||||
(concat "^\\(Release[ \t]*:[ \t]*\\)"
|
||||
"\\(.*[ \t\\.}]\\)\\([0-9]+\\)\\([ \t\\.%].*\\|$\\)") nil t)
|
||||
(let ((release (1+ (string-to-int (match-string 3)))))
|
||||
(setq release
|
||||
(concat (match-string 2) (int-to-string release) (match-string 4)))
|
||||
(replace-match (concat (match-string 1) release))
|
||||
(message "Release tag changed to %s." release))
|
||||
(if (search-forward-regexp "^Release[ \t]*:[ \t]*%{?\\([^}]*\\)}?$" nil t)
|
||||
(rpm-increase-release-with-macros)
|
||||
(message "No Release tag found...")))))
|
||||
(message "No Release tag to increase found...")))))
|
||||
|
||||
;;------------------------------------------------------------
|
||||
|
||||
|
91
rpm-spec-mode.patch
Normal file
91
rpm-spec-mode.patch
Normal file
@ -0,0 +1,91 @@
|
||||
--- rpm-spec-mode.el~ 2008-04-22 15:14:40.000000000 -0400
|
||||
+++ rpm-spec-mode.el 2008-04-22 16:19:09.000000000 -0400
|
||||
@@ -63,7 +63,9 @@
|
||||
|
||||
;;; Code:
|
||||
|
||||
-(defconst rpm-spec-mode-version "0.12.1x" "Version of `rpm-spec-mode'.")
|
||||
+(require 'compile)
|
||||
+
|
||||
+(defconst rpm-spec-mode-version "0.12.1x.rh1" "Version of `rpm-spec-mode'.")
|
||||
|
||||
(defgroup rpm-spec nil
|
||||
"RPM spec mode with Emacs/XEmacs enhancements."
|
||||
@@ -189,11 +191,6 @@
|
||||
:type 'boolean
|
||||
:group 'rpm-spec)
|
||||
|
||||
-(defcustom rpm-spec-use-compilation-mode t
|
||||
- "*If non-nil, build in `compilation-mode' if it's available."
|
||||
- :type 'boolean
|
||||
- :group 'rpm-spec)
|
||||
-
|
||||
(defcustom rpm-spec-default-release "1"
|
||||
"*Default value for the Release tag in new spec files."
|
||||
:type 'string
|
||||
@@ -225,6 +222,11 @@
|
||||
:type 'string
|
||||
:group 'rpm-spec)
|
||||
|
||||
+(defcustom rpm-spec-auto-topdir nil
|
||||
+ "*Automatically detect an rpm build directory tree and define _topdir."
|
||||
+ :type 'boolean
|
||||
+ :group 'rpm-spec)
|
||||
+
|
||||
(defgroup rpm-spec-faces nil
|
||||
"Font lock faces for `rpm-spec-mode'."
|
||||
:prefix "rpm-spec-"
|
||||
@@ -1025,20 +1027,30 @@
|
||||
(setq buildoptions (cons "--nodeps" buildoptions)))
|
||||
(if (and rpm-spec-sign-gpg (not rpm-no-gpg))
|
||||
(setq buildoptions (cons "--sign" buildoptions)))
|
||||
- (save-excursion
|
||||
- (set-buffer (get-buffer rpm-buffer-name))
|
||||
- (and rpm-spec-use-compilation-mode
|
||||
- (fboundp 'compilation-mode)
|
||||
- (compilation-mode))
|
||||
- (goto-char (point-max)))
|
||||
- (let* ((process-environment (cons "EMACS=t" process-environment))
|
||||
- (process
|
||||
- (apply 'start-process rpm-spec-build-command rpm-buffer-name
|
||||
- rpm-spec-build-command buildoptions)))
|
||||
- (if (and rpm-spec-sign-gpg (not rpm-no-gpg))
|
||||
- (let ((rpm-passwd-cache (read-passwd "GPG passphrase: ")))
|
||||
- (process-send-string process (concat rpm-passwd-cache "\n"))))
|
||||
- (set-process-filter process 'rpm-command-filter)))
|
||||
+
|
||||
+ (if rpm-spec-auto-topdir
|
||||
+ (if (string-match ".*/SPECS/$" default-directory)
|
||||
+ (let ((topdir (expand-file-name default-directory)))
|
||||
+ (setq buildoptions
|
||||
+ (cons
|
||||
+ (concat "--define \"_topdir "
|
||||
+ (replace-regexp-in-string "/SPECS/$" "" topdir)
|
||||
+ "\"")
|
||||
+ buildoptions)))))
|
||||
+
|
||||
+ (progn
|
||||
+ (defun list->string (lst)
|
||||
+ (if (cdr lst)
|
||||
+ (concat (car lst) " " (list->string (cdr lst)))
|
||||
+ (car lst)))
|
||||
+ (compilation-start (list->string (cons rpm-spec-build-command buildoptions)) 'rpmbuild-mode))
|
||||
+
|
||||
+ (if (and rpm-spec-sign-gpg (not rpm-no-gpg))
|
||||
+ (let ((build-proc (get-buffer-process
|
||||
+ (get-buffer
|
||||
+ (compilation-buffer-name "rpmbuild" nil nil))))
|
||||
+ (rpm-passwd-cache (read-passwd "GPG passphrase: ")))
|
||||
+ (process-send-string build-proc (concat rpm-passwd-cache "\n")))))
|
||||
|
||||
(defun rpm-build-prepare (&optional arg)
|
||||
"Run a `rpmbuild -bp'."
|
||||
@@ -1409,5 +1421,8 @@
|
||||
;;;###autoload(add-to-list 'auto-mode-alist '("\\.spec\\(\\.in\\)?$" . rpm-spec-mode))
|
||||
|
||||
(provide 'rpm-spec-mode)
|
||||
+;;;###autoload
|
||||
+(define-compilation-mode rpmbuild-mode "RPM build" ""
|
||||
+ (set (make-local-variable 'compilation-disable-input) t))
|
||||
|
||||
;;; rpm-spec-mode.el ends here
|
Loading…
Reference in New Issue
Block a user