Remove obsolete patches
Signed-off-by: Petr Hracek <phracek@redhat.com>
This commit is contained in:
parent
5e82f73ff7
commit
d8d465e820
@ -1,37 +0,0 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 458648e..077fe50 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -3072,10 +3072,12 @@ if test "${opsys}" = "mingw32"; then
|
||||
AH_TEMPLATE(HAVE_JPEG, [Define to 1 if you have the jpeg library (-ljpeg).])dnl
|
||||
if test "${HAVE_JPEG}" = "yes"; then
|
||||
AC_DEFINE(HAVE_JPEG)
|
||||
- AC_EGREP_CPP([version= *(6[2-9]|[7-9][0-9])],
|
||||
+ AC_EGREP_CPP([version 6b or later],
|
||||
[#include <jpeglib.h>
|
||||
- version=JPEG_LIB_VERSION
|
||||
-],
|
||||
+ #if JPEG_LIB_VERSION >= 62
|
||||
+ version 6b or later
|
||||
+ #endif
|
||||
+ ],
|
||||
[AC_DEFINE(HAVE_JPEG)],
|
||||
[AC_MSG_WARN([libjpeg found, but not version 6b or later])
|
||||
HAVE_JPEG=no])
|
||||
@@ -3091,10 +3093,12 @@ elif test "${HAVE_X11}" = "yes" || test "${HAVE_W32}" = "yes"; then
|
||||
AH_TEMPLATE(HAVE_JPEG, [Define to 1 if you have the jpeg library (-ljpeg).])dnl
|
||||
if test "${HAVE_JPEG}" = "yes"; then
|
||||
AC_DEFINE(HAVE_JPEG)
|
||||
- AC_EGREP_CPP([version= *(6[2-9]|[7-9][0-9])],
|
||||
- [#include <jpeglib.h>
|
||||
- version=JPEG_LIB_VERSION
|
||||
-],
|
||||
+ AC_EGREP_CPP([version 6b or later],
|
||||
+ [#include <jpeglib.h>
|
||||
+ #if JPEG_LIB_VERSION >= 62
|
||||
+ version 6b or later
|
||||
+ #endif
|
||||
+ ],
|
||||
[AC_DEFINE(HAVE_JPEG)],
|
||||
[AC_MSG_WARN([libjpeg found, but not version 6b or later])
|
||||
HAVE_JPEG=no])
|
@ -1,13 +0,0 @@
|
||||
diff --git a/src/frame.h b/src/frame.h
|
||||
index ff696df..fc19768 100644
|
||||
--- a/src/frame.h
|
||||
+++ b/src/frame.h
|
||||
@@ -1349,7 +1349,7 @@ x_set_bitmap_icon (struct frame *f)
|
||||
{
|
||||
Lisp_Object obj = assq_no_quit (Qicon_type, f->param_alist);
|
||||
|
||||
- if (CONSP (obj))
|
||||
+ if (CONSP (obj) && !NILP (XCDR (obj)))
|
||||
x_bitmap_icon (f, XCDR (obj));
|
||||
}
|
||||
|
@ -26,9 +26,7 @@ Patch1: emacs-spellchecker.patch
|
||||
|
||||
# Fix for default PDF viewer bug #971162
|
||||
Patch2: emacs-pdf-default.patch
|
||||
#Patch3: emacs-no-bitmap-icon.patch
|
||||
#Patch4: emacs-configure.patch
|
||||
Patch5: emacs-grep-deprecated.patch
|
||||
Patch3: emacs-grep-deprecated.patch
|
||||
|
||||
BuildRequires: atk-devel
|
||||
BuildRequires: cairo-devel
|
||||
@ -188,9 +186,7 @@ packages that add functionality to Emacs.
|
||||
|
||||
%patch1 -p1 -b .spellchecker
|
||||
%patch2 -p1 -b .pdf-default.patch
|
||||
#%patch3 -p1 -b .bitmap
|
||||
#%patch4 -p1 -b .config
|
||||
%patch5 -p1 -b .grep-deprecated
|
||||
%patch3 -p1 -b .grep-deprecated
|
||||
autoconf
|
||||
|
||||
# We prefer our emacs.desktop file
|
||||
|
Loading…
Reference in New Issue
Block a user