- fixed FTBFS in F12 and higher (#540921)
This commit is contained in:
parent
e1b2423b8e
commit
d1aa660db7
21
emacs-23.1-cpp.patch
Normal file
21
emacs-23.1-cpp.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up emacs-23.1/configure.in.cpp emacs-23.1/configure.in
|
||||
--- emacs-23.1/configure.in.cpp 2009-11-30 13:24:53.000000000 +0100
|
||||
+++ emacs-23.1/configure.in 2009-11-30 13:25:45.000000000 +0100
|
||||
@@ -2983,7 +2983,7 @@ echo creating lib-src/Makefile
|
||||
sed -e '1,/start of cpp stuff/d'\
|
||||
-e 's,/\*\*/#\(.*\)$,/* \1 */,' \
|
||||
< Makefile.c > junk.c
|
||||
- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
|
||||
+ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
|
||||
sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
|
||||
cat junk1.c junk2.c > Makefile.new
|
||||
rm -f junk.c junk1.c junk2.c
|
||||
@@ -2999,7 +2999,7 @@ echo creating src/Makefile
|
||||
sed -e '1,/start of cpp stuff/d'\
|
||||
-e 's,/\*\*/#\(.*\)$,/* \1 */,' \
|
||||
< Makefile.c > junk.c
|
||||
- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
|
||||
+ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
|
||||
sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
|
||||
cat junk1.c junk2.c > Makefile.new
|
||||
rm -f junk.c junk1.c junk2.c
|
@ -4,7 +4,7 @@ Summary: GNU Emacs text editor
|
||||
Name: emacs
|
||||
Epoch: 1
|
||||
Version: 23.1
|
||||
Release: 13%{?dist}
|
||||
Release: 14%{?dist}
|
||||
License: GPLv3+
|
||||
URL: http://www.gnu.org/software/emacs/
|
||||
Group: Applications/Editors
|
||||
@ -28,6 +28,7 @@ Patch2: po-mode-auto-replace-date-71264.patch
|
||||
Patch3: rpm-spec-mode-utc.patch
|
||||
Patch4: emacs-gtk.patch
|
||||
Patch5: emacs-23.1-xdg.patch
|
||||
Patch6: emacs-23.1-cpp.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: atk-devel, cairo-devel, desktop-file-utils, freetype-devel, fontconfig-devel, dbus-devel, giflib-devel, glibc-devel, gtk2-devel, libpng-devel
|
||||
@ -122,6 +123,7 @@ Emacs packages or see some elisp examples.
|
||||
%patch0 -p1 -b .glibc-open-macro
|
||||
%patch4 -p1 -b .gtk
|
||||
%patch5 -p1 -b .xdg
|
||||
%patch6 -p1
|
||||
|
||||
# install rest of site-lisp files
|
||||
( cd site-lisp
|
||||
@ -165,6 +167,8 @@ fi
|
||||
%build
|
||||
export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
|
||||
|
||||
#we patch configure.in so we have to do this
|
||||
autoconf
|
||||
%configure --with-dbus --with-gif --with-jpeg --with-png --with-rsvg \
|
||||
--with-tiff --with-xft --with-xpm --with-x-toolkit=gtk
|
||||
|
||||
@ -391,6 +395,9 @@ alternatives --install %{_bindir}/etags emacs.etags %{_bindir}/etags.emacs 80 \
|
||||
%dir %{_datadir}/emacs/%{version}
|
||||
|
||||
%changelog
|
||||
* Mon Nov 30 2009 Daniel Novotny <dnovotny@redhat.com> 1:23.1-14
|
||||
- fixed FTBFS in F12 and higher (#540921)
|
||||
|
||||
* Mon Oct 19 2009 Daniel Novotny <dnovotny@redhat.com> 1:23.1-13
|
||||
- fixed update-directory-autoloads (#474958)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user