RHEL 9.0.0 Alpha bootstrap

The content of this branch was automatically imported from Fedora ELN
with the following as its source:
https://src.fedoraproject.org/rpms/emacs#1cedb9402777fa85d9d893044b18a02ace83e089
This commit is contained in:
Petr Šabata 2020-10-15 00:01:21 +02:00
parent b2d9c5954c
commit c03f302505
14 changed files with 2536 additions and 0 deletions

29
.gitignore vendored
View File

@ -0,0 +1,29 @@
/emacs-23.3a.tar.bz2
/php-mode.el
/emacs-24.0.92.tar.gz
/emacs-24.0.93.tar.gz
/emacs-24.0.94.tar.gz
/emacs-24.0.95.tar.gz
/emacs-24.0.97.tar.gz
/emacs-24.1-rc.tar.gz
/emacs-24.1.tar.bz2
/emacs-24.2.tar.xz
/emacs-24.3.tar.xz
/emacs-24.4.tar.xz
/emacs-24.5.tar.xz
/emacs-25.0.92.tar.xz
/emacs-25.0.93.tar.xz
/emacs-25.0.94.tar.xz
/emacs-25.0.95.tar.xz
/emacs-25.1-rc1.tar.xz
/emacs-25.1-rc2.tar.xz
/emacs-25.1.tar.xz
/emacs-25.2-rc2.tar.xz
/emacs-25.2.tar.xz
/emacs-25.3.tar.xz
/emacs-26.1.tar.xz
/emacs-26.2.tar.xz
/emacs-26.3.tar.xz
/emacs-26.3.tar.xz.sig
/emacs-27.1.tar.xz
/emacs-27.1.tar.xz.sig

7
default.el Normal file
View File

@ -0,0 +1,7 @@
;;; default.el - loaded after ".emacs" on startup
;;;
;;; Setting `inhibit-default-init' non-nil in "~/.emacs"
;;; prevents loading of this file. Also the "-q" option to emacs
;;; prevents both "~/.emacs" and this file from being loaded at startup.
(setq-default smime-CA-directory "/etc/ssl/certs")

12
dotemacs.el Normal file
View File

@ -0,0 +1,12 @@
;; .emacs
(custom-set-variables
;; uncomment to always end a file with a newline
;'(require-final-newline t)
;; uncomment to disable loading of "default.el" at startup
;'(inhibit-default-init t)
;; default to unified diffs
'(diff-switches "-u"))
;;; uncomment for CJK utf-8 support for non-Asian users
;; (require 'un-define)

16
emacs-spellchecker.patch Normal file
View File

@ -0,0 +1,16 @@
diff --git a/lisp/textmodes/ispell.el b/lisp/textmodes/ispell.el
index 1d28de7..1daec44 100644
--- a/lisp/textmodes/ispell.el
+++ b/lisp/textmodes/ispell.el
@@ -200,9 +200,9 @@
;; cause an error; and one of the other spelling engines below is
;; almost certainly installed in any case, for enchant to use.
(defcustom ispell-program-name
- (or (executable-find "aspell")
+ (or (executable-find "hunspell")
+ (executable-find "aspell")
(executable-find "ispell")
- (executable-find "hunspell")
"ispell")
"Program invoked by \\[ispell-word] and \\[ispell-region] commands."
:type 'string

View File

@ -0,0 +1,11 @@
--- a/src/gnutls.c 2016-01-24 10:29:58.000000000 +0100
+++ b/src/gnutls.c 2016-02-02 09:32:28.477274274 +0100
@@ -1557,7 +1557,7 @@
gnutls_certificate_credentials_t x509_cred = NULL;
gnutls_anon_client_credentials_t anon_cred = NULL;
Lisp_Object global_init;
- char const *priority_string_ptr = "NORMAL"; /* default priority string. */
+ char const *priority_string_ptr = "@SYSTEM"; /* default priority string. */
char *c_hostname;
/* Placeholders for the property list elements. */

11
emacs-terminal.desktop Normal file
View File

@ -0,0 +1,11 @@
[Desktop Entry]
Name=Emacs Terminal
GenericName=Emacs Terminal
Comment=Emacs Terminal Mode
Exec=emacs-terminal
Icon=utilities-terminal
Type=Application
Terminal=false
Categories=Application;Utility;X-Red-Hat-Base;GTK;TerminalEmulator;
Encoding=UTF-8
StartupWMClass=Emacs

3
emacs-terminal.sh Normal file
View File

@ -0,0 +1,3 @@
#!/bin/sh
exec /usr/bin/emacs -Q --eval '(term "/bin/bash")'

64
emacs.appdata.xml Normal file
View File

@ -0,0 +1,64 @@
<?xml version="1.0" encoding="UTF-8"?>
<!-- Copyright 2014 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> -->
<component type="desktop">
<id>emacs.desktop</id>
<metadata_license>CC0-1.0</metadata_license>
<project_license>GPL-3.0+</project_license>
<name>GNU Emacs</name>
<summary>Edit text files, view pictures and binary files</summary>
<description>
<p>
Emacs is a powerful, customizable, self-documenting, modeless
editor. It is used primarely to edit text, including text
documents, source code of programs, web pages and XML documents,
but can also be used to display and edit binary files.
</p>
<p>
Emacs allows efficient editing of text with shortcuts which
allow operating on letters, words, sentences, and paragraphs as
single units. This includes both moving around and operations
like copying, deleting, transposing, and pasting. Macros can be
conveniently defined to repeat sequences of commands. In
addition, Emacs is (partially) built in a scripting language
(elisp) which can also be used to define further functions
extending existing capabilities.
</p>
<p>
Emacs has extensive support for editing source code, including
programmable syntax highlighting, automatic indentation, source
code indexing, overview modes, and navigation based on language
specific units like functions and blocks. It is also possible to
invoke the compiler from within Emacs and easily move between
compiler output and corresponding positions in the source.
</p>
<p>
Emacs has multiple modules which provide further functionality.
This provides the capability to read mail, news, browse
pictures, read man and info pages, browse the web, execute
arbitrary programs, and more, without leaving the editor.
</p>
</description>
<screenshots>
<screenshot type="default" height="888" width="1595">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-two-buffers.png</image>
</screenshot>
<screenshot height="667" width="1199">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-editing-xml.png</image>
</screenshot>
<screenshot height="572" width="1019">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-hexl-mode.png</image>
</screenshot>
<screenshot height="667" width="1199">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-showing-svg.png</image>
</screenshot>
<screenshot height="439" width="794">
<image>http://in.waw.pl/~zbyszek/fedora/emacs-with-python-source.png</image>
</screenshot>
</screenshots>
<url type="homepage">http://www.gnu.org/software/emacs/</url>
<url type="bugtracker">https://www.gnu.org/software/emacs/manual/html_node/emacs/Bugs.html</url>
<url type="donation">https://my.fsf.org/donate/</url>
<url type="help">https://www.gnu.org/software/emacs/manual/</url>
<update_contact>zbyszek@in.waw.pl</update_contact>
<translation/>
</component>

12
emacs.desktop Normal file
View File

@ -0,0 +1,12 @@
[Desktop Entry]
Name=Emacs
GenericName=Text Editor
Comment=Edit text
Comment[zh_TW]=
MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
Exec=emacs %f
Icon=emacs
Type=Application
Terminal=false
Categories=Utility;TextEditor;X-Red-Hat-Base;
StartupWMClass=Emacs

11
emacs.service Normal file
View File

@ -0,0 +1,11 @@
[Unit]
Description=Emacs: the extensible, self-documenting text editor
[Service]
Type=forking
ExecStart=/usr/bin/emacs --daemon
ExecStop=/usr/bin/emacsclient --eval "(kill-emacs)"
Restart=always
[Install]
WantedBy=default.target

2258
emacs.spec Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,91 @@
-----BEGIN PGP PUBLIC KEY BLOCK-----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=/cmd
-----END PGP PUBLIC KEY BLOCK-----

9
site-start.el Normal file
View File

@ -0,0 +1,9 @@
;;; loaded before user's ".emacs" file and default.el
;; load *.el and *.elc in /usr/share/emacs/site-lisp/site-start.d on startup
(mapc
'load
(delete-dups
(mapcar 'file-name-sans-extension
(directory-files
"/usr/share/emacs/site-lisp/site-start.d" t "\\.elc?\\'"))))

2
sources Normal file
View File

@ -0,0 +1,2 @@
SHA512 (emacs-27.1.tar.xz) = dfb26531d2c19cf9fb56505f03d799654b45e5f9528e777900e8280ed2c1d21e04c52f510528e31e015977c471ae63164cedee6174b7439ebcf479a21fc18064
SHA512 (emacs-27.1.tar.xz.sig) = 8873c9f7a812db4d44625eb5d4de1a3e1abb458584a70e5e68dd97b79361ce729f9007cb41d89ba9d9a5730fa024913690bdfa71f7482554aaf45cd635c30355