Updating to the newest upstream version
This commit is contained in:
parent
1a3424dfef
commit
a8163b3c90
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
|||||||
/emacs-24.1-rc.tar.gz
|
/emacs-24.1-rc.tar.gz
|
||||||
/emacs-24.1.tar.bz2
|
/emacs-24.1.tar.bz2
|
||||||
/emacs-24.2.tar.xz
|
/emacs-24.2.tar.xz
|
||||||
|
/emacs-24.3.tar.xz
|
||||||
|
@ -1,7 +1,8 @@
|
|||||||
diff -up emacs-24.2/lisp/textmodes/ispell.el.hunspell emacs-24.2/lisp/textmodes/ispell.el
|
diff --git a/lisp/textmodes/ispell.el b/lisp/textmodes/ispell.el
|
||||||
--- emacs-24.2/lisp/textmodes/ispell.el.hunspell 2013-01-21 18:45:01.743335126 +0100
|
index 1daec44..7167dc9 100644
|
||||||
+++ emacs-24.2/lisp/textmodes/ispell.el 2013-01-21 18:51:02.082010837 +0100
|
--- a/lisp/textmodes/ispell.el
|
||||||
@@ -572,6 +572,40 @@ re-start Emacs."
|
+++ b/lisp/textmodes/ispell.el
|
||||||
|
@@ -574,6 +574,40 @@ re-start Emacs."
|
||||||
(coding-system :tag "Coding System")))
|
(coding-system :tag "Coding System")))
|
||||||
:group 'ispell)
|
:group 'ispell)
|
||||||
|
|
||||||
@ -41,8 +42,8 @@ diff -up emacs-24.2/lisp/textmodes/ispell.el.hunspell emacs-24.2/lisp/textmodes/
|
|||||||
+ `ispell-dictionary-base-alist'.")
|
+ `ispell-dictionary-base-alist'.")
|
||||||
|
|
||||||
(defvar ispell-dictionary-base-alist
|
(defvar ispell-dictionary-base-alist
|
||||||
'((nil
|
'((nil ; default
|
||||||
@@ -1106,9 +1140,57 @@ aspell is used along with Emacs).")
|
@@ -1112,9 +1146,57 @@ aspell is used along with Emacs).")
|
||||||
ispell-encoding8-command)
|
ispell-encoding8-command)
|
||||||
ispell-aspell-dictionary-alist
|
ispell-aspell-dictionary-alist
|
||||||
nil))
|
nil))
|
@ -1,47 +0,0 @@
|
|||||||
From: Sergio Durigan Junior <sergiodj@riseup.net>
|
|
||||||
Date: Tue, 02 Oct 2012 05:10:16 +0000
|
|
||||||
Subject: Bugfix for EUDCB-BBDB queries.
|
|
||||||
|
|
||||||
* net/eudcb-bbdb.el (eudc-bbdb-format-record-as-result): Fix
|
|
||||||
querying BBDB for entries without a last name.
|
|
||||||
|
|
||||||
2012-10-02 Sergio Durigan Junior <sergiodj@riseup.net>
|
|
||||||
|
|
||||||
* net/eudcb-bbdb.el (eudc-bbdb-format-record-as-result): Fix
|
|
||||||
querying BBDB for entries without a last name (Bug#11580).
|
|
||||||
|
|
||||||
Index: emacs-23.3/lisp/net/eudcb-bbdb.el
|
|
||||||
===================================================================
|
|
||||||
--- emacs-23.3.orig/lisp/net/eudcb-bbdb.el
|
|
||||||
+++ emacs-23.3/lisp/net/eudcb-bbdb.el
|
|
||||||
@@ -169,18 +169,18 @@ The record is filtered according to `eud
|
|
||||||
(symbol-name attr)))
|
|
||||||
'record))))
|
|
||||||
(t
|
|
||||||
- (setq val "Unknown BBDB attribute")))
|
|
||||||
- (if val
|
|
||||||
- (cond
|
|
||||||
- ((memq attr '(phones addresses))
|
|
||||||
- (setq eudc-rec (append val eudc-rec)))
|
|
||||||
- ((and (listp val)
|
|
||||||
- (= 1 (length val)))
|
|
||||||
- (setq eudc-rec (cons (cons attr (car val)) eudc-rec)))
|
|
||||||
- ((> (length val) 0)
|
|
||||||
- (setq eudc-rec (cons (cons attr val) eudc-rec)))
|
|
||||||
- (t
|
|
||||||
- (error "Unexpected attribute value")))))
|
|
||||||
+ (error "Unknown BBDB attribute")))
|
|
||||||
+ (cond
|
|
||||||
+ ((or (not val) (equal val ""))) ; do nothing
|
|
||||||
+ ((memq attr '(phones addresses))
|
|
||||||
+ (setq eudc-rec (append val eudc-rec)))
|
|
||||||
+ ((and (listp val)
|
|
||||||
+ (= 1 (length val)))
|
|
||||||
+ (setq eudc-rec (cons (cons attr (car val)) eudc-rec)))
|
|
||||||
+ ((> (length val) 0)
|
|
||||||
+ (setq eudc-rec (cons (cons attr val) eudc-rec)))
|
|
||||||
+ (t
|
|
||||||
+ (error "Unexpected attribute value"))))
|
|
||||||
(nreverse eudc-rec)))
|
|
||||||
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up emacs-24.1/lisp/org/org-exp-blocks.el.locate-library emacs-24.1/lisp/org/org-exp-blocks.el
|
|
||||||
--- emacs-24.1/lisp/org/org-exp-blocks.el.locate-library 2012-07-11 17:11:42.053056590 +0200
|
|
||||||
+++ emacs-24.1/lisp/org/org-exp-blocks.el 2012-07-11 17:11:47.716973793 +0200
|
|
||||||
@@ -240,7 +240,7 @@ which defaults to the value of `org-expo
|
|
||||||
(file-name-as-directory
|
|
||||||
(expand-file-name
|
|
||||||
"../contrib"
|
|
||||||
- (file-name-directory (find-library-name "org")))))))
|
|
||||||
+ (file-name-directory (locate-library "org")))))))
|
|
||||||
"Path to the ditaa jar executable."
|
|
||||||
:group 'org-babel
|
|
||||||
:type 'string)
|
|
@ -1,15 +1,16 @@
|
|||||||
qdiff -up emacs-23.3/lisp/textmodes/ispell.el.spellcheck emacs-23.3/lisp/textmodes/ispell.el
|
diff --git a/lisp/textmodes/ispell.el b/lisp/textmodes/ispell.el
|
||||||
--- emacs-23.3/lisp/textmodes/ispell.el.spellcheck 2011-11-16 10:54:57.363513864 +0100
|
index 1d28de7..1daec44 100644
|
||||||
+++ emacs-23.3/lisp/textmodes/ispell.el 2011-11-16 10:55:17.209577635 +0100
|
--- a/lisp/textmodes/ispell.el
|
||||||
@@ -348,9 +348,9 @@ Must be greater than 1."
|
+++ b/lisp/textmodes/ispell.el
|
||||||
|
@@ -351,9 +351,9 @@ Must be greater than 1."
|
||||||
:group 'ispell)
|
:group 'ispell)
|
||||||
|
|
||||||
(defcustom ispell-program-name
|
(defcustom ispell-program-name
|
||||||
- (or (locate-file "aspell" exec-path exec-suffixes 'file-executable-p)
|
- (or (executable-find "aspell")
|
||||||
+ (or (locate-file "hunspell" exec-path exec-suffixes 'file-executable-p)
|
+ (or (executable-find "hunspell")
|
||||||
+ (locate-file "aspell" exec-path exec-suffixes 'file-executable-p)
|
+ (executable-find "aspell")
|
||||||
(locate-file "ispell" exec-path exec-suffixes 'file-executable-p)
|
(executable-find "ispell")
|
||||||
- (locate-file "hunspell" exec-path exec-suffixes 'file-executable-p)
|
- (executable-find "hunspell")
|
||||||
"ispell")
|
"ispell")
|
||||||
"Program invoked by \\[ispell-word] and \\[ispell-region] commands."
|
"Program invoked by \\[ispell-word] and \\[ispell-region] commands."
|
||||||
:type 'string
|
:type 'string
|
||||||
|
44
emacs.spec
44
emacs.spec
@ -2,8 +2,8 @@
|
|||||||
Summary: GNU Emacs text editor
|
Summary: GNU Emacs text editor
|
||||||
Name: emacs
|
Name: emacs
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 24.2
|
Version: 24.3
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.gnu.org/software/emacs/
|
URL: http://www.gnu.org/software/emacs/
|
||||||
Group: Applications/Editors
|
Group: Applications/Editors
|
||||||
@ -18,12 +18,8 @@ Source6: emacs-terminal.desktop
|
|||||||
Source7: emacs-terminal.sh
|
Source7: emacs-terminal.sh
|
||||||
# rhbz#713600
|
# rhbz#713600
|
||||||
Patch7: emacs-spellchecker.patch
|
Patch7: emacs-spellchecker.patch
|
||||||
# rhbz#830162, fixed in org-mode upstream
|
|
||||||
Patch8: emacs-locate-library.patch
|
|
||||||
# Fix for Emacs bug #111500.
|
|
||||||
Patch9: emacs-bz11580-eudc-bbdb.patch
|
|
||||||
# Fix for emacs bug #13460.
|
# Fix for emacs bug #13460.
|
||||||
Patch100: emacs-24.2-hunspell.patch
|
Patch100: emacs-24.3-hunspell.patch
|
||||||
|
|
||||||
BuildRequires: atk-devel cairo-devel freetype-devel fontconfig-devel dbus-devel giflib-devel glibc-devel libpng-devel
|
BuildRequires: atk-devel cairo-devel freetype-devel fontconfig-devel dbus-devel giflib-devel glibc-devel libpng-devel
|
||||||
BuildRequires: libjpeg-devel libtiff-devel libX11-devel libXau-devel libXdmcp-devel libXrender-devel libXt-devel
|
BuildRequires: libjpeg-devel libtiff-devel libX11-devel libXau-devel libXdmcp-devel libXrender-devel libXt-devel
|
||||||
@ -31,13 +27,17 @@ BuildRequires: libXpm-devel ncurses-devel xorg-x11-proto-devel zlib-devel gnutls
|
|||||||
BuildRequires: librsvg2-devel m17n-lib-devel libotf-devel ImageMagick-devel libselinux-devel
|
BuildRequires: librsvg2-devel m17n-lib-devel libotf-devel ImageMagick-devel libselinux-devel
|
||||||
BuildRequires: GConf2-devel alsa-lib-devel gpm-devel liblockfile-devel libxml2-devel
|
BuildRequires: GConf2-devel alsa-lib-devel gpm-devel liblockfile-devel libxml2-devel
|
||||||
BuildRequires: bzip2 cairo texinfo gzip desktop-file-utils
|
BuildRequires: bzip2 cairo texinfo gzip desktop-file-utils
|
||||||
%if 0%{?el6}
|
%if 0%{?rhel} == 6
|
||||||
BuildRequires: gtk2-devel
|
BuildRequires: gtk2-devel
|
||||||
%else
|
%else
|
||||||
|
%if 0%{?rhel} == 7
|
||||||
|
BuildRequires: gtk3-devel python2-devel
|
||||||
# Buildrequire both python2 and python3 on systems containing both,
|
# Buildrequire both python2 and python3 on systems containing both,
|
||||||
# since below we turn off the brp-python-bytecompile script
|
# since below we turn off the brp-python-bytecompile script
|
||||||
|
%else
|
||||||
BuildRequires: gtk3-devel python2-devel python3-devel
|
BuildRequires: gtk3-devel python2-devel python3-devel
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
%ifarch %{ix86}
|
%ifarch %{ix86}
|
||||||
BuildRequires: util-linux
|
BuildRequires: util-linux
|
||||||
%endif
|
%endif
|
||||||
@ -153,8 +153,6 @@ packages that add functionality to Emacs.
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch7 -p1 -b .spellchecker
|
%patch7 -p1 -b .spellchecker
|
||||||
%patch8 -p1 -b .locate-library
|
|
||||||
%patch9 -p1 -b .emacs-bz11580-eudc-bbdb
|
|
||||||
|
|
||||||
%patch100 -p1 -b .hunspell
|
%patch100 -p1 -b .hunspell
|
||||||
|
|
||||||
@ -173,12 +171,12 @@ rm -f lisp/play/tetris.el lisp/play/tetris.elc
|
|||||||
rm -f etc/sex.6 etc/condom.1 etc/celibacy.1 etc/COOKIES etc/future-bug etc/JOKES
|
rm -f etc/sex.6 etc/condom.1 etc/celibacy.1 etc/COOKIES etc/future-bug etc/JOKES
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define info_files ada-mode auth autotype calc ccmode cl dbus dired-x ebrowse ede ediff edt eieio efaq eintr elisp emacs emacs-gnutls emacs-mime epa erc ert eshell eudc flymake forms gnus idlwave info mairix-el message mh-e newsticker nxml-mode org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve smtpmail speedbar tramp url vip viper widget woman
|
#%define info_files ada-mode auth autotype calc ccmode cl dbus dired-x ebrowse ede ediff edt eieio efaq eintr elisp emacs emacs-gnutls emacs-mime epa erc ert eshell eudc flymake forms gnus idlwave info mairix-el message mh-e newsticker nxml-mode org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve smtpmail speedbar tramp url vip viper widget woman
|
||||||
|
|
||||||
if test "$(perl -e 'while (<>) { if (/^INFO_FILES/) { s/.*=//; while (s/\\$//) { s/\\//; $_ .= <>; }; s/\s+/ /g; s/^ //; s/ $//; print; exit; } }' Makefile.in)" != "%info_files"; then
|
#if test "$(perl -e 'while (<>) { if (/^INFO_FILES/) { s/.*=//; while (s/\\$//) { s/\\//; $_ .= <>; }; s/\s+/ /g; s/^ //; s/ $//; print; exit; } }' Makefile.in)" != "%info_files"; then
|
||||||
echo Please update info_files >&2
|
# echo Please update info_files >&2
|
||||||
exit 1
|
# exit 1
|
||||||
fi
|
#fi
|
||||||
|
|
||||||
%ifarch %{ix86}
|
%ifarch %{ix86}
|
||||||
%define setarch setarch %{_arch} -R
|
%define setarch setarch %{_arch} -R
|
||||||
@ -432,6 +430,10 @@ update-desktop-database &> /dev/null || :
|
|||||||
%dir %{_datadir}/emacs/site-lisp/site-start.d
|
%dir %{_datadir}/emacs/site-lisp/site-start.d
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 18 2013 Petr Hracek <phracek@redhat.com> - 1:24.3-1
|
||||||
|
- Updated to the newest upstream release
|
||||||
|
- solved problem with distribution flag in case of rhel
|
||||||
|
|
||||||
* Mon Mar 18 2013 Rex Dieter <rdieter@fedoraproject.org> 1:24.2-12
|
* Mon Mar 18 2013 Rex Dieter <rdieter@fedoraproject.org> 1:24.2-12
|
||||||
- rebuild (ImageMagick)
|
- rebuild (ImageMagick)
|
||||||
|
|
||||||
@ -616,7 +618,7 @@ update-desktop-database &> /dev/null || :
|
|||||||
- Added filesystem subpackage (rhbz#661866)
|
- Added filesystem subpackage (rhbz#661866)
|
||||||
- Added emacsclient desktop file (rhbz#665362)
|
- Added emacsclient desktop file (rhbz#665362)
|
||||||
|
|
||||||
* Thu Jan 7 2011 Karel Klic <kklic@redhat.com> - 1:23.2-16
|
* Fri Jan 7 2011 Karel Klic <kklic@redhat.com> - 1:23.2-16
|
||||||
- Removed dependency on both hunspell and aspell. Emacs does not
|
- Removed dependency on both hunspell and aspell. Emacs does not
|
||||||
_require_ spell checker, e.g. if user wants to uninstall one, there
|
_require_ spell checker, e.g. if user wants to uninstall one, there
|
||||||
is no reason why Emacs should also be uninstalled. Emacs can run one
|
is no reason why Emacs should also be uninstalled. Emacs can run one
|
||||||
@ -626,7 +628,7 @@ update-desktop-database &> /dev/null || :
|
|||||||
- Cleaned spec file header
|
- Cleaned spec file header
|
||||||
- Removed gcc-4.5.0 specific CFLAGS
|
- Removed gcc-4.5.0 specific CFLAGS
|
||||||
|
|
||||||
* Thu Jan 7 2011 Karel Klic <kklic@redhat.com> - 1:23.2-15
|
* Fri Jan 7 2011 Karel Klic <kklic@redhat.com> - 1:23.2-15
|
||||||
- The emacs-terminal package now requires emacs package
|
- The emacs-terminal package now requires emacs package
|
||||||
|
|
||||||
* Thu Jan 6 2011 Karel Klic <kklic@redhat.com> - 1:23.2-14
|
* Thu Jan 6 2011 Karel Klic <kklic@redhat.com> - 1:23.2-14
|
||||||
@ -926,7 +928,7 @@ update-desktop-database &> /dev/null || :
|
|||||||
- fix pkgconfig path (from pkg-config to pkgconfig (Jonathan Underwood)
|
- fix pkgconfig path (from pkg-config to pkgconfig (Jonathan Underwood)
|
||||||
- use macro instead of variable style for buildroot.
|
- use macro instead of variable style for buildroot.
|
||||||
|
|
||||||
* Mon Aug 28 2007 Chip Coldwell <coldwell@redhat.com> - 22.1-3
|
* Tue Aug 28 2007 Chip Coldwell <coldwell@redhat.com> - 22.1-3
|
||||||
- change group from Development to Utility
|
- change group from Development to Utility
|
||||||
|
|
||||||
* Mon Aug 13 2007 Chip Coldwell <coldwell@redhat.com> - 22.1-2
|
* Mon Aug 13 2007 Chip Coldwell <coldwell@redhat.com> - 22.1-2
|
||||||
@ -934,7 +936,7 @@ update-desktop-database &> /dev/null || :
|
|||||||
- glibc-open-macro.patch to deal with glibc turning "open" into a macro.
|
- glibc-open-macro.patch to deal with glibc turning "open" into a macro.
|
||||||
- leave emacs info pages in default section (Resolves: bz199008)
|
- leave emacs info pages in default section (Resolves: bz199008)
|
||||||
|
|
||||||
* Fri Jun 6 2007 Chip Coldwell <coldwell@redhat.com> - 22.1-1
|
* Wed Jun 6 2007 Chip Coldwell <coldwell@redhat.com> - 22.1-1
|
||||||
- move alternatives install to posttrans scriptlet (Resolves: bz239745)
|
- move alternatives install to posttrans scriptlet (Resolves: bz239745)
|
||||||
- new release tarball from FSF (Resolves: bz245303)
|
- new release tarball from FSF (Resolves: bz245303)
|
||||||
- new php-mode 1.2.0
|
- new php-mode 1.2.0
|
||||||
@ -1266,7 +1268,7 @@ update-desktop-database &> /dev/null || :
|
|||||||
and remove redundant next-line-add-newlines setting
|
and remove redundant next-line-add-newlines setting
|
||||||
- update info_file list (Reuben Thomas,114729)
|
- update info_file list (Reuben Thomas,114729)
|
||||||
|
|
||||||
* Wed Mar 16 2004 Mike A. Harris <mharris@redhat.com> 21.3-11
|
* Tue Mar 16 2004 Mike A. Harris <mharris@redhat.com> 21.3-11
|
||||||
- Removed bogus Requires: XFree86-libs that was added in 21.3-8, as rpm
|
- Removed bogus Requires: XFree86-libs that was added in 21.3-8, as rpm
|
||||||
find-requires will automatically pick up the dependancies on any runtime
|
find-requires will automatically pick up the dependancies on any runtime
|
||||||
libraries, and such hard coded requires is not X11 implementation
|
libraries, and such hard coded requires is not X11 implementation
|
||||||
@ -1587,7 +1589,7 @@ update-desktop-database &> /dev/null || :
|
|||||||
* Sat Jan 27 2001 Jakub Jelinek <jakub@redhat.com>
|
* Sat Jan 27 2001 Jakub Jelinek <jakub@redhat.com>
|
||||||
- Preprocess Makefiles as if they were assembly, not C source.
|
- Preprocess Makefiles as if they were assembly, not C source.
|
||||||
|
|
||||||
* Thu Jan 24 2001 Yukihiro Nakai <ynakai@redhat.com>
|
* Wed Jan 24 2001 Yukihiro Nakai <ynakai@redhat.com>
|
||||||
- Fix the fontset problem when creating a new frame.
|
- Fix the fontset problem when creating a new frame.
|
||||||
|
|
||||||
* Thu Jan 18 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
* Thu Jan 18 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||||
|
Loading…
Reference in New Issue
Block a user